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YESterm/IP Overview 
 

AS/400 Requirements 
 
• OS/400 V3R2 with appropriate PTFs or higher. 
 

iSeries Requirements 
 
• No special requirements. 
 

Technical Characteristics 
 
The YESterm/IP TN3270e and TN5250e emulators provide users with a powerful capability to connect to an 
IBM AS/400, iSeries, 3290, or zSeries host computer via the TCP/IP protocol. They provide enhanced 
emulation functions for a wide range of IBM terminals and “true” IBM 3812 or 3287 Printer emulation with 
the support of all the enhanced features normally available only on very expensive printer interfaces.  Up to 
four concurrent TCP/IP connections can be configured with identical or unique hosts.  In addition, 
YESterm/IP TN5250E supports the “Enhanced Display Auto-Signon and Password Encryption” allowing a 
secure connection to the AS/400, with no need of any SSL option. Basic session configuration is made 
simple by a Wizard application that guides the user during the configuration process. 
 

Display Session 
  
Significant characteristics of YESterm/IP display sessions are: 
• IBM emulations supported: 3180-2, 3196, 3278/9, 3477-FG, 3477-FC, 5251, 5291. 
• Numerous resident national keyboard templates and Code Pages. 
• Enhanced keyboard mapping and customization, including macro assignment. 
• EURO (€) symbol supported. 
• Enhanced copy and paste options. 
• Programmable Keypad. 
• Attributes editing. 
• Enhanced customizable Hot Spot feature. 
• Enhanced macro Record/Playback feature. 
• Supports “Enhanced Display Auto-Signon and Password Encryption” allowing a secure connection to an 

AS/400. 
• Choice of Windows or “Green Screen” Text presentation modes.  See Editing a Session|Display 

Session|Advanced|Appearance for details. 
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Printer Session 
 
Significant characteristics of YESterm/IP printer sessions are 
• IBM Emulations supported: 3287, 3812. 
• Support for continuous forms, multi drawers, envelope, manual feeders, simplex/duplex, auto page 

orientation, and COR (Computer Output Reduction). 
• Supports CPI, LPI Override and LQ, NLQ. 
• Supports Host Transform Feature (TN5250e only). 
• Supports Hex Pass-Through (HPT) feature, with customizable leading and ending sequences and support 

of “non-printable characters”. 
• Supports EURO symbol (€). 
 

 
Return to Table of Contents
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Adding a Session 
 

Session additions, removals, and configuration are initiated from the Terminal Connection Manager screen.  
Click on the Configure tab, and then click on Add. 
 
You are faced with a choice of four different YESterm IP emulation types.  After choosing an emulation 
type, a wizard will guide you through setup.  You can have a maximum of four emulation sessions, and each 
session can have a unique server address, if desired. 
 
After your setup and configuration are complete, you can secure parameters from any user changes as 
follows: 
1. From the Connection Manager screen, press F2. 
2. Select the Password tab (Windows CE), or select the Control Panel tab (Windows CE.net). 
3. If you selected Control Panel, double-click on the Security icon. 
4. Check the box that says “Disable Terminal Connection Configure Tab”. 
5. Check the box that says “Password Enable”. 
6. Choose and confirm a password. 
7. Click on Modify. 
8. Click on OK. 
 

Display Emulation 
 
A Setup Wizard will take you through three screens.  Activate Next to go to the next screen, Back to return 
to the previous screen, and Cancel or the Esc key to abort the process. 
 
1. 

 
Display Setup Screen #1 

 
• Host Name/IP Address: If you have a local DNS or WINS server, you can type in the host network 

name.  Otherwise, type in the IP address of the host. 
• Port Number: Use the default of 23 unless directed to do otherwise by your network administrator. 
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2. 

 
Display Setup Screen #2 

• Connection Name: This is the friendly name that will appear in the Terminal Connection Manager 
screen. 

• Device Type:  Select one from the drop-down list.  The default 3477-FC works well for TN5250e 
emulation, unless you have special needs.  If you are adding a TN3270e session, you will see a choice of 
3278/9 terminal types here. 

• Device Name: If you are using named sessions, enter the session name here. 
 

 
Final Display Setup Screen 

• Host Code Page:  Choose the applicable country from the drop-down list. 
• Keyboard Type:  It is recommended that you choose the default 101 Terminal keyboard type. 
 
This concludes the setup parameters covered by the wizard.  However, you can configure many more 
parameters in each Display Session by highlighting the connection name in the Configure tab window and 
activating Edit.  See Editing a Session|Display Session. 
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Printer Emulation 
 
You can have multiple local printers, but you must create a printer session for each one.  Setup and 
configuration are initiated from the Configure tab of the Terminal Connection Manager window.  Click on 
Add.  You are faced with a choice of four emulation types.  After choosing YESterm IP 3270  Printer or 
YESterm IP 5250 Printer, a wizard will guide you through setup.  You can have a maximum of four printer 
and/or display emulation sessions, with any mixture of 5250 and 3270 emulations.  Each session may have a 
unique host, if desired.  If you want to create a session for extended local Print Screens (see Editing a 
Session|Display Session|General|Print Screen Key), you can create it here, but you will have to edit it later 
(see Editing a Session|Printer Session) since the default is for standard host printing.  A Setup Wizard will 
take you through three screens. 
 
1. 

 
Printer Setup Screen #1 

• Host Name/IP Address: If you have a local DNS server, you can type in the AS/400 host network name.  
Otherwise, type in the IP address of the AS/400 server.  If you are creating this session for Extended 
Local Printing, an IP address is irrelevant, but you must enter at least one character to satisfy the Wizard. 

• Port Number: Use the default of 23 unless directed otherwise by your network administrator. 
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2. 

 
Printer Screen #2 

• Connection Name: This is the friendly name that will appear in the Terminal Connection Manager 
screen. 

• Device Type:  Only 3812 (TN5250e) or 3287 (TN3270e is available for TCP/IP devices. 
• Device Name: If you are using named sessions, enter the session name here. 
 
3. 

 
Final Printer Setup Screen 

• Host Code Page:  Choose the applicable country from the drop-down list. 
• Printer Driver: If you are doing extended local Print Screens, or if you are not using the AS/400 Host 

Print Transform, choose a driver here that is compatible with the target printer.  If you can’t find one in 
the list, try Empty Driver. 

 
This concludes the configuration parameters covered by the wizard.  However, you can customize many 
more parameters in each Printer Session by highlighting the connection name in the Configure tab and 
activating Edit. 
 

Return to Table of Contents
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Editing a Session 
 

After adding a session, you can customize many more parameters in each session by highlighting the 
connection name in the Configure tab of Terminal Connection Manager and clicking on Edit. 
 

Display Session 
 
The screen shots you see in this section are TN5250e editing screens.  There are very few differences 
between the 5250 and 3270 screens, and any significant differences for TN3270e sessions will be discussed 
in the text. 
 
Go to the Terminal Connection Manager screen, open the Configure tab, highlight a display session, and 
click on Edit.  For TN5250e sessions, you will see a Displays Sessions Properties sheet with seven property 
tabs.  For TN3270e sessions, you will see a Displays Sessions Properties sheet with six property tabs.  The 
opening view is of the Connections tab and property sheet. 
 

Connection 
 

 
Connection Properties Sheet 

Five of the six properties on this property sheet were already configured in the Setup Wizard, although you 
can change them here if you wish.  The other property is: 
• Encryption Level.   If you want to use sign-on encryption, choose an appropriate encryption level from 

the drop-down list.  Your host must also be configured for this encryption level. 
. 
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General 
 

 
General Properties Sheet 

 

Code Page 
YESterm/IP supports numerous Code Pages. The Code Page selected here from the drop-down list should be 
the same one configured on the host for this specific device. It is also possible to create a new custom Code 
Page Table.  See How To…|Create a Custom Language Code Page for instructions. 
 
Keyboard Type 
YESterm/IP supports 3 different keyboard types (101 PC, 101 Terminal, and 122 Key) for several different 
languages.  It is also possible to create a new custom keyboard map.  See How To …|Create a Custom 
Keyboard Map.  Select your keyboard from the drop-down list.  To see how that keyboard is mapped, click 
on Edit to get to the keyboard map page. 
 

 
Keyboard Map Page for 5250 122-Key U.S. English Keyboard 
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You can check the current mapping in one of two ways: 
• Scan Codes.  The keyboard sends a unique scan code to the terminal when a key is pressed.  If you want 

to see what key is associated with a specific scan code, type that code in the Edit box, shown highlighted 
in the above figure.  The associated key will highlight, and any command mapped to that key will show 
in the Action boxes.  Of course, most people couldn’t care less about scan codes, so this method may be 
of little use to you. 

• Mouse Clicks.  Position the cursor over the key of interest and click.  The scan code for that key will 
show in the Edit box, and any mapped command will show in the Action boxes.  If you want to see the 
effect of that key plus a modifier key (Shift, Alt, Ctrl), click on the modifier key and then on the action 
key. 

 
Edit 
Activate this button to initiate custom keyboard mapping.  See How To…|Create a Custom Keyboard Map 
for the mapping procedure. 
 
Default 
This button will erase any custom mapping that exists in this map.  Everything goes back to defaults.  
Obviously, you want to be very careful around this key if you have done much custom mapping. 
 
Options 

 
Keyboard Options Dialog Box 

This button opens a special dialog box where you can specify the Host Keyboard Language Option, and 
enable the Multinational character set. 
 

Font 
Select the Font style to be used as Default Font for the Display Session 
 

Print Screen Options 
From the drop-down list, select how the Print Screen function is to be performed: 
• Local Direct Print.  Make this selection if you wish to print to a local printer attached to the LPT1 port. 
• Through the Host.  Make this selection if you wish to print to a remote printer through the host. 
• Extended Local Print.  This selection provides local printing on steroids.  To use it, you must create a 

printer emulation session.  This session can be used with either a local or a network printer, and it allows 
you to format your print output.  See Printer Session for more information.  If you select this option, you 
must choose a printer session from the lower drop-down list. 

• Function Disabled.  Screens cannot be printed. 
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The Print Screen function can be activated from the: 
• Emulator Button bar. 
• Emulator Menu bar (File|Print) 
• Keyboard in accordance with the keyboard map. 
• Key Pad, if it contains a corresponding button 
 

Cursor 
Select the type of cursor you want to use. 
 

Miscellaneous 
• Euro Support. When this option is enabled, you will enter the Euro symbol when you press Alt+E. 
• Keyboard Buffer.  This option enables Typeahead. 
• Keyboard Clicker. If this option is enabled, you can hear an enhanced click every time you press a key 

on the keyboard. 
• Error Message Beep.  If this option is enabled, you can hear a "Beep" when an input error is made. 
• System Message Beep.  If this option is enabled, you can hear a "Beep" when a message is received 

from the Host. 
• Lock NumLock.  This option has no effect since NumLock is always enabled in an emulator session. 
 

Attributes 
 
This properties sheet allows extensive editing of your screen appearance.  At the lower right corner of this 
sheet are two radio buttons allowing you to make these edits global for all sessions, or restrict their use to this 
session only. 
 

 
Attributes Properties Sheet 
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Default View 
• Advanced (Recommended).  This default selection provides a “graphics” appearance for your session 

screens, resembling a Windows application.  All the Hot Spots are shown as raised buttons.  Advanced 
View is usually the most productive way to operate in emulation sessions since all menu items, Function 
Keys, sub-file options, and custom hot spots are always visible and accessible as raised buttons. 

 

 
Display Emulation Screen with Advanced View and Hot Spots 

 
• Standard (Not Recommended).  This selection provides the standard green screen “text” appearance 

for your session screens, duplicating terminal screens.  Hot Spots are invisible unless the mouse cursor is 
placed over one of them, and then only that one Hot Spot is visible.  Obviously, operating within the 
Standard view can become tedious if you have any custom Hot Spots or are unfamiliar with the default 
Function Key and Option Hot Spots. 

 

 
Display Emulation Screen with Standard View and Hot Spots 

Either default view can be overridden from the emulation screen Toolbars if desired. 
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Attribute Settings (Standard View Only) 
Set how the attribute font appears on the screen. This includes properties such as foreground and background 
color, blinking, underscore, and the use of column separators.  You will see a preview of the “new look” in 
the Sample field.  Be careful with the colors you choose; a wrong choice can cause text or fields to be 
invisible on the screen because of lack of color contrast. 
• Edit (Column Separator).  Activate this button to invoke this dialog box. 
 

 
Edit Column Separator Dialog Box 

Make your choices and view them in the Sample field. 
 

Hot Spot 
 
Changes made in this property sheet affect all sessions.  There is only one Hot Spot configuration per 
emulator, not one per session.   
 

 
Hot Spot Properties Sheet 
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A Hot Spot is an area of the session window on which you can single-click the left mouse button to execute a 
command or function. Actually, a Hot Spot is the result of a text search by the emulator for the specified 
Keyword on the screen.  The Function Key and Numeric fields (from 1 to 99 followed by a "period" or 
"space") Hot Spots are active by default, but you can add other Hot Spot keys and/or edit/remove them. 
 
A Hot Spot can be used to: 
• Simulate a function key. 
• Execute a Recorded Sequence that has the same name as the word that you select on the screen. 
• Execute a command that you select. 
 
To enable the use of Hot Spots, you must check the Enable Hot Spots box. 
 
Standard View 
If Standard View is selected in the Advanced tab or the emulation screen Toolbars, Hot Spots are invisible 
unless a mouse cursor is dragged over them, and then only the one under the mouse cursor becomes visible. 
 

 
Emulation Screen with Standard View and Hot Spots 

 
Advanced View 
Hot Spots are displayed as raised buttons if the Advanced View option is selected in the Attributes tab or the 
emulation screen Toolbars.  Advanced View is the most productive way to operate in non-TBT viewing 
mode since all menu items, Function Keys, sub-file options, and custom hot spots are always visible and 
accessible as raised buttons. 
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Emulation Screen with Advanced View and Hot Spots 

To Edit a Hot Spot: 
1. Select the Function Key you want to modify. 
2. Click on Edit. 
3. If you want to send a Text String to the host every time you press the Function key, type it into the Text 

String field. 
4. Select the Action from the Drop-Down List 
5. From the drop-down list, select the command or the Recorded Sequence that you want to associate to the 

Hot Spot key. 
6. In c.80, specify where, in an 80-column screen, the text search engine should start looking for the 

specified Keyword.  For example, the default start for the word “More” is column 68.  So if there is a 
word “More” to the left of that column, it will not be defined as a Keyword or Hot Spot. 

7. In c.132, specify where, in a 132-column screen, the text search engine should start looking for the 
specified Keyword. 

8. Click on Accept. 
9. Click on Apply. 
 
To Remove a pre-defined Hot Spot: 
1. Select the Function Key. 
2. Click on Remove. 
. 
To Add a Hot Spot: 
1. Click on Add. 
2. Type the Hot Spot Key Word you want to detect. If you want to send a Text String to the host, type it 

into the Text String field. 
3. Select the Action from the Drop-Down List 
4. From the drop-down list, select the command or the Recorded Sequence that you want to associate to the 

Hot Spot. 
5. Specify the text search start columns in c.80 and c.132. 
6. Click on Accept. 
7. Click on Apply. 
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Key Pad 
 
A Key Pad is a small window with several customizable push buttons, each having an assigned function. You 
can make it visible on the screen by clicking on the button on the Buttons toolbar, or selecting View/Key 
Pad from the menu bar. You can choose a function from the Key Pad with your mouse instead of typing the 
equivalent command, pressing a key, or running a Recorded Sequence. 
 

 
Emulation Screen with Key Pad 

The Key Pad tab allows you to change the characteristics of the pop-up Key Pad.  Changes made in this 
property sheet affect all sessions.  There is only one Key Pad configuration per emulator, not one per session. 
 

 
Key Pad Property Sheet for TN5250e 

To Edit a Key Pad button: 
1. Select the Function Key you want to modify from the Button Label list. 
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2. Click on Edit. 
3. If you want to send a Text String to the host every time you press the Function key, type it into the Text 

String field. 
4. Select the Action from the Drop-Down list 
5. Select the command or the Recorded sequence from the Drop-Down list that you want to associate to the 

Hot Spot key. 
6. Click on Accept. 
7. Click on Apply. 
 
To Remove a Key Pad button: 
1. Select the Function Key you want to remove. 
2. Click on Remove. 
 
To Add a Key Pad button: 
1. Click on Add. 
2. In the Name field, type the text you want to associate to the button when you pop up the Key Pad. 
3. If you want to add a Text String to be sent to the host, type it into the Text String field. 
4. Select the Action from the Drop-Down List. 
5. From the Drop-Down list, select the command or the Recorded sequence that you want to associate to 

the Key Pad button. 
6. Click on Accept. 
7. Click on Apply. 
 

Sign On (5250 Only) 
 
The Sign On feature of the emulator uses the "Enhanced Display Auto-Signon and Password Encryption" 
feature of the AS/400 to allow a secure connection to the AS/400without using SSL. 
 

 
Sign On Property Sheet for TN5250e 

For this feature to work to your benefit, the "Remote Signon" parameter of the AS/400 configuration should 
be enabled. To verify if this parameter is enabled, use the WRKSYSVAL command.  To enable this 
parameter, you may use the following command: 
CHGSYSVAL SYSVAL(QRMTSIGN) VALUE('*VERIFY'). 
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Advanced 
 
The Advanced property sheet allows enabling/disabling several useful features. 
 

 
Advanced Property Sheet for TN5250e 

 
 

Appearance 
• Show Menu and Toolbar.  If you want to eliminate the “Windows” look, uncheck this box.  In addition 

to changing the appearance, this will also prevent the user from using Hot Spots or Key Pad, and from 
viewing the keyboard mapping. 

• Status Bar type. 
o Classic 5250/3270.  Provides the classic “green screen” look in the status bar. .  This also 

enables the assignment of recorded key sequences to F keys in the classic terminal fashion, using 
the Record and Play keys (on a 122-key keyboard). 

 

 
 

o Graphic.  Provides the “Windows” look to the status bar and displays the connection name. This 
disables the classic assignment of recorded key sequences to F keys, although macros can still 
be assigned to F keys, or any other keys, via the keyboard map editor. 
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Security Configuration 
YESterm/IP provides extreme flexibility in allowing, or prohibiting, the user to view and change the 
characteristics of the display screen.  If you choose to show the Menu and Tool bars in Appearance above, 
you can choose to individually enable or hide every option item shown in the Menu bar, and its 
corresponding button in the Buttons bar.  The default is that all options except Properties are enabled. 
1. Select the appropriate item from the drop-down list 
2. Click on the Enable… check box. to insert a check in the check box, or to remove one that is already 

there.  
 

Host Device Connection 
When using named devices, careless name assignment or unusual session activation circumstances, such as a 
power failure/reconnect, can cause two sessions to request the same name.  In such a case, the host will not 
open the second session.  Checking the Allow request of….  box will cause the emulator to request a virtual 
assignment for the second session if it is rejected because of name conflict.  This doesn’t fix the basic 
problem, but at least the session can be opened. 
 
IBM recommends setting the AS/400 “Keep Alive Timeout” to 40 seconds in order to facilitate reconnection 
of named sessions.  The AS/400 command CHGTELNA, executed from an AS/400 green screen, followed 
by the F4 key will display the screen that controls the setting of this parameter. 
 

Miscellaneous 
• Acoustic messages.  Select Wave device if you want to use external speakers. 
• Enable debug trace.  If you enable the trace, enter the Destination IP Address. 
 

Printer Session 
 
For TN5250e sessions, you will see a Printer Sessions Properties sheet with six properties tabs.  For 
TN3270e sessions, you will see a Printer Sessions Properties sheet with four properties tabs.  The opening 
view is of the Connections tab and properties sheet. 
 

Connection (5250) 
 

 
Connection Property Sheet for TN5250e 

 18



Six of the seven parameters on this property sheet were already configured in the Setup Wizard when this 
session was created, although you can change them here if you wish.  The additional parameter is: 
• Use this session to support….  If this session is used for Print Screen Extended Local Printing, check 

this box. 
 

Connection (3270) 
 

 
Connection Property Sheet for TN3270e 

Six of the eight parameters on this property sheet were already configured in the Setup Wizard, although you 
can change them here if you wish.  The additional parameters are: 
• Use this session to support….  If this session is used for Print Screen Extended Local Printing, check 

this box. 
• Associate device.  Usually a printer session is associated with a specific printer device name.  However, 

there are some mainframe configurations with no "free" printer devices, but only printer devices 
associated to specific display devices.  In this case, you have to specify a display session name to which 
a printer is associated. 

 

Input (5250) 
 
The Input Tab allows you to define specific parameters that affect the appearance of the printed page. 
Note:  If you are using Host Print Transform (see Advanced), the Input settings do not apply. 
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Input Property Sheet for TN5250e 

Language 
YESterm/IP supports a number of different Code Pages. The Code Page selected here should be the same as 
that configured on the AS/400 for the specific device. 
 
It is also possible to create a new custom Code Page Table.  See How To…|Create a Custom Language Code 
Page for instructions. 
 
Page Layout 
Set the default page layout.  Parameters are: 
• Page Orientation. Select from Portrait, Landscape, and COR (Computer Output Reduction).  Note: If 

you are using an impact dot-matrix printer, Portrait is recommended. 
• Automatic Page Orientation. This option is enabled by Default.  Note: If you are using an impact dot-

matrix printer, it is recommended that this be Disabled. 
• COR Line Spacing Reduction. This feature solves the problem of nonprintable margin area on the 

printer.  Note: It is recommended that this feature be used only with laser printers. 
• COR Override. This function corresponds to the IBM 3812 configuration parameter and defines that a 

job with draft quality is printed in COR. 
 

Overrides 
If you wish to override the host system output settings, you can do so. 
Note: If you are using an impact dot-matrix printer, it is recommended that you set Print Quality to Force 
Draft. 
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Input (3270) 
 

 
Input Property Sheet for TN3270e 

Language 
YESterm/IP supports a number of different Code Pages. The Code Page selected here from the drop-down 
list should be the same as that configured on the mainframe for the specific device. 
 
It is also possible to create a new custom Code Page Table.  See How To…|Create a Custom Language Code 
Page for instructions. 
 
Default Page Settings 
Select the desired default settings from the drop-down lists and enter the maximum print parameters.  Note: 
If you are using an impact dot-matrix printer, Portrait is recommended for Page Orientation. 
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Output 
 
The Output properties define the communication with the printer. 
 

 
Output Property Sheet for TN5250e 

• Time Out.  This parameter defines a timer (in seconds) that starts to count down every time, during a 
printing job, that the host system stops sending data. If no more data are received within the timeout 
value selected, the printer session will assume that the print job is finished, and a Form Feed command is 
sent to the printer. 

• Printer Driver. The PassThrough Drivers offered here, specifically developed by Affirmative, generate 
a standard text data stream. Everything is sent to the printer in text mode allowing better control of the 
printer and better performance.  Select a PassThrough Driver from the drop-down list of pre-configured 
Printer Profiles for your selection and use.  Even if your printer is not on this list, it probably emulates 
one of the listed printers.  Note:  If you are using an HP PCL printer, it is recommended that you use HP 
PCL (Standard COR) for U.S. operation and HP PCL Laser Emulation for European operation.  
Note:  If you are using Host Print Transform (see Advanced), select Empty Driver. 

• Driver Configuration.  If you wish, you can modify parameters of a listed driver. For more information 
on how to customize or create a new Passthrough Printer Driver, refer to How To…|Modify a 
Passthrough Driver. 

 

Euro 
If your printer is Euro ready, you may wish to bypass the PassThrough Euro sequence.  To do so, activate the 
Euro button to bring up the Euro Printing Mode dialog box 
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Euro Printing Mode Dialog Box 

Select the Use Euro ready printer radio button and choose a Code Page character. 
 

Printer Port 
Choose and configure the local or network printer port used in this session.  Choose Parallel port, COM1/2 
(if your model has COM ports), Lan printer, or USB.  You can have multiple local printers, but you must 
define a session for each one. 
• Port printer configuration.  After you choose a printer port, you need to configure it. 

o Parallel Port.  Click on Parallel Port Config… to configure whether or not to reset the printer 
at the start of every print job. 

o COM1/2 (2614 only).  Click on Serial Port Configuration to see the Serial Port dialog box.   
 

 
Serial Port Dialog Box 

Select the baud rate and flow control from the drop-down lists.  Note that parity and stop bits are 
not configurable. 

o Lan Printer.  Click on Lan Configuration to see the Lan Printer Configuration dialog box. 
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LAN Printer Configuration Dialog Box 

o LPR printer.  Make this selection to assign print jobs to a network printer that is 
configured as an LPD server. 

 Host name/IP Address.  Type in the IP address of the LPD host. 
 LPR queue name.  This will be the queue name assigned at the LPD host to be 

used by LPR devices to assign print jobs. 
 Port Number.  Leave at the default unless otherwise directed by your network 

administrator. 
 Job length counter.  Leave unchecked unless otherwise directed by your 

system administrator. 
o RAW printer.  RAW is the default protocol for most TCP/IP networks.  RAW data is 

not modified by the spooler at all, but is sent directly to the printer. 
 Host name/IP.  Type in the IP address of the RAW host. 
 Port Number.  Leave at the 9100 default unless otherwise directed by your 

system administrator. 
o SMB printer.  If your network printer is accessed through a Windows print server, 

make this selection and enter the appropriate parameters. 
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HPT (Hex Passthrough) (5250 only) 
Hex Passthrough allows portions of a data stream to be sent directly from the host to the printer.  There is no 
modification done to these portions by the emulator driver.  In order for the emulator to recognize these 
inviolate data stream portions, they must be identified at the beginning and end by escape sequences – a 
combination of special characters that the emulator can identify. 
 

 
Hex Passthrough Property Sheet for TN5250e 

• Sequences.  Enter the Leading Sequence and the Trailing Sequence you want to use. The default 
sequences are %& and %&; however, most printers use the reverse (&%).  You can enter up to 4 
characters for each sequence. 

• HPT Mode.  Select one of four modes to define rather or not HPT prints spaces and rather or not it 
updates the column counter. 

 
Advanced (5250 Only) 
 
The Advanced Tab allows you to set Default parameters and enable the Host Print Transform feature. 
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Advanced Property Sheet for TN5250e 

• Queue Name/Queue Library/Default Font.  These are host parameters and should be given to you by 
your host administrator. 

 
Host Transform 
When Host Print Transform is enabled, the host does the EBCDIC-to-ASCII conversion of the print stream, 
and the local Passthrough Driver is not used. 

• Printer.  You must choose a compatible model from the drop-down list.  Your AS/400 may have a 
more extensive list of compatible printers.  If your printer is on the AS/400 list, but not on our list, 
you can type in the printer model here as it appears in the AS/400 list; be sure to put an asterisk in 
front of the model name. 

• Drawer # 1.   Choose an input print media size if applicable. 
• Drawer # 2.   Choose an input print media size if applicable. 
• Envelope.  Choose an envelope size if applicable. 
• Customizing Object Name.  Enter the object name here if you have chosen *WSCTS from the 

Printer drop-down list. 
• Customizing Object Library.  Enter the object library name here if you have chosen *WSCTS 

from the Printer drop-down list. 
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Miscellaneous 
 

 
Miscellaneous Property Sheet for TN5250e 

• Security Configuration.  Default mode is to hide the Properties entries from the Tool bar and the Menu 
bar so that the user cannot make configuration changes.  Check this box if you wish to provide user 
access to the configuration parameters. 

• Misc.  If you enable the debug trace, enter the Destination IP Address. 
 

How To… 
 

Create a Custom Language Code Page 
This procedure is the same for either a display or a printer session.  To do this, select one of the available 
Code Pages (the one that comes closest to the one you want to create) and click on Edit.  Assuming that your 
base Code Page is International 5, the following screen will appear: 
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International 5 Code Page Table 

To read the table, use the left column for the first hex character of the EBCDIC code, and the top row for the 
second hex character of the EBCDIC code.  For example, the standard EBCDIC code for A is C1; the 
standard ASCII code for A is 41.  Look at the table above and you see that the cell corresponding to 
EBCDIC C1 has the value 41 in it. 
 
Double-click the cells you want to change and enter the new values.   To assist you in your customization, 
the standard code tables for EBCDIC and ASCII are shown here. 
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EBCDIC Code Page 

 29



 
ASCII Code Page for Terminal Font 
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Create a Custom Keyboard Map 
 
To do this, select, in Display Session Properties>General>Keyboard Type, one of the available Keyboard 
Layouts (the one that best matches the one you want to create) and click on Edit.  Assuming that you chose 
the 101 PC keyboard for U.S. English, the following screen will appear 
 

 
Keyboard Map Page for 101 PC Keyboard 

Select the key, or key plus modifier (Ctrl, Alt, Shift) to which you want to associate a specific action. On the 
upper half of the window, you can see the keyboard Scan-Code and the associated default action. To modify 
the action, click on Edit. The following dialog box will appear: 
 

 
Edit Scancode Map Dialog Box 

From the Action drop-down list, you can select the action that you want to associate with the selected key 
from among the following options: 
• No operation. No action will be performed when you press the key. 
• Host Command. Choose the desired command function from the lower drop-down list. 
• Recorded Key Sequence. If you have previously recorded one or more key sequences, you will see their 

names in the lower drop-down list.  Choose the desired Recorded Sequence from this list. 
• EBCDIC Characters Sequence. Enter the Scan-Code sequence you want to associate to the key.  

Although you can use this to enter multiple characters, like a Recorded Sequence, this option is typically 
used to access some special character not normally seen on a keyboard.  See How To…|Create a Custom 
Language Code Page for a standard code page for EBCDIC.  
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Modify a Printer Passthrough Driver 
Any Passthrough Driver can be customized, and it is also possible to create a new Driver.  To edit an existing 
Passthrough Driver, do the following: 
1. Highlight the connection name in the Configure tab of Connection Manager and activate Edit. 
2. Follow the path Printer Session Properties>Output>Printer Driver. 
3. Select the Driver from the drop-down list and activate Driver Configuration in the Output.  You will 

see a screen with five tabs. 
 
General 

 
Driver General Property Sheet 

This sheet allows you to select: 
• Variable Line Spacing.  If you enable this function you must enter the Inch fractions. 
• Default Tray. 
• Permanent Save.  You must check this box if you wish to save the driver changes. 
• New Driver Name.  This name will appear in the Passthrough Driver drop-down list if you check 

Permanent Save.  The default new name is User- in front of the selected driver name.  But you can enter 
a completely new name if you wish. 
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Transcode Table 

 
Driver Transcode Property Sheet 

This sheet allows you to: 
• Define the Default Code Page. If you want, you can also edit the Code Page by clicking on Edit Code 

Page.  Select a value that you wish to modify, click on Edit, and a Code Page screen will appear where 
you can enter the new value.  See How To…|Create a Custom Language Code Page for editing 
instructions. 

• Customize the Escape sequence used to call the Code Page.  Select the Code Page from the list, activate 
Edit, and an Edit Passthrough Sequence dialog box will appear where you can enter the new value.  

 

 
Transcode Edit Passthrough Sequence Dialog Box 
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Escape Sequences 

 
Driver Escape Sequences Property Sheet 

This sheet allows you to customize all the Escape commands used to perform specific functions.  Select a 
function, activate Edit, and an Edit Passthrough Sequence dialog box will appear.  Make your changes there. 
 

 
Edit Passthrough Sequence Dialog Box 
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Euro 

 
Driver Euro Property Sheet 

This sheet allows you to customize the Escape command used to print the EURO symbol. This special 
function allows you to print the EURO symbol even on those printers that are not EURO ready.  Select the 
command you wish to customize, then activate Edit, and an Edit Passthrough Sequence dialog box will 
appear where you can enter the new value. 
 

 
Edit Passthrough Sequence Dialog Box 
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Font ID 

 
Driver Font ID Property Sheet 

This sheet allows you to customize the Escape commands used to call a Printer Font that has been associated 
with a Host System Font ID.  To edit a Font ID, select the item, activate Edit, and an Edit Font ID and 
Sequence dialog box will appear where you can enter the new value. 
 

 
Edit Font ID and Sequence Dialog Box 

You can also remove a font or add a new font to the list.   If you activate Add, an Edit Font ID and Sequence 
dialog box will appear where you can enter the new values.  
 

 
Return to Table of Contents
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Emulator Operation 
 

Display Session 
 

Menu Bar 
 
Menu-bar commands of the display session window consist of commands and functions that are unique for 
each window (session). 
 

 
Display Session Menu Bar 

The system administrator may disable any or all of the Menu bar commands.  See Editing a Session|Display 
Session|Connection|Advanced|Security Configuration. 
 
If you have a mouse, open the desired menu by left-clicking on the menu name.  Without using a mouse, you 
can view the File menu by pressing and releasing the LeftAlt key.  Then you can use the Tab or 
Left/RightArrow keys to move to other menus.  Or you can press Alt+e/t/v/? to open the Edit/Tools/View/? 
menu. 
 
The Menu bar may be enabled but invisible, if visibility is not enabled in Editing a Session|Display 
Session|Connection|AdvancedAppearance.  In this case, use the mouseless method of menu viewing 
described above 
 

File (Alt) 

 
Display File Menu 

• Connect (n).  A display session typically comes up in the connected state.  But if, for some reason, the 
session is not connected, this command will attempt to connect the display session to the host. 

• Disconnect (d).  This command disconnects the display session from the host.  It is recommended that 
you disconnect only from the Sign-On screen. 

• Properties (p)…  This command allows you to edit/modify the Properties of the display session in use.  
For more information on this function, please refer to Editing a Session|Display Session.  When you 
change properties here, most changes are effective immediately, but some require that you exit the 
session and reopen it. 
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• Print (r).  This command prints the contents of the display screen to the printer designated in Editing a 
Session|Display Session|General|Print Screen Options. 

• Close All (a).  This command closes all active sessions, including printer sessions. 
• Close (c).  This command closes the display session in use. 
 

Edit 

 
Display Edit Menu 

• Cut (t).  This command copies, into the Clipboard, data contained in the selected area and removes it 
from the display.  A mouse is required for this operation, since the mouse cursor is used to draw a box 
around the selected area.  The Cut process is: 
1. Use the mouse cursor to draw a box around the area to be copied.  Be precise when you draw the 

box, or else the paste process may try to copy the data into a restricted area.  The selected area will 
be highlighted in white. 

2. Open the Edit menu. 
3. Activate Cut.   Note: Cut does not duplicate host attributes such as color and intensity.   
4. Return the mouse cursor to the green screen and left click.  The white highlight will disappear. 

• Copy (r).  This command accomplishes the same function as Cut, except that the selected data is not 
removed from the display.  The Copy process is the same as the Cut process, except that you activate 
Copy in Step 3. 

• Copy All (a).  This command copies the entire screen into the Clipboard. 
• Paste (p).  This command pastes the current contents of the Clipboard onto the session window, starting 

at the current cursor position.  If the contents of the clipboard are larger than the space available in the 
presentation space (screen), they may be clipped.  Paste does not overlay the clipboard contents onto 
areas that are protected by the host application. 

 

Tools 

 
Display Tools Menu 

Tools commands allow you to work with the Record/Playback function.  If you regularly do the same things 
when you work with a host system, it is convenient to record the keystrokes you make and have YESterm/IP 
play them back when you want to do the same job again.  Record/Playback allows you to do this. All your 
keystrokes can be saved in a macro file; when you play the file back (Playback), everything that happened 
will be reproduced exactly.  Any macro that you create is available in all display emulation sessions.  For 
more information on how to work with Record/Playback, refer to How To…|Record a Keystrokes Sequence.
 
• Start Recording (s).  This command starts the Keystrokes Recording process. 
• Stop Recording (r).  This command stops the Keystrokes Recording process. 
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Macro Recording Dialog Box 

When you Stop Recording, the Macro Recording dialog box will be displayed, allowing you to save the 
recorded keystrokes into a named file for subsequent playback. 

• Pause Recording (p).  Including a Pause command into a recorded sequence will cause the Playback 
operation to pause at this point in the sequence. This pause is typically used to enter variable data during 
Playback. 

• Delete Macro (d).  This command will bring up the Recorded Macro Delete dialog box. 
 

 
Recorded Macro Delete Dialog Box 

In this box will be a list of the available macros for this session.  Select the one to be deleted and activate 
OK.  This macro will now be deleted from all display emulation sessions. 

• Playback.  No, you don’t see an actual Playback command.  But, at the bottom of the Tools menu below 
the line, you will see a list of the available macros for this session.  Select the one to be played and press 
the PC Enter key; that macro will then be executed. 

 
View 
Commands in the View menu are used to manipulate the Emulator display window. 
 

 
Display View Menu 
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• Toolbar-Menu (t).  This toggle command hides or displays the Menu and Buttons toolbars.  After you 
hide the toolbars, you will have to use LeftAlt and the Arrow keys to access menu options. 

• Ruler (r).  This toggle command hides or displays the crosshairs Ruler.  It has the same effect as the 
Rule key on the keyboard.  When the command is checked, the Ruler is displayed.   

• Attributes (a).  This toggle command hides or displays the 5250 attribute fields. 
• Advanced View (d).  This toggle command activates/deactivates the graphics Windows look, with Hot 

Spots displayed as raised buttons if they have been enabled. 
 

 
Emulation Screen with Advanced View and Hot Spots 

Hot Spots are only useful if you have a mouse.  For more information on the Hot Spot feature, refer to 
Editing a Session|Display Session|Hot Spot. 
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• Keypad (k).  This toggle command hides or displays the Key Pad.  The Key Pad can be repositioned as 
desired on the screen by dragging and dropping. 

 

 
Partial Emulation Screen Showing Keypad 

Key Pad is only useful if you have a mouse.  For more information on the Key Pad feature, refer to  
Editing a Session|Display Session|Key Pad. 

 

? 

 
Display Help Menu 

• Contents (c).  This command is not used in the TBT. 
• Keyboard Help… (k).  This command displays the keyboard map in use. You can see the mapping, but 

you cannot edit it from this screen.  This display can be used in two ways: 
1. If you click on a key to which a command has been mapped, you will see that command highlighted 

in the List Box. 
2. If you highlight a command in the List Box, the key or key combination that executes that command 

will be highlighted on the keyboard graphic.  Some commands can be executed from several 
different key combinations.  In that case, you will see the notation (x of y), which indicates that this 
is the xth sequence out of y possibilities.  To cycle through the combinations for that command, click 
on Next Sequence. 

• About… (a).  This command displays detailed information on the YESterm/IP program such as version, 
copyrights, and other useful information. 
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Buttons Bar 
 
The Buttons bar is displayed across the top of the application window to the right of the Menu bar. The 
Buttons bar provides quick access to commands you use on a regular basis, if you have a mouse.  If you do 
not need it, you can hide it and the Menu bar to increase the size of your display window. When the toolbar 
is displayed, a check mark appears next to the Toolbar option in the View menu. 
 

 
Display Session Buttons Bar 

The system administrator may disable any or all of the Menu bar commands.  See Editing a SessionDisplay 
Session|Advanced|Security Configuration. 
 
The command/button definitions are: 
 

 
Connect.  Duplicates the function of the menu File>Connect command. 
 

 
Disconnect.  Duplicates the function of the menu File>Disconnect command. 
 

 
Print.  Duplicates the function of the menu File>Print command. 
 

 
Properties.  Duplicates the function of the menu File>Properties command. 
 

 
Copy.  Duplicates the function of the menu Edit>Copy command. 
 

 
Paste.  Duplicates the function of the menu Edit>Paste command 
 

 
Start Recording.  Duplicates the function of the menu Tools>Start Recording command.  In fact, if you use 
the menu version, you will see that this button is also depressed. 
 

 
Pause.  Duplicates the function of the menu Tools>Pause command.  If you use the menu version, you will 
see that this button is also depressed. 

 
Stop Recording.  Duplicates the function of the menu Tools>Stop Recording command. 
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Playback.  Displays a list of available macros.  Click on the one to be played, and that macro will then be 
executed. 
 

 
Ruler.  Duplicates the function of the menu View>Ruler command. 
 

 
Attributes.  Duplicates the function of the menu View>Attributes command. 
 

 
Hot Spots. Duplicates the function of the menu View>Advanced View command. 
 

 
Keypad.  Duplicates the function of the menu View>Keypad command. 
 

 
Keyboard Help.  Duplicates the function of the menu ?>Keyboard Help command. 
 

 
I, II, III, IV.  These buttons correspond to the emulation sessions shown in order in the Terminal 
Connections Manager screen.  Inactive sessions will have corresponding grayed-out buttons, while buttons 
for active sessions will not be grayed-out.  To jump to another active session, just click on the button for that 
session. 
 

Printer Session 
 

Menu Bar 
 
Menu-bar commands of the printer session window consist of commands and functions that are unique for 
each printer window (session). 
 
If you have a mouse, open the desired menu by left-clicking on the menu name.  Without using a mouse, you 
can view the File menu by pressing and releasing the LeftAlt key.  Then you can use the Tab or 
RightArrow keys to move to other menus.  Or you can press Alt+t/? to open the Tools or ? menu. 
 

 
Printer Session Menu Bar 
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File (Alt) 

 
Printer File Menu 

• Connect (n).  A printer session typically comes up in the connected state.  But if, for some reason, the 
session is not connected, this command will attempt to connect the printer session to the host. 

• Disconnect (d).  This command disconnects the printer session from the host. 
• Properties… (p).  This command allows you to view/edit/modify the Properties of the printer session in 

use.  It will be grayed out and inactive unless it has been enabled in Editing a Session|Printer 
Sessions|Miscellaneous.  For more information on Properties, please refer to Editing a Session|Printer 
Session.  When you change properties here, most changes are effective immediately. 

• Close (c).  This command closes the printer session. 
 
Tools 

 
Printer Tools Menu 

• Abort Print Job (a).  This command aborts the print job in process. 
• Clear Document List (c).  This command clears the Document List.  The Document List contains a 

history of all documents printed since the session was started. 
. 

? 

 
Printer Help Menu 

 
• Contents (c).  This command is not used in the TBT.  
• About… (a).  This command displays detailed information on the YESterm/IP program such as version, 

copyrights, and other useful information. 
 

Buttons Bar 
 
The Buttons bar is displayed across the top of the application window to the right of the Menu bar. The 
Buttons bar provides quick access, if you have a mouse, to commands you use on a regular basis. 
 

 
Printer Session Buttons Bar 
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The command/button definitions are: 

 
Connect.  Duplicates the function of the menu File>Connect command. 
 

 
Disconnect.  Duplicates the function of the menu File>Disconnect command. 
 

 
Properties.  Duplicates the function of the menu File>Properties command. 
 

 
Contents.  Duplicates the function of the menu ?>Contents command. 
 

 
I, II, III, IV.  These buttons correspond to the emulation sessions shown in order in the Terminal 
Connections Manager screen.  Inactive sessions will have corresponding grayed-out buttons, while buttons 
for active sessions will not be grayed-out.  To jump to another active session, just click on the 
button for that session. 
 

How To …. 
 

Record a Keystrokes Sequence (Macro) 
 
If you regularly do the same things when you work with a host system, it is convenient to record the 
keystrokes you make and have YESterm/IP play them back when you want to do the same job again.  
Record/Playback allows you to do this. All your keystrokes can be saved in a file; when you play the file 
back (Playback), everything that happened will be reproduced   The macro that you create is available in all 
display emulation sessions of the same type; a 5250 macro will not be seen in a 3270 display session, and 
vice versa. 
 
 
Note: Macros are limited to 512 data “items”.  A character keystroke counts as one item, while a cursor 
movement keystroke counts as two items.  If you try to enter more than 512 items, an error message will 
appear and a spurious character will be attached to the macro that may make the macro useless. 
 
Graphics Display Session 
When configuring a display emulation session, you have the choice of a graphics display mode or a 5250 text 
display mode.  See Editing a Session|Display Session|Advanced|Appearance for details on making this 
choice. 
 
In order to create a Keystroke sequence in a graphics display session, you have to: 
1. Open a display session. 
2. Place the cursor in the field where you wish to start the sequence. 
3. Activate Tools>Start Recording or press the Recrd key or click on the corresponding Toolbar button.  

You will see, in the center of the Status bar, the information REC: 0.  This tells you how much 
information has been entered into the macro. 

4. Type the data and cursor movements that you want to record.  As you type, the information counter will 
advance by one for each character and by two for each cursor movement. 
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5. Stop the Recording by clicking on Tools|Stop Recording or on the corresponding button. 
6. You will see the Macro Recording dialog box.  Name the recorded Keystroke sequence.  There are no 

naming restrictions. 
 
Example: 
Assume you want to record the CL command to display the description of a specific device. The command is 
WRKDEVD PRTXXXX, where PRTXXXX identifies a specific Printer.  So, the procedure is: 
1. Place the cursor. 
2. Click on Start the Recording. 
3. Type WRKDEVD 
4. Click on Pause. 
5. Type PRTXXXX (the name of the device) and press Enter. 
6. Click on Stop the Recording. When you stop, you will be prompted to save the recorded keystrokes to a 

file. 
Note: The Pause function will automatically end when you press the Enter key. 
 
Text Display Session 
In a text display session, you can record a macro in exactly the same way as in a graphics display session 
(see above).  But you also have another option if you are using a 122-key keyboard.  This additional 
procedure for recording macros is as follows: 
1. Place the cursor in the field where you want to record the macro. 
2. Press Recrd.  You will see, in the right-hand side of the Status bar, 24 tiny squares representing the 24 F 

keys.  A filled-in square designates an F key that already has an assigned macro. 
3. Press the F key that you wish to associate with the forthcoming macro.  You will see the square for that 

key become a filled-in square. 
4. Type the data and cursor movements that you want to record 
5. Press Recrd again.  This ends the recording process, and the squares will disappear. 
 
 

Play a Recorded Keystrokes Sequence (Macro) 
 

Graphics Display Session 
In order to play a recorded keystrokes sequence in a graphics display session, you have to: 
1. Place the cursor on the screen where you want to play the sequence. 
2. Activate Tools or press the Play key or click on the corresponding Toolbar button.  You will see a list of 

available macros. 
3. Select the sequence from the prompted list of stored sequence.  The sequence will be executed. 
 
If you have assigned a sequence to a key, you can also play the sequence as follows: 
1. Place the cursor on the screen where you want to play the sequence. 
2. Press the designated key.  The sequence will be executed. 
 
Text Display Session 
In a text display session, you can play back a macro in exactly the same way as in a graphics display session 
(see above).  But you also have another option if you are using a 122-key keyboard and if you have used the 
alternate method of sequence recording.  This additional procedure for playing macros is as follows: 
1. Place the cursor on the screen where you want to play the sequence. 
2. Press Play.  You will see, in the right-hand side of the Status bar, 24 tiny squares representing the 24 F 

keys.  A filled-in square designates an F key that has an assigned macro. 
3. Press the F key corresponding to the desired macro.  The macro will be executed, and the squares will 

disappear. 
 

Return to Table of Contents
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Support 
 

Affirmative Computer Products offers Technical Support services for all the Affirmative products.  You can 
access Affirmative Technical Support in one of the following ways: 
 
• via Phone 

o 480-946-1444 
o 888-353-5250 

• via Fax 
o 480-946-9250 

• via E-mail 
o support@affirmative.net 

 
 

Return to Table of Contents
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