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YEStation Limited Warranty 
 

General Terms and Conditions 
 
Limited Product Warranty.  Affirmative Computer Products warrants that the YEStation Hardware 
Product (Logic unit and keyboard) shall be free from defects in materials and workmanship that arise 
under proper and normal use and service for three years from the date of purchase.  A warranty 
extension of two years is available at extra cost, if obtained at the time of the original YEStation 
purchase.  In the event that the YEStation Hardware Product fails to comply with the warranty set forth 
above, Affirmative Computer Products will repair or replace the Product. 
 
 
Software Warranty.  Affirmative Computer Products warrants that, for a period of ninety (90) days 
from the date of purchase by the End User, its Software Products shall conform to its published 
specifications under normal usage.  AFFIRMATIVE COMPUTER PRODUCTS DOES NOT 
WARRANT THAT THE OPERATION OF THE SOFTWARE WILL BE UNINTERRUPTED OR 
ERROR FREE, OR THAT ALL SOFTWARE DEFECTS WILL BE CORRECTED.  In the event that a 
Software Product fails to comply with the warranty set forth above, Affirmative Computer Products 
will replace the product.  End User must, however, return all copies of the Software, along with proof 
of purchase, to Affirmative Computer Products within 90 days from the Software purchase date. 
 
 
Warranty Limitations.  End User’s sole remedy under any Warranty provided by Affirmative 
Computer Products shall be limited to the replacement or repair of the Product or, at Affirmative 
Computer Products’ sole discretion, a refund of the purchase price.  AFFIRMATIVE COMPUTER 
PRODUCTS GRANTS NO WARRANTY, EXPRESS OR IMPLIED, OTHER THAN THE 
WARRANTIES STATED ABOVE.  EXPRESSLY EXCLUDED ARE THE IMPLIED 
WARRANTIES OF MERCHANTIBILITY AND FITNESS FOR A PARTICULAR PURPOSE.  IN 
NO EVENT SHALL AFFIRMATIVE COMPUTER PRODUCTS BE LIABLE FOR SPECIAL, 
INCIDENTAL, OR CONSEQUENTIAL DAMAGES, INSTALLATION COSTS, LOST REVENUE 
OR PROFITS, OR ANY OTHER COSTS INCURRED AS A RESULT OF THE USE OF ANY 
AFFIRMATIVE COMPUTER PRODUCTS PRODUCT, WHETHER OR NOT USED IN 
ACCORDANCE WITH INSTRUCTIONS. 
 
 
Warranty Procedure.  Affirmative Computer Products will replace or repair any defective, 
undamaged units for which a Return Material Authorization number (RMA#) has been obtained from 
the Technical Support Department.  (Contact 888-353-5250 or 480-946-1444 or 
support@affirmative.net) 
 

 iii

mailto:support@affirmative.net


 
 

Copyright and Trademarks    
 

Copyright Notice               
This manual, as well as the software described in it, is furnished under license. No part of this 
publication may be reproduced, transmitted, stored in a retrieval system, or translated into any human 
or computer language, in any form or by any means, electronic, mechanical, magnetic, optical, 
chemical, manual or otherwise, without the prior written permission of the copyright owner. 

Note: Information in this document is subject to change without notice.  
 

Trademarks Notice  
• YEStation® is a registered trademark of Affirmative Computer Products® 
• YESterm/IP™  is a trademark of Affirmative Computer Products® 
• Microsoft® is a registered trademark of Microsoft® Corporation.  

• Windows® is a registered trademark of Microsoft® Corporation.   

• ICA® is a registered trademark of Citrix® Systems Inc.  

• MetaFrame® is a trademark of Citrix® Systems Inc.  

• Adobe®, the Adobe logo, Acrobat®, the Acrobat logo, and Acrobat Reader are trademarks or 
registered trademarks of Adobe Systems Incorporated. 

• Micro Touch® is a trademark of Micro Touch® Inc.  

• Ericom® and PowerTerm® are registered trademarks of Ericom® Software Ltd. 

• Other company and brand, product and service names are trademarks or registered trademarks 
of their respective holders.  
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End User License Agreement    

 

End User License Agreement (EULA)    

EULA for Microsoft Windows CE Operating System for Windows-based Terminal Devices 
Version 1.5 

IMPORTANT! READ CAREFULLY 

This End User License Agreement (EULA) is a legal agreement between you (either an individual or a 
single entity) and the manufacturer (MANUFACTURER) of the special purpose computing device 
(SYSTEM) you acquired which includes certain Microsoft software product(s) installed on the 
SYSTEM and/or included in the SYSTEM package (SOFTWARE). The SOFTWARE includes 
computer software, the associated media, any printed materials, and any online or electronic 
documentation. By installing, copying or otherwise using the SOFTWARE, you agree to be bound by 
the terms of this EULA. If you do not agree to the terms of this EULA, MANUFACTURER and 
Microsoft Licensing, Inc. (MS) are unwilling to license the SOFTWARE to you. In such event, you 
may not use or copy the SOFTWARE, and you should promptly contact MANUFACTURER for 
instructions on return of the unused product(s) for a refund. 

SOFTWARE LICENSE 

The SOFTWARE is protected by copyright laws and international copyright treaties, as well as other 
intellectual property laws and treaties. The SOFTWARE is licensed, not sold. 

1. GRANT OF LICENSE 

SOFTWARE includes software already installed on the SYSTEM (SYSTEM 
SOFTWARE) and, if included in the SYSTEM package, software contained on the CD-
ROM disk and/or floppy disk(s) labeled "Desktop Software for Microsoft Windows CE" 
(DESKTOP SOFTWARE). This EULA grants you the following rights to the 
SOFTWARE: 

• System Software.  

You may use the SYSTEM SOFTWARE only as installed in the SYSTEM. 
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• Desktop Software.  

DESKTOP SOFTWARE might not be included with your SYSTEM. If DESKTOP 
SOFTWARE is included with your SYSTEM, you may install and use the component(s) 
of the DESKTOP SOFTWARE in accordance with the terms of the end user license 
agreement provided with such component(s). In the absence of a separate end user 
license agreement for particular component(s) of the DESKTOP SOFTWARE, you may 
install and use only one (1) copy of such component(s) on a single computer with which 
you use the SYSTEM. 

• Use of Windows CE Operating System for Windows-Based Terminal Devices with 
Microsoft Windows NT Server, Terminal Server Edition.  

If the SOFTWARE is Windows CE operating system for Windows-Based Terminal 
devices, the following special provisions apply. In order to use the SYSTEM in 
connection with Windows NT Server, Terminal Server Edition, you must possess (1) a 
Client Access License for Windows NT Server, Terminal Server Edition and (2) an end 
user license for Windows NT Workstation or an end user license agreement for 
Windows NT Workstation for Windows-Based Terminal Devices (please refer to the end 
user license agreement for Windows NT Server, Terminal Server Edition for additional 
information). MANUFACTURER may have included a Certificate of Authenticity for 
Windows NT Workstation for Windows-Based Terminal Devices with the SYSTEM. In 
that case, this EULA constitutes an end user license for the version of Windows NT 
Workstation for Windows-Based Terminal Devices indicated on such Certificate of 
Authenticity. 

• Back-up Copy.  

If MANUFACTURER has not included a back-up copy of the SYSTEM SOFTWARE 
with the SYSTEM, you may make a single back-up copy of the SYSTEM SOFTWARE. 
You may use the back-up copy solely for archival purposes. 

2. Description of Other Rights and Limitations.  

• Speech/Handwriting Recognition  

If the SYSTEM SOFTWARE includes speech and/or handwriting recognition 
component(s), you should understand that speech and handwriting recognition are 
inherently statistical processes; that recognition errors are inherent in the processes; that 
it is your responsibility to provide for handling such errors and to monitor the 
recognition processes and correct any errors. Neither MANUFACTURER nor its 
suppliers shall be liable for any damages arising out of errors in the speech and 
handwriting recognition processes. 
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• Limitations on Reverse Engineering, Recompilation and Disassembly  

You may not reverse engineer, decompile, or disassemble the SYSTEM SOFTWARE, 
except and only to the extent that such activity is expressly permitted by applicable law 
notwithstanding this limitation. 

• Single SYSTEM  

The SYSTEM SOFTWARE is licensed with the SYSTEM as a single integrated 
product. The SYSTEM SOFTWARE installed in Read Only Memory (ROM) of the 
SYSTEM may only be used as part of the SYSTEM. 

• Single EULA  

The package for the SYSTEM SOFTWARE may contain multiple versions of this 
EULA, such as multiple translations and/or multiple media versions (e.g., in the user 
documentation and in the software). Even if you receive multiple versions of the EULA, 
you are licensed to use only one (1) copy of the SYSTEM SOFTWARE. 

• Rental  

You may not rent or lease the SOFTWARE. 

• Software Transfer  

You may permanently transfer all of your rights under this EULA only as part of a sale 
or transfer of the SYSTEM, provided you retain no copies, you transfer all of the 
SOFTWARE (including all component parts, the media, any upgrades or backup copies, 
this EULA and, if applicable, the Certificate(s) of Authenticity), and the recipient agrees 
to the terms of this EULA. If the SOFTWARE is an upgrade, any transfer must include 
all prior versions of the SOFTWARE. 

• Termination  

Without prejudice to any other rights, MANUFACTURER or MS may terminate this 
EULA if you fail to comply with the terms and conditions of this EULA. In such event, 
you must destroy all copies of the SOFTWARE and all of its component parts. 

3. Upgrades.  

If the SYSTEM SOFTWARE and this EULA are provided separate from the SYSTEM 
by MANUFACTURER and the SYSTEM SOFTWARE is on a ROM chip, CD ROM 
disk(s) or floppy disk(s), and labeled "For ROM Upgrade Purposes Only" ("ROM 
Upgrade"), you may install one copy of the ROM Upgrade onto the SYSTEM as a 
replacement copy for the SYSTEM SOFTWARE originally installed on the SYSTEM 
and use it in accordance with Section 1 of this EULA. 

4. Copyright. 

All title and copyrights in and to the SOFTWARE (including but not limited to any 
images, photographs, animations, video, audio, music, text and "applets," incorporated 
into the SOFTWARE), the accompanying printed materials, and any copies of the 
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SOFTWARE, are owned by MS or its suppliers (including Microsoft Corporation). You 
may not copy the printed materials accompanying the SOFTWARE. All rights not 
specifically granted under this EULA are reserved by MS and its suppliers (including 
Microsoft Corporation). 

5. Product Support. 

Product support for the SOFTWARE is not provided by MS, its parent corporation, 
Microsoft Corporation, or their affiliates or subsidiaries. For product support, please 
refer to MANUFACTURER’S support number provided in the documentation for the 
SYSTEM. Should you have any questions concerning this EULA, or if you desire to 
contact MANUFACTURER for any other reason, please refer to the address provided in 
the documentation for the SYSTEM. 

6. Export Restrictions. 

You agree that you will not export or re-export the SOFTWARE to any country, person, 
or entity subject to U.S. export restrictions. You specifically agree not to export or re-
export the SOFTWARE: (i) to any country to which the U.S. has embargoed or 
restricted the export of goods or services, which as of March 1998 include, but are not 
necessarily limited to Cuba, Iran, Iraq, Libya, North Korea, Sudan and Syria, or to any 
national of any such country, wherever located, who intends to transmit or transport the 
products back to such country; (ii) to any person or entity who you know or have reason 
to know will utilize the SOFTWARE or portion thereof in the design, development or 
production of nuclear, chemical or biological weapons; or (iii) to any person or entity 
who has been prohibited from participating in U.S. export transactions by any federal 
agency of the U.S. government.  

If the SOFTWARE is labeled "North America Only Version" above, on the Product 
Identification Card, or on the SOFTWARE packaging or other written materials, then 
the following applies: The SOFTWARE is intended for distribution only in the United 
States, its territories and possessions (including Puerto Rico, Guam, and U.S. Virgin 
Islands) and Canada. Export of the SOFTWARE from the United States is regulated 
under "EI controls" of the Export Administration Regulations (EAR, 15 CFR 730-744) 
of the U.S. Commerce Department, Bureau of Export Administration (BXA). A license 
is required to export the SOFTWARE outside the United States or Canada. You agree 
that you will not directly or indirectly, export or re-export the SOFTWARE (or portions 
thereof) to any country, other than Canada, or to any person or entity subject to U.S. 
export restrictions without first obtaining a Commerce Department export license. You 
warrant and represent that neither the BXA nor any other U.S. federal agency has 
suspended, revoked or denied your export privileges. 

7. Note on Java Support. 

The SYSTEM SOFTWARE may contain support for programs written in Java. Java 
technology is not fault tolerant and is not designed, manufactured, or intended for use or 
resale as on-line control equipment in hazardous environments requiring fail-safe 
performance, such as in the operation of nuclear facilities, aircraft navigation or 
communication systems, air traffic control, direct life support machines, or weapons 
systems, in which the failure of Java technology could lead directly to death, personal 
injury, or severe physical or environmental damage. 
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8. Limited Warranty.  

• Limited Warranty  

MANUFACTURER warrants that the SOFTWARE will perform substantially in 
accordance with the accompanying written materials for a period of ninety (90) days 
from the date of receipt. Any implied warranties on the SOFTWARE are limited to 
ninety (90) days. Some states/jurisdictions do not allow limitations on duration of an 
implied warranty, so the above limitation may not apply to you. 

• Customer Remedies  

MANUFACTURER’S and its suppliers’ entire liability and your exclusive remedy shall 
be, at MANUFACTURER’S option, either (a) return of the price paid, or (b) repair or 
replacement of the SOFTWARE that does not meet the above Limited Warranty and 
which is returned to MANUFACTURER with a copy of your receipt. This Limited 
Warranty is void if failure of the SOFTWARE has resulted from accident, abuse, or 
misapplication. Any replacement SOFTWARE will be warranted for the remainder of 
the original warranty period or thirty (30) days, whichever is longer. 

• No Other Warranties  

EXCEPT AS EXPRESSLY PROVIDED IN THE LIMITED WARRANTY SECTION 
ABOVE, THE SOFTWARE IS PROVIDED TO THE END USER "AS IS" WITHOUT 
WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, 
BUT NOT LIMITED TO, WARRANTIES OF NON- INFRINGEMENT, 
MERCHANTABILITY, AND/OR FITNESS FOR A PARTICULAR PURPOSE. THE 
ENTIRE RISK OF THE QUALITY AND PERFORMANCE OF THE SOFTWARE IS 
WITH YOU. 

• No Liability for Consequential Damages  

MANUFACTURER OR MANUFACTURER’S SUPPLIERS, INCLUDING MS AND 
ITS SUPPLIERS, SHALL NOT BE HELD TO ANY LIABILITY FOR ANY 
DAMAGES SUFFERED OR INCURRED BY THE END USER (INCLUDING, BUT 
NOT LIMITED TO, GENERAL, SPECIAL, CONSEQUENTIAL OR INCIDENTAL 
DAMAGES INCLUDING DAMAGES FOR LOSS OF BUSINESS PROFITS, 
BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION AND THE 
LIKE), ARISING FROM OR IN CONNECTION WITH THE DELIVERY, USE OR 
PERFORMANCE OF THE SOFTWARE. 

If you acquired this EULA in the United States, this EULA is governed by the laws of the State of 
Washington. 

If you acquired this EULA in Canada, this EULA is governed by the laws of the Province of Ontario, 
Canada. Each of the parties hereto irrevocably attorns to the jurisdiction of the courts of the Province of 
Ontario and further agrees to commence any litigation which may arise hereunder in the courts located 
in the Judicial District of York, Province of Ontario. 

If this EULA was acquired outside the United States, then local law may apply. 

Should you have any questions concerning this EULA, please contact the MANUFACTURER of your 
SYSTEM. 
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U.S. GOVERNMENT RESTRICTED RIGHTS 

The SOFTWARE and documentation are provided with RESTRICTED RIGHTS. Use, duplication, or 
disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the 
Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 or subparagraphs 
(c)(1) and (2) of the Commercial Computer Software XRestricted Rights at 48 CFR 52.227- 19, as 
applicable. MANUFACTURER is Microsoft Corporation/One Microsoft Way/Redmond, WA 98052-
6399.  
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Installing Your Terminal 
 

 
• Your terminal has no internal fan, and relies on natural airflow for cooling.   When you mount it, 

make sure to keep as many ventilation holes, as possible, unobstructed. 
• DO NOT use any AC-DC adapter other than the one provided with the terminal or acquired from 

Affirmative Computer Products or its distributors 
 

22xx Terminals 
 

Mounting 
 
The 22xx terminal can be placed horizontally on a flat surface, or it can be mounted vertically on a 
wall.  A self-adhesive template and four #3, ½-inch wood screws are included with every terminal.   
The following figure shows one mounting possibility. 
 

 
22xx Wall Mounting 

 1



Another possibility is shown here. 
 

 
22xx Monitor Mounting 

We have done some testing with the provided screws, and have the following suggestions: 
• In soft wood, such as pine, no pilot holes are needed. 
• In hard wood or plastic, such as the side of a monitor, drill pilot holes with a 3/64” drill bit. 
• In dry wall, these screws do not hold well; if you must install on dry wall, we suggest: 

o Drill 3/64” pilot holes and put super glue in the holes before inserting the screws. 
Or 
o Use longer screws with coarser threads. 

 

Cabling 
 
Please make all cable connections before turning on the power. The following figures show the 22xx 
rear and front connectors. 
 

 
22xx Rear Connectors 
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22xx Front Connectors 

Power On and Boot Up 
 
1. Turn on the terminal after all rear panel connections have been made. 
2. The translucent Power button will change from faint orange to light green. 
3. You will see the message Starting System.  Please Wait … on a black screen. 
4. After several seconds, you will see the Affirmative Computer Products logo screen with the 

message Loading and a series of dots at the bottom. 
5. After several seconds, you will see a blank grey screen. 
6. After approximately ten seconds, the first dialog box of the Setup Wizard will appear if the 22xx 

has not been pre-configured. Refer to WBT Setup Wizard for setup instructions. If setup has already 
been done, the 22xx will come up in the Terminal Connections Management screen. 

 

26xx Terminals 
 

Mounting 
 
The 26xx terminal can be placed vertically on a flat surface, using the provided stand, or it can be 
mounted permanently using the provided brackets. 
• Vertical Mounting.  See the picture on the front cover of this manual. 
• Permanent Mounting.  The 26xx terminal can be mounted permanently on a desk or under a table or 

attached to a wall. The following figures show two possible mounting procedures 
 

 3



 
                            Mounting the 26xx on a desk or a wall 

 
 

 
                    Mounting the 26xx under a table 
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Cabling 
 
Please make all cable connections before turning on the power. The following figures show the 26xx 
connectors on the rear panel.   

 
26xx Rear Panel 

 
 

 
26xx Rear Panel with PCMCIA Slot 

 

Power On and Boot Up 
 
There are three LED indicator lights placed together on the front panel: 
• Power (on the right or bottom).  This indicator is on when the terminal has been powered up. 
• Network Connection (on the left or top).  This indicator is on when there is a good physical 

connection to the Local Area Network. 
• Network Activity (in the middle).  This indicator flashes to indicate LAN activity. 
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1. Turn on the terminal after all cable connections have been made. 
2. The Power and Network Connection lights should come on immediately. 
3. You will briefly see some information and the message Loading Win CE … Go on a black screen, 

and the Network Connection LED should start to flash slowly. 
4. You will see the Affirmative Computer Products logo screen with the message Loading and a series 

of dots at the bottom. 
5. After initial setup, if you are using a PCMCIA wireless LAN adapter to connect to your LAN, you 

may see, depending upon the settings in Configure Terminal Properties|Control Panel|Wireless, a 
Checking Wireless IP window with the message Checking Wireless… until your adapter has 
connected to an access point.   

6. After approximately 10-15 seconds, the first dialog box of the Setup Wizard will appear if the 26xx 
has not been pre-configured. Refer to WBT Setup Wizard for setup instructions. If setup has already 
been done, the 26xx will come up in the Terminal Connection Manager screen or in an Autostart 
session. 

 

733x Terminals 
 

Cabling 
 
Please make all cable connections before turning on the power. The following figure shows the 733x 
connectors seen from the bottom of the terminal display/logic unit. 
 

 
733x Connectors 

 

Power On and Boot Up 
 
1. Turn on the terminal using the small Power button at the lower right corner of the display/logic 

unit. 
2. The Power light (at the left of the Power button) should come on immediately. 
3. You will briefly see the message Loading Win CE … Go on a black screen. 
4. You will see the Affirmative Computer Products logo screen. 
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5. After approximately fifteen seconds, the first dialog box of the Setup Wizard will appear if the 733x 
has not been pre-configured. Refer to WBT Setup Wizard for setup instructions. If setup has already 
been done, the 733x will come up in the Terminal Connections Management screen. 

 
Return to Table of Contents 
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WBT Setup Wizard 
 

The WBT Setup Wizard is used for the terminal initial setup. The wizard runs when: 
• A terminal is first booted up after being received from the factory. 
• A terminal is reset to factory defaults and then rebooted. 
• The terminal firmware is upgraded and the terminal is rebooted. 
 
The WBT Setup Wizard sets the basic terminal network configuration, display, and printer parameters. 
Any parameters set in the WBT Setup Wizard can be changed later from Terminal Properties. You can 
launch Terminal Properties by pressing the F2 key at any time from the Terminal Connection Manager 
window.  Please refer to Configure Terminal Properties. 
 
When proceeding through the WBT Setup Wizard process: 
• Activate the Next or Accept buttons to display the next dialog box in the sequence. 
• Activate the Back button to return to the previous dialog box. 
• Activate the Cancel or X button to quit and display the terminal's Terminal Connection Manager. 
  
The WBT Setup Wizard dialog boxes are discussed here in the order in which they will appear on your 
terminal. 
 

 
EULA Dialog Box  

Please read the license agreement carefully before you click on Accept. 
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IP Address Dialog Box 

• Select Yes to use the IP address information supplied by the DHCP server.  Then the next screen 
will be the Name Servers dialog box. 

• Select No to use static IP address information. Then the next screen will be the Specify an IP 
Address dialog box. 

• If this is a 26xx terminal, you will also see a warning here that this part of the setup is only for use if 
you are making a cable connection to the LAN. 

 
NOTE: If you are using a wireless LAN adapter to connect to your LAN, be sure to select Yes and 
then ignore the following Name Servers dialog box. 
 
 

 

Specify an IP Address Dialog Box 

• Ask your network administrator for the IP addresses to enter here. 
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• For identification purposes by network management software, we recommend that you enter a 
unique name in the Terminal Name field.  If you don’t see this dialog box, because you are not 
specifying an IP address, you can enter a terminal name later in Terminal Properties (see Configure 
Terminal Properties|General). 

 
NOTE: If you are using a wireless LAN adapter to connect to your LAN, you shouldn’t see this 
dialog box.  Back up one screen and select Yes. 
 
 

 
Name Servers Dialog Box 

• If you specify an IP address, you will have to enter name server information here if you are going to 
browse the Web. 

• If you use a DHCP server for IP addressing, you may still have to enter information here for Web 
browsing, depending upon how the DHCP server is configured. 

 
NOTE: If you are using a wireless LAN adapter to connect to your LAN, ignore the Name 
Servers dialog box. 
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Desktop Area/Refresh Freq. Dialog Box 

Note: The default setting is 800 x 600 8bpp @ 75Hz, not “Best Available Using DDC” as shown in the 
screen shot. 
If you select a different setting from the drop-down list, please be sure to use the Test button before 
proceeding.  If you enter a setting that your monitor cannot support, you will be faced with an unusable 
screen when you reboot the terminal.  See Troubleshooting Q&A if this occurs. 
 
 

 
Browser Setup Dialog Box 

If you have a Model 2x12 or 2x13 terminal, you will see the above screen. 
• If you select Yes, you will then be faced with several more browser setup screens that provide you 

with some of the usual Internet Explorer browser options. 
• If you select No, you will advance to the Printer Setup dialog box. 
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Browser URL Dialog Box 

 
 

 

 
Browser Preferences Dialog Box 
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Browser History and Favorites Dialog Box 

 
 

 
Browser Connection Dialog Box 
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Browser Proxy Server Dialog Box 

This is the last dialog box for browser setup.  Next is the Local Printer Setup dialog box. 
 
 

 
Local Printer Setup Dialog Box 

• If you select Yes here, you will be faced with several more dialog boxes used to configure printer 
properties.  You should only answer Yes if you wish to use a local attached printer in ICA or RDP 
sessions.  If you only want to use a local printer for text emulation sessions, you answer No here, 
and printer setup is done within the text emulation setup. 

• If you select No, you will advance to the Finish dialog box. 
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Select Printer Port Dialog Box 

• You must select a printer port.  You can have more than one local printer, but each one must be 
assigned to a different printer port.  If you have a USB printer already connected to the terminal, 
you will see a USB option in the drop-down list, as well as the typical LPT1, COM1/2 (non-22xx 
terminals), and Network options. 

• If you select a network printer, enter the printer network path in the Network field.  You can have 
multiple network printers. 

• If you select a COM port (not applicable for 22xx terminals), The default properties are 19200 
baud, 8-N-1, Hardware Flow Control.  If you want to change any of these properties, you must 
add a bogus Dial-Up connection in Terminal Connection Manager  Configure for your printer 
COM port and configure the properties there.  See Creating a New Connection|Dial-Up 
Client|Configure for more information. 

 
Select the Printer Model Dialog Box (not shown) 

• Select a printer manufacturer from the manufacturer drop-down list.  After you select the 
manufacturer, the right-hand drop-down list will provide a list of models for that manufacturer. 

• Select the printer model.  If your model is not shown here, try to find a compatible printer in the list.  
It may be that your printer is compatible with a model from a different manufacturer.  If that is the 
case, go back, change the manufacturer selection, and then choose the compatible model from that 
drop-down list.  Note:  There are no local Windows printer drivers in these terminals.  You must 
have a driver in your Windows Terminal Server that corresponds to the selected model. 

• Another option, if your printer is not found in the lists, is to check User Defined.  In this case, you 
should then enter the model name, in the Model Name field, that corresponds to the printer driver 
on your Windows Terminal Server. 
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Name Your Printer Dialog Box 

You must provide a “friendly” name for your printer.  This name will identify your printer in the 
Printers settings dialog box on your server. The default name is the model name that you selected in the 
previous dialog box. 
 
 

 
Set Default Printer Dialog Box 

Select whether or not you want this local printer to be the default printer for your Windows (ICA and 
RDP session) applications. 
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Configure Another Printer Dialog Box 

You are given the opportunity to begin the configuration of another printer.  If you select Yes, you will 
repeat the above dialog boxes for that printer.  If you select No, you will go on to the Finish dialog box.  
 
 

 
Finish Dialog Box  

Click on Finish to apply your selections.  Depending upon the selections you have make, the terminal 
will either reboot or go to the Terminal Connection Manager screen. 
Click on Back to return to the previous dialog box. 
Click on X or Cancel to forget the whole thing and go to the Terminal Connection Manager screen.  If 
you do this, you will be faced with the WBT Setup Wizard again the next time you restart the terminal. 
                                                    

Return to Table of Contents
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Configure Terminal Properties 
 

Using the Terminal Properties window, you can change the terminal properties. Invoke this window by 
pressing the F2 key in the Terminal Connection Manager window.  The Terminal Properties window 
consists of seven (22xx terminals) or eight property sheets that can be invoked by activating their 
individual tabs.  You will not see the FTP Update tab in 22xx Terminal Properties. 
 
At the bottom of each sheet are three buttons: 
• OK.  Activate OK to save changes and quit Terminal Properties after you have set desired 

properties in all the property sheets. 
• Cancel.  Activate Cancel to quit Terminal Properties without saving any changes.  You can also do 

this by clicking on X in the upper right corner. 
• Apply.  Ignore this button. 
 
If a password has been enabled for this terminal (see Control Panel|Security), you will see the Setup 
Password dialog box when you press F2.  Type in your password and activate OK. 
 

General 
 

 
General Properties Sheet 

This property sheet is informational except for Terminal Name and Reset…. 
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• Product ID.  This is a unique product identification code.  The last 12 characters are used as the 
“UUID” by the TCO Remote Management software and are a permutation of the terminal MAC 
address. 

• SDRAM Size.  This shows the amount of DRAM in the terminal.  DRAM is used for working 
storage.  The standard amount is 64MB, but an upgrade to 128MB is available.  More RAM allows 
you to have more sessions open at the same time. 

• Flash Memory Size.  This shows the amount of non-volatile flash memory in the terminal.  Flash 
memory is used to store all of the operating system and program software.  The amount is 8MB or 
16MB, depending upon the terminal model. 

• MAC Address.  This is a unique hardware identifier.  Every device on every LAN in the world is 
supposed to have a unique identifier. 

• Software Version.  This is the version of the firmware installed in this terminal.  If you contact 
Affirmative Computer Products Tech Support about a problem, please have this version, including 
the build number, available. 

• Microsoft Windows CE.  This is the family of the Windows CE operating system that is installed 
in the terminal.  All the terminals discussed in this document should read CE.net here.  The 
operating system can only be upgraded as part of a general firmware upgrade; it cannot be upgraded 
by itself. 

• Terminal Name.  We recommend that you enter a unique name here for easy identification when 
using network management and administration software.  The first character of this name must be 
an alpha character, and the name should have no more than fifteen characters 

• Reset the terminal to factory-default property settings.  Activate this check box to reset the 
terminal to its factory default settings. When you do this, you will get a dialog box asking you to 
confirm your intentions. 

 

RDP Local Resources 
 
This sheet is used to configure audio and local devices for RDP sessions. 
 

 
RDP Local Resources Properties Sheet 
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• Remote computer sound.  Note: This feature works only with a Windows 2003 server. 
o Bring to this computer.  Map the audio (sound) from the server to the terminal.  
o Do not play.  Do not play computer sound on terminal or server.  
o Leave at remote computer.  Does not map the audio (sound) from the server to the 

terminal.  
• Local devices 

o Disk drivers.  Enable local USB port mapping for USB disk drives such as USB FDD, 
HDD, Flash Disk and CDROM.  Note:  This feature works only with a Windows 2003 
server. 

o Printers.  Enable local parallel port mapping. It supports both parallel printers from LPT1 
and USB printers from USB port. 

o Serials ports.  Enable local serial ports mapping.  Note:  This feature works only with a 
Windows 2003 server. 

 

Display Properties 
 
Use the Display properties sheet to configure the terminal's display screen and RDP session display 
properties. 
 

 
Display Properties Sheet (26xx and 733x models) 

• Desktop Area and Refresh Frequency.  Use the scroll list to select the terminal display resolution. 
The terminal will support resolutions from 600x480x8x60 up to1280x1024x16x60 if the monitor 
will support them. Eight-bit color is typically sufficient for emulator sessions.  Another available 
setting is Best Available Using DDC, which will automatically choose the best available monitor 
resolution if that monitor is DDC-compatible.  NOTE: Be sure to test your new setting if you are 
going up in frequency or resolution.  If you don’t test, you could be faced with an unreadable screen 
after boot-up. 
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o Test Resolution.  Use this button to preview the resolution and frequency selected on the 
scroll list.  Testing is recommended before locking in this setting; if the monitor will not 
support your selection, you will be faced with an unreadable screen after boot-up.  See 
Troubleshooting Your terminal if this situation occurs. 

• Enable Screen Saver.  Check here to enable the screen saver. By default this function is activated. 
o Screen Saver.  Click on this radio button to use a screen saver.  Then choose, from the drop-

down list, either a floating logo screen saver or a blank screen.  Use the Test button to 
preview your choice for three seconds. 

o Turn Off Monitor (26xx and 733x models).  Click on this radio button to turn off the 
monitor as a screen saver. By default this function is inactivated. Use the Test button to 
preview your choice for three seconds. 

o Wait. Adjust the amount of idle time before either the Screen Saver or Turn Off Monitor is 
activated. 

• RDP Sessions Color Setting.  Select 256 Colors for reduced network traffic; select High Color 
(16 bit) for better image quality.  By default, High Color (16 bit) is activated.  Note:  Even though 
you select High Color, you may not get it because: 

o The local hardware video driver must be set to 16-bit depth.  See Display Driver Colors 
below. 

o The Terminal Server must use a version of Windows Server 2003 or higher. 
o The Terminal Server settings must be compatible.  See 

http://support.microsoft.com/default.aspx?scid=kb;EN-US;323353 for more information. 
• Display Driver Colors.  This is the terminal hardware video color setting. There are two selections 

in 26xx and 733x models, 256 Colors and High Color (16 bit).  In 22xx models, a third selection, 
True Colors (24 bit) is also available.  By default, High Color (16 bit) is activated. If you 
encounter any display problem in your RDP or ICA session applications, try the 256 Colors setting.  
Note:  If the setting is 256 Colors, the RDP Sessions Color Setting will automatically revert to 256 
Colors. 

 

RDP Experience 
 

 
RDP Experience Properties Sheet 
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This properties sheet is only useful if you are connecting to a Windows 2003 server.  If so, you can 
optimize performance and desktop appearance by selecting connection speed and enabling/disabling 
desktop parameters. 
 
Note:  The Custom connection speed option is not supported on these terminals. 
 

FTP Update 
 
This properties sheet is not seen directly in Terminal Properties in 22xx terminals.  For those terminals, 
the properties sheet is found under Control Panel, and it looks slightly different. 
 

 
FTP Update Properties Sheet (Not seen in 22xx terminals) 

Use the FTP Update sheet if you wish to update your terminal's firmware from an FTP server. For more 
information, please refer to the Firmware Upgrade Utilities section. 
 

Profile Upload 
 
This properties sheet is intended for use with TCOSoft Remote Management software--optional (no-
cost) software that provides management of Affirmative Computer Products Windows Based Terminals 
connected to an Ethernet network.  The Remote Management software consists of a suite of agents (built-
in to the WBT firmware), and Remote Director and Address Book Service (ABS) modules installed on an 
NT/2000/XP workstation or server in the same network. Address Book Service maintains information 
about WBTs that are registered with it.  The Remote Director is the user interface to manage registered 
WBTs.  Agents, which are included in the WBT firmware, allow the WBT to communicate with 
Remote Director and Address Book Service.  For more information, please refer to the TCOSoft User 
Guide at http://www.affirmative.net/pub/TCOSoftUserGuide.pdf. 
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The configuration required by these agents is done in the Profile Upload properties sheet.  Obviously, if 
you don’t have the optional packages, Remote Director and Address Book Server, installed on the 
network, you can bypass this section 
 
The Profile Upload properties sheet configures the properties that allow the terminal to be added to the 
Address Book Service directory in an automatic plug-and-play manner and to upload its profile of 
terminal properties and session information to Address Book Service. A network administrator can then 
use Remote Director to modify the profile and then download the modified profile to other terminals on 
the network. 
 

 
Profile Upload Properties Sheet 

• TCOSoft Client Settings.  The Location and Remarks fields allow you to provide more 
information to Remote Director software. It can help the network administrator identify your WBT 
in Remote Director. Both fields are optional. 

• TCOSoft Address Book Servers.   A network device that has Address Book Service installed is 
called an Address Book Server.  Typically, Address Book Servers and WBTs communicate 
automatically with each other using TCP/IP broadcast  (restricted to a single sub-net) or multicast 
(requiring a router to go communicate across sub-nets) protocols.  Either broadcast or multicast 
protocol can be used if all devices are on the same sub-net.  If some devices are on different sub-
nets, multicast protocol must be used. 

o Enable Broadcast/Multicast.  Although the default is to have both of these boxes 
checked, only one should be checked, and the correct one depends upon whether or not 
all devices are on the same sub-net, as described above. All devices on the network, 
including the Address Book Server, must use the same “casting” type. 

o IP Address.  If broadcasting and multicasting have been enabled correctly on the WBT 
and on the Address Book Service, an ABS IP address should automatically appear in this 
field.  This is the ABS that stores the WBT information and that will receive an uploaded 
profile.  This should always work if all devices are on the same sub-net.  But in a 
network of sub-nets, all routing elements must be capable of multicasting and must be 
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configured to do so. If an ABS IP address does not appear in the IP Address field, or if 
you want to upload profiles to a different ABS, you can enter the IP addresses of one or 
more ABS by clicking on Insert. 

o Insert.  Click on this button and the Add New AddressBookService dialog box will 
appear. 

 
 

 
Add New AddressBookService Dialog Box 

Fill in the blanks.  A password may or may not be needed, depending upon how the 
network administrator has configured the ABS. 

o Up/Down. Arrange the order in which the ABS servers are to be contacted by using the 
Up and Down buttons. 

• Upload Profile.  You may wish to use the terminal properties and session information of this 
terminal to configure other terminals.  You can upload this terminal profile to the ABS by clicking 
on Upload Profile to display the TCO Profiling Agent dialog box. 

 

 
TCO Profiling Agent Dialog Box 

 25



Enter a friendly Profile Name to identify the profile at the Remote Director, and enter a password if 
required by the network administrator.  Then click OK.  You should get an acknowledgement after 
the upload is complete. 

  

Web 
 

The Web properties sheet appears in all WBTs, but it is only useful if you have a Model 22xx, Model 
2612, Model 2613, or Model 733x, since these models include browser support.  If you have one of 
these models, use this sheet to configure your browser settings. 
 

 
Web Properties Sheet 

• Enable Web Settings.  Check this box to allow Web sessions.  The other parameters that you 
configure here will be used as default settings for all new Web sessions. 

• Home page.  This is the default home page for new Web sessions.  This setting can be individually 
overridden in each Web session. 

• Search page.  This is the default search page for new Web sessions. 
• Persistent browser cache.  Check to maintain history and cookies across multiple web sessions.. 
• Enable Favorites.  Check to enable. 
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• Preferences.  Click on this button to see the Preferences dialog box. 
 

 
Preferences Dialog Box 

These are standard browser preferences.  Note: These preferences can be overridden in a web 
session. 

• Proxy information.  If your terminal connects to the web through a proxy server, click on this 
button.  You will see the Proxy Information dialog box. 

 

 
Proxy Information Dialog Box. 

• Access the Internet using a proxy server.  Check this box if you are using a proxy server  
• Proxy server name or IP address.  Enter the proxy server network name or IP address here. 
• Port.  This is the proxy server port that is handling your Web access.  The default is 80 and 

should not be changed unless directed to do so by your network administrator. 
• Bypass proxy server….  You may have a Web server on the same sub-net as the WBT, or you 

may want browser access to a device on the same sub-net.   In this case, check this box. 
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Control Panel 
 
This property sheet is very reminiscent of Windows 95/98 Control Panels.  You will see either nine 
(22xx) or eleven icons representing necessary utilities.  Double-click on an icon, or click on Open, to 
open the utility. 
 

 
Control Panel Sheet for 26xx and 733x Terminals (ThinPrint not shown) 

The positions of the icons are different in different terminal models, so they will be explained here in 
alphabetical order. 
 

Date/Time (all models) 
 
This utility is only useful for browser and ICA sessions. 
 

Date/Time 

 
Date/Time Dialog Box 
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• Calendar/Current Time.  These settings scan be useful in browser sessions, but are not used 
anywhere else. 

o 22xx models.  These models have a battery, so any adjustment that you make in these 
settings will be held while terminal power is off. 

o 26xx/733x models.  These models have no battery, so any adjustment that you make here 
will only be held until the power is turned off. 

• Time Zone.  Time Zone allows the user, when logging on to a MetaFrame XP server in a different 
time zone, to have the ICA sessions reflect the time zone of the local terminal.  For example, a user 
in London (Greenwich Mean Time) logs onto a MetaFrame XP server in New York City (Eastern 
time zone), and launches Microsoft Outlook as a published application; Microsoft Outlook stamps 
emails sent during this ICA session with the user’s GMT time zone information. 

 

SNTP 

 
SNTP Dialog Box 

This dialog box allows the terminal to sync the local Current Time, shown in the Date/Time dialog 
box, with a timeserver on the Web.  Obviously, it only works if you have a Web connection (but you 
don’t need a browser session). 
 
• Auto Sync….   Check this box to sync the time whenever the terminal is rebooted. 
• Time Server.  Select a timeserver from the drop-down list. 
• Add.  Click here to open a dialog box that allows you to add the name of another timeserver of your 

choice. 
• Synchronize.  Click here to synchronize immediately without waiting for a reboot. 
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Ethernet Network (all models) 
 
The Ethernet Network utility lets you control the terminal IP address, name server addresses, and global 
ICA client settings, as well as providing the useful ping function. 
 

 
Ethernet Network Properties Sheet 

• Obtain an IP address from a DHCP Server.  Select this radio button to enable DHCP addressing. 
• Specify an IP address. Select this radio button to enable the following three fields for a specific IP 

address setting.  
o IP Address.  Enter a static IP address in this field. 
o Subnet Mask.  Enter the subnet mask of the local network. 
o Gateway.  Enter the IP address of a gateway if any server is not on the local sub-net. 

• Keep Current IP Address….  If you are getting the IP address from a DHCP server, a check here 
will allow the terminal to use the last known IP address if the terminal cannot connect to the DHCP 
server. 
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Advanced Network 
Activate this button to configure name server settings. 
 

 
Advanced Network Settings Dialog Box 

• Enable DNS.  Activate this check box to enable the following three fields for the DNS setting.  
• Enable WINS.   Activate this check box to enable the following three fields for the WINS setting 
 

Client IP Address 
Click on this button to see the Local Client Information box. 
 

 
Local Client Information Box 

You will see all the network information for this terminal, either obtained from a DHCP server or 
manually specified.  The Client Name is the same as the terminal name. 
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Ping IP Address 
Activate this button to display the Ping dialog box.  You can ping the name or IP address of a host or 
any other device connected on the network. You can even ping a web site through a gateway. 
 

 
Ping Dialog Box 

• IP, Name or Web Site.  Enter the network name or the IP address of the device to be pinged. 
• Count.  Enter the desired number of ping attempts. 
• Timeout.  Enter the desired wait time, in milliseconds, before a ping attempt is recorded as failed. 
• Ping.  After entering the parameters above, activate this button to execute pings.  The results will be 

shown in the list box. 
 

ICA Utility 
Click on Global ICA Client Settings to see the Global ICA Client Settings window with five settings 
sheets that can be invoked by activating their individual tabs.  These settings will be used for all Citrix 
ICA sessions that are added to the terminal. 
 

Hotkeys 

 
Hotkeys Settings Sheet 
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Many hot-key combinations used in Windows applications cannot be used directly in client sessions 
because they are intercepted by the local operating system.  Therefore, Citrix provides a way to 
substitute, or map, more obscure key combinations for some of the standard Windows hot-key 
combinations.  For example, in the above screen, the combination Ctrl+8 is substituted in the ICA 
client session for the standard hot key combination Alt+Tab.  If you are in an ICA session, pressing 
Ctrl+8 will have the same result in the active Windows application as pressing Alt+Tab on a PC. 
 
The following table lists the default ICA Windows CE Client hotkeys. 
 

Function or PC 
Equivalent 

Default 
Hotkey Description 

Status Dialog CTRL+6 Displays ICA Client connection status. 

Close Session CTRL+2 

Disconnects the ICA Windows CE Client from the Citrix server 
and closes the client window on the terminal. Using this hotkey 
leaves the ICA session running in a disconnected state on the 
Citrix server. If you do not want to leave your session running in 
a disconnected state, log off instead. 

ESC CTRL+3 Provides the functionality of an ESC key on your terminal. 

CTRL-ALT-DEL CTRL+4 Displays the Windows NT Security dialog box on a MetaFrame 
for Windows server. 

CTRL-ESC CTRL+5 
On MetaFrame for Windows servers, the Windows Start menu is 
displayed. On WINFRAME servers, this hotkey displays the Task 
List. 

ALT-ESC CTRL+7 This hotkey cycles the focus through the minimized icons and 
open windows of applications running in your ICA session 

ALT-TAB CTRL+8 
This hotkey cycles through all applications in the ICA session. A 
pop-up box appears and displays the programs as you cycle 
through them. The selected application receives keyboard and 
mouse focus. 

ALT-BACKTAB CTRL+9 
Like the ALT+TAB hotkey, this key sequence cycles through 
applications that have been opened in the ICA session, but in the 
opposite direction. The chosen application receives keyboard and 
mouse focus. 

 
But you may want to change this mapping.  If so, execute the following procedure: 
1. Click on the drop-down arrow for the hot-key combination that you want to change. 
2. Select a new combination from the drop-down list.  Note:  There are no safeguards to prevent you 

from choosing the same hotkey combination for multiple functions.  Expect erratic performance if 
you do so. 

3. Repeat for other hot keys as desired. 
4. OK out of the window, or select another tab to change other settings.  If you OK out, you will be 

asked if you want to reboot to make the changes effective. 
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Preferences 

 
Preferences Settings Sheet 

• Serial Number.   This is the serial number of your ICA Client software. This number is only 
necessary when you are using the ICA Windows CE Client with a product such as WINFRAME 

Host/Terminal, which requires each ICA Client to have a Citrix PC Client Pack serial number. If a 
serial number is required, you must enter it exactly as it appears on the Serial Number card. The 
serial number is not used when connecting to MetaFrame servers. 

• Client Name.   The name shown here is the same as the terminal name seen in Terminal 
Properties|General.  Citrix servers use the client name to uniquely identify resources (such as 
mapped printers) associated with a given client device. The client name should be unique for each 
terminal running a Citrix ICA Client.  Note: If you do not use unique client names, device mapping 
and application publishing may not operate correctly. 

• Default Colors.  We recommend that you select 16 or 256 colors.  There is a Citrix bug that 
sometimes produces strange video results at higher settings. 

  

Server Location 
The information entered in this dialog box is used to help locate available Citrix servers and published 
applications. 
 

 
Server Location Settings Sheet 

Server location (also called server browsing) provides a method for a user at a network-connected 
Citrix ICA Client to view a list of all MetaFrame servers on the network that have ICA connections 
configured for that network protocol, or a list of all published applications. You can specify a separate 
server location for each network protocol. Tip: Set a specific server address for the Citrix server that 
functions as the master ICA Browser when your network configuration uses routers or gateways, or to 
eliminate broadcasts on your network. 
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The way in which server location works depends on which network protocol has been configured: 
• TCP+HTTP Browser and SSL+HTTPS Browser — The default server address is 

ica.domainname, where domainname is a TCP/IP domain name. The ICA Client uses the HTTP or 
HTTPS protocol respectively to contact the MetaFrame servers.  Note: If you are going to use SSL 
security for your ICA sessions, you must choose SSL+HTTPS Browser protocol. 

• TCP Browser — The default setting for server location is auto-locate. The ICA Client attempts to 
contact all of the servers on the subnet by broadcasting on the UDP protocol. Alternatively, you can 
set specific addresses for MetaFrame servers. 

 
Business recovery provides consistent connections to published applications in the event of a master 
ICA browser server disruption. You can define up to three groups of MetaFrame servers to which you 
want to connect: a primary and two backups. Each group can contain from one to five servers. When 
you specify a server group for your client, the client attempts to contact all the servers within that group 
and the first server to respond passes its master browser address to the client. 
 
To configure server location and business recovery: 
1. Select the required network protocol from the drop-down list. 
2. Click Add to display the Add Server Address dialog box. 
3. Enter the name or IP address of a MetaFrame server.  Note: For the TCP/IP+HTTP and 

SSL+HTTPS protocols, if you do not enter an IP address, you must have a MetaFrame server on 
your network mapped to the default name of ica.domainname, where domainname is a TCP/IP 
domain name. TCP/IP+HTTP and SSL+HTTPS server locations do not support the (Auto-Locate) 
function. 

4. To define other server groups, select the required group from the Server Group and repeat steps 2 
and 3. 

5. Click OK. 
 

Firewall Settings  
If the network has a SOCKS proxy server to limit access to your Citrix servers, you must enter the 
proxy server information here to handle connections between clients and the server. You can configure 
a default SOCKS proxy for all connections here, or you can configure a SOCKS proxy for a specific 
client session under the specific session properties (see Creating a New Connection|Citrix ICA 
Client|Network Connection). 
 

 
Firewall Settings Sheet 

 
Configuring a Default SOCKS Proxy Server 
1. In the Proxy drop-down list, select SOCKS. 
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2. In the Proxy Address box, enter the SOCKS proxy server’s IP address or DNS name. 
3. In the Port box, enter the proxy server’s port number (if different than 1080). 
4. Click OK to save your changes. 
Note: If you configure a default SOCKS proxy, you must specify at least one server in the Server 
Location tab for server and published application browsing to work. 
 
Configuring a Secure Proxy Server 
If you want to connect to a MetaFrame server beyond a firewall, and your network is using a Secure 
proxy server, you must configure the ICA Client to connect to MetaFrame servers through the Secure 
proxy server. You can configure a default Secure proxy for all connections here or a Secure proxy for a 
specific client session (see Creating a New Connectio|Citrix ICA Client|Network Connection). 
 
To configure a default Secure proxy server: 
1. Select Secure (HTTPS) from the Proxy drop-down list. 
2. In the Proxy Address box, enter the Secure proxy server’s IP address or DNS name. 
3. In the Port box enter the Secure proxy server’s port number. 
4. To enable SSL/TLS Relay, enter the Address of relay and the Port number in the appropriate 

boxes. 
5. Click OK to save your changes. 
 
Note: If you configure a default Secure proxy, you must specify at least one server in the Server 
Location tab for server and published application browsing to work. 
 
Connecting to a Server Across a Firewall 
Network firewalls can allow or block packets based on the destination address and port.  You can 
configure the ICA Client here to connect to a MetaFrame server through a firewall.  If the firewall uses 
address remapping, you must configure the ICA Client to use the alternate address returned by the 
master ICA Browser. This is necessary whether or not you are using a SOCKS/Secure proxy server. 
 
To use alternate address translation for all connection entries: 
1. Check Use alternate address through firewalls. 
2. Click OK to save your changes. 
Note:  If you set alternate address translation here, it cannot be disabled for specific Client sessions. 
 

PNLite  
PNLite is a connection mode that allows you to connect to an Nfuse-enabled Citrix server and obtain a 
list of published applications that you can connect to. In this mode, you do not have to manually 
configure each ICA connection, but a list of published applications will be 'pushed' (made available) to 
your session. Connect to any published application in that list by double-clicking on an entry. 
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PNLite Settings Sheet 

To use PNLite: 
1. Check Enable PNLite. 
2. Enter the address and port number of the Citrix Nfuse server in the Address and port of NFuse 

server box. 
3. To connect using SSL/TLS, check Use SSL/TLS TLS. 
4. Enter your user name, password, and domain in the appropriate User Credentials box. 
5. If you want the program to remember your password, check Save Password. 
6. Click OK to save your changes. 
The list of available applications will now be displayed in the Connection Manager dialog box. 
 

FTP Update (22xx models) 
 
For 26xx and 733x models, see Configure Terminal Properties|FTP Update. 
Use the FTP Update sheet if you wish to update your terminal's firmware from a local FTP server. For 
more information, please refer to the Firmware Upgrade Utilities section. 
 

Input & Volume (all models) 
 
Configure your keyboard, mouse, and audio settings here. 
 

Keyboard, Volume 

 
Keyboard, Volume Settings Sheet 
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• Keyboard 
o NumLock on Boot.  Check to force Numeric Pad NumLock when the WBT starts up.  
o Locale.  Use the scroll list to select a language and number of keys for the keyboard.  

Default is OEM 122 USA, which is the setting required if the Affirmative Computer 
Products 122-key keyboard is used with the terminal.  If “122” is not shown, the number of 
keys is assumed to be 101. 

• Character Repeat 
o Repeat Delay.  Use this slider control to define how long a character key must be held down 

before that character will start to repeat on the screen. 
o Repeat Rate.  Use this slider control to define how often a character will repeat when that 

character key is held down. 
You can test your repeat settings in the test box. 

• Volume Control. 
o Use the slider control to adjust the volume of the audio.  
o Use the "Mute" check box to disable the audio of the WBT. 

 

Mouse 

 
Mouse Settings Sheet 

• Speed.  Use the slider control to set the speed of the cursor movement on screen vs. the movement 
of the mouse. 

• Button Configuration.  Use the radio buttons to select "Right Handed" or "Left Handed" for your 
clicking convenience. 

• Set.  Place the cursor on the grid and then double-click to set speed and distance sensitivity. 
• Test.  Test your double-click sensitivities here. 
 

Mouse Miscellanea 
• PS/2 wheel mice work well in ICA and RDP sessions.  The extra wheel/button does not work in 

native applications (emulators, viewers, browsers). 
• USB mice plugged directly into a USB port do not work well.  The cursor movement is very jerky. 
• Two-button USB mice work well if they are plugged into the PS/2 port through a converter. 
• Three-button USB mice work if they are plugged into the PS/2 port through a converter, except: 

o The extra wheel/button does not work in native applications (emulators, viewers, browsers). 
o Wheel scrolling does not work in ICA and RDP sessions. 
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LPD (all models) 
 
The Berkeley versions of the UNIX™ operating system provide printer spooling with a collection of 
programs: lpr (assign to queue), lpq (display the queue), lprm (remove from queue), and lpc (control the 
queue). These programs interact with an autonomous process on network print servers called the line 
printer daemon (LPD). 
 
Each YEStation terminal includes an LPD module that allows an LPR device on the network to assign 
print jobs to a local printer attached to the terminal. 
 
Double-click on the LPD icon to see the following dialog box. 
 

 
LPD Dialog Box 

Check Enable LPD and then click on LPD Setting. 
 

 
LPD Settings Sheet 

• Queue name.  Define a queue name here.  This will be the queue name used by LPR devices to 
assign print jobs. 

• Printer Port.  Select a port from the drop-down list.  You may have several printers on different 
ports, but only one of them can be assigned as an LPD printer. 

• Queue.  This box shows the status and source of all the print jobs currently in the LPD queue. 

 39



 

Printers (all models) 
 
Click on this icon to show the printers that are currently configured on your terminal.  
 

 
Printer Status Sheet 

Note:  You will not see any ThinPrintClient box or button.  This has now been moved to a separate icon 
in the Control Panel.  See ThinPrint. 
 
If you already have configured printers on this terminal, double-click on a printer icon, or highlight an 
icon and click on Properties, to see the printer properties. 
 
To add a printer, double-click on the Add Printer icon, or highlight this icon and click on Open, to 
start the WBT Printer Wizard. 
 

 
WBT Printer Wizard Dialog Box #1 
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• You must select a printer port.  You can have more than one local printer, but each one must be 
assigned to a different printer port.  If you have a USB printer already connected to the terminal, 
you will see a USB option in the drop-down list, as well as the typical LPT1, COM1/2 (non-22xx 
terminals), and Network options. 

• If you select a network printer, enter the printer network path in the Network field.  You can have 
multiple network printers. 

• If you select a COM port (not applicable for 22xx terminals), you can configure the properties later 
in Terminal Connection Manager by creating a bogus Dial-Up session (see Creating a New 
Connection|Dial-Up Client|Configure). 

 
 

 
WBT Printer Wizard Dialog Box #2 

• Select a printer manufacturer from the manufacturer drop-down list.  After you select the 
manufacturer, the right-hand drop-down list will provide a list of models for that manufacturer. 

• Select the printer model.  If your model is not shown here, try to find a compatible printer in the list.  
It may be that your printer is compatible with a model from a different manufacturer.  If that is the 
case, go back, change the manufacturer selection, and then choose the compatible model from that 
drop-down list.  Note:  There are no local Windows printer drivers in these terminals.  You must 
have a driver in your Windows Terminal Server that corresponds to the selected model. 

• Another option, if your printer is not found in the lists, is to check User Defined.  In this case, you 
will then see dialog box #2a.should then enter the model name, in the Model Name field, that 
corresponds to the printer driver on your Windows Terminal Server. 
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WBT Printer Wizard Dialog Box #2a 

If you chose User Defined in the previous dialog box, #2, you will see this dialog box #2a.  Enter the 
model name, in the Model Name field, that corresponds to the printer driver on your Windows 
Terminal Server. 
 
 

 
WBT Printer Wizard Dialog Box #2b 

 
If you chose a network printer in dialog box #1, you will see this dialog box #2b. 
• Model Name.  This is the model name entered in dialog box #2 or #2a. 
• Network.  Enter the path to your network printer. 
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WBT Printer Wizard Dialog Box #3 

You must provide a “friendly” name for your printer.  This name will identify your printer in the 
Printers settings screen on your server. The default name is the model name that you selected in the 
previous dialog boxes. 
 
 

 
WBT Printer Wizard Dialog Box #4 

Select whether or not you want this local printer to be the default printer for your Windows (ICA and 
RDP session) applications. 
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WBT Printer Wizard Dialog Box #5 

You are given the opportunity to begin the configuration of another printer.  If you select Yes, you will 
repeat the above dialog boxes for that printer.  If you select No, you will go on to the Finish dialog box. 
 
 

 
Final WBT Printer Wizard Dialog Box 

• Click on Finish to apply your selections. 
• Click on Back to return to the previous dialog box. 
• Click on X to forget the whole thing and go back to the Control Panel screen. 
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Screen Keyboard (26xx models) 
 
This feature is intended for use only with touch screens (see TouchSetup), but you can play with it 
using a mouse cursor if you want to. 
 

 
Screen Keyboard Settings Sheet 

• Current input.  Choose one of two sizes of keyboard from the drop-down list. 
• Enable Screen….  Check this box to cause an Enable/Disable button to be shown in the lower right 

corner of the screen after the terminal is booted up.  Then you can click on the button to enable or 
disable the screen keyboard.  This is useful when you bypass the Terminal Connection Manager, 
which also has an Enable/Disable button, because of an Autostart session.  This check box only 
takes effect on boot up. 

• To quickly switch….  Ignore these instructions; I can’t figure out what they mean. 
 

Security (all models) 
 
Several levels of security can be configured in this utility. 
 

 
Security Settings Screen 

• Password Enable.  Check this box to enable password security.  Then enter and confirm a 
password in the boxes.  The factory default password is "guest". 
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Note: The password is designed to avoid any unreasonable change to the Terminal Properties 
Settings. Please do NOT change the password unless you are the administrator.  If you forget the 
password, it will be difficult to recover.  There are two methods of recovery if you forget the 
password. 

o Contact your distributor or Affirmative Computer Products get a super password. 
o Use Remote Management software to change the password settings. 

• Enable Browser Terminal Properties Information.  If you check this box, a user can view 
Terminal Properties even if a password is enabled, but the user cannot change any of them without 
entering the password. 

• Disable Terminal Connection Configure Tab.  Check this box to hide the Configure tab of the 
Terminal Connection Manager.  This can be done even if a password is not enabled.  If you do this, 
the user will be unable to add, delete, or edit any sessions. 

 

SNMP (all models) 
 
Simple Network Management Protocol (SNMP) is the Internet standard protocol for network 
management and is part of the TCP/IP protocol suite. SNMP uses a distributed architecture that consists 
of managers and agents.  The SNMP agent is an application that monitors network traffic and responds 
to queries from SNMP manager applications.  The agent also notifies the manager when significant 
events occur by sending a trap.  The SNMP manager is an application that generates queries to SNMP-
agent applications and receives traps from SNMP-agent applications. 
 
All YEStation terminals contain an SNMP agent. 
 

 
SNMP Description Sheet 

This sheet only provides descriptive information to an SNMP manager. 
• System Name.  This is the Network Name shown in the General tab of Terminal Properties. 
• UUID.  This is the Product Identification shown in the General tab of Terminal Properties. 
• Description.  This gives the version and build of the Windows CE operating system, with the 

information provided automatically by the operating system.  Note:  Version 4.x denotes the CE.net 
operating system. 

• Location/Contact.  You can enter information here to aid the SNMP manager. 
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ThinPrint (all models) 
 
ThinPrint enables direct printing from the terminal to network printers and local printers. With the 
ThinPrint Client, a print job can be delivered over the Citrix ICA protocol to the device and from there 
direct to the selected printer.   To learn more about ThinPrint advantages, go to 
http://www.thinprint.com/ on the Web. 
 
To configure ThinPrint: 
1. Double-click on the icon 
2. A small ThinPrint dialog box will appear.  Check Enable ThinPrintClient. 
3. You will be told that you have to restart the terminal.  Click on Yes. 
4. After the terminal has rebooted, enter Control Panel again and double-click on the ThinPrint icon. 
5. You will see the ThinPrint dialog box again, but now you can click on Enable.  Do so. 
6. You will see the ThinPrint Client Configuration window appear. 
 

 
ThinPrint Client Configuration Window 

For information on using this window, go to 
http://www.thinprint.com/download/information/manuals/englisch/dot_print_client_winCE_e_01.pdf 
on the Web. 
 

TouchSetup (26xx models) 
 
Only the 26xx models can support a touch screen, because a touch screen requires a serial port to 
communicate the touch information.  Two touch screen vendors, MicroTouch and ELO Touch, are 
supported 
 

 
TouchSetup Dialog Box 

 47

http://www.thinprint.com/
http://www.thinprint.com/download/information/manuals/englisch/dot_print_client_winCE_e_01.pdf


• Enable TouchScreen.  Check this box to enable touchscreen support. 
• Setup.  Select your touch screen vendor from the drop-down list, and then click on Setup.  The next 

window you see will depend upon which vendor you chose. 
 

ELO Touch 
Most ELO Touch configuration is done from on-screen menus under control of the built-in controllers.  
Very little can be done here in the terminal Control Panel.  After you click on Setup, you will see the 
following dialog box. 

 
ELO Touch Dialog Box 

• Port.  Select the serial port used with the touch screen. 
• Baud.  Select the baud rate to be used with the touch screen. 
• Calibrate.  Click on this button to initiate the calibration procedure. 
 

MicroTouch 
Click on Setup to see the properties window with four tabs. 
 

Hardware 

 
MicroTouch Hardware Properties Sheet 

• Port.  Select COM1 or COM2.  You will see other choices in the drop-down list, but they are not 
applicable here. 

• Baud Rate.  Select an appropriate baud rate for your touch screen. 
• Find touchscreen.  When you select a port, it will automatically be searched for a touch screen 

connection, and the results will be shown in the Information area.  But if you want to repeat the 
search, click on this button. 
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Calibrate 

 
MicroTouch Calibration Sheet 

After you connect your touch monitor, you must calibrate the touch screen.  The calibration process 
aligns the touch screen with the underlying video.  It defines the dimensions of the active area of the 
touch screen and locates the center of the touch screen. 
 
You should calibrate in the following cases: 
• The first time you change to a particular video resolution. 
• Any time you change the size of the video image by adjusting the horizontal and vertical controls on 

your monitor. 
• Any time you run the Stabilize Cursor function from the Cursor tab. 
• Any time the cursor does not follow the movement of your finger or does not reach the edges of the 

touch screen. 
 
To calibrate the touch screen, click on Calibrate.  Follow the directions displayed on the screen.  When 
calibrating, make sure that you: 
• Face the screen directly. 
• Perform the calibration in the position (sitting or standing) that you expect to use at the terminal. 
• Touch the calibration target firmly and precisely with your fingertip.  Be careful to keep your other 

fingers away from the touch screen 
 

Touch Settings 

 
MicroTouch Touch Settings Sheet 

Use the Touch Mode options to specify the touch actions that equate to mouse click, double-click, and 
drag events.  See the following table for details on the three available modes. 
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Event Desktop Mode Drawing Mode Button Mode 

When the action 
occurs 

A touch positions the cursor. 
Holding the touch steady is 
equivalent to pressing and 
holding the mouse button. 
Lifting off is equivalent to 
releasing the mouse button. 

A touch is equivalent to 
pressing and holding down 
the mouse button. Lifting off 
is equivalent to releasing 
the mouse button. 

Touching the screen is 
equivalent to pressing 
and releasing the mouse 
button. The action occurs 
as soon as you touch the 
screen. 

Click 
• Touch the object 

• Lift off the screen 
• Same as desktop 

mode • Touch the object 

Double click 
• Tap the object twice 

quickly at the same 
location. 

• Same as desktop 
mode 

• Same as desktop 
mode 

Drag 

• Touch the object. 

• Pause momentarily. 

• Drag the object to a 
new location. 

• Lift off the screen. 

• Touch the object. 

• Drag the object to a 
new location. 

• Lift off the screen. 

• Same as Drawing 
mode 

Select text 

• Touch the text. 

• Drag to starting point 
of your selection. 

• Pause momentarily. 

• Continue to drag to 
select text. 

• Lift off the screen. 

Not Applicable Not Applicable 

 

Cursor 
These settings enable you to customize the response of the cursor to your touch. 
 

 
MicroTouch Cursor Settings Sheet 
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Vertical Offset 
After you calibrate the touch panel, the mouse cursor should be located directly underneath your finger 
when you touch the center of the screen. However, you may prefer to offset the cursor slightly above 
your touch so you can point more easily and precisely.  This option lets you define the distance between 
your touch and the position of the cursor on the screen. Offsetting the cursor is helpful when selecting 
small items, such as single letters in word processing, check boxes, or radio buttons. 
 
To set the Vertical Offset: 
1. Check Vertical.  The Set button then becomes active. 
2. Click on Set. 
3. Touch the screen at the desired distance below the tip of the arrow within the rectangular space 

provided.  The distance between your liftoff position and the tip of the arrow is the offset distance.  
Thereafter, the cursor will be positioned above your finger or pen by a distance equal to the offset 
distance.  As your finger or pen approaches the bottom edge of the screen, the cursor offset 
automatically decreases so that you can touch items in this area. 

 
Horizontal Edge Adjust 
There may be times when the screen image extends completely to the left and right edges of the screen 
(that is, beyond the edge of the monitor bezel). In these cases, it may be difficult to touch items at the 
left and right edges of the screen. 
 
If you check the Horizontal Edge Adjust box, the horizontal position of the cursor is automatically 
offset near the left and right edges. You can now easily reach the edges of the screen image.  This 
adjustment is only made at the left and right edges of the screen, and you cannot define the horizontal 
offset amount. 
 
Stabilize 
This option adjusts the operating frequency of the touch screen controller.  Some controllers do not 
require stabilization and thus do not support this option.  However, if you are having problems with 
very erratic or jittery cursor movements, you should stabilize. 
 
The stabilization procedure is: 
1. Click on Stabilize. 
2. The controller will test each frequency setting and determine the optimum setting. 
3. A dialog box will inform you of the best frequency as determined by the test.  The test results are 

displayed in descending order with the recommended frequency at the top. 
4. Accept the recommended frequency or select a different frequency. 
5. Test your selection by touching the screen in several places and sliding your finger around the 

screen.  The cursor should hold steady and smooth.  If it does not, select a different controller 
frequency. 

6. Go to the Calibrate tab and recalibrate.  

 51



Wireless (2613P model) 
You will see this icon in the standard 2613 model also, but Wireless is actually supported only in the 
2613P YEStation.  The 2613P has a PCMCIA slot in the rear panel that accepts an optional Cisco 350 
Aironet wireless LAN adapter card.  Note:  Only the Cisco 350 Aironet card is supported.  No other 
PCMCIA card will work. 
 

 
Wireless Setting Sheet (sort of) 

You will see a screen similar to this, but the information shown in this setting sheet—Status, Signal 
Strength, Channel—is no longer accurate.  For this information, you will have to go to the Aironet 
Client Utility (ACU) in Terminal Connection Manager  Configure  Add.  But this sheet is still 
useful, and necessary, for several items. 
• Waiting for….  If you check this box, the terminal will not advance to the Terminal Connection 

Manager or to an Autostart session until the wireless connection has been made with an access 
point.  Instead, you will see a small Checking Wireless IP dialog box until the connection is made. 

• Wireless Setting.  Click on this button to open the Cisco 802.11 Miniport Settings window.  In this 
window, you can specify IP and Name Server addresses just as you would in the Ethernet Network 
utility for a cabled LAN connection.  NOTE: If you want to specify addresses for wireless 
operation, you must do it here.  Do not specify them in Ethernet Network or in the WBT Setup 
Wizard. 

• IP Address.  Click on this button to see the following informational window. 
 

 
Wireless IP Address Information Window 

 
Return to Table of Contents 
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Terminal Connection Manager 
 

Note: The terms “connection” and “session” are used interchangeably in this section. 
 
In the Terminal Connection Manager window, you can select either the Connections or the Configure 
tab to manage or activate your terminal's network connections and viewers.  The Terminal Connection 
Manager starts with two or three default sessions, ICA, RDP, and browser (if you have a browser 
terminal model).  The ICA and RDP sessions will have to be configured before they will be useful. 
 
You must be in the Terminal Connection Manager in order to enter Terminal Properties.  Press F2 to 
enter Terminal Properties 
 

Configure 
 
The Configure tab allows five basic functions.    
 

 
Configure Tab 
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Add 
 
Activate the Add button to create a new session. A New Connection dialog box is displayed. 
 

 

 
New Connection Dialog Box 

Click on the drop-down arrow to see a long list of possible connections.  The exact list will depend 
upon your terminal model.  See Creating a New Connection for information on adding specific 
connections.  As sessions are added, they will be displayed alphabetically. 
 

Edit 
 
Activate the Edit button to edit the properties of a selected connection. A Sessions Properties window 
will pop up.  Please refer to Editing an Existing Connection for more information about editing a 
connection.  
 

Delete 
 
Activate the Delete button to delete the highlighted connection. When you activate this button, a 
Confirm Connection Delete dialog box is displayed. 
 

 
Confirm Connection Delete Dialog Box 

 Activate the Yes button to complete the deletion. Activate No to cancel the deletion.  
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Startup 
 
Activate the Startup button to specify the Autostart connection option when the terminal boots up. The 
Connection Startup dialog box displays after the Startup button is pressed. Using the dialog box, your 
terminal can be set to automatically connect to a server when the terminal is turned on. Any or all 
sessions can be configured for automatic startup. 
 

 
Connection Startup Dialog Box 

• Make the selected connection your Default connection.  Enable this function to use the selected 
connection as the default connection.  This connection will be highlighted in Connection Manager 
when the terminal is powered up. 

• Automatically start the selected connection at startup.  Enable this function to automatically 
start the selected connection when the terminal starts up. 

 

Failover 
 
FailOver provides backup connections if any of the sessions that are configured for Autostart fail to 
start.  
 
Click on FailOver to display the FailOver dialog box. 
 

 
FailOver Dialog Box 

A list of all connections eligible for use as backup sessions is shown in the left-hand box; browser 
sessions cannot be used for backup, although they can initiate fail-over backup if they are set for 
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Autostart but fail to start.  A list of all connections selected for use as backup sessions is shown in the 
right-hand box.  FailOver operates as follows:  
1. FailOver operation is activated if any Autostart session fails to connect to its server when the WBT 

is powered on.. 
2. FailOver pings the first (top) connection from the FailOver list. If the ping is successful, then the 

backup connection is made.  
3. If ping is not successful, then FailOver pings next connection from the FailOver list, and so on.  
4. If no connection is made, FailOver stops and displays an error message. 
 
For example, in the dialog box shown in this section: If an Autostart connection fails for some reason, 
the terminal will automatically search and connect to the Denny (an ICA server) server. If the 
connection to the Denny server fails also, the terminal will automatically search and connect to the Neil 
Hsu (a RDP server) server. If that connection fails, the terminal will display an error message.  Note:  
FailOver does not match the type of backup session with the failed Autostart session.  In this example, 
the failed Autostart could have been an emulation connection to an IBM server, but the first failover 
backup is an ICA session. 
 
The dialog box functions as follows: 
Connection.  This box lists all of the terminal connections that are eligible for backup duty. 
Failover order.  This box lists all of the terminal connections that are being used for backup duty.  The 
priority of use is top to bottom. 
FailOver TimeOut.  You can set the connection timeout (in seconds) before a session is considered as 
having “failed”. 
=>.  Add the selected connection to the FailOver list. 
<=.  Remove the selected connection from the FailOver list. 
Up.  Increase the FailOver Priority of the selected connection. 
Down.  Decrease the FailOver priority of the selected connection. 
 
Note:  A session can be manually activated from the Connections tab and used even if it is in the 
FailOver list, but not called upon for backup. 
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Connections 
 

 
Connections Tab for 26xx and 733x Models  

The Connections tab is used to make or end network connections with the server(s).  Initially, you will 
probably see two or three default sessions, as shown here.  These sessions can be renamed and 
reconfigured in the Configure tab, and new sessions added in the Configure tab will be listed here also, 
all in alphabetical order. 
• Connect.  Activate the Connect button to make a network connection.  You can also activate a 

connection by double-clicking on it. 
• End.  Activate the End button to end a connection shown as Active in the status field.  A dialog 

box will pop up asking for confirmation.  You can also end a session from the session screen itself, 
without going to Connections, and that is the recommended way to end a session. 

• Shutdown (Not shown).  It is recommended that you shut down your terminal using this button, 
although usually just shutting off the power does no harm.  You will see a box asking you to 
confirm your decision. 

o 22xx.  Executing a Shutdown will result in the power being turned off automatically. 
o 26xx, 733x.  Executing a Shutdown will result in a Shutdown Terminal progress bar and 

then a dialog box telling you that you can now shut down.  During the progress bar, you can 
recant your decision and cancel the Shutdown.  After you see the dialog box, you have no 
recourse but to manually turn off the power. 
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• Enable Screen KB (26xx only).  Click on this button to display an on-screen keyboard, as shown 
here. 

 

 
On-Screen Keyboard 

This is typically useful only if you are using a touch screen, but you can amuse yourself by typing with 
the mouse cursor if you wish.  The size of the keyboard is determined by the settings in Control 
Panel|Screen Keyboard.  After you enable the on-screen keyboard, the button will change to Disable 
Screen KB, for obvious reasons. 
 

Multiple Sessions 
 

Start Multiple Sessions 
 
You can configure any or all sessions to start automatically at terminal boot-up, as described in 
Terminal Connection Manager|Configure|Startup.  If you choose not to do this, you can invoke the 
Terminal Connection Manager from any working session by pressing Ctrl+Alt+End.  Then, in the 
Connections tab, highlight another connection and activate Connect or double-click to start a new 
session. 
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Toggle Between Sessions 
 
You do not have to return to Terminal Connection Manager to go to another active session.  Alternate 
methods are: 
• Press Ctrl+Alt+UpArrow to proceed to the next session.  
• Press Ctrl+Alt+DownArrow to proceed to the previous session. 
• In emulator sessions, press the Jump key on your keyboard. 

o Alt+PgDn for a 122-key 5250 keyboard. 
o Shift+PgDn for a 122-key 3270 keyboard. 
o Alt+PgUp for a 101-key 5250 keyboard. 

• Every YESterm IP emulator session Buttons toolbar contains the icons I, II, III, and IV.  These icons 
represent emulator sessions, shown from top to bottom, in the Terminal Connection Manager.  Click 
on an icon to switch to the corresponding session – if it is already active. 

 
 

Return to Table of Contents 
. 
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Creating a New Connection 
 

Connections are created in the Configure tab of Terminal Connection Manager.  Click on Add to see 
the New Connection dialog box.  Then click on the drop-down arrow to see the drop-down list of 
possible connections.  Actually, the term “Connections” is now misleading.  In older versions this list 
contained only client sessions that connected to network servers via LAN, dial-up, or Web; now the list 
has been expanded to include file viewers and wireless utilities. 
 

 

 
New Connection Dialog Box 

Each network client session can be to a unique server, if desired.  The total number of concurrent active 
sessions is limited by the amount of RAM in your WBT, the type of emulator in your WBT, and 
whether or not the WBT has browser capability.  Model 2610 WBTs allow the highest number of 
concurrent connections, while Model 2613 allows the least.  With the standard 64MB RAM, there is 
seldom any practical limitation unless you are running multiple browser sessions or multiple file 
viewers.  A 128MB RAM option is available to overcome any limitation that you might encounter. 
 
The connection types available in the drop-down list vary depending upon terminal model.  They will 
be covered here in alphabetical order.  Highlight the desired connection type and then click OK to open 
the associated dialog box. 
 
After your setup and configuration are complete, you can secure parameters from any user changes--if 
you do not intend to use Cisco Aironet Client Utilities, PMail, or VNC Viewer-- as follows: 
1. From the Connection Manager screen, press F2 to enter Terminal Properties. 
2. Select the Control Panel tab. 
3. Double-click on the Security icon. 
4. Check the box for Disable Terminal Connection Configure Tab. 
5. Check the box for Password Enable. 
6. Choose and confirm a password. 
7. OK out of Terminal Properties 
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Cisco Aironet Client Utilities (2613P 
only) 
 
You will see this selection in all 2613 models, but it is of use only in the 2613P model, which can 
support a PCMCIA Cisco Aironet wireless LAN adapter.  The ACU is not really a connection; it is a 
utility used to configure the properties of the Cisco adapter. 
 
For complete details on using the ACU, please go to the Web site 
http://www.cisco.com/univercd/cc/td/doc/product/wireless/airo_350/350cards/index.htm. 
 

Firmware Update 
 
One of the things you can do with the Cisco ACU is update the firmware in the Aironet card.  This is a 
very straightforward operation, but it requires browsing to the new firmware image file.  There are three 
ways to access this file from your terminal. 
1. Put the image file on a shared network drive, and then browse to that drive by typing in the path in 

the Name field. 
2. Put the file on an external USB drive, and then browse to the USB Storage folder. 
3. Have the file sent to you as an email attachment, download the file using PMail, and then browse to 

the Program Files\Inbox\Mail Attachments folder. 
 

Cisco Wireless Login Module (2613P 
only) 
 
You will see this selection in all 2613 models, but it is of use only in the 2613P model, which can 
support a PCMCIA Cisco Aironet wireless LAN adapter.  The WLM is not really a connection; it is a 
utility used to access a LEAP-secured network. 
 
If LEAP authentication is enabled in the ACU, a valid username and password must be entered 
whenever a connection is made to the access point.  WLM is used to enter these values.  Follow these 
steps to enter the LEAP username and password. 
1. WLM starts automatically whenever you start ACU change the LEAP parameter from Disabled to 

Enabled, click OK, and then connect to a LEAP-enabled access point.  If LEAP is already enabled, 
WLM starts automatically whenever you insert the client adapter, or reboot the YEStablet, or load 
new firmware, and then connect to a LEAP-enabled access point. You can also start WLM by 
selecting it from the Add drop-down list of Terminal Connection Manager|Configure. 

 
When WLM starts, the Wireless Login Module dialog box appears. 
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Wireless Login Module Dialog Box 

2. Obtain the username and password for your authentication server account from your system 
administrator.  Note: The password is optional because not all host accounts on the authentication 
server are set up with a password. 

3. Enter the username in the User Name field.  Usernames and passwords are case sensitive and can 
contain up to 32 alphanumeric characters.  Note: If your RADIUS server account specifies a 
domain, enter the domain name before the username and separate the two with a forward slash (e.g., 
domain/username). 

4. Enter the password in the Password field if the authentication server account was set up with a 
password.  Note: For security reasons, the characters entered for the password are displayed as 
asterisks. 

5. Click OK. If the username and password were entered correctly, they are written to volatile 
memory on the Aironet adapter. The username and password remain on the adapter until power is 
removed from the adapter, typically due to the adapter being ejected or the YEStablet powering 
down. 

6. One of three scenarios occurs: 
a) The client adapter authenticates to the authentication server using your username and password 

and receives a dynamic, session-based WEP key. The bottom of the ACU screen indicates that 
your client adapter is authenticated to an access point. 

b) If you enter the username and password incorrectly or enter ones that are not valid, the Wireless 
Login Module screen reappears with a message indicating that your login was incorrect. You are 
able to retry immediately by re-entering the username and password. 

c) The adapter times out while trying to authenticate, possibly because it is out of range of an 
access point. After 60 seconds, a message appears indicating that the first attempt to 
authenticate failed and that the adapter will continue trying.  Note: During the 60 seconds 
before the timeout occurs, WLM is running in the background. It is hidden and does not appear 
as a running program. If you try to start WLM during this time, nothing happens because it is 
already running. 

 

Citrix ICA Client (all models) 
 
You can configure and run two types of ICA sessions: Citrix server connections and published 
applications.  
Citrix server connections allow you to connect to the Windows desktop of a specific Citrix server; you 
can run any applications that have been mad available on the desktop by your system administrator, in 
any order. 
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Published applications are specific applications set up by an administrator for remote users.  When 
connected, you are presented with the application itself. 
This manual describes the simplest way to create a session entry either network or dial-up.  When you 
follow these steps, you set the essential items you need to connect to a Citrix server from the Windows 
CE device, See Editing an Existing Connection for more information about changing the other 
properties for a connection entry.  For the ultimate in detailed information about ICA operation and 
features, please refer to the Windows Based Terminal Administrator's Guide for Citrix ICA Client at 
http://www.affirmative.net/pub/icaceUG.pdf. 
 
When you click on OK after selecting Citrix ICA Client, a Setup Wizard with a series of dialog boxes 
will be invoked.  Some of them will allow you to override some of the global ICA properties that you 
set in Configure Terminal Properties|Control Panel|Ethernet Network|ICA Utility.  In each dialog box, 
click on Next to advance to the next box, or click on Done to bypass the remaining boxes. 
 

 
Specify Connection Type Dialog Box 

• Click Network Connection to make an Ethernet network connection.   Make sure your WBT is 
connected to the network through the Ethernet connector or wireless LAN adapter.  Click Next to 
continue. 

• Click Dial-In Connection to make a dial-in connection.  Make sure your modem is installed and 
properly configured.  Click Next to continue. 

 

Network Connection 
 
If you chose Network Connection, you will see the following dialog box. 
 

 
Select a MetaFrame Server or Published Application Dialog Box 
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1. Select Server or Published Application. 
2. If your server or published application is on the local sub-net, click on Refresh. 
3. The terminal will search the local sub-net for all Citrix servers or published applications, and will 

present a list in the lower box.  You will get an error message if none are found. 
4. Double-click on the desired item in the list.  It will appear in the upper box. 
5. If your server or application is not found for some reason, you can type in the IP address or 

application name in the upper box, or you may want to choose an alternate server location. 
• If your WBT is not on the same network as the Citrix server you want to connect to (for 

example, if you are on the other side of a router, across the Internet, or using RAS to connect to 
a remote network containing Citrix servers), the Server and Published Application lists will not 
contain that server. In this case, click Server Location and go to the Server Location dialog box 
to choose, add or delete a Server Location.  Alternate locations may already have been set up in 
Configure Terminal Properties|Control Panel|Ethernet Network|ICA Utility|Server Location.  If 
not, follow the instructions in that section to add more servers. 

6.  

 
Select a Title Dialog Box 

By default, the Citrix server or published application name appears in the edit field. You can accept 
this name or enter another. The name you choose will be the name of the entry in the Terminal 
Connection Manager Connection Name list and will appear in the title bar of the ICA session 
window. 

7.  

 
Specify an Application Dialog Box 

Note:  This dialog box does not appear when configuring a published application connection. 
If you want this session to open in a specific application on the server after the logon to the Citrix 
server is successful, enter the path and executable file name of an application in the Command 
Line field.  Leave this field blank to run a Windows desktop from the Citrix server. Working 
Directory lets you associate a directory with the application specified in Command Line. 
• For example, if the application Notepad.exe is in the C:\WTSRV directory on the Citrix server, 
type C:\WTSRV\Notepad.exe in the Command Line field.  If you use Notepad to work on 
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documents in the C:\My Documents directory, type C:\My Documents in the Working Directory 
field.  When you log on to the Citrix server, Notepad begins. In Notepad, if you click the File menu, 
the directory C:\My Documents is displayed. 

8.  

 
Specify Logon Information Dialog Box. 

Type a valid user name, domain, and password. If you leave these fields blank, you are prompted 
for your user name, domain, and password whenever the ICA Windows CE Client connects to the 
Citrix server. 

9.  

. 
Select Window Options Dialog Box 

We recommend that you select 16 or 256 colors.  There is a Citrix bug that sometimes produces 
strange video results at higher settings. 

10.  

 
Compression, Encryption and Sound Dialog Box 

• Click Use Printer Configuration Utility to enable printer auto-configuration. 
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• Click Compress Data Stream to reduce the amount of data transferred between the ICA 
Windows CE Client and the Citrix server hosting the session. (If your connection is bandwidth-
limited, enabling compression may increase performance. If your WBT is on a high-speed LAN, 
you may not need compression.) 

• Click Enable Sound to enable sound support. Remote applications will be able to play sounds 
on your client. From the pull-down list, select a sound presentation quality level. High provides 
the greatest audio quality but should only be used when bandwidth consumption is not a 
concern. Medium results in less bandwidth consumption than when using High. Compression 
of sound data provides greater bandwidth efficiency but reduces sound quality somewhat. This 
value is recommended for most LAN-based connections. Low offers the most efficient use of 
bandwidth but also decreases sound quality severely. This value is recommended for low-
bandwidth connections, including most modem connections. 

• Speed Screen latency reduction improves responsiveness over high latency connections by 
providing feedback to the user in response to typed data or mouse clicks.  Speed Screen will 
only work if the server-side Speed Screen feature is available and has been enabled on the Citrix 
server to which you are connecting.  In the “Speed Screen” field, select the setting you need.  
• For slower connections (for example, if you are connecting over a WAN or a dial-in 

connection), set mode to On to decrease the delay between user input and screen display.  
• For faster connections (for example, if you are connecting over a LAN), set mode to Off.  
• If you are not certain of the connection speed, set the mode to Auto to turn Speed Screen 

latency reduction on or off automatically depending on the latency of the connection. 
• Encryption increases the security of your ICA connection. By default, basic encryption is 

enabled on all connections. If the Citrix server you are connecting to supports advanced 
encryption (e.g., Secure ICA services), you can use it to improve security.  Click Encryption 
Level and select the level of encryption you want to use.  Select RC5 128-bit Login Only to use 
encryption only during authentication. The Citrix server must be configured to allow the 
selected encryption level or greater. For example, if the Citrix server is configured to allow RC5 
128-bit connections, the ICA client can connect with RC5 56 or 128-bit encryption. 
Note:  To use advanced encryption, you need to install Secure ICA on your Citrix server. The 
Citrix server must also be configured to allow the selected encryption level or greater. 

11.  

 
Firewall Settings Dialog Box 

See Configure Terminal Properties|Control Panel|Ethernet Network|ICA Utility|Firewall Settings for an 
explanation of these settings. 
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Dial-In Connection 
 
Some Citrix servers are configured to allow direct dial-in without going through a RAS dial-up 
connection.  If this is your situation, you can use this Dial-In Connection option.  Do NOT use this 
option if you want this session to connect to a Citrix server through a RAS dial-up connection.  In that 
case, create an ICA session as a network connection with the server IP address of the remote Citrix 
server.  Then create a RAS dial-up connection (see Creating a New Connection|Dial-Up Client) and, in 
step 3 of that setup, choose the network connection that you just created to automatically start after the 
RAS connection has been made. 
 
Note: The ICA Windows CE Client does not support modem callback for Dial-In connections. 
 
If you have a 22xx terminal, you must have a USB-to-Serial converter between your serial modem and 
a terminal USB port. 
 
When you choose Dial-in Connection in the “Specify Connection Type” dialog box, and click on 
Next, the Dial-In Devices dialog box displays. 
 

 
Dial-In Devices Dialog Box 

• Phone Number.  Enter the complete phone number, including area code and country code, if 
applicable, of the Citrix server. 

• Use Tone Dialing.  Check this box if your modem uses tone dialing, as is typical these days. 
 

Dial-In Device 
Select your device from the drop-down list.  Then click on Configure to set the device properties. 
 

 
Port Settings Dialog Box 
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• Manual Dial.  Check this box to use manual dialing instead of the number entered in Telephone 
Number. 

• Terminals.  Per your application requirement, you can check one or both of these boxes. The 
default setting disables both check boxes and executes an automatic log-on to the server. 

• Connection Preferences.  Select the serial connection preferences from the drop-down lists.   
These preferences will be identical for all COM connections in this session; you cannot have 
different preferences for COM1 and COM2. 

 

 
Call Options Dialog Box 

• Call Setup.  Check the appropriate boxes and set the time to wait for connection or dial tone before 
canceling a call. 

• Extra Settings (Alt+x).  A common problem is that some “Hayes-compatible” modems, including 
some from a very popular vendor, are not really 100% Hayes compatible.  When that occurs, it can 
usually be fixed by entering a modem initiation string here.  Talk to your modem vendor for the 
details of this initiation string. 

 
The remaining steps of Dial-In Connection setup are the same as Network Connection setup. Please 
refer to steps 6 through 11 of Network Connection setup. 
 

Dial-Up Client (all models) 
 
The Dial-up networking feature is implemented with Remote Access Service (RAS) and the Point-to-
Point Protocol (PPP). Dial-up Networking allows the terminal to access network resources from a 
remote server. The terminal can connect to a remote access server using direct serial as well as dial-up.   
 
If you have a 22xx terminal, you must have a USB-to-Serial converter between your serial modem and 
a terminal USB port.  If you do not have this converter, you will get an error message when you try to 
add a dial-up session. 
 
You will use the Remote Connection Wizard to create a new Dial-Up connection. Click Next to display 
the next dialog box in the sequence. Click Back to return to the previous dialog box.  When you are 
finished, a new connection will be added to the Connection Name list in the Terminal Connection 
Manager. 
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There are three major steps for the Dial-Up Remote Connection Wizard process. 
1.  

 
Remote Connection Wizard Dialog Box #1 

The name entered here is the name that will be listed in the Terminal Connection Manager. 
2.  

 
Remote Connection Wizard Dialog Box #2 

• Telephone Number. 
o Force local/long distance.  Leave these boxes unchecked 
o Country/Area Code.  Ignore these fields. 
o Telephone.  Put the complete number, including area code, here.  If you are making an 

international call, enter the international prefix (011) and the country code also. 
• Device Setting for RAS Connection: Select a device from the drop-down list. 

 

Dialing Properties 
 
Click on this button to display the Dialing Properties dialog box.  
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Dialing Properties Dialog Box 

• When Dialing From.  Ignore this parameter. 
• The Local Area/Country Code is.  Ignore these fields. 
• Dial Using.  Select the appropriate radio button. 
• Disable Call Waiting By.  Check this box, if applicable, and enter the appropriate disable 

sequence. 
 

Dialing Patterns 
Activate this button to open the Dialing Patterns dialog box. 
 

 
Dialing Patterns Dialog Box 

All calls are treated as local calls.  Ignore the Long Distance and International fields, and delete 
everything except G from the Local field unless you have to dial a numeral to get an outside line.  In 
that case, add the numeral to the Local field (i.e. 9,G).   

 

Configure 
 
This button is used to configure the device that you selected in Device Setting for RAS 
Connection.  When this button is pressed, the Device Properties dialog box displays with two tabs. 
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Port Settings Dialog Box 

• Manual Dial.  Check this box to use manual dialing instead of the number entered in Telephone 
Number. 

• Terminals.  Per your application requirement, you can check one or both of these boxes. The 
default setting disables both check boxes and executes an automatic log-on to the server. 

• Connection Preferences.  Select the serial connection preferences from the drop-down lists.   
These preferences will be identical for all COM connections in this session; you cannot have 
different preferences for COM1 and COM2. 

 

 
Call Options Dialog Box 

• Call Setup.  Check the appropriate boxes and set the time to wait for connection or dial tone 
before canceling a call. 

• Extra Settings (Alt+x).  A common problem is that some “Hayes-compatible” modems, 
including some from a very popular vendor, are not really 100% Hayes compatible.  When that 
occurs, it can usually be fixed by entering a modem initiation string here.  Talk to your modem 
vendor for the details of this initiation string. 

 72



 

TCP/IP Setting 
 
Click on this button to see the TCP/IP Settings dialog box. 
 

 
TCP/IP Settings Dialog Box 

The default settings you see here are commonly used to access a RAS server, and seldom need 
changing.  Your network administrator will give you any changes that are necessary. 

3.  

 
Remote Connection Wizard Dialog Box #3 

• Automatic Logon.  Click on this box and enter the appropriate parameters here for an 
automatic RAS logon. 

• Automatic Connection.  Click on this box to automatically open an ICA, RDP, or YESterm IP 
session after the RAS connection is made.  A list of all eligible sessions is shown in the list box.  
Highlight the desired session.  Note:  Any session considered for automatic connection in this 
box MUST have been configured for network connection, not dial-in connection.  Also, the 
session should NOT be set to Autostart in the Terminal Connection Manager. 
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4.  

 
Remote Connection Wizard Dialog Box #4 

Check "Finish" to complete the Dial-Up connection setup. 
 

Microsoft Internet Explorer (all models 
except 2610 and 2611) 
 
These terminals use Internet Explorer 5.5. It has most of the features of the PC version, but it does not 
support Java Virtual Machine, Active X, or Flash.  New Web connections take on the default properties 
established in Configure Terminal Properties|Web, except for the Start Page. 
 

 
Web Connection Add Dialog Box 

• Name.  This name will appear in the Connection Name list of Terminal Connections Manager. 
• Default Start Page.  Check this box to use the default Start Page.  If you want a unique Start url, 

leave the box unchecked and enter that url here. 
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Microsoft Remote Desktop Client (all 
models) 
 
The WTS Connection Wizard is used to create a new RDP connection to a Microsoft Terminal Server. 
When you are finished, a new connection will be added to the Connection Name list in the Terminal 
Connection Manager.  There are four dialog boxes for the WTS Connection Wizard process. 
1.  

 
WTS Connection Wizard Dialog Box #1 

• Name.  Enter the connection name to be listed in the Connections Name list of the Terminal 
Connection Manager. 

• Server.  If you have a local DNS or WINS server, enter the network name of the selected 
server.  Otherwise, enter the IP address of the selected server. 

2.  

 
WTS Connection Wizard Dialog Box #2 
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• Automatic Logon.  Check this box to enable automatic logon. The Username, Password and 
Domain fields will be enabled, and you can enter the necessary logon information. 

3.  

 
WTS Connection Wizard Dialog Box #3 

• Desktop.  Click on this button to start the session with the server desktop. 
• Application file name.  Click on this button to start the session in an application.  In the first 

field, enter the name of the executable file of an application to run on the server once the logon 
to the server is successful. 

• Working Directory.  Enter the path, on the server, to that executable file.  For example, if the 
application Notepad.exe is in the C:\WTSRV directory on the server, type Notepad.exe in the 
file name field.  Type C:\WTSRV in the Working Directory field.  When you log on to the 
server, Notepad begins. 

4. 

 
WTS Connection Wizard Dialog Box #4 

Note:  Microsoft Corporation has acknowledged three not-so-obvious RDP connection issues with 
Windows 2000 Terminal Services & Windows NT 4.0 Terminal Server.   
 
Issue #1. Microsoft has acknowledged licensing issues when Thin Clients like the Affirmative 
YEStation connect to a Windows 2000 Terminal Services server.  Microsoft strongly recommends 
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applying the Terminal Services Licensing Enhancement Update, which can be found by accessing 
Microsoft’s Knowledge Base Article: Q287687.  Duplicate client licenses, inability for a thin client to 
connect, and other unknown repercussions could result if this update is not applied. 
 
Issue #2. If your organization connects to a Windows 2000 or Windows NT 4.0 Terminal Server with a 
host name, the RDP Server parameter in the YEStation requires a fully qualified name.  For example, if 
your Windows 2000 Terminal Service host name is: SERVER1 and the DNS Default Domain is: 
COMPANY.COM, then the fully qualified name is:  SERVER1.COMPANY.COM 
 
Issue #3. If your organization connects to a Windows 2000 or Windows NT 4.0 Terminal Server using 
the RDP Protocol and you use DNS entries in your Thin Client setup, Microsoft requires a local DNS 
Server to resolve the server IP address or fully qualified name.  Users who do not specify DNS entries 
in the YEStation Network setup will not need a DNS server to resolve the server’s IP address. 
 

Microsoft Viewers (all models except 
2610, 2611, 2612, and 7330) 
 
Four viewers, Excel, Acrobat PDF, PowerPoint, and Word, are provided.  The appropriate viewer will 
open automatically when document is downloaded in a browser connection.  Note:  When trying to 
open a downloaded document, you may get an error message “xxx Viewer encountered an internal error 
trying to load or display the requested file”.  This usually means that there is not enough room in your 
browser cache.  You can try any or all of the following corrective procedures: 
• Clear cache in View|Internet Options and download again. 
• Increase the cache size in View|Internet Options and download again. 
• Close the browser session, reopen, and download again. 
 
You can also view email attachments, files in USB storage, and files in shared network drives with the 
following procedure: 
1. Click on Add in the Configure tab. 
2. Select the desired viewer from the drop-down list. 
3. Click on OK. 
4. In the resulting window, open the File menu. 
5. Click on Open. 
6. Browse to the desired file. 

• For email attachments, browse to Program Files\Inbox\Mail Attachments. 
• For USB storage, browse to USB Storage. 
• For shared network drives, type the path in the Name field. 

7. Close the viewer from the File menu when you are finished.  You will have to repeat the procedure 
when you want to again use a viewer. 

 
Note:  When a viewer window is open, you cannot get back to Connection Manager.  You can switch to 
other active sessions by using Ctrl+Alt+UpArrow/DownArrow, but Ctrl+Alt+End will return you to 
the open viewer window. 
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PMail (Inbox) (all models except 2610 
and 2611) 
 
PMail is exactly like Inbox, except for name, for those of you who are familiar with this email program 
in Pocket PC.  You can send and receive e-mail by connecting to POP3 or IMAP4 servers. PMail 
contains an e-mail service for each method you use. For example, if you receive e-mail through a 
connection to a POP3 server and through a connection to an IMAP4 server, PMail will contain two 
services: POP3 Mail and IMAP4 Mail. Each e-mail service has its own folder hierarchy with four 
default folders: Inbox, Outbox, Deleted (local), and Sent. The messages you receive and send through 
the mail service are stored in these folders. You can also create additional folders within each hierarchy.  
You can set up multiple services of either protocol, but you can only connect to one service at a time. 
 
Note:  PMail only allows email connections through the LAN.  Modem connections are not allowed. 
 

Connecting to a Mail Server 
 
To connect to your POP3 or IMAP4 mail server, you need to set up a mail service. 
1. Get the following information from your ISP or network administrator: POP3 or IMAP4 server 

name, SMTP host name, user name, password, and domain name. 
2. Open PMail from the Add drop-down list in Connection Manager, and select the Services > 

Options > Services tab. 
3. Select Add. 
4. From the Service type list, select POP3 Mail or IMAP4 Mail. 
5. Enter a unique name for the service. This name cannot be changed later; if you later want to change 

the name, you will have to delete the service and add a new one with the desired name. 
6. Select OK. 
7. Follow the steps in the Setup wizard.  For more information, see the following topics. 
8. You will not see a PMail session in the Connections list.  Whenever you want to use PMail, you 

will have to access it from the New Connections drop-down list in Configure.  But all of your setup 
and configuration information is saved, so you don’t have to do that again unless you want to make 
changes. 

 
Notes: 
• When a PMail window is open, you cannot get back to Connection Manager.  You can switch to 

other active sessions by using Ctrl+Alt+UpArrow/DownArrow, but Ctrl+Alt+End will return 
you to the open PMail window. 

• Other mail protocols, such as the protocol used by AOL, are not supported. In addition, services that 
use special authentication, such as MSN, are not supported. 

• If you use the same service to connect to different mailboxes, set up and name a different service for 
each mailbox. 

 

Set Service Definitions (wizard dialog box #1) 
The Mail Service Definition dialog box appears after you add a service. If you are adjusting the 
settings of an existing service, select Services > Options, select the service you are using, and then 
Properties. In the Service Definition dialog box, complete the following entries as needed: 
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• Connection.  Select Network Connection. 
• POP3 Host (POP3 only). Enter the name of the mail server you use to receive and send messages. 
• Server (IMAP4 only). Enter the name of the mail server you use to receive and send messages. 
• User ID. Enter the user name or mailbox ID assigned to you. 
• Password. Enter the password you use to access this mail account. If you do not want to be 

prompted to enter the password each time you connect, select Save password. 
• Domain (Windows NT). Enter your Windows NT domain name. This name is required only when 

connecting to networks, such as a corporate network, that use Windows NT domain security. This is 
not required for most ISP accounts. If you have trouble connecting, try clearing this box. 

• SMTP Host. If your mail service uses a separate server for SMTP, enter the name in the box. If 
you're setting up a POP3 Mail service with an ISP, the ISP must use an SMTP mail gateway. 

• Return Address. By default, the return address is set to username@POP3host or 
username@Servername, depending on the service you are using. If this is not your e-mail address, 
enter the correct address in the box. 

 

Set general preferences (wizard dialog box #2) 
If you are adjusting the settings of an existing service, select Services > Options, select the service you 
are using, select Properties, and then select Next. In the General Preferences dialog box, choose any 
of the following settings, all of which are optional: 
• Disconnect service after actions are performed: Select to automatically disconnect from the 

server upon completion of all pending actions. This option minimizes connect time and cost. 
• Check for new messages every: Select the time interval (in minutes) at which you want the device 

to check for new mail. If this option is turned off, you must check for new mail manually by 
selecting Services > Send/Receive Mail. 

• Display a message box when new mail arrives (POP3 only): Select to be informed that new mail 
has arrived. 

• Play a sound (IMAP4 only): Select to be informed that new mail has arrived. 
• Send using MIME format (POP3 only): Select to send messages with extended characters. 
• Only display messages from the last 3 days: Select how many day's messages you want 

downloaded. 
 

Set Inbox preferences (wizard dialog box #3) 
If you are adjusting the settings of an existing service, select Services > Options, select the service you 
are using, select Properties, and then select Next twice. In the Inbox Preferences dialog box, choose 
any of the following options: 
• Get message headers only: Select to save storage space and time by downloading only headers. 

You can download a full copy of the message later by selecting the message and then Services > 
Get Full Copy. 

• Include <number> lines: Select to set the message length (approximate number of lines) that you 
want to download. 

• Get full copy of messages: Select to receive a full copy of all messages. In addition to the message 
body, any options you select in When getting full copy will be downloaded. Selecting this option 
increases the amount of time needed to download messages. 

• Only synchronize folder hierarchy under Inbox (IMAP4 only): Select to speed download time by 
preventing the complete download of the folder list every time you connect. 

• Get meeting requests (POP3 only): Select to download and store copies of meeting requests when 
getting full copies of messages. This setting applies whether you have chosen to download full 
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copies of messages by default, or if you selectively download full copies of messages by opening 
the message and selecting Services > Get Full Copy. Limitations apply. 

• Get file attachments (POP3 only): Select to download and save message attachments when getting 
full copies of messages. This option may use significant RAM and slow download time. This setting 
applies whether you have chosen to download full copies of messages by default, or if you 
selectively download full copies of messages by opening the message and selecting Services > Get 
Full Copy. 

• Get file attachments and meeting requests (IMAP4 only): Select to download and store meeting 
requests and message attachments when getting full copies of messages. This setting applies 
whether you have chosen to download full copies of messages by default, or if you selectively 
download full copies of messages by opening the message and selecting Services > Get Full Copy. 
Limitations apply. 

• Only if smaller than (IMAP4 only):  Select to restrict the size of the attachments you download. 
Set to 10K if you want to receive meeting requests only. 

 

Download messages from the server 
 
When you download messages, you need to create two connections: a remote connection and a mail 
server connection. The remote connection connects you to your ISP or network.  The mail server 
connection downloads messages from your mail server to Inbox on your device. When you select 
Services > Connect in Inbox, Inbox starts a remote connection using the connection you specified 
when setting up the current mail service. If you are already connected through a remote connection 
other than the one you specified in the mail service, you will be asked if you want to use the current 
connection. If you choose not to, you will need to disconnect from the current connection before you 
can check for new messages.  The procedure is: 
1. Select the Services menu and make sure that the service you want to use is selected (the selected 

service has a bullet next to it.) 
2. Select Services > Connect. The messages on your device and mail server are synchronized: new 

messages are downloaded to the device Inbox folder, messages in the device Outbox folder are sent, 
and messages that have been deleted on the server are removed from the device Inbox. Double-click 
a message in the message list to open it. 

3. If you read a message and decide that you need the full copy, select File > Get Full Copy while in 
the message window or Services > Get Full Copy while in list view. This will also download 
message attachments and meeting requests if you have those options selected in the Inbox 
Preferences dialog box. You can also choose to download full copies of messages by default. 

4. When finished, select Services > Connect to disconnect. You also need to disconnect your dial-up 
connection by double-clicking the icon in the status bar and selecting Disconnect. 

 
Notes: 
• Receiving entire messages consumes storage memory. 
• The size column in the Inbox list view displays the local size and server size of a message. Even 

when a message has been downloaded fully, these numbers may differ because the size of a 
message can vary between the server and the device. 

• When using IMAP4 to get Outlook or Schedule+ data, you will see the contents of your Journal 
folder. File editing transactions and documents (such as Task items, e-mail messages, and Word 
documents) attached using drag and drop will appear as shortcuts on the device. A copy of the 
document will not be moved to your device, and the shortcut on the device cannot be used to access 
the document. To move documents associated with a journal entry to the device, attach the 
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document to the entry rather than dragging and dropping it. Also, be sure to set your IMAP4 service 
to receive full copies of messages, attachments, and meeting requests. For more information on 
using Journal, see the Help for the desktop version of Outlook. 

 

Reply to or forward a message 
1. Open the message, and then select Compose > Reply to Sender, Reply to All, or Forward. 
2. Enter your response. 
3. Select File > Send. 

• Selections in the Options dialog box determine whether the original text is included. 
• To see more header information, select the inverted triangle in the lower-right corner of the 

header area. Select the triangle again to collapse the header area. 
 

Add the sender to Address Book 
1. Open the message, and then select Compose > Add Sender to Address Book.  A new contact card 

will open with the sender's name and e-mail address already entered. 
2. Enter other desired information. 
 
Or 
 
1. Select Go > Address Book. 

• To add a new entry, select New. Enter the name you want to type in the To and CC fields of 
messages in the Name field. 

• To delete an entry, select it, and then select Delete. 
• To edit an entry, select it, and then select Edit. 

   

Check Inbox status 
In list view, select Compose > Status.  You can view details such as the number of messages to be 
sent, deleted, and copied, and the number of attachments to be downloaded. 
 

Include the original message in a reply 
1. Select Services > Options > Compose tab. 
2. Under Reply, select Include Body.  This setting will place a copy of the original message beneath 

your response text. 
3. To indent the original message, select Indent. 
4. To add leading characters (such as >) to the original message lines, select Add leading character, 

and enter the character you want. 
 

Enlarge the message font 
1. Open the message you want to read. 
2. Select File > Large Font. 
3. To return the font to its original size, select File > Large Font again. 
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Composing and Editing Messages 
 
1. In list view, select Compose > New Message. 
2. Enter the address of one or more recipients, separating them with a semicolon. If the recipient is 

listed in the Address Book, enter a few letters of the recipient's name and select Compose > Check 
Names. If there is only one match, the e-mail address is inserted. If there is more than one match, 
select the correct address from the Choose E-mail Recipients dialog box. If there is no match, add 
a new e-mail address through Choose E-mail Recipients. 

3. To attach a file, select File > Attachments > Add Attachment.   
4. Select File > Send. If you are working offline, the message is moved to the Outbox folder and will 

be sent the next time you connect. 
 
To see more header information, select the triangle in the lower-right corner of the header area.  Select 
the triangle again to collapse the header area. 
 

Save a message 
Select File > Save to save the message you are composing or editing.  The message is not sent and is 
saved in the Inbox folder of the active service. 
 

Save copies of sent messages 
By default, sent messages are not saved on your device.  To automatically save sent messages: 
1. Select Services > Options > Compose tab. 
2. Select Keep copy of sent mail in Sent folder. 
 

Working with Folders 
 
Inbox contains folders from mail services you have set up. You can set up services to connect directly 
to a remote mail server. When you set up a service, it appears in the Inbox list view.  Each service 
contains four default folders: Inbox, Deleted (local), Outbox, and Sent. The Deleted (local) folder 
contains messages that have been deleted on the device. If you are using IMAP4, you may see a 
Deleted Items folder. This folder is for messages deleted on the server. The behavior of the Deleted 
(local) and Sent folders depends on the Inbox options you have chosen. 
 
You can also create your own folders. The behavior of the folders you create depends on whether you 
are using POP3 or IMAP4. 
 
If you are using POP3 and you drag messages to a folder you created, the link is broken between the 
messages and their copies on the mail server. The next time you connect, the mail server will see that 
the messages are missing from the device Inbox and delete them from the server. This prevents you 
from having duplicate copies of a message, but it also means that you will no longer have access to 
messages you move to folders you create from anywhere except the device. 
 
If you are using IMAP4, the folders you create and the messages you move are mirrored on the server. 
For example, if you move two messages from the Inbox folder to a folder called Family, the server will 
create a copy of the Family folder and copy the messages into that folder. Therefore, messages are 
available to you anytime you connect to your mail server, whether it is from your device or PC. This 
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synchronization of folders occurs when you create a new folder, move messages into a folder, exit the 
Inbox program, or select Services > Synchronize Folders. If you want to view the messages in a folder 
while disconnected from your mail server, select the folder and then Services > Offline Folder. 
 

Create a folder 
1. Select File > Folder > New Folder. 
2. Type a name for the folder. 
 

Rename a folder 
1. Select the folder you want to rename. 
2. Select File > Folder > Rename Folder. 
3. Type the new name for the folder. 
 
Notes 
• Default folders, such as Inbox, can't be renamed. 
• Folders you create for IMAP4 mail servers can't be renamed. 
  

Delete a folder 
1. Select the folder you want to delete. 
2. Select File > Delete. 
 
Note: Default folders, such as Inbox, can't be deleted. 
   

Designate a folder as offline 
Only IMAP4 folders can be designated as offline. All IMAP4 default folders, such as Inbox, are 
automatically designated as offline. Messages in offline folders can be viewed when you are 
disconnected from your mail server. If a folder is not designated as offline, you will be able to read and 
respond to messages in that folder only when connected to the server. 
 
To designate a folder as offline, select the folder, and then select Services > Offline Folder. 
 

Synchronize folders while connected 
When you synchronize folders, the contents of your device folders and mail server folders are 
compared and updated. New mail messages are downloaded, and messages in your device Outbox 
folder are sent. The synchronization behavior depends on how you connect to your mail server. 
 
When you connect to a POP3 server, the Inbox and Outbox folders on your device are 
synchronized with the corresponding folders on the mail server. To synchronize after the initial 
connection, select Services > Send/Receive Mail. 
 
When you connect to an IMAP4 server, Inbox, Outbox, and all folders marked as offline are 
synchronized. To synchronize all folders after the initial connection, select Services > 
Synchronize Folders. To synchronize just the selected folder and the Outbox folder, select 
Services > Send/Receive Mail. 

 83



 

Organizing Messages 
 

Move or copy a message 
1. Select the message. 
2. Select File > Move To or File > Copy To. 
3. Select the destination folder. 
 
If you are working offline, the message will be moved or copied from the server the next time you 
connect. 
 
Caution: When you move a message that you have received through POP3 or synchronization to a 
folder you created on your device, the copy of the message on the server is deleted. This prevents 
duplicate copies of messages. Although the complete message is moved, message attachments will be 
deleted if you have not selected the option to download attachments. Once the message is moved, you 
will be able to access the message only from your device. 
 

Delete a message 
Select the message and select File > Delete. Messages are moved to the Deleted (local) folder and 
deleted according to the option you have selected in Services > Options > Delete tab: 
• On connect/disconnect: Deletes messages when you connect or disconnect from your mail service 

or exit Inbox. 
• Immediately: Deletes messages as soon as you select File > Delete. 
• Manual: Deletes messages when you select File > Empty Deleted (local). 
 
Note If you are working offline, messages that have been deleted from the server will be deleted from 
the device the next time you connect. 
   

Empty the Deleted (local) folder 
Select File > Empty Deleted (local).  This permanently deletes messages in the Deleted (local) folder. 
To check or adjust the current settings for deleting messages, select Services > Options > Delete tab. 
 

Clear messages and folders 
When receiving mail from a POP3 or IMAP4 server, select the service that contains the folders and 
messages you want to clear, and then select Service > Clear All. All messages and folders that are 
linked to the selected service are cleared and memory space is expanded on the device without deleting 
messages on the server. The next time you connect, the messages and folders are downloaded again. 
 

Unmark a message 
To unmark a message that is marked for download, double-click the marked message. 
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Working with Message Attachments 
 

Receive attachments 
If you receive messages through a remote mail server, in Inbox on the device, select the Get file 
attachments and meeting requests (IMAP4) or Get meeting requests (POP3) setting in the Inbox 
Preferences dialog box. 
 
Notes: 
• Embedded images and OLE objects cannot be received as attachments. 
• Embedded messages can be viewed as an attachment when using IMAP4 to receive e-mail. 

However, this feature does not work if TNEF is enabled so that you can receive meeting requests. 
 

Check attachment status 
• An attachment sent with an e-mail message, whether it has been downloaded or not, will appear as 

an icon at the bottom of the message in its own windowpane. If you don't see this pane, select File > 
Attachments > Show Attachments. If TNEF is turned on so you can receive meeting requests, you 
will not see attachments until they are fully downloaded. 

• To mark an attachment for downloading in a POP3 or IMAP4 service, double-click it. The 
attachment will be downloaded the next time you connect. You can also set Inbox to download 
attachments automatically when you get a full copy of a message. 

 

Open an attachment 
With the message open, double-click the attachment's icon at the bottom of the message. If you don't 
see this pane, select File > Attachments > Show Attachments. 
 

Store an attachment 
1. Select Services > Options > Storage tab. 
2. Select to store attachments on internal RAM or a storage card. 
3. If you use more than one storage card, select it from the list. 
 
Note: Once you make the above selection, all attachments will be moved to the selected card. 
 

Delete an attachment 
1. To delete an attachment from a message you are sending, select the attachment, and then select Edit 

> Clear or press the DEL key on the keyboard. 
2. To delete an attachment you have received, delete the message. 
 

Attach a file to a message 
1. With the message open, select File > Attachments > Add Attachment. 
2. Select the file you want to attach. 
 
Note: OLE objects cannot be attached to Inbox messages. 
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Adding, removing, and viewing mail services 
• All installed mail services are listed in the Installed services box. 
• To add a mail service, select Add. 
• To remove a mail service, select the service from the Installed services box and then select 

Remove. 
• To view a mail service's properties, select the service from the Installed services box and then 

select Properties. 
 

Terminal Emulation (2212, 2610, 2612, 
7330 models) 
 
The Terminal Emulation selection allows you to add PowerTerm sessions for 3270, 5250, and ASCII 
terminal emulations.  When you add a Terminal Emulation session, the Connection Properties dialog 
appears. 
1. Select the desired Terminal Type. 
2. Supply the host IP address. 
3. Type the Terminal Name if necessary. 
4. Modify the Port # if necessary. 
5. Type the Connection Name. This name automatically appears in the Setup Name field. 
6. Click OK. The new connection appears in the Connection Name list of the Connection Manager. 
 

Virtual Private Network (all models) 
 
Follow the VPN Connection Wizard to configure a VPN connection. 
1.  

VPN Connection Wizard Dialog Box #1 (Not Shown) 

• Name: This is the connection name that will be listed in the Connection Manager. 
2.  

 
VPN Connection Wizard Dialog Box #2 
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• Please key in….  Enter the VPN host name or IP address. 
• Automatic Logon.  Check this box and enter the logon information if you want an 

automatic logon after communication is established with the host. 
• TCP/IP Settings.  Click on this button to see the TCP/IP Settings dialog box. 

 

 
TCP/IP Settings Dialog Box 

The default settings you see here are commonly used to access a VPN server, and seldom need 
changing.  Your network administrator will give you any changes that are necessary. 

3.  

 
VPN Connection Wizard Dialog Box #3 

Click on Finish to complete the VPN connection setup. 

 87



 

VNC Viewer (all models except 2610 and 
2611) 
 
VNC (Virtual Network Computing) is, in essence, a remote display system which allows you to view a 
computing 'desktop' environment from anywhere on the Internet.  It is platform-independent. A desktop 
running on a Linux machine may be displayed on a PC, or on your YEStation.  VNC requires a server 
software module in the machine that is being viewed and a viewer software module in the viewing 
machine.  With this VNC Viewer, you can view and control the desktop on any machine that is running 
the VNC server software.  Of course, you need a TCP/IP connection to allow this to happen. 
 
You can learn much more about VNC from the Web site 
http://www.uk.research.att.com/vnc/index.html. 
 
1. The first time that you add a VNC Viewer, you will see a dialog box that is very similar to this one. 
 

 
VNC Connection Details Dialog Box 

• VNC server.  Enter the network name or the IP address of the device that you wish to view, 
along with the display number on the device (display 0 always works for me).  For example, if 
the device name is snoopy, the entry will be snoopy:0.  An IP address entry might be 
100.100.10.10:0.  NOTE: You must enter a display number; the viewer will not default to 
0. 

• Options.  Click on this button to open the Connection Options dialog box.  Probably the most 
important option here is View only.  As the name implies, if this box is checked, you can only 
view the server desktop.  If the box is not checked, you can provide keyboard and mouse input 
to the server desktop, much like an ICA or RDP session.  For details on using other options, see 
the documentation at the above-referenced Web site. 

2. When you press OK, the viewer will attempt to make a connection to the server identified in VNC 
server.  If the server software is on at that device, you will see a dialog box asking for the password 
that has been configured in the VNC server properties.  After entering the correct password, you 
will see a rendition of the server desktop.  Note:  When the viewer window is open, you cannot get 
back to Connection Manager.  You can switch to other active sessions by using 
Ctrl+Alt+UpArrow/DownArrow, but Ctrl+Alt+End will return you to the open viewer window. 

3. To close the viewer window, double-click on Close in the Connection menu. 
4. Whenever you want to use VNC Viewer, you will have to go to the Connection Details dialog box.  

But all of your initial options and server information will still be in the dialog boxes, so all you have 
to do in subsequent viewings is click on OK, unless you want to go to a different server or change 
the options. 
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YESterm IP Emulators (2213, 2611, 2613, 
2613P, 7331 models) 
 
The YESterm IP emulators are powerful Telnet emulators that provide Windows CE users with the 
capability to connect to an AS/400 or an IBM mainframe, via the TCP/IP protocol. They provide 
enhanced emulation functions for a wide range of IBM terminals and "true" IBM 3812 or 3287 Printer 
emulation with the support of all the enhanced features normally available only on very expensive 
printer interfaces.  YESterm/IP can easily support up to 4 concurrent TCP/IP connections with different 
AS/400 and/or mainframe hosts.  In addition, YESterm/IP TN5250E supports the "Enhanced Display 
Auto-Signon and Password Encryption" allowing a secure connection to the AS/400, with no need of 
any SSL option. The configuration of Telnet sessions is made simple by a Wizard application that 
guides the user during the configuration process. 
 

Display Sessions 
 
Significant characteristics of YESterm IP display sessions are: 
• IBM emulations supported: 3180-2, 3196, 3278/9, 3477-FG, 3477-FC, 5251, 5291. 
• Numerous resident national keyboard templates and Code Pages. 
• Enhanced keyboard mapping and customization, using Shift, Caps Lock, Alt, Ctrl, function keys, 

etc. 
• EURO (€) symbol supported. 
• Enhanced copy and paste options. 
• Programmable Keypad. 
• Attributes editing. 
• Enhanced customizable Hot Spot feature. 
• Enhanced macro Record/Playback feature. 
• Supports "Enhanced Display Auto-Signon and Password Encryption" allowing a secure connection 

to the AS/400. 
• Choice of Windows or 5250 Text presentation modes. 
 

Setup 
In the Add drop-down list, you are faced with a choice of TN3270e or TN5250e emulation types.  After 
choosing one, a wizard will guide you through setup.  You can have a maximum of four emulation 
sessions, with any mixture of 5250 and 3270 display and/or printer emulations. 
 
The Setup Wizard will take you through three dialog boxes.  Activate Next to go to the next box, Back 
to return to the previous dialog box, and Cancel or the Esc key to abort the process. 
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1.  

 
 

Display Setup Wizard Dialog Box #1 

• Host Name/IP Address.  If you have a local DNS or WINS server, you can type in the host 
network name.  Otherwise, type in the IP address of the host. 

• Port Number.  Use the default of 23 unless directed to do otherwise by your system 
administrator. 

2.  

 
Display Setup Wizard Dialog Box #2 

• Connection Name.  This is the friendly name that will appear in the Connection Manager 
screen. 
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• Device Type.  Select one from the drop-down list.  The default 3477-FC works well for 
TN5250e emulation, unless you have special needs. 

• Device Name.  If you are using named sessions, enter the session name here. 
3.  

 
Final Display Setup Wizard Dialog Box 

 
• Host Code Page.  Choose the applicable country from the drop-down list. 
• Keyboard Type.  Choose 101 Terminal if you are using the Affirmative Computer Products 

1010T, 1019T, 1023T, or 1027T 101-key keyboard; choose 122 keys if you are using the 
Affirmative Computer Products 1220T, 1223T, or 1227T 122-key keyboard; otherwise, choose 
101 PC. 

 
This concludes the configuration parameters covered by the wizard.  However, you can customize 
many more parameters in each Display Session by highlighting the connection name in the Configure 
tab of Connection Manager and activating Edit. 
 

Printer Sessions 
 
Significant characteristics of YESterm IP printer sessions are 
• IBM Emulation supported: 3287, 3812. 
• Support for continuous forms, multi drawers, envelope, manual feeders, simplex/duplex, auto page 

orientation, and COR (Computer Output Reduction). 
• Supports CPI, LPI Override and LQ, NLQ. 
• Supports Host Transform Feature (5250 only). 
• Supports Hex Pass-Through (HPT) feature, with customizable leading and ending sequences and 

support of "non-printable characters". 
• Supports EURO symbol (€). 
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Setup 
You can have multiple local printers, but you must create a printer session for each one.  After you 
choose from 3270 Printer or 5250 Printer, a Setup Wizard will take you through three dialog boxes. 
1.  

 
Printer Setup Wizard Dialog Box #1 

• Host Name/IP Address.  If you have a local DNS server, you can type in the host network 
name.  Otherwise, type in the IP address of the host.  If you are creating this session for 
extended local printing, an IP address is irrelevant, but you must enter at least one character to 
satisfy the Wizard. 

• Port Number.  Use the default of 23 unless directed otherwise by your system administrator. 
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2.  

 
Printer Setup Wizard Dialog Box #2 

• Connection Name.  This is the friendly name that will appear in the Terminal Connection 
Manager screen. 

• Device Type.  Only 3287 (3270) or 3812 (5250) is available for TCP/IP devices. 
• Device Name.  If you are using named sessions, enter the session name here. 

3.  

 
Printer SetupWizard Dialog Box #3 

• Host Code Page.   Choose the applicable country from the drop-down list. 
• Printer Driver.  If you are doing local or extended local Print Screens, or if you are not using 

the AS/400 Host Print Transform, choose a driver here that is compatible with the local-attached 
or LAN printer.  If you can’t find one in the list, try Empty Driver. 
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This concludes the configuration parameters covered by the wizard.  However, you can customize 
many more parameters in each Printer Session by highlighting the connection name in the Configure 
tab of Connection Manager and activating Edit. 

 

Return to Table of Contents
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Editing an Existing Connection 
 

Connection properties are edited in the Configure tab of Terminal Connection Manager.  Highlight the 
session of interest and click on Edit. 
 

Citrix ICA Client 
 
When you click on Edit, you will see an Edit Connection Details window with seven properties tabs. 
 

 
Edit Connection Details Window 

 
The properties in each of these tabs exactly correspond to the properties specified in the dialog boxes of 
Creating a New Connection|Citrix ICA Client. 
 

Dial-Up Client 
 
When you click on Edit, you will be led through the same Remote Connection Wizard described in 
Creating a New Connection|Dial-Up Client. 
 

Microsoft Internet Explorer 
 
When you click on Edit, you will see the same Web Connection Add Dialog Box seen in Creating a 
New Connection|Microsoft Internet Explorer.  Other options can be edited within the active session 
from the Internet Options selection of the View menu. 
 

Microsoft Remote Desktop Client 
 
When you click on Edit, you will see an Edit Connection window with two tabs. 
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RDP Edit Connection Window 

The properties in these two tabs are exactly the same as those specified in the WTS Connection Wizard 
in Creating a New Connection|Microsoft Remote Desktop Client. 
 

Terminal Emulation 
 
For detail on editing PowerTerm emulation sessions, see the Affirmative Computer Products Web site 
at http://www.affirmative.net/pub/PowerTermUserGuide.pdf. 

 

YESterm IP Emulators 
 
For detail on editing YESterm IP emulation sessions, see the Affirmative Computer Products Web site 
at http://www.affirmative.net/pics/archive/YESterm-IP_CE.pdf. 
 
 

Return to Table of Contents
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Firmware Upgrade Utilities 
 

There are two methods to upgrade your firmware. 
 

Upgrade from FTP Server 
 
This function can run when an FTP server is available on your Local Area Network (LAN) or on a 
Wide Area Network.  The FTP server must be able to respond to a file size query from the terminal.  
The FTP server included in Windows 2000 servers does provide this information, but some shareware 
FTP servers do not. 
1. Download the latest-version firmware from the Affirmative Computer Products Web site, per the 

Affirmative Computer Products Technical Support instructions. 
2. Extract the downloaded files.  You will see 1, 2, or 3 files; one of them will be a .bin file. 
3. Save the extracted files in your FTP server with a known path. 
4. Configure your FTP server software with the desired User Name, User Password, and path to the 

firmware files, as required by your particular FTP software package. 
5. Proceed to one of the following sections, depending upon your terminal model. 
 
Note: Your FTP server should not have Proxy protection. 
 

Model 22xx 
 
WARNING: You may lose all your configuration information during the upgrade.  So record your 
configuration information before upgrading. 
 
1. Click on the Control Panel tab. 
2. Double-click on the FTPUpdate icon to see the FTPUpdate dialog box (not shown here). 
3. Enter the information in the fields. 

• Server Name.  Enter the FTP server’s IP address. 
• Server Path Name.  Depending upon how you have configured your FTP server, you may have 

to enter path information to the latest-version firmware .bin file. 
• Server File Name.  Enter the latest-version firmware .bin file name.  An attractive alternative is 

to click on the drop-down arrow at the right of this field.  You will see a drop-down list of all 
the available .bin files in the server path, and you can select the one you want.  If you don’t see 
a drop-down list, there is an error in your path information or in your network connection. 

• User Name.  Enter your User Name to access the FTP server.  
• User Password.  Enter your Password to access the FTP server 

4. Activate the Download button to start the firmware upgrade.  WARNING: DO NOT make any 
change that may corrupt the upgrade procedure, such as turning off power or disconnecting 
from the network, after you activate the Download button. 
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5. A progress bar will show if you connect to the FTP server successfully..  The upgrade process is 
done in two phases, with a progress bar for each phase.  In phase 1, the new firmware is transferred 
over the network into terminal RAM.  If there are any problems in this phase, an error message will 
pop up. Activate the OK button and re-check your upgrade information.  Check the file name for 
accuracy and verify that you have established the correct path information at your FTP server.  The 
error may also possibly be caused by incorrect settings in the Network tab. 

6. In phase 2, which happens automatically after phase 1 is complete, the new firmware will be written 
into flash. 

7. After the second phase is complete, you will be told that the terminal must be rebooted before the 
upgrade takes effect.  You may think that you have a choice at this point, but you really don’t.  You 
cannot proceed any further without rebooting. 

8. If necessary, go through the Setup Wizard and reconfigure your terminal. 
 

Models 26xx and 733x 
 
1. Invoke the Terminal Properties dialog box by pressing the F2 key in the Terminal Connection 

Manager window. 
2. Click on the FTP Update tab.  You will see the following properties sheet. 
 

 
FTP Update Properties Sheet (Not seen in 22xx terminals) 

 
3. Enter the information in the fields. 

• Server Name.  Enter the FTP server’s IP address. 
• Server File Name.  Enter the latest-version firmware .bin file name.  Depending upon how you 

have configured your FTP server, you may also have to enter path information here. 
• User Name.  Enter your User Name to access the FTP server.  
• User Password.  Enter your Password to access the FTP server 
• Auto upgrade….  Do not check this box.  The auto upgrade feature is troublesome. 
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4. Activate the Ready button to start the firmware upgrade.  WARNING: DO NOT make any change 
that may corrupt the upgrade procedure, such as turning off power or disconnecting from the 
network, after you activate the Ready button. This may cause the flash memory in your terminal to 
become unusable until repaired by Affirmative Computer Products. 

5. The FTP Upgrade progress window will show if you connect to the FTP server successfully. 
 

 
FTP Upgrade Progress Window 

6. The upgrade process is done in two phases.  In phase 1, the new firmware is transferred over the 
network into terminal RAM.  If there are any problems in this phase, an error message will pop up. 
Activate the OK button and re-check your upgrade information.  Check the file name for accuracy 
and verify that you have established the correct path information at your FTP server.  The error may 
also possibly be caused by incorrect settings in the Network tab. 

7. In phase 2, which happens automatically after phase 1 is complete, the new firmware will be written 
into flash. 

8. After the second phase is complete, you will be told that the terminal must be rebooted before the 
upgrade takes effect.  You may think that you have a choice at this point, but you really don’t.  You 
cannot proceed any further without rebooting. 

9. If necessary, go through the Setup Wizard and reconfigure your terminal 
. 

Upgrade Using Remote Central 
Management 
 
If TCOSoft or YESManager central management software is installed on your network, you can use 
either of them to upgrade your firmware. This method is usually used on large network systems with a 
large quantity of terminals.  Please see the appropriate User Guide for this upgrade procedure. 
• For TCOSoft, go to http://www.affirmative.net/pub/TCOSofUserGuide.pdf. 
• For YESManager, go to http://www.affirmative.net/pub/YESmanagerUserGuide.pdf. 
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Recovering a Corrupted DOC (models 
26xx and 733x only) 
 
If the DOC in your terminal fails for any reason and the terminal cannot work again (usually evidenced 
by being stuck on the Affirmative logo screen when you boot up), try the following procedure to 
recover. 
 
1. Obtain the DOC Recovery files from Affirmative Computer Products. 
2. Place these files in a separate folder on your FTP server. 
3. On the server side, execute TFTP Server.exe in the DOC Recovery folder.  You will see the 

following window: 
 

 
TFTP Server “Waiting” Window 

4. Reboot the failed unit.  PRESS and HOLD Ctrl + LeftShift + RightShift after the “Loading 
WinCE, Go” display and before the Affirmative logo screen to reach the DOC Recovery utility. 

5. You will see a Recovery screen on the terminal with the brief message “Waiting for server”, and 
then you will see upgrade progress bars. 

6. The terminal will automatically upgrade to a preset version and then automatically reboot.  The bad 
DOC will have been recovered. 

7. On the server, the TFTP Server window will change to: 
 

 
TFTP Server “Done” Window 

8. Go through the Setup Wizard on the terminal. 
9. Upgrade the terminal to the desired version and reconfigure it. 
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Troubleshooting Your Terminal 
 

The following table provides some solutions to common problems that can occur during setting up or 
using your Windows-Based Terminal. 
 

Problems Solution 

1 The monitor screen is blank 

• Make sure the terminal is turned on. 
• Make sure the monitor is plugged into an AC outlet and turned 

on. 
• Make sure the VGA connector is plugged into the terminal. 

2 
Your monitor can not display after 
advancing past the logo screen or after 
changing the display setting 

The display setting may be at a higher resolution or refresh frequency 
than the monitor will support.  Execute one of the following recovery 
options: 
• Use a better monitor for display. 
• Use a better monitor for display while changing the display 

settings to be compatible with the original monitor. 
• Ask your MIS or network administrator to reset your terminal to 

factory default settings through the Remote Management" 
software, if it is installed at your server site. 

3 The mouse does not work 
• Make sure the mouse is plugged into the mouse port, not the 

keyboard port. 
• Test the terminal using a known good PS/2 mouse. 

4 The keyboard does not respond 
• Make sure the keyboard is plugged into the keyboard port, not the 

mouse port. 
• Test the terminal using a known good PS/2 keyboard. 

5 The network connection does not work 

• Check the network connection. 
• Verify the terminal IP address is correct in the Network 

properties sheet of Terminal Properties. 
• Check the server's IP address. 
• If you are using the terminal default setting of DHCP address 

assignment, make sure there is a workable DHCP server on your 
network. 

• If you are using a specified IP address, make sure that there is not 
another network device with the same IP address. 

 101



6 Forgot the password setting and cannot 
reconfigure the terminal. 

Ask your MIS or network administrator to reset your terminal to 
factory default settings through the Remote Management 
software, if it is installed at your server site. 

. 

7 
You have created a Dial-up session, 
but it cannot dial out through an 
external modem. 

Make sure that the Dialing Properties are correct in the Dial-Up 
Connection dialog box of the Dialup properties sheet of Terminal 
Properties.. 

8 
Your Dial-up session dials out through 
your external modem, but it cannot 
make a connection with the server. 

• Your modem may not be 100% Hayes-compatible.  If not, you 
will have to specify a special modem initialization string in the 
Call Options dialog box. 

• Your Login Name or Password may be incorrect. in the Dial-Up 
Connection dialog box of the Dialup properties sheet of Terminal 
Properties... 

• Your Connection Preferences are incorrect in the Port Settings 
part of the Device Properties dialog box in the Dialup properties 
sheet of Terminal Properties. 

9 

When trying to open a downloaded 
document, you get an error message 
“xxx Viewer encountered an internal 
error trying to load or display the 
requested file. 
 

There is not enough room in your browser cache.  You can try any or 
all of the following corrective procedures: 
• Clear cache in View|Internet Options and download again. 
• Increase the cache size in View|Internet Options and download 

again. 
• Close the browser session, reopen, and download again 
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Support 
 
Affirmative Computer Products offers Technical Support services for all the Affirmative products.  You 
can access Affirmative Technical Support in one of the following ways: 
 
• via Phone 

o 480-946-1444 
o 888-353-5250 

• via Fax 
o 480-946-9250 

• via E-mail 
o support@affirmative.net 
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Appendix 1.  Specifications 
 

22xx Models 

     

ITEM SPECIFICATIONS 
Processor SIS 550 200 MHz  

Communication and Ports 

• Microsoft RDP and Citrix ICA protocol compliant. 
• 10/100 dual-speed Ethernet, Twisted Pair (RJ45). 
• One parallel port (DB-25 Female connector). 
• Enhanced ps/2 keyboard interface. 
• Enhanced ps/2 mouse interface. 
• Two USB ports. 

Embedded O.S. Microsoft Windows CE.net with Microsoft IE 5.5 browser 

Video 
• SVGA 
• 640x480, 800x600, 1024x768, and 1280x1024 with high color. 
• Refresh frequency up to 85 Hz 

Memory • SDRAM -- 64 MB SDRAM standard. (Max. 256MB) 
• Flash -- 16 MB DOC standard. (Max. 64MB) 

Server Operating System Support 

• Microsoft Windows 2003 Server 
• Microsoft Windows 2000 (Server Edition) 
• Microsoft Windows NT 4.0 (TSE) 
• Citrix MetaFrame XP 
• Citrix MetaFrame 
• Citrix WinFrame 

Optional Devices • USB storage 
• USB to COM port adapter 
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ITEM SPECIFICATIONS 

Software Features 

• Remote Management Software 
• Wake on LAN (WOL) 
• SNMP support 
• Time zone and SNTP support 
• Terminal access password for security 
• Multi-session Autostart with Fail-over 
• LPD & ThinPrint support 
• Virtual Private Network support 
• Office Viewer and PDF Viewer 
• VNC Viewer 
• Inbox (email) 
• RAS dial-up (option) 
• Terminal emulation (option) 
 

Temperature • Operating: 5 ºC to 40 ºC (41 ºF to 104 ºF) 
• Storage: -40 ºC to 60 ºC (-4 ºF to 140 ºF) 

Relative Humidity 90% maximum, non-condensing 

Operating Altitude 
Range 0 to 10,000 feet (0 to 3050 meters) 

Environment 
      
      
      
     

Power • Full range auto-sensing 100 ~ 240 VAC at 50 Hz ~ 60 Hz 
• 10 Watts 

Regulatory Compliance 

• UL 
• C-UL 
• TUV 
• FCC Class B 
• CE mark 

Dimension (WxDxH) 194.5 x 151.5 x 40 (mm) Physical 
Characteristics 

Weight 0.65 Kg 
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26xx Models 

              

ITEM SPECIFICATIONS 
Processor 
  

National Semiconductor Media Gx1 300 MHz with 5530A support 
chip 

Communication and Ports 

• Microsoft RDP and Citrix ICA protocol compliant 
• 10/100 dual speed Ethernet, Twisted Pair (RJ45) 
• One parallel port (DB-25 Female connector) 
• Two serial ports with RS-232C (DB-9 male connectors) 
• Enhanced ps/2 keyboard interface 
• Enhanced ps/2 mouse interface 
• Two USB ports 
• Audio out and Microphone in 

Embedded O.S. Microsoft Windows CE.net with optional Microsoft IE 5.5 browser 

Video 

• SVGA 
• 640x480, 800x600, and 1024x768 with high colors 
• 1280x1024 with 256 colors 
• Refresh frequency up to 85 Hz 

• SDRAM -- 64 MB SDRAM standard. (Max. 256MB) 
• Flash -- 8 or 16 MB DOC standard. (Max. 96MB) 

Server Operating System Support 

• Microsoft Windows 2003 Server 
• Microsoft Windows 2000 (Server Edition) 
• Microsoft Windows NT 4.0 (TSE) 
• Citrix MetaFrame XP 
• Citrix MetaFrame 
• Citrix WinFrame 

Optional Devices 
• Touch Screen 
• USB storage 
• Wireless Adaptor card (PCMCIA, 802.11b) 

Memory 
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ITEM SPECIFICATIONS 

Software Features 

• Remote Management Software 
• SNMP support 
• Time zone and SNTP support 
• Terminal access password for security 
• Multi-session Autostart with Fail-over 
• LPD & ThinPrint support 
• Virtual Private Network support 
• Office Viewer and PDF Viewer 
• VNC Viewer 
• Inbox (email) 
• RAS dial-up 
• Terminal emulation (option) 

Temperature • Operating: 5 ºC to 40 ºC (41 ºF to 104 ºF) 
• Storage: -40 ºC to 60 ºC (-4 ºF to 140 ºF) 

Relative Humidity 90% maximum, non-condensing 

Operating Altitude 
Range 0 to 10,000 feet (0 to 3050 meters) 

Environment 
      
      
      
     

Power • Full range auto-sensing 100 ~ 240 VAC at 50 Hz ~ 60 Hz 
• 15 Watts 

Regulatory Compliance 

• UL 
• C-UL 
• TUV 
• FCC Class B 
• CE mark 

Dimension (WxDxH) 231 x 201 x 45 (mm) Physical 
Characteristics 

Weight 1.35 Kg 
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733x Models 

    
ITEM SPECIFICATIONS 

Processor 
  

National Semiconductor Geode Gx1 300 MHz with 5530A support 
chip 

Communication and Ports 

• Microsoft RDP and Citrix ICA protocol compliant 
• 10/100 dual speed Ethernet, Twisted Pair (RJ45) 
• One parallel port (DB-25 Female connector) 
• Two serial ports with RS-232C (DB-9 male connectors) 
• Enhanced ps/2 keyboard interface 
• Enhanced ps/2 mouse interface 
• Two USB ports 

Embedded O.S. Microsoft Windows CE.net with Microsoft IE 5.5 browser 

Video 
• Integrated 15" LCD monitor 
• 640x480, 800x600, and 1024x768 with high colors 
• Refresh frequency up to 85 Hz 

Audio Integrated high quality stereo speakers 

Optional Devices Touch Screen 
USB storage 

Software Features 

• Remote Management Software 
• SNMP support 
• Time zone and SNTP support 
• Terminal access password for security 
• Multi-session Autostart with Fail-over 
• LPD & ThinPrint support 
• Virtual Private Network support 
• Office Viewer and PDF Viewer 
• VNC Viewer 
• Inbox (email) 
• RAS dial-up 
• Terminal emulation (option) 

Memory • SDRAM -- 64 MB SDRAM standard. (Max. 256MB) 
• Flash -- 16 MB DOC standard. (Max. 96MB) 
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ITEM SPECIFICATIONS 

Server Operating System Support 

• Microsoft Windows 2003 Server 
• Microsoft Windows 2000 (Server Edition) 
• Microsoft Windows NT 4.0 (TSE) 
• Citrix MetaFrame XP 
• Citrix MetaFrame 
• Citrix WinFrame 

Temperature • Operating: 5 ºC to 40 ºC (41 ºF to 104 ºF) 
• Storage: -40 ºC to 60 ºC (-4 ºF to 140 ºF) 

Relative Humidity 90% maximum, non-condensing 

Operating Altitude 
Range 0 to 10,000 feet (0 to 3050 meters) 

Environment 
      
      
      
     

Power • Full range auto-sensing 100 ~ 240 VAC at 50 Hz ~ 60 Hz 
• 35 Watts 

Regulatory Compliance 

• UL 
• C-UL 
• TUV 
• FCC Class B 
• CE mark 

Dimension (WxDxH) 393 x 175 x 393 (mm) Physical 
Characteristics 

Weight 5.1 Kg 
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Appendix 2.  TCP/IP Error Codes 
 

Here is a comprehensive list of standard TCP/IP error codes that can occur during network operation.  
Some of them are quite esoteric and may not be applicable to YEStation operation, but this list should 
include any networking error code that you encounter.  They should be useful in troubleshooting 
network errors, many of which are caused by incorrect configuration. 
 
10004  
Interrupted function call.  
 
10013  
Permission denied.  
 
10014  
Bad address.  
 
10022  
Invalid argument.  
 
10024  
Too many open sockets.  
 
10035  
Resource temporarily unavailable.  
 
10036  
Operation now in progress. A blocking operation is in progress.  
 
10037  
Operation already in progress.  
 
10038  
Socket operation on non-socket.  
 
10039  
Destination address required.  
 
10040  
Message too long.  
 
10041  
Protocol wrong type for socket.  
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10042  
Bad protocol option.  
 
10043  
Protocol not supported.  
 
10044  
Socket type not supported.  
 
10045  
Operation not supported.  
 
10046  
Protocol family not supported.  
 
10047  
Address family not supported by protocol family.  
 
10048  
Address is already in use. If you attempt to set up a server on a port that is already is in use, you will get 
this error.  
 
10049  
Cannot assign requested address.  
 
10050  
Network is down.  
 
10051  
Network is unreachable.  
 
10052  
Network dropped connection on reset.  
 
10053  
Software caused the connection to abort, usually due to connection or protocol error.  
 
10054  
Connection reset by peer. This occurs when an established connection is shut down for some reason by 
the remote computer.  
 
10055  
No buffer space available.  
 
10056  
Socket is already connected.  
 
10057  
Socket is not connected.  
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10058  
Cannot send after socket shutdown.  
 
10060  
Connection timed out.  
 
10061  
Connection refused. You will usually see this error when a server refuses a connection from a client, 
because the server is not listening on that port. 
  
10064  
Host is down.  
 
10065  
No route to host.  
 
10067  
Too many processes.  
 
10091  
Network subsystem is unavailable.  
 
10092  
Unsupported version of WINSOCK.DLL.  
 
10093  
TCP networking has not been initialized on your computer.  
 
10094  
Graceful shutdown in progress.  
 
11001  
Host not found. (DNS error.)  
 
11002  
Non-authoritative host not found. Temporary DNS error.  
 
11003  
Non-recoverable error. (DNS error.) 
 
11004  
Valid name, no data record of requested type. (DNS error.) 
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