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YEStation Limited Warranty 
 

General Terms and Conditions 
 
LIMITED PRODUCT WARRANTY. Affirmative Computer Products warrants that the YEStation Hardware 
Product  shall be free from defects in materials and workmanship that arise under proper and normal use and 
service for three years from the date of purchase. A warranty extension of two years is available at extra cost, if 
obtained at the time of the original YEStation purchase. In the event that the YEStation Hardware Product fails 
to comply with the warranty set forth above, Affirmative Computer Products will repair or replace the Product. 
Note: Advanced Replacement for warranted units is only available for user sites in the United States and Canada. 
 
SOFTWARE WARRANTY. Affirmative Computer Products warrants that, for a period of ninety (90) days 
from the date of purchase by the End User, its Software Products shall conform to its published specifications 
under normal usage. AFFIRMATIVE COMPUTER PRODUCTS DOES NOT WARRANT THAT THE 
OPERATION OF THE SOFTWARE WILL BE UNINTERRUPTED OR ERROR FREE, OR THAT ALL 
SOFTWARE DEFECTS WILL BE CORRECTED. In the event that a Software Product fails to comply with the 
warranty set forth above, Affirmative Computer Products will replace the product. End User must, however, 
return all copies of the Software, along with proof of purchase, to Affirmative Computer Products within 90 days 
from the Software purchase date. 
 
 
WARRANTY LIMITATIONS. End User’s sole remedy under any Warranty provided by Affirmative 
Computer Products shall be limited to the replacement or repair of the Product or, at Affirmative Computer 
Products’ sole discretion, a refund of the purchase price. AFFIRMATIVE COMPUTER PRODUCTS GRANTS 
NO WARRANTY, EXPRESS OR IMPLIED, OTHER THAN THE WARRANTIES STATED ABOVE. 
EXPRESSLY EXCLUDED ARE THE IMPLIED WARRANTIES OF MERCHANTIBILITY AND FITNESS 
FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL AFFIRMATIVE COMPUTER PRODUCTS BE 
LIABLE FOR SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES, INSTALLATION COSTS, 
LOST REVENUE OR PROFITS, OR ANY OTHER COSTS INCURRED AS A RESULT OF THE USE OF 
ANY AFFIRMATIVE COMPUTER PRODUCTS PRODUCT, WHETHER OR NOT USED IN 
ACCORDANCE WITH INSTRUCTIONS. 
 
 
WARRANTY PROCEDURE. Affirmative Computer Products will replace or repair any defective, undamaged 
units for which a Return Material Authorization number (RMA#) has been obtained from the Technical Support 
Department. (Contact 888-353-5250 or 480-946-1444 or support@affirmative.net). 
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Copyright and Trademarks 

 

Copyright Notice               
This manual, as well as the software described in it, is furnished under license. No part of this publication may be 
reproduced, transmitted, stored in a retrieval system, or translated into any human or computer language, in any 
form or by any means, electronic, mechanical, magnetic, optical, chemical, manual, or otherwise, without the 
prior written permission of the copyright owner. 
Note: Information in this document is subject to change without notice.  

 
 

Trademarks Notice  
• YEStation® is a registered trademark of Affirmative Computer Products®  
• ICA® is a registered trademark of Citrix® Systems Inc.  
• MetaFrame® is a trademark of Citrix® Systems Inc.  
• Adobe®, the Adobe logo, Acrobat®, the Acrobat logo, and Acrobat Reader are trademarks or registered 

trademarks of Adobe Systems Incorporated. 
• Micro Touch® is a trademark of Micro Touch® Inc.  
• Ericom® and PowerTerm® are registered trademarks of Ericom® Software Ltd. 
• Other company and brand, product and service names are trademarks or registered trademarks of their 

respective holders.  
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Installing Your Terminal 
 

 
 

Installing Your Terminal 
 

• Your terminal has no internal fan, and relies on natural airflow for cooling. When you mount it, make sure to 
keep as many ventilation holes, as possible, unobstructed. 

• DO NOT USE any AC-DC adapter other than the one provided with the terminal or acquired from 
Affirmative Computer Products or its distributors. 

• References to “eProManager” in this document refer to the remote central management software available at 
no cost from Affirmative Computer Products. 

 
NOTE: The information in this document is derived from terminal firmware at build level 0422. However, most 
of the information is applicable to earlier build levels. With earlier levels, you may not see all of the features 
described in this document. 
 
 

Mounting 
 

22xx 
 
Typically, a 22xx terminal placed horizontally on a flat surface, with the terminal resting upon four attached soft 
plastic feet. However, there are also several vertical mounting options using the four mounting holes on the 
bottom of the terminal. These holes are shown in the following figure. 
 

 
22xx Mounting Holes 
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Installing Your Terminal 
 
A self-adhesive template and four #3, ½-inch wood screws are included with every terminal. The following 
figure shows one mounting possibility on a wooden wall. 
 

 
22xx Wall Mounting 

Another possibility is shown here. 
 

 
22xx Monitor Mounting 

We have done some testing with the provided screws, and have the following suggestions: 
• In soft wood, such as pine, no pilot holes are needed. 
• In hard wood or plastic, such as the side of a monitor, drill pilot holes with a 3/64” drill bit. 
• In dry wall, these screws do not hold well; if you must install on dry wall, we suggest: 

o Drill 3/64” pilot holes and put super glue in the holes before inserting the screws. 
Or 
o Use longer screws with coarser threads. 

 
The four terminal mounting holes are spaced to match the mounting pins of a standard VESA mounting plate 
available from Affirmative Computer Products distributors. Such a plate can be attached to most of the current 
crop of LCD monitors, as shown in the following figure. 
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Installing Your Terminal 
 
 

 
VESA Mounting Plate on a 17” LCD Monitor 

The final result is shown below. 
 

 
22xx Mounted on a 17” LCD Terminal 

 

23x6 and 27x6 
 
These terminals can only be mounted vertically on a flat surface, using the provided stand, as shown in the 
picture on the front cover of this manual. Horizontal mounting will obstruct the airflow required to cool the 
terminal. 
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Cabling and Indicators 
 

22xx 
 
Please make all cable connections before turning on the power. The following figures show the 22xx rear and 
front connectors. 
 

 
2201 and 2216 Rear Connectors 

Note: On 222x models, the parallel printer connector is replaced by one serial and one USB connector. 
 

 
22xx Front Connectors 

There are three LED indicator lights: 
• Power. The translucent Power button serves as the Power indicator. This indicator is faint amber when DC 

power is connected at the rear connector, and turns green when the terminal is powered up. 
• Network Connection. This amber indicator at the upper right corner of the RJ-45 Ethernet connector is on 

when there is a good physical connection to the Local Area Network. 
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• Network Activity. This green indicator at the upper left corner of the RJ-45 Ethernet connector flashes to 

indicate LAN activity. 
 

23x6 and 27x6 
 
Please make all cable connections before turning on the power. The following figure shows the rear and front 
connectors and the card slots on the rear panel of a 23x6 terminal.  
 

 
 
Note: The 27x6 has two additional USB connectors on the rear panel. 
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Installing Your Terminal 
 
There are four LED indicator lights: 
• Power. The translucent Power button serves as the Power indicator. This indicator is faint amber when AC 

power is connected at the rear connector, and turns green when the terminal is powered up. 
• Network Connection. This amber indicator at the upper right corner of the RJ-45 Ethernet connector is on 

when there is a good physical connection to the Local Area Network. 
• Network Activity. This green indicator at the upper left corner of the RJ-45 Ethernet connector flashes to 

indicate LAN activity. 
• Flash Memory Activity. This green indicator flashes when there is read or write activity to the flash 

memory. 
 
 

Power On and Boot Up 
 
1. Turn on the terminal by pushing on the Power switch after all rear panel connections have been made. 
2. The translucent Power button will change from faint orange to light green. 
3. You will see the message Starting System. Please Wait … on a black screen. 
4. After several seconds, you will see some cryptic Linux text. 
5. After several seconds, you will see the Affirmative Computer Products logo screen. 
6. After several seconds, you will see a blank black screen. 
7. After several seconds, you will see the Linux desktop or an Autostart connection. 

 
 

Shutdown/Reboot 
 
These terminals should be shut down or rebooted gracefully by: 
• Going to Start>Shutdown or Start>Reboot. You will be asked to confirm your action. 
• Executing Shutdown or Reboot remotely from eProManager. In this case, the terminal will be shut down or 

rebooted almost immediately with no warning for the local user. 
In both of these cases, the terminal will save appropriate settings and make graceful connection disconnects 
before powering down by itself. 
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Desktop Styles 
 

NOTE:  In the remainder of this document, a reference to the Ctrl key actually means the LeftCtrl key, a 
reference to the Alt key actually means the LeftAlt key, and a reference to a click actually means a mouse left 
click. 
 
Three Desktop Styles are available: Desktop, WBT (Windows Based Terminal), and Kiosk. See Configuring 
Your Terminal|Configuration|Desktop Style for information on style selection. 
 
 

Desktop Style 
 
Desktop Style is the terminal default. The Desktop display presents the Desktop screen with a Taskbar, Start 
button, and a clock display, similar to a standard Windows desktop. Sessions are launched from the Start menu or 
from Desktop icons, unless they are configured to Autostart at bootup. 
 

 
Startup Desktop Screen 

The above screen shows a blank Desktop with no connection icons. When most connections are configured (see 
Creating a New Connection), an available option is to create a Desktop icon. In such cases, the startup screen 
would show those icons. Also, the default setting in Control Center>Window Manager is to hide the Taskbar 
(see Configure Terminal Properties|Configuration|Window Manager), in which case the above screen would be 
completely blank upon startup. 
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Taskbar 
 
If the terminal has been configured to hide the Taskbar (see Configure Terminal 
Properties|Configuration|Window Manager), you can display it be moving the mouse cursor to the bottom edge 
of the screen. 
 
Now let’s go through the individual items available on the Taskbar. 
 

Hide/Reveal Taskbar 
 
 
  
 
    Hide Taskbar Icon   Reveal Taskbar Icon 
 
If your Desktop is configured to show the Taskbar (xxx), you can still hide it by clicking on the Hide Taskbar 
icon. After it is hidden, you can reveal it again by clicking on the Reveal Taskbar icon in the lower right-hand 
corner of the screen. 
 

Clock 
 

Clock Display 

 
The time is displayed in military time (24-hour clock). Position the cursor over the clock to see calendar 
information. 
 

 
Date and Time Display 

 
Left-click on the clock to see a 12-hour analog time display. 
 

 
Analog Clock Display 

 
The date and time can only be set in the Control Center (xxx) 
 

Workspace Selection 
 

Workspace Selection Icons 

 
Two separate workspaces are provided. By default, the terminal boots up into Workspace 1, but you can switch 
to Workspace 2 by clicking on the 2 icon. See Workspaces for more information. 
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Mozilla (Not Available in Model 22x1) 
 

Mozilla Icon 

Click on this icon to open a Mozilla browser session. 
 

Control Center 
 

Control Center Icon 

Click on this icon to open the Control Center. All terminal configuration parameters are set in the Control Center 
(see Configure Terminal Properties). Control Center can also be opened from Start>Control Center or from the 
Desktop right-click menu. 
 

Show Desktop 
 

Show Desktop Econ 

Click on this icon to minimize all the open windows in that workspace and display the Desktop. 
 

Start 
 

Start Button 

Click on this button to open the Start menu. 
 

 
Start Menu 

This menu can also be opened by right-clicking on any blank area of the Desktop. All configuration and 
connection activation can be initiated from the Start menu, although there are also other ways to access some of 
these functions, such as Taskbar or Desktop icons. 
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Workspaces 
 
The working environment of a Linux-Based Terminal can be separated into two workspaces. Actions taken, and 
connections opened, in one workspace will not affect the appearance or actions in the other workspace. Note: 
Parameter configuration in the Control Center and connection creation anywhere will affect both workspaces. 
 
By default, the terminal boots up into Workspace 1, and everything will happen in that workspace unless the user 
selects Workspace 2. Selection is done by clicking on one of the selection icons in the Taskbar (see 
Taskbar|Workspace Selection). 
 
You can see a list of the open windows in each workspace by clicking on Windows in the Start menu or in the 
Taskbar right-click menu. This will open the Windows List box. 
 

 
Windows List Box 

 
 

Multiple Windows 
 
Most of the windows that you open on the Desktop can be scaled, allowing you to display multiple windows 
simultaneously. To control the display of multiple windows, right-click on a blank area of the Taskbar and 
choose your preference from the resulting menu. 
 

 
Taskbar Right-Click Menu 
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Navigation 
 
• To open the Start menu; 

o Click on the Start button in the Taskbar. 
o Right-click on any open space on the Desktop 

• To open Control Center: 
o Select it from the Start menu. 
o Click on the icon in the Taskbar. 

• To activate non-Autostart, non-PowerTerm connections: 
o In the Start menu, click on the connection type and then on the connection name. 
o Click on the Desktop icon, if there is one. 
o For Mozilla connections, click on the icon in the Taskbar. 

• To activate a PowerTerm connection: 
1. From the Start menu, click on Programs>PowerTerm. 
2. In the resulting blank PowerTerm connection screen, click, in the Menu bar, Communication>Connect. 
3. In the resulting Connect dialog box, highlight the desired connection from the Session List and click on 

the Connect button. 
Or 

1. Click on the Desktop icon, if there is one. 
• To close a PowerTerm connection: 

o Go to the Sign On screen, open the File menu, and activate Exit. 
o Go to the Sign On screen and click on X in the upper right corner. 

• To power down or reboot, select Shutdown or Reboot from the Start menu.  
 
 

WBT Style 
 

 
Startup WBT Style Screen 

The WBT style presents you with a Connection Manager very similar to those seen in Windows Based Terminals 
using the Windows CE operating system. 
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Desktop Styles 
 
The Control Center in WBT style only provides the Connections group, as seen here. 
 

 
Control Center in WBT Style 

 

Kiosk Style 
 
In Kiosk style, the terminal boots up into a Mozilla browser page aimed at the url specified as shown in 
Configuring Terminal Properties|Configuration|Desktop Style. 
 
In order to change any terminal properties or to change your Display Style, you must open the Control Center. In 
Kiosk mode, you can only do that by temporarily returning to Desktop Style; this is done by pressing the key 
combination Ctrl+Alt+Insert.
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Configuring Terminal Properties 
 

All of the terminal properties and connection properties are accessible from the Control Center.  
 

 
Control Center 

The connection properties, under the Connections group, are covered in Creating a New Connection. The other 
groups in Control Center are discussed here. 
Note: When a dialog box contains an Apply button, you must click on it to save any parameter changes that you 
make in that box. 
Note: References to “eProManager” in this document refer to the remote central management software available 
at no cost from Affirmative Computer Products. 
Note:  We recommend that you change terminal properties only when all sessions are inactive. Many 
changes will invoke a restart or reboot of the terminal. 
 

Network 

 
 

In this group, you define the network properties of the terminal and the protocol used to reach the network. 
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Ethernet 
 
Click on Ethernet to see the Ethernet dialog box. These settings are crucial for network operation. If a network 
connection cannot be made, it is usually because of an error in these settings. 
 

 
Ethernet Dialog Box 

• Hostname. In this field, enter a unique “friendly” name which can be used to quickly identify this terminal 
in remote management software. Click on Apply to lock in this name, or else it will disappear when you 
close this box. 

• DNS Suffix. If you are using DHCP address assignment, you must manually enter the DNS suffix here. 
• Connection. Choose from a wired (default) connection or a wireless connection. Of course, for a wireless 

connection to be valid, you must have a supported wireless LAN adapter in the PCMCIA slot. 
• Obtain IP settings…. Click on this radio button to get the terminal IP parameters automatically (default) 

from a network DHCP server. If you make this selection, the IP parameter headings will be grayed out and, 
when the terminal obtains an IP address lease from a DHCP server, that address and other network settings 
will show in the static address boxes; you will be unable to manually enter anything in these fields. If this 
radio button is not enabled, you must manually enter IP information into the parameter fields. 
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Wireless LAN (Models 23xx and 27xx Only) 
 

 
Wireless LAN Dialog Box 

Wireless support is not currently available, but when it does become available, it will be only for Models 23xx 
and 27xx. 
 

VPN (PPTP) 
 
These terminals support Virtual Private Networks. Click on VPN (PPTP) to see the VPN dialog box 
 

 
VPN Dialog Box 
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• Host. Enter the VPN host name or IP address. 
• Username/Password. Enter the logon information if you want an automatic logon after communication is 

established with the host. 
• DNS. Click on the Obtain from server radio button to obtain all the IP information from the ISP server. 

Click on the Reference to… button (default) to use the information entered in the Ethernet dialog box 
discussed earlier. 

• Connect. Click here to make the connection. Since Autostart is not available for this protocol, you will have 
to access this dialog box and initiate the connection whenever you need to connect. However, the 
information entered in the information fields will remain until you change it. 

 

ADSL (PPoE) 
 
Point to Point Protocol over Ethernet (PPPoE) allows users to connect to a broadband Internet Service Provider 
(ISP) on an as-needed basis rather than being always connected as is typical in a broadband connection. In this 
mode of operation, it uses a Point-to-Point protocol much like a dial-up connection to an ISP. Your system or 
network administrator will tell you if you need such a connection. If you do need a PPPoE connection, click on 
ADSL (PPoE) to open the ADSL dialog box. 
 

 
ADSL Dialog Box 

• Username/Password. Enter the information required for authentication at the ISP. 
• DNS. Click on the Obtain from server radio button to obtain all the IP information from the ISP server. 

Click on the Reference to… button (default) to use the information entered in the Ethernet dialog box 
discussed earlier. 

• Connect. Click here to make the connection. Since Autostart is not available for this protocol, you will have 
to access this dialog box and initiate the connection whenever you need to connect. However, the 
information entered in the information fields will remain until you change it. 
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Remote FS Mounting 
 
You can mount a network drive for use as external storage in the terminal. Click on Remote FS Mounting to 
open the Remote FS Mounting dialog box. 
 

 
Remote FS Mounting Dialog Box 

• Type. You can select from two types of network drives in the drop-down list. 
o SMBFS. Mount Windows drives (default). Enter the appropriate settings in the entry boxes. 
o NFS. Mount UNIX/Linux drives. Enter the appropriate settings in the entry boxes. 

• Mount. After you have entered all the settings, click on this button. You will get a message regarding the 
success or failure of the mount operation. If you do not succeed, confirm your settings with your network 
administrator. 

 

Tools 
 
Three useful tools are available. Select a tool from the Tool drop-down list. 
 

Ping 
This tool is extremely useful in network troubleshooting, since it allows you to verify a successful network 
connection. Ping sends a query to a designated IP device, and expects a response from that device. You can ping 
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a host or any other device connected on the local network. You can also ping a remote host, device, or web site 
through a gateway if the gateway is configured to allow outbound pinging. Ping is the default tool, so you will 
see the Ping dialog box as soon as you open Tools. 
 

 
Default Tool (Ping) Dialog Box 

 

Enter the network name or the IP address of the device to be pinged, and click on Run it. Examples of a 
successful and an unsuccessful ping are shown here. 
 

 
Ping Examples 

The ping to IP address 24.221.238.181 was successful, while the ping to 24.221.238.18 is not. 
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Traceroute 
Traceroute operates in a similar fashion to ping, but it details the Internet nodes encountered in the Internet cloud 
between the terminal and the target IP address. Enter the network name or the IP address of the device to be 
pinged, and click on Run it. 
Note: Your Internet Service Provider may not allow trace routing through its gateway. In that case, your results 
will look something like the following window. 
 

 
Blocked Traceroute Example 

 

Ifconfig 
This tool provides information about the terminal IP parameters and about the health of the local IP network. 
Click on Run it to collect and display the information per the following example. 
 

 
Ipconfig Example 
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Configuration 

 
 

In this group, you define the GUI and I/O port parameters. 
 

Display 
 
The Display parameters control the appearance of your monitor screen. 
 

 
Display Dialog Box 

• Resolution . Select a monitor resolution from the drop-down list. This list shows all possible resolutions, 
regardless of monitor type. 

• Refresh Rate. Select a monitor refresh rate from the drop-down list. This list shows all possible refresh 
rates, regardless of monitor type. 

• Color Depth. This is the terminal hardware video color setting. By default, 24 bits… is activated, but this 
high color resolution is only useful if you are using ICA connections and if your Citrix server supports them. 
If you encounter any display problem in your RDP or ICA connection applications, try a lower setting. 

• Test. You must test your new settings, or else the terminal will not retain them. When you click on Test after 
changing settings, the terminal will test your new settings. You will see a blank, black screen for several 
seconds. Then, if these settings are compatible with your monitor, you will see an analog clock face with the 
new settings, and a box allowing you to accept or cancel the settings. If you fail to do either, the terminal will 
automatically revert to the old settings. If the settings are not compatible, you will eventually return to a blue, 
blank screen resembling a standard desktop. But you will not be able to do anything from this screen. Do not 
despair, though; when you reboot, the previous settings will return and you can use the terminal. 
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Keyboard 
 

 
Keyboard Dialog Box 

• Keyboard. If you want to use a language other than the default US keyboard, select one from the extensive 
drop-down list. 

• Enable Fn keys. You can enable three Fn hot keys as described in the dialog box. 
 

Mouse 
 

 
Mouse Dialog Box 

• Mouse. Change from PS/2 Standard to …PS/2 Wheel Mouse, using the droop-down list, if you want to 
want to use wheel scrolling from a wheel mouse. 

• Motion speed. Adjust the screen speed of your mouse cursor. 
• Switch primary…. Click on this radio button to switch the functions of the left and right mouse buttons. 

 

 21 
 
 



Configure Terminal Properties 
 

Printer 
 
These terminals support LPD, ThinPrint, and RDP Autocreate printing. 
 

 

Printer Dialog Box 

LPD 
The Berkeley versions of the UNIX™ operating system provide printer spooling with a collection of programs: 
lpr (assign to queue), lpq (display the queue), lprm (remove from queue), and lpc (control the queue). These 
programs interact with an autonomous process on network print servers called the line printer daemon (LPD). 
Although LPD printing is generally associated with UNIX/Linux networks, Microsoft networks now also support 
this printing method. 
 
Each YEStation terminal includes an LPD module that allows an LPR device on the network to assign print jobs 
to a local printer attached to the terminal. Click on the LPD Start button to enable this service. The LPR 
requestor should use the printer name lp or printer when sending a print job to this terminal. 
 
It is also possible to redirect LPD requests to another LPD printer on the network. In that case, the LPR requestor 
should use the printer name lp2 or printer2 when sending a print job to this terminal. Additional configuration is 
necessary as follows: 
• Remote-Queue Host. Enter the IP address of the network LPD printer to which the print jobs are redirected. 
• Remote-Queue Printer Name. Enter the printer name used by the network LPD printer to which the print 

jobs are redirected. 
 

ThinPrint 
ThinPrint enables direct printing from the terminal to a local printer. With the ThinPrint Client, a print job can be 
delivered over the Citrix ICA protocol to the terminal and from there directly to the local printer. Click on the 
ThinPrint Start button to enable this service. The print requestor should use the printer name printer when 
sending a print job to this terminal. 
 
To learn more about ThinPrint advantages, go to http://www.thinprint.com/ on the Web. 
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RDP Autocreate 
If you are using an RDP session to a Windows Terminal Server, and you have a printer connected to your 
terminal, the server can automatically create a printer for your use in the Printer and Faxes section of its Control 
Panel. Click on this radio button if you want this autocreation. 
 

COM Port 
 
The COM Port dialog box provides the usual serial port configuration options.  
Note: ThePowerTerm emulator provides its own COM configuration options, so the settings here will have no 
effect in PowerTerm. 
 

 
COM Port Dialog Box 

 

Screen 
 
Some screen saver options are provided in this dialog box 
 

 
Screen Dialog Box 
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Sound 
 
If you are using sound through external speakers, you can adjust the volume here. 
 

 
Sound Dialog Box 

 

Window Manager 
 

 
Window Manager Dialog Box 

Desktop appearance and navigation options available here. These options are self-explanatory, except perhaps for 
Window auto focus. If this radio button is selected, the window focus will automatically follow the mouse 
cursor, even without clicking the left mouse button. When it is not selected, the focus functions in the usual 
Windows fashion, requiring a left-click to change focus. 
Note: A reboot may be necessary before your selections take effect. 
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Desktop Style 
 

 
Desktop Style Dialog Box 

 

Storage 
 
Two types of external storage are available: 
• Network storage (see Network|Remote FS Mounting). 
• USB storage. 
 

USB Storage 
 
Various types of USB storage devices can be connected, but only one can be connected at a time. Connect a 
device and then open the USB Storage dialog box. 
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USB Storage Dialog Box 

Click on Mount and a USB-connected storage device will be mounted for use as external storage. If the terminal 
does not detect a USB storage device, an error message will be displayed. 
Note: If the storage device is connected at boot-up, it will automatically be mounted. 
 
 

System 

 
 

This group provides terminal management and control. 
 

Information 
 
The Information box is, as the name implies, for system information only. There are no input opportunities here. 
 

 26 
 
 



Configure Terminal Properties 
 

 
Information Box 

• Software. This is probably the most useful information in the box. The Version information gives you the 
installed firmware version and is necessary when obtaining technical support from Affirmative Computer 
Products. 

• Hardware. You see a variety of hardware information, but the only one you can do anything about is RAM. 
If you want more free RAM, you can order a RAM upgrade for your terminal. The example shown above is 
with the optional 256 MB RAM installation. 

• Ethernet Adapter. The IP information shown here is also available in Network>Ethernet. 
• Storage. The local flash memory is shown in Flash. Mounted USB storage is shown in USB. Mounted 

network storage is shown in Remote F/S. 
 

VNC Server 
 
VNC (Virtual Network Computing) is a remote display system which allows a device with an installed VNC 
client to view a computing 'desktop' environment from anywhere on the Internet. It is platform-independent; a 
desktop running on a Linux machine may be displayed on a PC, or on your YEStation. VNC requires a server 
software module in the machine that is being viewed. If you enable the VNC Server here, the terminal can be 
viewed and controlled by any machine that is running the VNC client software. Of course, you need a TCP/IP 
connection to allow this to happen. You can learn much more about VNC from the Web site 
http://www.realvnc.com. 
 
NOTE: You must enable VNC Server here if you want to control the terminal remotely using Remote Control in 
eProManager. 
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VNC Server Dialog Box 

The password is used to provide some security from VNC clients on your network. If you enable VNC Server, 
the password must be given a non-blank value. 

 

Remote Management 
 

 
Remote Management Dialog Box 

Remote Management must be enabled if the terminal is to be visible to eProManager for configuration and 
firmware updates. 
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STD200 Smart Card 
 
STD200 Smart Card readers are optional for Models 2326 and 2726. 
 

 
Smart Card Dialog Box 

 

Backup & Restore 
 
A backup file containing all your connection and configuration information can be created if you have mounted 
external USB or network storage. This information can then be restored back to this terminal or another terminal. 
This is especially useful when: 
• You do a firmware upgrade, since the terminal is automatically set to factory defaults after an upgrade. 
• You want to “clone” a terminal’s configuration and connections to another terminal. 
• You do a reset to factory defaults for troubleshooting purposes. 
 

 
Backup & Restore Dialog Box 
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• Path. Click here to see a drop-down list of the available external storage. Then select one as the backup (or 

restore) medium. 
• File Name. Name the backup file that you want to create or use for restoration. 
• Backup configuration. Click on this button to create a backup file and store it in the selected mounted 

external drive. 
• Restore configuration. Click on this button to restore a configuration previously stored in the file specified 

in File Name. NOTE: This button will be grayed out unless the path contains a file named backup.tgz. You 
do not have to restore from this file; you can enter another File Name, but you will not be able to restore at 
all unless this file exists. So make one in a backup operation, even if you want to use some other scheme for 
backup file naming. 

 

Factory Defaults 
 
It may be necessary, primarily for trouble shooting, to restore the terminal configuration to the factory default 
state. If so, invoke the Factory Default dialog box and click on the button. You will be asked to confirm your 
decision. 
Note: You will also lose any connections that you have created. If you want to recover the pre-default state, you 
should do a backup before resetting to defaults and a restore after completing your troubleshooting (see above). 
 

 
Factory Default Dialog Box 

 

Update Software 
 
Use the Upgrade Software dialog box if you wish to update your terminal's firmware from an FTP server. You 
can also import a background image if you enabled one (see Configuration|Window Manager). 
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Update Software Dialog Box 

 
 

Shutdown 
 
You can shut down from this dialog box, but it is usually more convenient to shut down from Start>Shutdown. 

 
Shutdown Dialog Box 

Click on the Enable… radio button if you want the terminal to shut down automatically when all Autostart 
sessions are closed. 
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Reboot 
 
This dialog box serves the same function as Start>Reboot. 
 

 
Reboot Dialog Box 

 
 

 

Security 
 
This group of one is used to restrict access to the Control Center. 
 

Access Control 
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Access Control Dialog Box 

Click on the radio button to require a password in order to access the Control Center. Then enter and confirm a 
password and click on Set. 
 
After enabling, you will be asked for a password when trying to open Control Center. 
 

 
Login Dialog Box 

Note: After a Control Center login, the Control Center can be subsequently opened without a password until the 
next boot up. 
Note: If you enable Access Control and subsequently forget your password, the only recovery is to use 
eProManager to reset to factory defaults or re-flash the firmware. 
 

Time 
 

 
If you want an accurate display of date and time, configure from this group. 
Note: You may have to reboot to apply changes, even if you click on one of the Apply buttons. 
 

Time Zone 
 
Time Zone has two uses: 
• It allows the user, when logging on to a MetaFrame XP server in a different time zone, to have the ICA 

sessions reflect the time zone of the local terminal. For example, a user in London (Greenwich Mean Time) 
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logs onto a MetaFrame XP server in New York City (Eastern time zone), and launches Microsoft Outlook as 
a published application; Microsoft Outlook stamps emails sent during this ICA session with the user’s GMT 
time zone information. 

• When SNTP synchronization is used (see below), Time Zone provides the correct offset from the timeserver 
base time. 

Note: We recommend that you select your time zone before setting date and time. Otherwise, you may find that 
your time/date settings have changed after you change the time zone from the default Asia/Taipei.  
 

 
Time Zone Dialog Box 

Choose your time zone from the comprehensive drop-down list. 
 

Set Time and Date 
 
After you select a time zone, open this dialog box to complete the time configuration. These settings can be 
useful in browser sessions when date stamping a site printout. The time is displayed at the right end of the 
Taskbar, and the date is displayed by passing the cursor over the time display. 
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Set Time and Date Dialog Box 

• Date. Click on the calendar icon to see a calendar page.  
 

 
Calendar Page 

Use the arrows to find the correct month, and then highlight the correct date. 
• Time. Click on the clock icon to see an analog clock face. 
 

 
Clock Face for Time Adjustment 

Drag the hands to the desired time and select AM or PM. Each hand must be dragged separately. An 
alternative to this manual adjustment is to use the Network Time Sync. 
Note: After adjusting the clock, the time display in the Taskbar may sometimes display as a 12-hour clock 
for pm time (i.e. 3:57 pm). But after a reboot it will revert to a 24-hour clock (i.e. 15:57). 

• Network Time Sync. Click on this button to sync the local time with a timeserver on the Web. Obviously, it 
only works if you have a Web connection (but you do not need a browser session). 
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ICA Settings 
 
• Enable PNAgent. Check this box if you wish to connect to an Nfuse-enabled Citrix server and obtain a list 

of available published applications. In this mode, you do not have to manually configure each ICA 
connection, but a list of published applications will be 'pushed' (made available) to your session. If you select 
this option, you must then click on the PNAgent Settings button to specify the URL or IP address of your 
Nfuse server. 

 
Nfuse Server Address Box 

  

 

RDP Settings 

 
 

This utility is used to configure local resources and display properties for all RDP connections. Many of these 
settings are only valid when connected to a Windows 2003 server. 
 

Local Resources 

 
RDP Local Resources Properties Sheet 

• Remote computer sound. Note: This feature works only with a Windows 2003 server. 
o Bring to this computer. Map the audio (sound) from the server to the terminal.  
o Do not play. Do not play computer sound on terminal or server.  
o Leave at remote computer. Does not map the audio (sound) from the server to the terminal.  

• Local devices 
o Disk drivers. Enable local USB port mapping for USB disk drives such as USB FDD, HDD, Flash Disk, 

and CDROM. Note:  This feature works only with a Windows 2003 server. 
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o Printers. Enable local parallel port mapping. It supports both parallel printers from LPT1 and USB 
printers from USB port. 

o Serials ports. Enable local serial ports mapping. Note:  This feature works only with a Windows 2003 
server. 

Display the connection bar. If this box is checked, a Connection bar will be shown at the top of every RDP 
session screen. 

 
RDP Connection Bar Example 

This bar is useful in several ways: 
o Server IP Address. The bar shows the IP address of the Terminal Server for this session. 
o Minimize. Clicking on the Minimize icon will conveniently take you back to the Desktop (Desktop 

shell) or Connection Manager (WBT shell). 
o Disconnect. Clicking on the X will evoke the Disconnect dialog, allowing you to disconnect without 

closing your programs. 
 

Experience 

 
RDP Experience Properties Sheet 

This properties sheet is only useful if you are connecting to a Windows 2003 server. If so, you can optimize 
performance and desktop appearance by selecting connection speed and enabling/disabling desktop parameters. 
Default parameters vary depending upon the chosen connection speed. 
 
• Enable/Disable button, because of an Autostart session. This check box only takes effect on boot up. 
 
 

File Management 
There is a limited amount of file management available in your terminal, with several methods to transfer and 
store files: 
• USB-attached storage. 
• Shared network storage. 
• Web download 
• Email attachment. 
Regardless of the transfer/storage method, there is no way to save new files internally in the terminal flash 
memory in the event of a Shutdown. To save files, you must move them, before Shutdown, to external USB or 
network storage. 
 
USB-Attached Storage 
If USB storage is enabled in the USB Storage Management dialog box, any type of attached USB storage will 
appear in My Computer as the Hard Disk folder. Whenever you are given a storage browse option, this folder 
will be available. You can, of course, create subfolders if you wish. 
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Shared Network Storage 
From the My Computer screen, you are able to view shared content on Windows PC (Windows 95 and above) 
storage partitions connected to the same network subnet as your terminal. Please make sure that the appropriate 
partitions and folders on the PCs have Sharing enabled. To access this shared storage: 
1. In the address field of My Computer, enter the name of the target PC: \\<target_PC_name>.  
2. You may be prompted for username and password if the sharing is password-protected. 
3. After any authentication is processed successfully, the shared folders should be displayed. 
4. You can now transfer files to and from the shared folders. 
Note:  This procedure does not work in the reverse direction. You cannot see or manipulate the terminal file 
structure from a network-attached PC. 
Note:  This shared storage is not visible from a storage browse option of an application, since this shared storage 
is not mapped in the terminal. 
 
Web Download 
File downloads from the Web are done in the familiar Web download manner: 
1. You are asked if you want to save or open. 
2. Choose Save. 
3. The My Computer file structure will appear. Browse to the folder where the new file should be stored. If 

you have external USB storage, you can save directly to that external storage. 
4. Tap Go or the PC Enter key. 
5. The file will be downloaded to the designated folder. 
 

VNC Viewer Settings 

 
 

 
VNC Viewer Settings Dialog Box 

The VNC Viewer is used to view and control a remote desktop on a computer that has an installed and enabled 
VNC Server. Use this utility here only if you want a viewer connection to Autostart at every bootup. For one-
time viewing, use Start>Programs>VNC Viewer or Add a VNC Viewer connection from Connection 
Manager>Configure. 
 
If you check Auto start…, the two entry fields will be opened. 
• VNC server. Enter the network name or the IP address of the device that you wish to view, along with the 

display number on the device (display 0 always works for me). For example, if the device name is snoopy, 
the entry will be snoopy:0. An IP address entry might be 100.100.10.10:0. 

• Password. VNC servers typically are password protected. Enter the correct password here. 
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When you boot up, the viewer will attempt to make a connection to the server identified in VNC server. If the 
server software is enabled at that device, and the password is correct, you will see a rendition of the server 
desktop. In the viewer session, you have some additional options from the session menus. 
 

 
VNC Viewer Session Menu Bar 

 

Connection 

 
VNC Viewer Connection Menu 

New 
You can launch a new session here, but it will not be a repetitive Autostart session. Click on New to open the 
Connection Details dialog box. 
 

 
Connection Details Dialog Box 

Enter the network name or the IP address of the device that you wish to view, along with the display number on 
the device (display 0 always works for me). For example, if the device name is snoopy, the entry will be 
snoopy:0. An IP address entry might be 100.100.10.10:0. When you click on OK, the session will be initiated 
with the server. See Creating a New Connection|VNC Viewer for more information on one-time VNC sessions. 
 
Options 
Click on Option in the Connection menu to set some options for this session. 
 

 
Connection Options Dialog Box 

Any option changes that you make here are only good for the life of this session. When you reboot the terminal, 
the options will revert to the defaults shown here. 
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Info 

 
VNC Connection Information Box 

This information-only box provides some details about your session. 
 

Keys 

 
VNC Viewer Keys Menu 

Computer hot key combinations are typically trapped locally in the terminal, rather than being passed on to the 
VNC server. This menu allows you to select and transmit one of several hot key combinations to the server. 
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Creating a New Connection 
 

It is tempting to use the terms “connection” and “session” interchangeably, but we do try to maintain a 
distinction in this document. 
• Connection. A connection defines the parameters used to establish and control communication between a 

server and a YEStation client. 
• Session. When a connection is activated and successful communication is established between the server and 

the client, the server/client communication becomes a session. 
Despite these precise definitions, it is necessary to confess that the Start>Programs list includes one item, X 
PDF, that does not meet the above definition for Connection since it does not invoke or configure a connection to 
a server. 
 
All connections can be created from the Start menu, and all except Tarantella and X PDF can also be created 
from Control Center. 

 

 
Each network client connection can be to a unique server, if desired. The total number of concurrent active 
connections is limited by the amount of RAM. With the standard 128MB RAM, there is seldom any practical 
limitation unless you are running multiple browser sessions or multiple X PDF viewers. A 256MB RAM option 
is available to overcome any limitation that you might encounter. 
 
The connection types will be covered here in alphabetical order. Highlight the desired connection type and then 
click OK to open the associated dialog box. 
 
In every connection dialog box accessed from the Control Center, except WWW, you are given the radio button 
options to Auto Start the connection and to display a connection Desktop Icon. 
 
After your setup and configuration are complete, you can secure connection parameters, except for those 
connections accessed from Start>Programs, from any user changes as follows: 
1. Open Control Center>Access Control. 
2. Click on the radio button for Enable Access Control. 
3. Choose and confirm a password. 
4. Click on Set. 

 
Control Center 

 
Start Menu 
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nection is used to access a Citrix server or Citrix published application. Citrix server connections 
e 

e 
nt 

ly given a set of default parameters. These default parameters 
 

o customize the defaults, begin with the ICA dialog box. 

ICA 
 

n ICA conA
allow you to connect to the Windows desktop of a specific Citrix server; you can run any applications that hav
been made available on the desktop by your system administrator, in any order. Published applications are 
specific applications set up by an administrator for remote users. When connected, you are presented with th
application itself. Published applications can be run in seamless mode, where the applications appear to the clie
as if they are running locally, each application running in its own resizable window. 
 

Connection Defaults 
 

hen a new ICA connection is created, it is initialW
can be customized by the administrator, so that all new connections can easily be given the look and feel that you
desire. The default parameters are accessible from the Tools menu of the Citrix ICA Client for Linux dialog box. 
Only the most common default parameters will be discussed here. For a full discussion, the reader is referred to 
the Citrix Clients for Users Administrator’s Guide at xxx 
 
T

 

 
ICA Dialog Box 

Click on the Citrix ICA Client button to see the Citrix ICA Client for Linux dialog box. 
 

 
Citrix ICA Client Connections Dialog Box 

Click on Tools>Settings to see the first settings dialog box, Preferences. 
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Settings>Preferences 
 

 
Preferences Settings Dialog Box 

• In the Keyboard Layout field, click r input locale from the list. Input locale 

• , click the Browse button to select your correct keyboard type from the 

• ysical keyboard type 

• le Windows Alert Sounds if you want Windows alert sounds to be played using the YEStation 

• utomatic Client Updates to allow the client software at this workstation to be automatically 

• 

 the Browse button to select you
is the language you want to type in. 
In the Keyboard Type (Client) field
list. The default LINUX works well with Affirmative Computer Products keyboards. 
In the Keyboard Type (Server) field, click the Browse button to select the specific ph
you are using from the list. You will likely stick with the default, since all the other choices are Japanese 
keyboards. 
Select Enab
sound system. 
Select Allow A
updated when a newer version is available. This feature also requires configuration on the Citrix server. 
Select Allow Audio Input to enable support for client-side microphone input.  
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Settings>Window 
 

 
Windows Settings Dialog Box 

• Window Size. 
o Fixed Size. Choose the desired size in the Fixed Window Size fields. You can select a size from the drop-

down list, or you can enter a special size in one or both of the fields. 
o Percentage of Screen Size. If you select this radio button, the Fixed Window Size quadrant will change to a 

Percentage of Screen Size quadrant. You can select a percentage from the drop-won list or enter a special 
percentage in the field. 

o Full Screen. This selection will cause the session to occupy the full terminal screen. It will overlay the 
Taskbar area also, so you will have to use Alt+Tab to change windows. 

• Window Colors. If you choose one of the higher color ranges, be sure that it is supported in Control 
Center>Display and on your Citrix server. 

• 256 Color Mapping allows you to set up 256-color sessions to use approximate or exact colors. If you select 
Private - Exact Colors, the client will use a private color map to display the exact colors sent by the server. This 
may, however, cause color flashing when moving between windows. To avoid this, use Shared - Approximate 
Colors to eliminate color flashing when switching context. Note that if other applications allocate all 256 colors, 
the client uses a private color map 
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Settings>Server Location 
 

 
Server Location Settings Dialog Box 

See Citrix Clients for Users Administrator’s Guide at xxx for the details of server location. If your servers are on 
the local sub-net, select TCP/IP for the Server Protocol. 
 

Connection Creation 
 
You can create a connection in the ICA Dialog Box by entering the basic parameters here, or you can click on 
Citrix ICA Client to create a connection in the resulting dialog boxes. However, if you want to create a Desktop 
icon for your connection, if you want to Autostart your connection, or if you want the connection to appear in the 
Connection drop-down list, you must create it in the ICA dialog box. 
 

 
ICA Dialog Box 
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If you choose to use the ICA dialog box, enter the following information: 
• Connection: This drop-down list will initially be blank. As you add ICA connections, their names will 

appear in this list, allowing you to select one for editing or connection to its server. 
• Name. Enter a friendly name for this connection. This is the name that will be shown in the Connection list 

and under the Desktop icon. 
• Host. Enter the host IP address here. 
• Username/Password. If you want to log on to the server automatically, enter the Username and Password 

recognized by the server. Otherwise, leave them blank and you will be asked for them every time you 
establish the server connection. If you wish, you can enter only the Username here,  

• Connection Window Size. Select a radio button for the local window size that you desire for this 
connection. If you select a size that is larger than the Resolution Mode selected in Connections>Display, 
you will have to use scroll bars to select viewable portions of the session window. 

At this point, you have entered enough information to create a basic ICA connection to a Citrix server. But if you 
want to access a published application, if you want to go beyond a basic server configuration, or if you want to 
bypass the ICA Dialog Box, you will have to click on Citrix ICA Client to see the Citrix ICA Client for Linux 
dialog box. 
 

Citrix ICA Client 
 

 
Citrix ICA Client Connections Dialog Box 

By default, the main client window displays the Connection view, a list of all the connection entries that have 
been created, including connections to published applications and remote desktop sessions. If this is your first 
foray into defining ICA clients, the list will be empty. If users want to view the connections that are 
automatically set up to applications and content published on a server running the Web Interface, they can do so 
using the PNAgent view from View>Go To…. 
 
Note: You can copy an existing connection by highlighting the desired connection and then clicking on Copy 
from the Connections menu, or clicking on the Copy icon. You can then edit the copied connection as required. 
This is useful if many of the configuration details are the same for both connections. 
 
To create a connection from this box, click on the New icon, or click on New in the Connections menu. The 
Network Properties dialog box appears. 
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Properties>Network 

 
Network Properties Dialog Box 

Server Protocol. Select the TCP/IP protocol if your servers are on the local sub-net – a common situation. The 
default setting for server location or published application is auto-locate, although you can type in a specific 
network name or IP address in the Server field. To auto-locate: 

1. Select the Server or Published Application radio button. 
2. Click on the … button; the ICA Client attempts to contact all of the servers on the subnet by 

broadcasting on the UDP protocol. Alternatively, you can set specific addresses for MetaFrame servers. 
3. The ICA Client will list all of the servers or published applications that it finds in a Connection Select 

sub-window 
4. Select the desired connection in the sub-window and click on OK. 
5. The selected connection will appear in the Description and Server fields. 
6. You may want to change the Description, which is the entry that will appear in the Connections dialog 

box to identify this connection. 
7. If your server or application is not found for some reason, you can type in the IP address or application 

name in the Server field. 
8. Click on Apply if you want to save the settings and move on to another selection from the Properties 

drop-down list, or OK if you want to return to the Connections dialog box. 
 
After you have entered your network settings, you may want to configure other parameters of your connection. A 
host of parameters can be configured for each individual connection from Connections>Properties. Default 
properties for all connections are set in Tools>Settings, as discussed in Connection Defaults, but they can be 
overridden for individual connections from Connections>Properties. In this manual, we will cover only the 
most commonly adjusted parameters. For the finer points of ICA configuration, see the Citrix Administrators 
Guide for Unix Clients, available from the Affirmative Computer Products’ web site at xxx 
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Properties>Window 

 
Windows Properties Dialog Box 

The Window dialog box controls the window size and number of colors used for the connection highlighted in 
the Connections dialog box. 
• Window Size allows you to select from Fixed Size, Percentage of Screen Size, or Full Screen. Select 

Fixed Size or Percentage and type the size (in pixels) or percentage in the Window Size boxes. If you are 
connecting to a published application, you can also select Seamless Window, which integrates local and 
remote windows on the desktop. 

• Window Colors allows you to set the number of window colors to 16, 256, 32 Thousand, or 16 Million. 
Your display must be capable of displaying the resolution and color depth you select. Your Citrix server 
must also be configured to support at least the number of colors that you select. Remember that more colors 
consume more network bandwidth for your connections. 

• 256 Color Mapping allows you to set up 256 color sessions to use approximate or exact colors. If you select 
Private - Exact Colors, the client uses a private color map on PseudoColor displays to display the exact 
colors sent by the server. This may, however, cause color flashing when moving between windows. To avoid 
this, use Shared - Approximate Colors. Note that if other applications allocate all 256 colors, the client uses 
a private color map. 

• In each case, select Use Default to use the default setting defined in Tools>Settings>Window.  
 
Properties>Application 
If you selected Server in Properties>Network, you have the option of specifying an application to run when you 
connect to a server. If you specify an application, you do not see the desktop of the server when you connect; you 
go directly to the application. The connection is closed when you exit the application. Use the Application dialog 
box to specify the application 
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Application Properties Dialog Box 

To specify an application to run at connection: 
• In the Application field, specify the pathname of an application to be run after connecting to a server. 
• In the Working Directory field, specify the pathname of a directory to be used with the application. 
 
For example, if the application Notepad.exe is in the C:\WTSRV directory on the Citrix server, type 
C:\WTSRV\Notepad.exe in the Application field. If you use Notepad to work on documents in the C:\My 
Documents directory, type C:\My Documents in the Working Directory field. When you log on to the Citrix 
server, Notepad begins. In Notepad, if you click the File menu, the directory C:\My Documents is displayed 
 
Note: If the entry you are configuring is a connection to a published application rather than a server, the 
Application dialog box is not available. 
 
Properties>Login 

 
Login Properties Dialog Box 

The Login dialog box allows you to enter logon details of your server connection so that you do not need to type 
them each time you connect. To configure login properties, type your Username, Domain (optional) and 
Password for the connection. 
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Although you can also provide your password automatically, as shown here, for security reasons it is not good 
practice to configure the connection in this way. Instead, it is better to leave the Password field blank in this 
dialog box and type your password each time when establishing the connection. 
 

Mail & Newsgroups 
 
No, you won’t see a Mail & Newsgroups entry in Control Center or the Start menu. But email and newsgroup 
accounts can be created from a Mozilla browser connection. 
 
1. Open a browser connection and click on Window>Mail & Newsgroups or on the Mail & Newsgroups icon 

in the Window toolbar at the bottom of the browser screen 
 

 
Mozilla Screen Showing Access to Mail & Newsgroups 

2. If this is the first account to be created in this Mozilla connection, you will see the Mail & Newsgroups 
screen overlaid with the first dialog box of the Account Wizard. If you already have an account here, but 
want to add another one, click on File>New>Account to open the Account Wizard. You can have multiple 
accounts in each Mozilla connection if you wish. 
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Account Wizard Dialog Box #1 

3. Select the type of account you need and click on Next. 
 
4. Follow the explicit instructions in each of the subsequent Account Wizard dialog boxes. You will also find 

detailed information in Help in the Menu bar. 
 
After your accounts are created, you can edit many parameters as discussed in xxx 
 

Mozilla 
 
A default Mozilla session is already available in your terminal, accessible from the Taskbar and from 
Start>Programs>Mozilla. 
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Mozilla Default Connection 

The parameters of this default Mozilla connection can be edited, as will be discussed in xxx. You can also add 
more connections, called profiles in Mozilla, but only one can be opened at a time. Mozilla connections can also 
be added from Control Center>WWW or Start>WWW, with the advantage that these connections can be set 
to Autostart at bootup. See xxx for information on creating such connections. To differentiate between these two 
types of connections, and hopefully reduce some confusion, we will refer to Mozilla connections as separate 
entities from WWW connections, even though both use the Mozilla browser. 
 
To add a Mozilla connection: 
1. Open the default connection and click on Tools>Switch Profile. You will see the Manage User Profiles 

dialog box. 
 

 
Manage User Profiles Dialog Box 

2. Click on Crate Profile to open the Create Profile Wizard. 
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Create Profile Wizard Welcome Screen 

3. Click on Next to see the only dialog box in the wizard. 
 

 
Create Profile Wizard Dialog Box 

4. Enter a name for the new profile. Ignore the three buttons and click on Finish. You will then see the Manage 
User Profiles dialog box with the new profile added in the Available Profiles list. 
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Manage User Profiles Dialog Box 

5. Unless you click on the Don’t ask at startup radio button, you will be asked to choose a profile whenever 
you open a Mozilla connection. If you do click on this button, Mozilla will open with the last-used profile. 

 
As you can see, the only parameter that is configured in this creation is the connection name. There are many 
other parameters that can be edited after the creation; see xxx for editing information. 
 
 

PowerTerm 
 
Like the Mozilla browser, PowerTerm connections can be created from two paths, with slightly different results. 
If created from Control Center>PowerTerm, the options exist to Autostart at bootup and/or to place a 
connection icon on the Desktop. If created from Start>Programs>PowerTerm, these two options are not 
directly available. 

 

 
Control Center>PowerTerm Dialog Box 
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Your terminal will normally come with several pre-configured PowerTerm IBM 5250 connections. You have 
two types of configuration options: modify an existing default 5250 display connection, or initiate a new 
connection. We recommend that you modify one of the default connections, since they have been configured to 
take advantage of the most useful options and keyboard mapping. 
 

Modify a Default 5250 Display Connection 
 
Four 5250 default connections are provided: 101GREEN, 101GUI, 122GREEN, and 122GUI. As the names 
indicate, each connection is designed to optimize the use of an Affirmative 101-key or 122-key keyboard along 
with a classic “green screen” (text based) or contemporary graphical (GUI) display style. Proceed as follows: 
1. Each default connection is configured to connect over the Internet to the Affirmative Computer Products 

demonstration AS/400 server. Before you make any modifications, we recommend, if your terminal has an 
Internet connection, that you connect to our server to verify your network configuration and to experience the 
display alternatives. Use DEMO1 or DEMO2 for the user name and password. 

2. After you have decided which default connection most closely fits your needs, go to 
Start>Programs>PowerTerm. A blank connection window labeled Telnet will open. 

 

 
PowerTerm Telnet Window 

3. Click on the Connect icon in the Tool Bar or Communication>Connect in the Menu Bar. The Connect 
dialog box will open. 
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PowerTerm Connect Dialog Box 

4. In the Session List box, highlight the name of the default connection that serves as your model. 
5. Change the Host Name to the IP address or DNS-defined name of your host server. Each emulator 

connection can have a different host if desired. 
6. If you are using named sessions, enter the session name recognized by the host in Terminal Name. 
7. The Port Number is a commonly used default, so you generally do not need to enter anything here. 
8. Select the type of Security you wish to use. You will also have to enter additional details after you select the 

security type. 
9. If you want a previously-constructed script to run automatically when this connection is opened, select a 

Script File from the drop-down list. 
10. If you want to retain the same name as your default connection model, click on Modify. If you want to use a 

new connection name, click on Save As… and enter the new name in the Save Session dialog box. This new 
name will immediately appear in the Session List. 

11. With the connection name still highlighted, click on Connect. You can complete the following steps even if 
the connection fails, but you must have an open window for the connection of interest. 

12. In the open connection window, open the Terminal menu and select Setup. You will see the Terminal Setup 
dialog box. Ignore the Emulation tab since you have already decided to use 5250 display emulation for this 
connection. Open the other tabs and make your selections. 
Note: Any references to a History Buffer are only applicable for non-IBM emulations. 

 

 
PowerTerm Terminal Setup Dialog Box. 
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13. Keyboard mapping, Power Pad options, and other miscellany are available under the Options menu. If you 

change the keyboard mapping, be sure to execute a Save Keyboard File from the File menu, and we 
recommend that you save it under a new file name. 

14. If you change any connection properties in this step, you must save the changes. If you exercise File>Save 
Terminal Setup, the changes will be applied to the current setup file. We strongly recommend that you save 
the setup in a setup file with the same name as the connection name by exercising File>Save Terminal 
Setup As… before exiting the session. After you do this, these selections can be transferred to any new or 
existing connection by selecting that setup file when configuring the connection. If you do not do a Save, 
you will lose all these changes. 

15. Even if you did not change any connection properties in Steps 12-14, we strongly recommend that you save 
the setup in a setup file with the same name as the connection name by exercising File>Save Terminal 
Setup As… before exiting the session. The reason for this is given in the following steps. 

16. If you want to configure the connection to Autostart at bootup and/or have a shortcut with a Desktop icon, go 
to Control Center>PowerTerm and then continue with Step 17. If you don’t want to exercise these options, 
you are done with this connection. 

17. This Control Center utility works with setup files rather than connection names. Click on Configuration to 
see a drop-down list of the available setup files. You might think that if multiple connections use the same 
setup file, they would all have the same Autostart/Desktop properties that have been configured for that setup 
file. Not so. Only the first connection in the PowerTerm session list using that setup file will exhibit these 
properties. That is why every PowerTerm connection should have its own setup file. 

18. Highlight the desired setup file in the drop-down list, and the name will appear in the Name field 
19. Make your Autostart/Desktop Icon choices here and then click on Save. 
 

Configure a New Connection 
 
If you want to configure a new connection from scratch, or need something other than a 5250 display connection, 
you should follow this procedure: 

1. Go to Start>Programs>PowerTerm. A blank connection window labeled Telnet will open. 
 

 
PowerTerm Telnet Window 

2. Click on the Connect icon in the Tool Bar or Communication>Connect in the Menu Bar. The Connect 
dialog box will open. 
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PowerTerm Connect Dialog Box 

3. In Terminal Type, select the type of terminal that you wish to emulate. 
4. The configuration parameters in this window will vary slightly, depending upon the selected terminal 

type. The instructions here assumes IBM 3270 or 5250 emulation 
5. In Terminal ID, select the terminal model that you wish to emulate. 
6. In Host Name, enter an IP address, unless the system name is defined in a DNS server. Each emulator 

connection can have a different host if desired. 
7. In Terminal Name, enter the session name recognized by the host if you are using named sessions. For a 

printer session, it will probably be a named session as defined by your server administrator. 
8. The Port Number will default, so you generally do not need to enter anything here. 
9. If you want to keep the connection alive during periods of inactivity, put a number of minutes in the 

Keep Alive Timeout field. This is especially useful if you are using a slow WAN link to a remote 
server. 

10. If you want a secure connection, and your host supports it, select the type of security from the drop-down 
list of Security. 

11. If you want to clone the configuration parameters of a previously-defined configuration, click on the 
button to the right of the Setup File field and select a setup file. For 5250 display connections using an 
Affirmative Computer Products keyboard, we strongly recommend that you choose an existing file. If 
you don’t choose a setup file, the default file, ptdef.pts, will be assigned to this connection. 

12. If you want to automatically invoke a previously-constructed logon script, click on the button to the right 
of the Script File field and select a script file. 

13. Click on Save As… and enter a connection name in the Save Session window. This new name will 
immediately appear in the Session List. 

14. If you want to connect immediately, click on Connect. Otherwise, you can click on Close or X and the 
connection will be saved for future use. 

15. If you want to select other configuration options, you will need to open (connect) the connection to 
complete the configuration. See xxxDisplay Connection or xxxPrinter Connection, as appropriate, to 
complete the configuration. 

 

Display Connection 
You can complete the following steps even if the connection fails, but you must have an open window for the 
connection of interest. 

1. In the open connection window, open the Terminal menu and select Setup. You will see the Terminal 
Setup dialog box. Ignore the Emulation tab since you already made that selection earlier in this process. 
Open the other tabs and make your selections. 
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Note: Any references to a History Buffer are only applicable for non-IBM emulations. 
 

 
PowerTerm Terminal Setup Dialog Box for Display Connection 

2. If you chose a pre-defined setup profile earlier, a keyboard map has already been selected. If not, open 
the File menu with the mouse or by pressing the LeftAlt button. 

3. One 5250 122-key keyboard map, one 5250 101-key map, one 3270 122-key map, and one 3270 101-key 
map have been  predefined in the firmware for use with Affirmative Computer Products keyboards. 
Choose one of these by selecting Open Keyboard File, highlighting your selection, and clicking on OK. 
DO NOT CLICK ON DELETE FOR ANY OF THESE PRE-DEFINED SETUPS. If you do not 
make a selection, your keyboard setup will default to a 101-key 5250 or 3270 map intended for use with 
a standard PC keyboard. 

4. If you do some custom keyboard mapping and want to save it for later use, be sure to use Save 
Keyboard File before exiting the connection. If you do not, you will lose this custom map. When you 
save, choose an existing keyboard map file or type a new name in the File Name field of the Save 
Keyboard File window. 

5. Follow Steps 13-19 under Modify a Default 5250 Display Connection. 
 

Printer Connection 
You can complete the following steps even if the connection fails, but you must have an open window for the 
connection of interest. 

1. In the open Printer Status window, open the Terminal menu and select Setup. You will see the Terminal 
Setup dialog box. Ignore the Emulation tab since you already made that selection earlier in this process. 
Open the other tabs and make your selections. 
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PowerTerm Terminal Setup Dialog Box for Printer Connection 

2. In the General tab offers several options. leave the code pages at their default settings f you are in the 
US. 

3. In the Printer tab: 
• Click on Advanced Printing to set printer parameters or to select Host Print Transform. 

o For local LPT1 printing, select Device and leave the Device Name field at LPT1. 
o For local serial printing, go to the Device Name field and overwrite the default LPT1 with 

COM1:. The default serial parameters are 9600 8 N 1. 
o For network printing: 

a. Set up the LPD network printer address and queue name in Control Center>Printer, 
b. Select Print Manager in Print Device. 
c. From the File menu, select Print Setup. 
d. In Print Destination, select your network printer. 

4. In the Preferences tab, History Buffer is only applicable for non-IBM emulations. 
5. Save the setup in a setup file with the same name as the connection name by exercising File>Save 

Terminal Setup As… before exiting the session. 
6. If you want to configure the connection to Autostart at bootup and/or have a shortcut with a Desktop 

icon, go to Control Center>PowerTerm and then continue with Step 7. If you don’t want to exercise 
these options, you are done with this connection. 

7. This Control Center utility works with setup files rather than connection names. Click on Configuration 
to see a drop-down list of the available setup files. You might think that if multiple connections use the 
same setup file, they would all have the same Autostart/Desktop properties that have been configured for 
that setup file. Not so. Only the first connection in the PowerTerm session list using that setup file will 
exhibit these properties. That is why every PowerTerm connection should have its own setup file. 

8. Highlight the desired setup file in the drop-down list, and the name will appear in the Name field. 
9. Make your Autostart/Desktop Icon choices here and then click on Save. 
 

Modify a Connection 
 
Depending upon the modifications that you want to make, there are three different paths to follow: 
1. Go to Control Center>PowerTerm or Start>PowerTerm>Set Configuration 

a. Select the configuration of interest from the drop-down list. 
b. Modify Auto Start or Desktop Icon. 
c. Click on Save. 
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2. Go to Start>Programs>PowerTerm 

a. Select the connection of interest from the Session List. 
b. Modify the parameters of interest in the Connect dialog box. 
c. Click on Modify. 

3. Launch the connection of interest. 
a. Go to Terminal>Setup. 
b. Modify the parameters of interest in the Terminal Setup dialog box. 
c. Click on OK. 
d. Execute a File>Save Terminal Setup to save these changes to your configuration/setup file. 

 
If you wish to delete a setup file, you can only do this from Control Center>PowerTerm. or 
Start>PowerTerm>Set Configuration. 
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Troubleshooting Your YEStation 
 

The following table provides some solutions to common problems that can occur during setting up or using your 
YEStation terminal. 
 

Problems Solution 

1 The monitor screen is blank 

• Make sure the terminal is turned on. 
• Make sure the monitor is plugged into an AC outlet and turned 

on. 
• Make sure the VGA connector is plugged into the terminal. 

2 
Your monitor cannot display after 
advancing past the logo screen or after 
changing the display setting. 

The display setting may be at a higher resolution or refresh 
frequency than the monitor will support. Execute one of the 
following recovery options: 
• Use a better monitor for display. 
• Use a better monitor for display while changing the display 

settings to be compatible with the original monitor. 
• Ask your MIS or network administrator to reset your terminal 

to factory default settings through the Remote Management" 
software, if it is installed at your server site. 

3 The mouse does not work. 
• Make sure the mouse is plugged into the mouse port, not the 

keyboard port. 
• Test the terminal using a known good PS/2 mouse. 

4 The keyboard does not respond. 
• Make sure the keyboard is plugged into the keyboard port, not 

the mouse port. 
• Test the terminal using a known good PS/2 keyboard. 

5 The network connection does not work. 

• Check the network connection. 
• Verify the terminal IP address is correct in the Network 

properties sheet of Control Center. 
• Check the server's IP address. 
• If you are using the terminal default setting of DHCP address 

assignment, make sure there is a workable DHCP server on 
your network. 

• If you are using a specified IP address, make sure that there is 
not another network device with the same IP address. 

6 Forgot the password setting and cannot 
reconfigure the terminal. 

• Ask your MIS or network administrator to reload your firmware 
through the eProManager remote management software, if it is 
installed at your server site. 

7 You cannot ping your terminal from 
another device on the network. 

See #5 above. 
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Problems Solution 

8 eProManager cannot communicate with 
your terminal. 

• See #5 above. 
• Make sure that eProManager has the current IP address for your 

terminal. 
          
                   

Support 
 
Affirmative Computer Products offers Technical Support services for all the Affirmative products. You can 
access Affirmative Technical Support in one of the following ways: 
 
• via Phone 

o 480-946-1444 
o 888-353-5250 

• via Fax 
o 480-946-9250 

• via E-mail 
o support@affirmative.net 
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2201 and 2216 Models 

     

ITEM SPECIFICATIONS 

Processor SIS 550 200 MHz  

Communication and Ports 

• Microsoft RDP and Citrix ICA protocol compliant. 
• 10/100 dual-speed Ethernet, Twisted Pair (RJ45). 
• One parallel port (DB-25 Female connector). 
• Enhanced ps/2 keyboard interface. 
• Enhanced ps/2 mouse interface. 
• Two USB ports. 
• Audio out. 

Embedded O.S. Linux 

Video 
• SVGA 
• 640x480, 800x600, 1024x768, and 1280x1024 with high color. 
• Refresh frequency up to 85 Hz 

Memory • SDRAM -- 64 MB SDRAM standard. (Max. 256MB) 
• Flash – 32MB CompactFlash for 2201, 128 MB CF for 2216  

Server Operating System Support 

• Microsoft Windows 2003 Server 
• Microsoft Windows 2000 (Server Edition) 
• Microsoft Windows NT 4.0 (TSE) 
• Citrix MetaFrame XP 
• Citrix MetaFrame 
• Citrix WinFrame 
• Tarantella 
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ITEM SPECIFICATIONS 

Optional Devices • USB storage 
• USB wireless LAN adapter 

Software Features 

• Remote Management client 
• Wake on LAN (WOL) 
• SNMP support 
• Time zone and SNTP support 
• Terminal access password for security 
• Multi-session Autostart with Fail-over 
• LPD & ThinPrint support 
• VNC viewer 
• PDF viewer 
• Virtual Private Network, SSH, and PPoE support 
• Mozilla email (2216 only) 
• PowerTerm terminal emulation (2216 only) 
• Firmware upgrade over the network 

Temperature • Operating: 5 ºC to 40 ºC (41 ºF to 104 ºF) 
• Storage: -40 ºC to 60 ºC (-4 ºF to 140 ºF) 

Relative Humidity 90% maximum, non-condensing 

Operating Altitude Range 0 to 10,000 feet (0 to 3050 meters) 

Environment 
      
      
      
     

Power Full range auto-sensing 100 ~ 240 VAC at 50 Hz ~ 60 Hz 
• 10 Watts 

Regulatory Compliance 

• UL 
• C-UL 
• TUV 
• FCC Class B 
• CE mark 

Dimension (WxDxH) 194.5 x 151.5 x 40 (mm) Physical 
Characteristics 

Weight 0.65 Kg 

  

 66 
 
 



Appendix 1. Specifications 
 

2326 and 2726 Models 

 
 

ITEM SPECIFICATIONS 

Processor 
  

• 2326. AMD 466 
• 2726. Via 1 GHz 

Communication and Ports 

• Microsoft RDP and Citrix ICA protocol compliant 
• 10/100 auto sensing Ethernet, Twisted Pair (RJ45) 
• One parallel port (DB-25 Female connector) 
• One serial port with RS-232C (DB-9 male connectors) 
• Enhanced ps/2 keyboard interface 
• Enhanced ps/2 mouse interface 
• PCI slot 
• PCMCIA slot supporting wireless LAN adapter 
• USB ports (4) 
• Audio out and Microphone in 

Embedded O.S. Linux with Mozilla 1.7.7 browser 

Video 
• SVGA 
• 640x480, 800x600, 1024x768, and 1280x1024 with high colors 
• Refresh frequency up to 85 Hz 

Memory • RAM -- 128 MB DDR standard. (Max. 512MB) 
• Flash -- 128 MB CompactFlash 

Server Operating System Support 

• Microsoft Windows 2003 Server 
• Microsoft Windows 2000 (Server Edition) 
• Microsoft Windows NT 4.0 (TSE) 
• Citrix MetaFrame XP 
• Citrix MetaFrame 
• Citrix WinFrame 
• Tarantella 

Optional Devices • USB storage 
• Wireless LAN adapter, 802.11b (PCMCIA) 
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ITEM SPECIFICATIONS 

Software Features 

• Remote Management client 
• SNMP support 
• Time zone and SNTP support 
• Terminal access password for security 
• Multi-session Autostart with Fail-over 
• LPD & ThinPrint support 
• VNC viewer 
• PDF viewer 
• Virtual Private Network, SSH, and PPoE support 
• Mozilla email 
• PowerTerm terminal emulation 
• Wake on LAN (WOL) 
• Firmware upgrade over the network 

Temperature • Operating: 5 ºC to 35 ºC (41 ºF to 95 ºF) 
• Storage: -10 ºC to 60 ºC (14 ºF to 140 ºF) 

Relative Humidity 90% maximum, non-condensing 

Operating Altitude Range 0 to 10,000 feet (0 to 3050 meters) 

Environment 
      
      
      
     

Power • Full range auto-sensing 100 ~ 240 VAC at 50 Hz ~ 60 Hz 

Regulatory Compliance 
• UL 
• FCC Class B 
• CE mark 

Dimension (WxDxH) 9.25 x 6.5 x 1.5 (inches) Physical 
Characteristics 

Weight 3 pounds 
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Appendix 2. TCP/IP Error Codes 
 

Here is a comprehensive list of standard TCP/IP error codes that can occur during network operation. Some of 
them are quite esoteric and may not be applicable to YEStation operation, but this list should include any 
networking error code that you encounter. They should be useful in troubleshooting network errors, many of 
which are caused by incorrect configuration. 
 
10004  
Interrupted function call.  
 
10013  
Permission denied.  
 
10014  
Bad address.  
 
10022  
Invalid argument. This usually means that the host server IP address or name has been incorrectly specified when 
configuring the connection. 
 
10024  
Too many open sockets.  
 
10035  
Resource temporarily unavailable.  
 
10036  
Operation now in progress. A blocking operation is in progress.  
 
10037  
Operation already in progress.  
 
10038  
Socket operation on non-socket.  
 
10039  
Destination address required.  
 
10040  
Message too long.  
 
10041  
Protocol wrong type for socket.  
 
10042  
Bad protocol option.  
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10043  
Protocol not supported.  
 
10044  
Socket type not supported.  
 
10045  
Operation not supported.  
 
10046  
Protocol family not supported.  
 
10047  
Address family not supported by protocol family.  
 
10048  
Address is already in use. If you attempt to set up a server on a port that is already is in use, you will get this 
error.  
 
10049  
Cannot assign requested address.  
 
10050  
Network is down.  
 
10051  
Network is unreachable.  
 
10052  
Network dropped the connection on reset.  
 
10053  
Software caused the connection to abort, usually due to connection or protocol error.  
 
10054  
Connection reset by peer. This occurs when an established connection is shut down for some reason by the 
remote computer.  
 
10055  
No buffer space available.  
 
10056  
Socket is already connected.  
 
10057  
Socket is not connected.  
 
10058  
Cannot send after socket shutdown.  
 
10060  
Connection timed out. This is usually caused by specifying an incorrect host server IP address or port number 
when configuring the connection. 
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10061  
Connection refused. The server has refused a connection from the terminal, usually because the server is not 
listening on that port or the server is unable to accept additional connections. 
  
10064  
Host is down.  
 
10065  
No route to host.  
 
10067  
Too many processes.  
 
10091  
Network subsystem is unavailable.  
 
10092  
Unsupported version of WINSOCK.DLL.  
 
10093  
TCP networking has not been initialized on your computer.  
 
10094  
Graceful shutdown in progress.  
 
11001  
Host not found. (DNS error.)  
 
11002  
Non-authoritative host not found. Temporary DNS error.  
 
11003  
Non-recoverable error. (DNS error.) 
 
11004  
Valid name, no data record of requested type. (DNS error.) 
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