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YEStation Limited Warranty 
 

General Terms and Conditions 
 
Limited Product Warranty.  Affirmative Computer Products warrants that the YEStation Hardware 
Product (Logic unit and keyboard) shall be free from defects in materials and workmanship that arise 
under proper and normal use and service for three years from the date of purchase.  A warranty 
extension of two years is available at extra cost, if obtained at the time of the original YEStation 
purchase.  In the event that the YEStation Hardware Product fails to comply with the warranty set forth 
above, Affirmative Computer Products will repair or replace the Product. 
 
 
Software Warranty.  Affirmative Computer Products warrants that, for a period of ninety (90) days 
from the date of purchase by the End User, its Software Products shall conform to its published 
specifications under normal usage.  AFFIRMATIVE COMPUTER PRODUCTS DOES NOT 
WARRANT THAT THE OPERATION OF THE SOFTWARE WILL BE UNINTERRUPTED OR 
ERROR FREE, OR THAT ALL SOFTWARE DEFECTS WILL BE CORRECTED.  In the event that a 
Software Product fails to comply with the warranty set forth above, Affirmative Computer Products 
will replace the product.  End User must, however, return all copies of the Software, along with proof 
of purchase, to Affirmative Computer Products within 90 days from the Software purchase date. 
 
 
Warranty Limitations.  End User’s sole remedy under any Warranty provided by Affirmative 
Computer Products shall be limited to the replacement or repair of the Product or, at Affirmative 
Computer Products’ sole discretion, a refund of the purchase price.  AFFIRMATIVE COMPUTER 
PRODUCTS GRANTS NO WARRANTY, EXPRESS OR IMPLIED, OTHER THAN THE 
WARRANTIES STATED ABOVE.  EXPRESSLY EXCLUDED ARE THE IMPLIED 
WARRANTIES OF MERCHANTIBILITY AND FITNESS FOR A PARTICULAR PURPOSE.  IN 
NO EVENT SHALL AFFIRMATIVE COMPUTER PRODUCTS BE LIABLE FOR SPECIAL, 
INCIDENTAL, OR CONSEQUENTIAL DAMAGES, INSTALLATION COSTS, LOST REVENUE 
OR PROFITS, OR ANY OTHER COSTS INCURRED AS A RESULT OF THE USE OF ANY 
AFFIRMATIVE COMPUTER PRODUCTS PRODUCT, WHETHER OR NOT USED IN 
ACCORDANCE WITH INSTRUCTIONS. 
 
 
Warranty Procedure.  Affirmative Computer Products will replace or repair any defective, 
undamaged units for which a Return Material Authorization number (RMA#) has been obtained from 
the Technical Support Department.  (Contact 888-353-5250 or 480-946-1444 or 
support@affirmative.net) 
 

 iii

mailto:support@affirmative.net


2x14 User’s Guide 

 
 

Copyright and Trademarks 

 

Copyright Notice               
This manual, as well as the software described in it, is furnished under license. No part of this 
publication may be reproduced, transmitted, stored in a retrieval system, or translated into any human 
or computer language, in any form or by any means, electronic, mechanical, magnetic, optical, 
chemical, manual, or otherwise, without the prior written permission of the copyright owner. 
Note: Information in this document is subject to change without notice.  

 

Trademarks Notice  
• YEStation® is a registered trademark of Affirmative Computer Products®. 
• YESterm/IP™ is a trademark of Affirmative Computer Products®. 
• Adobe®, the Adobe logo, Acrobat®, the Acrobat logo, and Acrobat Reader are trademarks or 

registered trademarks of Adobe Systems Incorporated. 
• Linux® is a registered trademark of Linus Torvalds. 
• Windows® is a registered trademark of Microsoft® Corporation.   
• Java® is a registered trademark of Sun Microsystems, Inc. 
• Netscape®, Netscape Communicator®, and Netscape Navigator® are registered trademarks of 

Netscape Communications Corporation. 
• Microsoft® is a registered trademark of Microsoft® Corporation.  
• ICA® is a registered trademark of Citrix® Systems Inc.  
• MetaFrame® is a trademark of Citrix® Systems Inc.  
• Other company and brand, product and service names are trademarks or registered trademarks of 

their respective holders.  
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Installing Your Terminal 
 

• Your terminal has no internal fan, and relies on natural airflow for cooling.  When you mount it, 
make sure to keep as many ventilation holes, as possible, unobstructed. 

• DO NOT use any AC-DC adapter other than the one provided with the terminal or acquired from 
Affirmative Computer Products or its distributors. 

 

Mounting 
 

2214 Terminal 
 
The 2214 terminal can be placed horizontally on a flat surface, or it can be mounted vertically on a 
wall.  A self-adhesive template and four #3, ½-inch wood screws are included with every terminal.  The 
following figure shows one mounting possibility. 
 

 
2214 Wall Mounting 
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Another possibility is shown here. 
 

 
2214 Monitor Mounting 

We have done some testing with the provided screws, and have the following suggestions: 
• In soft wood, such as pine, no pilot holes are needed. 
• In hard wood or plastic, such as the side of a monitor, create pilot holes by: 

• Drilling with a 3/64” drill bit. 
• Using a pushpin. 
• Using an ice pick. 

• In dry wall, these screws do not hold well; if you must install on dry wall, we suggest that you: 
• Drill 3/64” pilot holes and put super glue in the holes before inserting the screws. 

Or 
• Use longer screws with coarser threads. 

 

2614 Terminal 
 
The 2614 terminal can be mounted in several ways: 
• Vertical Mounting.  Place the terminal in the provided stand as shown in the picture on the front 

cover of this manual. 
• Horizontal Mounting.  Adhere the provided rubber feet in the indentations on the bottom of the 

terminal, and place the terminal horizontally on a flat surface.  Your monitor can be placed on top 
of the 2614, if you wish, to minimize desktop footprint. 

• Permanent Mounting.  The 2614 terminal can be mounted permanently on a desk or under a table 
or attached to a wall.  The following figures show two possible mounting procedures 
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                            Mounting the 2614 on a desk or a wall 

 
 

 
                    Mounting the 2614 under a table 
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2814 Terminal 
 
The 2814 terminal can be mounted in two ways: 
• Vertical Mounting.  Place the terminal in the provided stand as shown in the picture on the front 

cover of this manual. 
• Horizontal Mounting.  Adhere the provided rubber feet to the four corners of the bottom of the 

terminal, and place the terminal horizontally on a flat surface.  Be sure that it is oriented as shown 
here.  Your monitor can be placed on top of the 2814, if you wish, to minimize desktop footprint. 

 

 
2814 Orientation for Horizontal Mounting 

 
 

Cabling 
 

2214 Terminal 
 
Please make all cable connections before turning on the power. The following figures show the 2214 
rear and front connectors.  Note:  If you want to connect an external speaker to the Audio Out port, it 
must have auxiliary power.   
 

 
2214 Rear Connectors 
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2214 Front Connectors 

 

2614 Terminal 
 
Please make all cable connections before turning on the power. The following figure shows the 2614 
connectors on the rear panel.  Note:  If you want to connect an external speaker to the Line Out port, it 
must have auxiliary power. 
 

 
2614 Rear Panel 
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2814 Terminal 
 

Please make all cable connections before turning on the power.  The following figures show the 2814 
rear and front connectors, indicators, and controls. 
Note:  If you want to connect an external speaker to the Audio Out port, it must have auxiliary power. 
Note:  The Smart Card and PCI options are not available. 
 

 
2814 Front Panel 

 
 

 6



2x14 User’s Guide—Installing Your Terminal 

 
2814 Rear Panel 

 

Power On 
 

2214 Terminal 
 

1. Power on the terminal after all cable connections have been made. 
2. The Power LED, incorporated into the Power button will, change from faint orange to light green. 
3. After several seconds, you will hear a beep and the bootup process will begin. 
 

2614 Terminal 
 

There are three LED indicator lights placed together on the front panel: 
• Power (on the right or top).  This indicator, incorporated into the Power switch, is green when the 

terminal is powered up. 
• Network Connection (on the left or bottom).  This indicator is on when there is a good physical 

connection to the Local Area Network. 
• Network Activity (in the middle).  This indicator flashes to indicate LAN activity. 
 
1. Turn on the terminal after all cable connections have been made. 
2. The Power and Network Connection lights should come on immediately. 
3. After several seconds, you will hear a beep and the bootup process will begin.  The Network 

Activity light should begin flashing 
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2814 Terminal 
 
There are three LED indicator lights on the front panel: 
• Power (on the right or top).  This indicator is on when the terminal has been powered up. 
• Network Activity (in the middle).  This indicator flashes to indicate LAN activity. 
• Smart Card.  Since the Smart Card option is not yet available, this LED should never come on. 
 
1. Turn on the terminal after all cable connections have been made. 
2. The Power light should come on immediately. 
3. The Network Activity light should come on in 1-2 seconds. 
4. After several seconds, you will see screen activity, and the bootup process will begin.  There is no 

beep. 
 
 

Bootup 
 
1. You will see the message Starting System.  Please Wait… on a black screen. 
2. After several seconds, you will see the Affirmative logo screen with a progress bar at the top and a 

dialog box at the bottom announcing significant steps in the boot up process. 
3. After the progress bar is complete, you will see a blank black screen, followed in several seconds by 

a blank grey screen, followed quickly by: 
• In the default Desktop viewing mode, the black screen will be quickly followed by a blue screen 

and then the Desktop screen. 
• If this is the initial bootup, you will see the first screen of the Setup Wizard. 
• If you have already configured an Autostart session (see Connections 

Management|Configuration|Startup), you will see a screen for that session. 
 

 
Bootup Desktop Screen for Desktop Viewing Mode 
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• In the WBT viewing mode, the black screen will be quickly followed by a blue screen that is 
overlaid with the Connections tab of the Connections Management screen.  If you have already 
configured an Autostart session (see Connections Management|Configuration|Startup), you will 
see a screen for that session. 

 

 
Bootup Connections Manager Screen for WBT Viewing Mode 

 
• In the TBT viewing mode, the grey screen will be quickly followed by a blank black screen and 

then by a “green screen” for one of the Autostart emulation sessions. 
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Terminal Setup 
 

The 2x14 can be operated in one of three viewing modes: TBT (Text Based Terminal), WBT (Windows 
Based Terminal), or Desktop.  The default is Desktop, which presents a desktop screen with a Taskbar 
and a Start button very similar to a standard Windows desktop, and the mechanics of Desktop setup are 
covered here.  However, the terminal properties and session properties are identical in the different 
viewing modes; only the look and feel are different. 
 
Initial terminal setup is done from the Setup Wizard screens in Desktop viewing mode.  Initial setup is 
done when: 
• A terminal is first booted up after being received from the factory. 
• A terminal is reset to factory defaults and then rebooted. 
Setup can even be done remotely from a remote central management YESmanager console using the 
Shadowing feature of YESmanager. 
 

Setup Wizard 
 
The Setup Wizard screens set the basic terminal network configuration and display parameters. Any 
parameters set here can be changed later.  When proceeding through the Setup Wizard process: 
• Activate the Next button to display the next dialog box in the sequence. 
• Activate the Back button to return to the previous dialog box. 
• Activate the Cancel or X button to return to the first Setup Wizard screen.  You cannot use the 

terminal without completing the Setup Wizard. 
There are four basic Wizard screens, and two supplemental screens if you choose static IP addressing. 
 
1. The first screen is informational only. 

 

 
Setup Wizard Screen #1 
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• Product ID.  This is a unique product identification code that also happens to be the terminal 
MAC address. Every device on every LAN in the world is supposed to have a unique MAC 
address. 

• Kernel Version.  This is the version of the Linux kernel used on the terminal. 
• Software Version.  This is the version of the firmware installed in this terminal.  If you contact 

Affirmative Computer Products Tech Support about a problem, please have this version 
information available. 

• Total RAM.  This is the amount of DRAM in the terminal after subtracting the memory used 
for some basic functions and the memory reserved for video. 

• CPU Info.  This shows some basic information about the CPU in the terminal. 
 
2. The second screen is used for network information. 
 

 
Setup Wizard Screen #2 

• Yes, I will….  Select this radio button to enable dynamic DHCP addressing from a DHCP 
server. 

• No, I will….  Select this radio button to enable static network settings and invoke the two 
supplemental Wizard screens.  The first supplemental screen is: 

 

 
Setup Wizard Screen #2a 
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• IP Address.  Enter a static IP address in this field.   
• Subnet Mask.  Enter the subnet mask of the local network 
• Default Gateway.  Enter the IP address of a gateway if any server is not on the local sub-net. 

 
The second supplemental screen is: 
 

 

Setup Wizard Screen #2b 

Check Activate DNS and enter your Domain Name System server here.  Get the entries from 
your network administrator. 
 

3. The third screen is used for basic display information. 
 

 
Setup Wizard Screen #3 

Select your resolution, refresh frequency, and color depth here.  If you choose a new combination 
from the drop-down list, the Next button will be grayed out until you use the Test button to preview 
the selected resolution and frequency.  Testing is required before locking in your settings since, if 
the monitor will not support your selection, you could be faced with an unreadable screen after 
boot-up. 
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4. The fourth screen commends you on your successful setup. 
 

 
Setup Wizard Screen #4 
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Viewing Modes 
 

You can choose one of three viewing modes (see Editing Terminal Properties|Desktop) to be used 
during configuration and terminal operation. 
 
NOTE:  In the remainder of this document, a reference to the Ctrl key actually means the LeftCtrl 
key, a reference to the Alt key actually means the LeftAlt key, and a reference to a click actually means 
a mouse left click. 
 

Desktop 
 

The Desktop viewing mode is the default, presenting a desktop screen with a Taskbar and a Start 
button, very similar to a standard Windows desktop.  A full set of configuration options is accessible 
from Terminal Properties.  Sessions are launched from the Start menu or from Connections Manager, 
although they can be configured to Autostart at bootup.   In Desktop mode, you can move, size, and 
show multiple emulator sessions on the screen in normal Windows fashion. 
 
An example of a Desktop screen with four emulator sessions is shown below. 
 

 
Four-Session Screen in Desktop Viewing Mode 

Sessions can be minimized, maximized, or midsized just as on a Windows desktop, and placeholders 
appear in the Taskbar. 
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Terminal Properties 
 
The Terminal Properties screen can be accessed with one of the following methods: 
• Select from the Start menu. 
• Press F2 while in the Connection Manager screen. 
• If you are using an Affirmative Computer Products 122-key keyboard and are in an active 

emulation session, press the SetUp key. 
 

 
Terminal Properties Screen for WBT and Desktop Viewing Modes 

The Terminal Properties screen is exactly the same in the WBT and Desktop viewing modes.  See 
Editing Terminal Properties for more information. 
 

Connections Manager 
 
The Connections Manager screen has only one tab, Configuration, in the Desktop viewing mode.  
However, the Connect button is added to allow launching sessions from this tab. 
 
To open the Connections Manager screen, use either of the following methods: 
• Select it from the Start menu. 
• Press Ctrl+Alt+End at any time. 
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Connections Manager Screen in Desktop Viewing Mode 

 

Navigation 
 
• To open the Start menu, use either of the following methods: 

• Click on the Start button in the Taskbar. 
• Right-click on any unused portion of the Desktop. 

• To access Terminal Properties, use one of the following methods: 
• Press F2 while in the Connections Manager screen. 
• Select it from the Start menu. 
• If you are using an Affirmative Computer Products 122-key keyboard and are in an active 

session, press the SetUp key 
• To open the Connections Manager screen, use either of the following methods: 

• Select it from the Start menu. 
• Press Ctrl+Alt+End at any time. 

• To open non-Autostart sessions, use either of the following methods: 
• In the Connections Manager screen, highlight the session name and click on Connect. 
• Select it from the Start menu. 

• If your display session is configured to hide the Menu and Tool bars, you can invoke the File menu 
by pressing Alt.  Then you can get to other menus by using the RightArrow and LeftArrow keys. 

• To close a display session, go to the Sign On screen, open the File menu, and activate Close or 
Close All.  If all your display sessions are at the Sign On screen, you can just power down. 

• To move among active emulator sessions, use one of the following methods: 
• Press Alt+PgUp for 101 keyboards or Alt+PgDn for 122 keyboards. 
• Press Ctrl+Alt+UpArrow/DownArrow for all keyboards. 
• Press RightAlt+Up/DownArrow for all keyboards, if enabled in Editing Terminal 

Properties|Desktop. 
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• Click on the appropriate button (I, II, III, or IV) in the tool bar. 
• Return to Connections Manager and select another session. 
• Move your mouse cursor to a new session if you are showing multiple sessions on the screen. 
• Click on the placeholder in the Taskbar. 
Note: The first two hot key methods listed above are only valid if the default WBT is selected in 
HotKeys in Editing Terminal Properties|Desktop. 

• In Desktop mode, you can size and show multiple emulator sessions on the screen in normal 
Windows fashion. 

• To power down or reboot, select Shutdown from the Start menu, and then select Shutdown or 
Reboot. 
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WBT (Windows Based Terminal) 
 
The Windows Based Terminal mode presents the kind of screens that you normally see in an 
Affirmative Computer Products YEStation that uses the Windows CE operating system.  Sessions are 
launched from the Connections Manager, although they can be configured to Autostart at bootup.  All 
sessions can be viewed simultaneously in a split-screen mode, if desired; each session will get the same 
amount of space on the screen. 
 
A split screen with four sessions is shown below. 
 

 
Split Session Screen in WBT Viewing Mode 

 

Terminal Properties 
 
The Terminal Properties screen is exactly the same in WBT viewing mode as in Desktop viewing 
mode.  It can be accessed with one of the following methods: 
• Press F2 while in the Connection Manager screen. 
• If you are using an Affirmative Computer Products 122-key keyboard and are in an active 

emulation session, press the SetUp key. 
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Connections Manager 
 
• The Connections Manager screen in the WBT viewing mode has separate tabs for connecting and 

configuring.  To open the Connections Manager screen, use either of the following methods: 
• This is the default screen at bootup, unless you have Autostart sessions. 
• Press Ctrl+Alt+End at any time. 

 

 
Connections Manager Screen for WBT Viewing Mode 

 

Navigation 
 
• To access Terminal Properties, press F2 while in the Connections Manager screen. 
• If you wish to activate more than one session in WBT viewing mode, press Ctl+Alt+End to be 

returned to the Connection Manager window.  You can now select another session for activation.  
All sessions can be activated at the same time. You can also set any or all sessions to start 
automatically at boot-up. 

 20



2x14 User’s Guide—Viewing Modes 

• To move among active emulator sessions, use one of the following methods: 
• Press Alt+PgUp for 101 keyboards or Alt+PgDn for 122 keyboards. 
• Press Ctrl+Alt+UpArrow/DownArrow for all keyboards. 
• Press RightAlt+Up/DownArrow for all keyboards, if enabled in Editing Terminal 

Properties|Desktop. 
• Click on the appropriate button (I, II, III, or IV) in the tool bar. 
• Return to Connections Manager and select another session. 
• Move your mouse cursor to a new session if you are showing multiple sessions on the screen. 
Note: The first two hot key methods listed above are only valid if the default WBT is selected for 
HotKeys in Editing Terminal Properties|Desktop. 

• To show multiple sessions in a split-screen, activate them and then press Shift+Alt+F2.  Each 
session will get the same amount of space on the screen.  To return to a single-session screen, move 
the input cursor to that session and again press Shift+Alt+F2. 

• If your display session is configured to hide the Menu and Tool bars, you can invoke the File menu 
by pressing Alt.  Then you can get to other menus by using the RightArrow, LeftArrow, and Tab 
keys. 

• To close a display session, go to the Sign On screen, open the File menu, and activate Close or 
Close All.  Also, if all your display sessions are at the Sign On screen, you can just power down. 
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TBT (Text Based Terminal) 
 
The Text Based Terminal mode is designed to allow terminal operation and basic configuration without 
a mouse.  The screens are very familiar to those users who have stared at dumb terminal “green 
screens”.  Sessions are Autostart at bootup by default, and normally only one session is viewed on the 
screen at a time.  However, all sessions can be viewed simultaneously in a split-screen mode, if desired; 
each session will get the same amount of space on the screen. 
 
Note:  Only emulation sessions can be opened and viewed in TBT mode 
 

Terminal Properties 
 
You can get to the Terminal Properties screen by: 

• Pressing Ctrl+Alt+End, even from a blank screen. 
• If you are using an Affirmative Computer Products 122-key keyboard and are in an active session, 

you can press the SetUp key. 
 
 

 
Terminal Properties Menu Screen in TBT Viewing Mode 

The Terminal Properties screens in TBT mode provide a basic set of configuration parameters.  To 
access the complete set, you will have to be in WBT or Desktop mode. 
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Connections Manager 
 
The Connections Manager screen is accessed from the Connections category of the Terminal 
Properties screen.  Since sessions are Autostart by default in TBT mode, Connections Manager need be 
accessed only when adding, deleting, or editing an emulation session.  You can prevent a session from 
being launched at bootup by marking it as Inactive in this screen. 
 

 
Connections Manager Screen for TBT Viewing Mode 

 

Navigation 
 
• In TBT viewing mode, you can get to the Terminal Properties screen by: 

• Pressing Ctrl+Alt+End, even from a blank screen. 
• If you are using an Affirmative Computer Products 122-key keyboard and are in an active 

session, you can press the SetUp key. 
• To get back to an active session from Terminal Properties, use the Esc key if no changes are to be 

saved. 
• To move among active emulator sessions: 

• Press Alt+PgUp for 101 keyboards. 
• Press Alt+PgDn for 122 keyboards. 
• Press Ctrl+Alt+UpArrow/DownArrow for all keyboards. 
• Press RightAlt+Up/Down Arrow for all keyboards, if this sequence is enabled (see Editing 

Terminal Properties|Desktop). 
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• Click on the appropriate button (I, II, III, or IV) in the tool bar. 
• If your display session is configured to hide the Menu and Tool bars, you can invoke the File menu 

by pressing Alt.  Then you can get to other menus by using the RightArrow and LeftArrow keys. 
• To close a display session, go to the Sign On screen, open the File menu, and activate Close or 

Close All.  Also, if all your display sessions are at the Sign On screen, you can just power down.  
Note:  If you close a session, you cannot reopen it without rebooting the terminal 
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Connections Manager 
 

Note: The terms “connection” and “session” are used interchangeably in this document. 
 
The Connections Manager window is used to manage or activate your terminal sessions in WBT and 
Desktop viewing modes.  In WBT mode, Connections Manager has both a Connections tab and a 
Configuration tab.  In Desktop mode, there is only a Configuration tab since connections are usually 
made from the Start menu. 
 
Initially, Connections Manager starts without any sessions.  Sessions are added from the Configuration 
tab. 
 

Configuration 
 
The Configuration tab in WBT mode allows four basic functions.    
 

 
Configuration Tab in WBT Viewing Mode 
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Add 
 
Activate the Add button to create a new session. A New Connection dialog box is displayed. 
 

 
New Connection Dialog Box 

Click on the drop-down arrow to see a list of possible connection types.  See Creating a New 
Connection for information on adding specific connections.  As sessions are added, they will be 
displayed alphabetically. 
 

Edit 
 
Activate the Edit button to edit the properties of a selected connection. A property window for that 
session type will pop up.  Please refer to Editing an Existing Connection for more information about 
editing a connection.  
 

Delete 
 
Activate the Delete button to delete the highlighted connection. When you activate this button, a 
Connection Delete dialog box is displayed. 
 

 
Connection Delete Dialog Box 

 Activate the Yes button to complete the deletion. Activate No to cancel the deletion.  
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Startup 
 
Activate the Startup button to configure startup options when the terminal boots up. The Startup 
Options dialog box displays after the Startup button is pressed.  Using the dialog box, your terminal can 
be set to automatically connect to a server when the terminal is booted.  Any or all sessions can be 
configured for automatic startup. 
 

 
Connection Startup Dialog Box 

• Enable the connection as the Default connection.  Check this box to use the selected connection 
as the default connection.  This connection will be highlighted in Connection Manager when the 
terminal is powered up.  If there is only one configured session, this option is grayed out 

• Enable connection autostart.  Check this box to automatically start the selected connection when 
the terminal boots up. 

• Enable Automatic reconnection.  This is not supported in the 2x14 terminals. 
 

Connect 
 

 
Connections Manager for Desktop Viewing Mode 
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In Desktop viewing mode, you will see a Connect button in addition to the four buttons previously 
discussed.  This allows you to start a session from Connections Manager even though the Connections 
tab is not available. 
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Connections 
 

 
Connections Tab in WBT Viewing Mode  

The Connections tab is used to make or end network connections with the server(s). 
Connect.  Highlight the session name and activate the Connect button to make a network connection.  
You can also activate a connection by double-clicking on it. 
End.  Highlight the session name and activate the End button to end a connection shown as Active in 
the status field.  A dialog box will pop up asking for confirmation.  You can also end a session from the 
session screen itself, without going to Connections, and that is the recommended way to end a session. 
PowerOff.  It is recommended that you shut down your terminal using this button, although usually just 
shutting off the power does no harm.  You will see the following dialog box. 
 

 
Power Off Dialog Box 

• Power-Off.  Click on this button to turn off terminal power.  Note: This button does not have any 
effect in the 2614 terminal. 

• Restart.  Click on this button to reboot without turning off terminal power. 
• Cancel.  Click on this button to cancel any power-off action and return to Connections. 
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Creating a New Connection 
 

Note: The terms “connection” and “session” are used interchangeably in this section. 
 
Connections are created in the Configure tab of Connections Manager.  Click on Add to see the New 
Connection dialog box.  Then click on the drop-down arrow to see the drop-down list of possible 
connections. 
 

 
New Connection Dialog Box 

Each network client session can be to a unique server, if desired.  The total number of concurrent active 
sessions is limited by the amount of RAM in your WBT, except that you are limited to have no more 
than four configured emulation sessions.  The standard 128MB of RAM in your terminal is enough for 
almost all practical session combinations, unless you configure multiple browser sessions. 
 
The connection types will be covered here in alphabetical order.  Highlight the desired connection type 
and then click OK to open the associated dialog box. 
 
After your setup and configuration are complete, you can secure parameters from any user changes as 
follows: 
1. Open Terminal Properties. 
2. Select the Security tab. 
3. Check the box for Hide connections configuration Tab. 
4. Check the box for Require password to modify configuration. 
5. Choose and confirm a password. 
6. OK out of Terminal Properties. 

 31



2x14 User’s Guide—Creating a New Connection 

 

Citrix ICA Client 
 
This client is used to run applications from a Citrix MetaFrame server.  When you click on OK after 
selecting Citrix ICA Client, the ICA Connection Configuration sheet will appear with eight property 
tabs. 
 

Name 
 

 
ICA Name Property Sheet 

The name you enter here will be the name of the entry in the Connections Manager connection list and 
will appear in the title bar of the ICA session window. 
 

Server 
 
You can configure and run two types of ICA sessions: Citrix server connections and published 
applications.  
• Citrix server connections allow you to connect to the Windows desktop of a specific Citrix server; 

you can run any applications that have been mad available on the desktop by your system 
administrator, in any order. 

• Published applications are specific applications set up by an administrator for remote users.  When 
connected, you are presented with the application itself. 
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ICA Server Property Sheet 

The procedure for using this property sheet is: 
1. Select Server or Published Application. 
2. If your server or published application is on the local sub-net, click on Refresh. 
3. The terminal will search the local sub-net for all Citrix servers or published applications, and will 

present a list in the lower box.  You will see an error message if none are found. 
4. Double-click on the desired item in the list.  It will appear in the upper box. 
5. If your server or application is not found for some reason, you can type in the IP address or 

application name in the upper box, or you may want to choose an alternate server location. 
• If your terminal is not on the same network as the Citrix server you want to connect to (for 

example, if you are on the other side of a router, across the Internet, or using RAS to connect to 
a remote network containing Citrix servers), the Server and Published Application lists will not 
contain that server.  In this case, click Server Location and go to the Server Location dialog 
box to choose, add or delete a Server Location. 

 

Server Location 
The information entered in this dialog box is used to help locate available Citrix servers and published 
applications. 
 

 
Server Location Dialog Box 

Server location (also called server browsing) provides a method for a user at a network-connected 
Citrix ICA Client to view a list of all MetaFrame servers on the network that have ICA connections 
configured for that network protocol, or a list of all published applications.  You can specify a separate 
server location for each network protocol.  Tip: Set a specific server address for the Citrix server that 
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functions as the master ICA Browser when your network configuration uses routers or gateways, or to 
eliminate broadcasts on your network. 
 
To configure server location: 
1. Select the required network protocol from the drop-down list. 

• HTTP browser and HTTPS +SSL browser.  The default server address is ica.domainname, 
where domainname is a TCP/IP domain name. The ICA Client uses the HTTP protocol to 
contact the MetaFrame servers.  Note: If you are going to use SSL security for your ICA 
sessions, you must choose HTTPS +SSL browser protocol. 

• TCP Browser.  You must set a specific address for one (any one) of the MetaFrame servers in 
your server farm, and then the auto-locate function will find the rest of them. 

2. Enter the name or IP address of a MetaFrame server in the first entry field; ignore the second entry 
field.  Note: For the TCP/IP+HTTP and SSL+HTTPS protocols, if you do not enter an IP address, 
you must have a MetaFrame server on your network mapped to the default name of 
ica.domainname, where domainname is a TCP/IP domain name. TCP/IP+HTTP and SSL+HTTPS 
server locations do not support the auto-locate function. 

3. Click OK. 
 

Applications 
 
This sheet does not apply, and the two fields are grayed out, if you selected Published Application in 
the server sheet. 
 

 
ICA Applications Property Sheet 

If you want this session to open in a specific application on the server after the logon to the Citrix 
server is successful, enter the path and executable file name of an application in the Command Line 
field.  Leave this field blank to run a Windows desktop from the Citrix server.  Working Directory lets 
you associate a directory with the application specified in Command Line. 
 
For example, if the application Notepad.exe is in the C:\WTSRV directory on the Citrix server, type 
C:\WTSRV\Notepad.exe in the Command Line field.  If you use Notepad to work on documents in the 
C:\My Documents directory, type C:\My Documents in the Working Directory field.  When you log 
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on to the Citrix server, Notepad begins. In Notepad, if you click the File menu, the directory C:\My 
Documents is displayed. 
 

Authentication 
 
This page allows you to enter login details of your ICA connection so that you do not need to type them 
in each time you connect. 
 

 
ICA Authentication Property Sheet 

Type a valid user name, domain, and password. If you leave these fields blank, you are prompted for 
your user name, domain, and password whenever the ICA Client connects to the Citrix server. 
 

Window 
 
This page allows you to specify the size and color presentation of the session window. 
 

 
ICA Window Property Sheet 
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• Window Colors allows you to set the number of window colors to 16, 256, 32K, or 16M. Your 
display must be capable of displaying the resolution and color depth you select. 

• Color Mapping.  If you choose 256 colors, Color Mapping is enabled to allow you to set up 256 
color sessions to use approximate or exact colors.  Use Shared - Approximate Colors to eliminate 
color flashing when switching context.  Note that if other applications have allocated all 256 colors, 
the client will use a private color map. 

• Window Size allows you to select from Maximize, Fixed Size, Percentage of Screen Size, Full 
Screen, or Seamless Window. 

• Maximize.  This will display the ICA session in the available desktop screen without underlaying 
the Task Bar. 

• Fixed Size.  This will display the ICA session in a fixed number of pixels, as defined in the Select 
fixed size fields. 

• Percentage.  This will display the ICA session in a percentage of the available screen, as defined in 
the Select percentage of screen field 

• Full Screen.  This will display the ICA session in the available desktop screen, but it underlays the 
Task Bar.  This means that part of the session is hidden behind the terminal desktop Task Bar unless 
the Task Bar is configured to be automatically hidden in Terminal Properties>Desktop. 

• Seamless Window.  If you are connecting to a published application, you can also make this 
selection, which integrates local and remote windows on the desktop. 

. 

Options 
 
 This page configures a variety of miscellaneous options. 
 

 
ICA Options Property Sheet 

• Use compress data stream.  Check this box to reduce the amount of data transferred between the 
ICA Client and the Citrix server hosting the session.  (If your connection is bandwidth-limited, 
enabling compression may increase performance.  If your terminal is on a high-speed LAN, you 
may not need compression.). 

• Use disk cache….  Check this box to store commonly used bitmaps (images) locally on your client 
so that they do not have to be transferred over the ICA connection every time they are needed. 
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• Enable sound.  Check this box to enable sound support.  Remote applications will be able to play 
sounds on your client.  From the pull-down list, select a sound presentation quality level.  
Remember that network bandwidth requirements go up as sound quality goes up.  Note:  If you 
wish to use an external speaker with your terminal, it must have auxiliary power. 

• Connection encryption level.  Encryption increases the security of your ICA connection.  By 
default, basic encryption is enabled on all connections.  If the Citrix server you are connecting to 
supports advanced encryption (e.g., Secure ICA services), you can use it to improve security.  
Select the level of encryption you want to use.  Select RC5 128-bit Login Only to use encryption 
only during authentication.  The Citrix server must be configured to allow the selected encryption 
level or greater.  For example, if the Citrix server is configured to allow RC5 128-bit connections, 
the ICA client can connect with RC5 56 or 128-bit encryption.  Note:  To use advanced encryption, 
you need to install Secure ICA on your Citrix server.  The Citrix server must also be configured to 
allow the selected encryption level or greater. 

• SpeedScreen Latency Reduction improves responsiveness over high-latency connections by 
providing local feedback to the user in response to typed data or mouse clicks. 
• Local Text Echo accelerates display of the input text. 
• Mouse Click Feedback provides visual feedback of a mouse click, in that the mouse pointer is 

immediately changed to an hourglass indicator. 
Speed Screen will only work if the server-side Speed Screen feature is available and has been 
enabled on the Citrix server to which you are connecting.  From the drop-down lists, select the 
settings you need.  
• For slower connections (for example, if you are connecting over a WAN or a dial-in 

connection), set mode to On to decrease the delay between user input and screen display.  
• For faster connections (for example, if you are connecting over a LAN), set mode to Off.  
• If you are not certain of the connection speed, set the mode to Auto to turn Speed Screen 

latency reduction on or off automatically depending on the latency of the connection. 
 

Firewall 
 

This page is applicable only if the network has a proxy server to limit access to your Citrix servers. In 
this case, you must enter the proxy server information here to handle connections between clients and 
the server.   
 

 
ICA Firewall Property Sheet 
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To configure a proxy server: 
1. Check the Connect through Proxy box. 
2. In the Proxy type drop-down list, select SOCKS or HTTPS (secure). 
3. In the Proxy IP address boxes, enter the proxy server’s IP address in the first box and the server’s 

port number in the second box (typically 1080) in the second box. 
4. Click OK to save your changes. 
Note: If you configure a proxy server, you must specify at least one server in the Server Location 
dialog box for server and published application browsing to work. 
 

Devices 
 

 
ICA Devices Property Sheet 

Device mapping makes USB storage devices attached to the 2x14 terminal available to the user during 
ICA sessions on MetaFrame servers.  When a MetaFrame server is configured to allow client drive 
mapping, users can access their-locally stored files, work with them during their ICA sessions, and then 
save them again either on a local drive or on a drive on the MetaFrame server. 
 
You can control drive mapping at the MetaFrame server in the Client Settings dialog box in Citrix 
Connection Configuration.  Use the Connection settings to specify the device to automatically map at 
login.  You can also use the Devices property sheet to control the device mapping from the terminal 
during ICA Client sessions. Use this property sheet to specify which USB drive to automatically map at 
login.  The settings apply for all ICA connection sessions.  The procedure is: 
1. Check the box of the appropriate USB drive type.  Note: Only one USB drive can be mapped. 
2. Leave Device at the default; the drive letter has no significance since only one drive can be mapped. 
3. Select the desired Read and Write permissions.  The Prompt permission invokes a prompt dialog at 

the first access for each session. 
4. Click on OK. 
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Client VNC 
 
VNC (Virtual Network Computing) is, in essence, a remote display system which allows you to view a 
computing 'desktop' environment from anywhere on the Internet.  It is platform-independent. A desktop 
running on a Linux machine may be displayed on a PC, or on your YEStation.  VNC requires a server 
software module in the machine that is being viewed and a viewer software module in the viewing 
machine.  With the VNC client on your 2x14, you can view and control the desktop on any machine 
that is running the VNC server software.  Of course, you need a TCP/IP connection to allow this to 
happen. 
 
You can learn much more about VNC from the Web site 
http://www.uk.research.att.com/vnc/index.html. 
 
Note:  You can add multiple Client VNC sessions, but only one can be active at a time. 
 
When you select Client VNC, you will see the VNCviewer Connection Configuration sheet with two 
property tabs. 
 
1.  

 
VNCviewer Name Property Sheet 

The name you enter here will be the name of the entry in the Connections Manager connection list. 
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2.  

 
VNCviewer Server Property Sheet 

• Server Address.  Enter the network name or the IP address of the device that you wish to view. 
• Display.  Enter the display number on the device (display 0 always works for me.  NOTE: You 

must enter a display number; the viewer will not default to 0. 
• Password.  The VNC viewer on the target device can be configured to allow client viewing 

only if a specific password is entered.  If you want the viewing connection to be made 
automatically when you open it from the Connections Manager, enter the password here.  If you 
do not enter the password here, you will see a password dialog box when you open the session. 
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Internet Browser 
 
The 2214 and 2614 terminals incorporate the Netscape 4.78 browser; the 2814 incorporates the 
Netscape 7.x browser.  When you select Internet Browser, you will see the Browser Connection 
Configuration sheet with two property tabs. 
 
1.  

 
Browser Name Configuration Sheet 

The name you enter here will be the name of the entry in the Connections Manager connection list. 
 
2.  

 
Browser Options Configuration Sheet 

• Initial page.  Enter the url that will be browsed automatically when this browser connection is 
opened. 

• Identify as….  Some Web sites work better, or only, with the Microsoft Internet Explorer browser.  
The browser in this terminal is Netscape.  Check this box to fool those particular Web sites. 

  
Obviously, you do not get a chance to do much configuration here.  Many more properties are 
accessible in the Menu bar at Edit>Preferences in an open session. 
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Microsoft Remote Desktop Client 
 
This client is used to run Windows applications from a Microsoft Terminal Server.  When you click on 
OK after selecting Microsoft Remote Desktop Client, the RDP Connection Configuration sheet will 
appear with five property tabs. 
 

Name 
 

 
RDP Name Property Sheet 

The name you enter here will be the name of the entry in the Connections Manager connection list and 
will appear in the title bar of the RDP session window. 
 

Server 
 
This sheet lets you specify the Terminal Server to be used with this session. 
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RDP Server Property Sheet 

The procedure for using this property sheet is: 
1. Select Server.  Published Application is not supported for RDP connections. 
2. If your server is on the local sub-net, click on Refresh. 
3. The terminal will search the local sub-net for all Terminal Servers, and will present a server list in 

the lower box.  You will get an error message if none are found. 
4. Double-click on the desired item in the list.  It will appear in the upper box. 
5. If your server is not found for some reason, you can type in the IP address in the upper box. 
Ignore Info Server.  This is not supported in the 2x14. 
 

Applications 
 

 
RDP Applications Property Sheet 

If you want this session to open in a specific application on the server after the logon to the Terminal 
Server is successful, enter the path and executable file name of an application in the Command Line 
field.  Leave this field blank to run a Windows desktop from the Terminal Server. Working Dir: lets 
you associate a directory with the application specified in Command Line. 
 
For example, if the application Notepad.exe is in the C:\WTSRV directory on the Terminal Server, 
type C:\WTSRV\Notepad.exe in the Command Line field.  If you use Notepad to work on documents 
in the C:\My Documents directory, type C:\My Documents in the Working Dir: field.  When you log 
on to the Terminal Server, Notepad begins.  In Notepad, if you click the File menu, the directory C:\My 
Documents is displayed. 
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Authentication 
 
This page allows you to enter login details of your RDP connection so that you do not need to type 
them in each time you connect.   
 

 
RDP Authentication Property Sheet 

Type a valid user name, domain, and password.  If you leave these fields blank, you are prompted for 
your user name, domain, and password whenever the RDP Client connects to the Terminal Server. 
 

Window 
 

 
RDP Window Property Sheet 
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• Keyboard Layout.  Choose a country from the drop-down list.  This will define the input locale 
used by the Terminal Server for this session. 

• Window Size allows you to select from Maximize, Fixed Size, or Full Screen. 
• Maximized.  This will display the RDP session in the available desktop screen without overlaying 

the Task Bar. 
• Fixed Size.  This will display the RDP session in a fixed number of pixels, as defined in the Fixed 

size fields. 
• Full Screen.  This will display the RDP session in the available desktop screen, but it overlays the 

Task Bar. 
 

Telnet Connection (2214, 2814 models) 
 
Telnet connections provide a choice of ASCII-terminal emulations for connection to UNIX, Linux, and 
older midrange computers.  When you select Telnet Connection, you will see the Telnet Connection 
Configuration sheet with two property tabs. 
 

Name 
 

 
Telnet Name Property Sheet 

The name you enter here will be the name of the entry in the Connections Manager connection list and 
will appear in the title bar of the Telnet session window. 
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Options 
 

 
Telnet Options Property Sheet 

• Host name.  Enter the IP address of the host. 
• Port.  Leave at 23 unless directed otherwise by your network administrator. 
• Protocol. 

• Telnet.  Select this radio button for unsecured communication. 
• SSH.  Select this radio button for secured (Secure Shell) communication.  Your host must be 

SSH-compatible. 
• Username.  If you select SSH protocol, this field will become active.  Enter a user name. 

• Terminal type.  Select a terminal type from the drop-down list. 
• Custom.  If you selected Custom for terminal type, this field will become active.  The 2x14 

telnet emulator actually supports a large number of terminals—too many to be placed in the 
drop-down list.  If you want to emulate one of the following terminal types, select Custom and 
enter its name, exactly as shown in the list, here.  
 
aixterm ansi cygwin dumb gnome 
hp kvt linux qansi rxvt 
scoansi sun vt52 vt102 vt220 
vt320 vt400 vt420 vt510 vt520 
wyse30 wyse50 wyse350   

 
• Rxvt….  Enter an optional r UNIX command here. 
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TNXXXXe 
 
The YESterm IP TN3270e and TN5250e emulators provide users with a powerful capability to connect 
to an AS/400, iSeries, or IBM mainframe via the TCP/IP protocol.  They provide enhanced emulation 
functions for a wide range of IBM terminals and “true” IBM 3812 or 3287 Printer emulation with the 
support of all the enhanced features normally available only on very expensive printer interfaces.  Up to 
four concurrent TCP/IP connections can be configured with identical or unique hosts.  In addition, 
YESterm/IP TN5250E supports the “Enhanced Display Auto-Signon and Password Encryption” 
allowing a secure connection to the AS/400, with no need of any SSL option.  Basic session 
configuration is made simple by a Wizard application that guides the user during the configuration 
process. 
 
Significant characteristics of YESterm IP display sessions are: 
• IBM emulations supported: 3180-2, 3196, 3278/9, 3477-FG, 3477-FC, 5251, 5291. 
• Numerous resident national keyboard templates and Code Pages. 
• Enhanced keyboard mapping and customization, including macro assignment. 
• EURO (€) symbol supported. 
• Enhanced copy and paste options. 
• Programmable Keypad. 
• Attributes editing. 
• Enhanced customizable Hot Spot feature. 
• Enhanced macro Record/Playback feature. 
• Supports “Enhanced Display Auto-Signon and Password Encryption” allowing a secure connection 

to the AS/400. 
• Choice of Windows or “Green Screen” Text presentation modes. 
 
Significant characteristics of YESterm IP printer sessions are 
• IBM emulations supported: 3287, 3812. 
• Support for continuous forms, multi drawers, envelope, manual feeders, simplex/duplex, auto page 

orientation, and COR (Computer Output Reduction). 
• Supports CPI, LPI Override and LQ, NLQ. 
• Supports Host Transform Feature (TN5250e only). 
• Supports Hex Pass-Through (HPT) feature, with customizable leading and ending sequences and 

support of “non-printable characters”. 
• Supports EURO symbol (€). 
 
Connections are created in Connections Manager, but the Add path is somewhat different in TBT and 
non-TBT viewing modes.  Initially, there will be no sessions configured in the terminal, so you will 
have to add at least one in order to get any use out of the terminal. 
 

Desktop and WBT Viewing Modes 
 
In WBT and Desktop viewing modes, sessions are added from the Configure tab of Connections 
Manager.  Each session can be to a unique server, if desired.  Click on Add to see the New Connection 
dialog box.  Then click on the drop-down arrow to see the drop-down list of possible connections. 
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New Connection Dialog Box 

 

Display Sessions 
In the Add drop-down list, you are faced with a choice of TN3270e or TN5250e emulation types.  After 
choosing one, a wizard will guide you through setup.  The Setup Wizard will take you through three 
dialog boxes.  Activate Next to go to the next box, Back to return to the previous dialog box, and 
Cancel or the Esc key to abort the process. 
 
1.  

 
Display Setup Wizard Dialog Box #1 

• Host Name/IP Address.  If you are using a Hosts table (see Editing Terminal 
Properties|Network|Advanced Parameters|Hosts Table), you can type in the host network name.  
Otherwise, type in the IP address of the host. 

• Port Number.  Use the default of 23 unless directed to do otherwise by your system 
administrator. 
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2. 

 
Display Setup Wizard Dialog Box #2 

• Connection Name.  This is the friendly name that will appear in the Connection Manager 
screen and at the bottom of your session screens and in the Taskbar (in Desktop Mode). 

• Device Type.  Select one from the drop-down list.  The default 3477-FC works well for 
TN5250e emulation, unless you have special needs.  If you are adding a TN3270e session, you 
will see a choice of 3278/9 terminal types here. 

• Device Name.  If you are using named sessions, enter the session name here. 
 
3.  

 
Final Display Setup Wizard Dialog Box 

• Host Code Page.  Choose the applicable country from the drop-down list. 
• Keyboard Type.  Choose 101 Terminal if you are using the Affirmative Computer Products 

1010T, 1019T, 1023T, or 1027T 101-key keyboard; choose 122 keys if you are using the 
Affirmative Computer Products 1220T, 1223T, or 1227T 122-key keyboard; otherwise, choose 
101 PC. 
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This concludes the configuration parameters covered by the Wizard.  However, you can customize 
many more parameters in each display session by highlighting the connection name in the Configure 
tab of Connection Manager and activating Edit.  See Editing an Existing 
Connection|TNXXXXe|Display Sessions for more information. 
 

Printer Sessions 
You can have multiple local printers connecting to identical or unique hosts, but you must create a 
printer session for each one.  If you want to create a session for extended local Print Screens (see 
Editing an Existing Connection|TNXXXXe|Display Sessions|General|Print Screen), you can create it 
here, but you will have to edit it later (see Editing an Existing Connection|TNXXXXe|Printer Sessions) 
since the default is for standard host printing. 
 
After you choose a session type, a Setup Wizard will take you through three dialog boxes. 
 
1.  

 
Printer Setup Wizard Dialog Box #1 

• Host Name/IP Address.  If you are using a Hosts table (see Editing Terminal 
Properties|Network|Advanced Parameters|Hosts Table), you can type in the host network name.  
Otherwise, type in the IP address of the host.  If you are creating this session for extended local 
print screens, an IP address is irrelevant, but you must enter at least one character to satisfy the 
Wizard. 

• Port Number.  Use the default of 23 unless otherwise directed by your system administrator. 
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2.  

 
Printer Setup Wizard Dialog Box #2 

• Connection Name.  This is the friendly name that will appear in the Connections Manager 
screen and at the bottom of your session screens and on the Taskbar (in Desktop mode). 

• Device Type.  Only 3287 (3270) or 3812 (5250) is available for TCP/IP devices. 
• Device Name.  If you are using named sessions, enter the session name here. 

 
3.  

 
Printer SetupWizard Dialog Box #3 

• Host Code Page.  Choose the applicable country from the drop-down list. 
• Printer Driver.  If you are doing extended local Print Screens, or if you are not using the 

AS/400 Host Print Transform, choose a driver here that is compatible with the local-attached or 
LAN printer.  If you cannot find one in the list, try Empty Driver. 
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This concludes the configuration parameters covered by the wizard.  However, you can customize 
many more parameters in each printer session by highlighting the connection name in the Configure tab 
of Connection Manager and activating Edit (see Editing an Existing Connection|TNXXXXe|Printer 
Sessions).  If you are adding multiple printer sessions, you will have to edit the sessions in this manner 
in order to assign a unique port to each session; the default port for every session is LPT1. 
 

TBT Viewing Mode 
 

Select the Connections category in Terminal Properties to display the Connections Manager property 
sheet.  In this sheet, you can add and edit emulation sessions.   
 

 
Connections Manager Property Sheet for TBT Viewing Mode 

Activate Add Session to see the session menu. 
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Add Session Menu 

Select the desired menu type to begin the appropriate Add Wizard.  In each wizard, press F3 to advance 
to the next screen, or F12 to cancel the add. 
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Display Sessions 
Use TN5250e protocol to connect to AS/400 or iSeries hosts.  Use TN3270e protocol to connect to 
IBM mainframes.  You will be led through two configuration screens.   
 
1. 

 
Display Session Add Wizard Screen #1 

• Host Name/IP Address.  If you are using a Hosts table (see Editing Terminal 
Properties|Network|Advanced Parameters|Hosts Table), you can type in the host network name.  
Otherwise, type in the IP address of the host. 

• Port Number.  Use the default of 23 unless directed to do otherwise by your system 
administrator. 

• Encryption Level.  You have no choice here. 
• Connection Name.  This is the friendly name that will appear in the Connection Manager 

screen and at the bottom of your session screens and in the Taskbar (in Desktop Mode). 
• Unit Name (aka Device Name).  If you are using named devices, enter the device name here 
• Device Type.  The default 3477-FC works well for TN5250e emulation, unless you have 

special needs.  If you are adding a TN3270e session, you will see a choice of 3278/9 terminal 
types here. 
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2. 

 
Display Session Add Wizard Screen #2 

• Code Page.  Choose the applicable country from the list. 
• Language.  Choose a keyboard language. 
• Keyboard Type.  Choose Terminal if you are using the Affirmative Computer Products 

1010T, 1019T, 1023T, or 1027T 101-key keyboard; choose 122 keys if you are using the 
Affirmative Computer Products 1220T, 1223T, or 1227T 122-key keyboard; otherwise, choose 
PC. 

 
This concludes the configuration parameters covered by the wizard.  However, you can customize 
many more parameters in each display session by using a non-TBT viewing mode and editing from the 
Configure tab of Connection Manager.  See Editing an Existing Connection|TNXXXXe|Display 
Sessions for more information. 
 
 

Printer Sessions 
You can have multiple local printers connecting to identical or unique hosts, but you must create a 
printer session for each one. If you want to create a TN5250e session for extended local Print Screens 
(see Editing an Existing Connection|TNXXXXe|Display Sessions|General|Print Screen), you can create 
it here, but you will have to edit it in non-TBT mode (see Editing an Existing 
Connection|TNXXXXe|Printer Sessions|Connection (5250)) since the default is for standard host 
printing. 
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When you add a printer session, you will be led through three configuration screens. 
 
1. 

 
Printer Session Add Wizard Screen #1 

• Host Name/IP Address.  If you are using a Hosts table (see Editing Terminal 
Properties|Network|Advanced Parameters|Hosts Table), you can type in the host network name.  
Otherwise, type in the IP address of the host.  If you are creating this session for extended local 
print screens, an IP address is irrelevant, but you must enter at least one character to satisfy the 
wizard. 

• Port Number.  Use the default of 23 unless directed otherwise by your system administrator. 
• Encryption Level.  You have no choice here. 
• Connection Name.  This is the friendly name that will appear in the Connections Manager 

screen and at the bottom of your session screens and on the Taskbar (in Desktop mode). 
• Unit Name (aka Device Name).  If you are using named sessions, enter the session name here. 
• Device Type.  Only 3287 (3270) or 3812 (5250) is available for TCP/IP devices. 
• Queue Name/Queue Library/Default Port.  These are host parameters and should be given to 

you by your host administrator.  If this session is for extended local print screens, these 
parameters are ignored. 
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2. 

 
Printer Session Add Wizard Screen #2 

• Host Code Page.  Choose the applicable country from the list. 
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3. 

 
Printer Session Add Wizard Screen #3 

• Time Out.  This parameter defines a timer (in seconds) that starts to count down every time, 
during a printing job, that the host system stops sending data. If no more data are received 
within the timeout value selected, the printer session will assume that the print job is finished, 
and a Form Feed command is sent to the printer. 

• Host Print Transform (TN5250e only).  When Host Print Transform is enabled, the host does 
the EBCDIC-to-ASCII conversion of the print stream, and the local Passthrough Driver is not 
used. 

• Driver.  If you are doing extended local Print Screens, or if you are not using the AS/400 Host 
Print Transform, choose a driver here that is compatible with the local-attached or LAN printer.  
If you can’t find one in the list, try Empty Driver. 

• Printer port.  Choose LPT1, Network, or COM1/2 (2614 only). 
• Port printer configuration.  After you choose a printer port, you need to configure it. 
• LPT1.  Click on Port printer configuration to configure whether or not to reset the printer at 

the start of every print job. 
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• COM1/2.  If you chose one of the COM ports, you can click on Port printer configuration to 
see the COM Port configuration screen. 

 

 
COM Printer Configuration Screen 

• Bits/s.  Select a data rate in bits/second. 
• Flow Control.  Select the type of data flow control. 
• Parity/Stopbits.  These parameters are not configurable. 
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• Network.  If you chose a network printer, you can click on Port printer configuration to see 
the Network Printer configuration screen. 

 

 
Network Printer Configuration Screen 

• Printer type-LPR.  Choose LPR (Line Printer Remote) to assign print jobs to a network 
printer that is configured as an LPD server. 
• Host name/IP.  If you are using a Hosts table (see Editing Terminal 

Properties|Network|Advanced Parameters|Hosts Table), you can type in the host network 
name.  Otherwise, type in the IP address of the LPD host. 

• LPR queue name.  This will be the queue name assigned at the LPD host to be used by 
LPR devices to assign print jobs. 

• Port Number.  Leave at the default unless otherwise directed by your network 
administrator. 

• Count job length.  Leave at the No default unless otherwise directed by your system 
administrator. 

• Printer type-RAW.  RAW is the default protocol for most TCP/IP networks.  RAW data is 
not modified by the spooler at all, but is sent directly to the printer. 
• Host name/IP.  If you are using a Hosts table (see Editing Terminal 

Properties|Network|Advanced Parameters|Hosts Table), you can type in the host network 
name.  Otherwise, type in the IP address of the RAW host. 

• Port Number.  Leave at the 9100 default unless otherwise directed by your system 
administrator. 

 
This concludes the configuration parameters covered by the wizard.  However, you can customize 
many more parameters in each printer session by using a non-TBT viewing mode and editing from the 
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Configure tab of Connection Manager.  See Editing an Existing Configuration|TNxxxe|Printer Sessions 
for more information. 
 

X Window Session (X11) 
 
X Windows emulation provides a graphical look and feel in connections to UNIX or Linux hosts, in 
contrast to the older command-line interface seen in Telnet emulations.  When you select X Windows 
Session and click on OK, you will see the X Window Connection Configuration sheet with six property 
tabs. 
 

 
X Window Name Property Sheet 

If you need assistance in adding an X Windows session, contact Affirmative Computer Products 
Technical Support. 
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Editing Terminal Properties 
 

If you are in TBT viewing mode, you can edit many terminal properties using the property sheets in 
Terminal Properties.  However, you can see a more comprehensive set of terminal properties in the 
Terminal Properties window of the WBT or Desktop viewing modes, and that comprehensive set will 
be discussed in this section. 
 
Invoke the Terminal Properties window by pressing the F2 key in the Connections Manager window or 
by selecting it from the Start menu. If a password has been enabled (see Security) for this terminal, you 
will see the Password dialog box when you press F2.  Type in your password and activate OK. 
 
The Terminal Properties window consists of nine property sheets that can be invoked by activating their 
individual tabs.  At the bottom of each sheet are three buttons: 
• OK.  Activate OK to save changes and exit Terminal Properties after you have set desired 

properties in all the property sheets.  Some settings will take effect immediately after you OK out, 
while others may cause the screen to go blank for several seconds, and some will cause the terminal 
to reboot. 

• Cancel.  Activate Cancel to quit Terminal Properties without saving any changes.  You can also do 
this by clicking on X in the upper right corner. 

• Apply.  Activate Apply to immediately apply the settings on the current properties sheet without 
exiting Terminal Properties.  Note:  You must subsequently OK out of Terminal Properties to save 
any changes in these settings.  If you Cancel out, the changes will be lost after the next reboot. 

 
NOTE: We recommend that you change terminal properties only when all sessions are inactive.  Many 
of the changes will invoke a restart (the screen goes black for several seconds and any active sessions 
are disconnected) or reboot of the terminal. 
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General 
 
This property sheet is informational except for Restore…. 
 

 
General Property Sheet 

• Product ID.  This is a unique product identification code that also happens to be the terminal MAC 
address.  Every device on every LAN in the world is supposed to have a unique MAC address. 

• Kernel Version.  This is the version of the Linux kernel used on the terminal. 
• Software Version.  This is the version of the firmware installed in this terminal.  If you contact 

Affirmative Computer Products Tech Support about a problem, please have this version information 
available. 

• Total RAM.  This is the amount of DRAM in the terminal after subtracting the memory used for 
some basic functions and the memory reserved for video. 

• Used RAM.  This is the amount of total RAM that is currently being used. 
• Video RAM.  This is the amount of RAM that has been reserved for video display.  This amount is 

set in the terminal BIOS and is not a configurable parameter. 
• CPU Info.  This shows some basic information about the CPU in the terminal. 
• Restore the terminal parameters to factory default.  Activate this check box to reset the terminal 

to its factory default settings. When you do this, you will get a dialog box asking you to confirm 
your intentions. 
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Network 
 
The Network property sheet lets you control the terminal IP address, name server addresses, and 
network speed, as well as providing the useful ping function. 
 

 
Network Property Sheet 

• Obtain an IP address from a DHCP Server.  Select this radio button to enable DHCP addressing. 
• Insert static IP address. Select this radio button to enable the following three fields for a specific 

IP address setting.  
• IP Address.  Enter a static IP address in this field.  If you have selected DHCP addressing, the 

assigned address will appear in grey in this field.   
• Subnet Mask.  Enter the subnet mask of the local network.  If you have selected DHCP 

addressing, the assigned subnet mask will appear in grey in this field 
• Gateway.  Enter the IP address of a gateway if any server is not on the local sub-net. 

• Terminal Name.  We recommend that you enter a unique name here for easy identification when 
using network management and administration software. 

 

Ping Function 
 
Activate this button to display the Ping dialog box.  You can ping the name or IP address of a host or 
any other device connected on the network. You can even ping a web site through a gateway. 
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Ping Dialog Box 

• Address.  Enter the network name or the IP address of the device to be pinged. 
• Ping.  Activate this button to begin the ping action.  Results will be displayed in the scroll box. 
• Stop.  After you start pinging, the ping action will continue until you press Stop. 
• Clear.  Activate this button to clear the scroll box. 
• Quit.  Activate this button to exit the Ping dialog box. 
 

Advanced Parameters 
 
Activate this button to configure name server settings or proceed to other advanced parameters.  You 
will see the Advanced Network Parameters dialog box.  If you have a 2214 with an attached Actiontec 
USB wireless adapter, you will also set the wireless parameters here. 

 

 
Advanced Network Parameters Dialog Box 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

 

 
Advanced Network Parameters Dialog Box with USB 

Wireless 

• Enable DNS.  You will only see this box if you if you have selected the radio button for Insert 
static IP address.  Activate this check box to enable the three fields for the DNS setting.  Get the 
entries from your network administrator.  If you have selected DHCP addressing and are not using a 
USB wireless LAN adapter, the assigned DNS information will appear in grey in these fields.   
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• Advanced parameters.  These entries will be active only if you have selected the radio button for 
Insert static IP address.  For typical networks, nothing need be entered here.  But some networks 
will require that you enter the first three octets of the network IP address in Network and the IP 
address of the network gateway in Broadcast.  Let your network administrator determine the need. 

• Ethernet Mode. 
• Mode.  Select network speed and traffic mode from the drop-down list, or let the network 

circuitry perform auto-negotiation with the hub or switch. 
• MTU.  Leave this number alone unless your network administrator dictates a change. 

 

Hosts Table 
A Hosts table allows you to create your own mini-DNS server, for use by your terminal only.  You can 
make one or more entries in the table—each entry correlating an IP address with a friendly name for 
that address.  These friendly names can be your sole creations; they do not have to be identical to the 
network names for that address.  After you make these entries, you can then use the friendly names in 
place of IP addresses in any configuration dialog box or utility on your terminal that requires an IP 
address. 
 
Activate the Hosts Table button to see the Hosts Table dialog box. 
 

 
Hosts Table Dialog Box 

In this example, the friendly name “dellawin” is equated to the IP address 100.100.100.10.  Make all 
your entries in this format, one per line. 
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DHCP Log File 
Activate this button to see the DHCP Log File.box. 
 

 
DHCP Log File Box 

This file logs the steps encountered by the terminal in obtaining a DHCP address. 
 

DHCP Leases 
Activate this button to see the DHCP Lease File box. 
 

 
DHCP Lease File Box 

This file shows the current state of the DHCP address lease, as well as showing a list of the options 
configured at the DHCP server. 
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Wireless Parameters (2214, 2814 models) 
 
If you have a 2214 with an attached Actiontec USB wireless adapter, you will see a button labeled 
Wireless Parameters instead of Ethernet Mode.  Click on this button to see the Wireless Network 
Parameters dialog box.  Note: Only the Actiontec wireless adapter can be used with the 2214. 
 

 
Wireless Network Parameters Dialog Box 

• Network Name (SSID).  All points in an 802.11b wireless network share a unique name called a 
Service Set ID (SSID).  This name is specified in each access point, and is configured in the 2214 in 
one of two ways. 
• Default.  An access point can be configured to broadcast its SSID.  Under the default setting, 

the Actiontec adapter will detect a broadcast SSID within its range.  Note: You must have 
“default” entered into this field.  A blank field will not work. 

• Non-Broadcast.  For security purposes, an access point may be configured to disable SSID 
broadcasts.  In this case, the SSID must be manually entered into this field.  Note that SSIDs are 
case-sensitive. 

• Mode.  Choose one of the following two modes.  Ignore the others in the drop-down list. 
• Managed.  This mode is also known as the “infrastructure” mode in the wireless world.  Use 

this mode when your wireless network is connected to a wired Ethernet network through an 
access point.  This is the most common situation. 

• Ad-hoc.  It is possible for a small network of wireless devices to communicate with each other 
without using an access point.  This is called the ad-hoc mode. 

• Channel.  The Actiontec adapter will scan across all channels, starting with the channel entered in 
this box, until it finds an access point or ad-hoc connection.  The default channel, 6, is also the 
default channel for most access points. 
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• Speed.  You have three choices. 
• Auto.  The adapter uses the 11Mbps data rate when possible but drops to lower rates when 

necessary. 
• 11M. The adapter uses the 11Mbps data rate only.  This offers the greatest throughput, but the 

shortest range. 
• 5.5M. The adapter uses the 5.5Mbps data rate only.  This offers the longest range, but the lowest 

throughput. 
• Wep.  WEP (Wired Equivalency Protocol) is a data privacy mechanism based on 64-bit or 128-bit 

encryption.  To use WEP encryption, all points in the wireless network must enable WEP and have 
the same 40-bit or 104-bit key setting.  WEP is disabled unless Enable Crypting is checked. 
• Open.  If your network is using Extensible Authentication Protocol (EAP), an authentication 

server assigns WEP keys dynamically for each session.  Choose Open if you are using EAP. 
• Restricted.  Choose Restricted if your network is not using EAP.  You will have to enter a 

WEP key as described below. 
• Enable Crypting.  Check this box to enable the WEP encryption. 

• Key.  If your network is not using EAP, enter a WEP key of ten hexadecimal digits (0-9, A-F).  
This key must match the key set in the access point. 

• Key Format.  Leave at the default Hexadecimal digits.  ASCII characters are not supported in 
the 2214. 

• Regulatory Domain/Frag/Rts.  These parameters are not supported in the 2214. 
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Input 
 
This property sheet allows you to configure your keyboard and mouse parameters. 
 

 
Input Property Sheet 

• Keyboard 
• Layout.  Use the scroll list to select a language for the keyboard. 
• Enable Numlock at startup. Check to force Numeric Pad NumLock when the 2x14 boots up. 

• Mouse. 
• Type.  Choose from PS/2, Serial (2614 only), or Wheel Mouse. 
• 3 button mouse emulation.  Check this box to emulate the third button of a 3-button mouse by 

left and right clicking simultaneously. 
• Acceleration.  Use the slider control to set the speed of the cursor movement on screen vs. the 

movement of the mouse. 
• Threshold.  Use the slider control to set the double-click sensitivity. 
• Test.  If you make any changes to the mouse parameters, the Test button will appear.  When 

you click on it, you will see a test screen that allows you to test your acceleration setting.  Note: 
You will not be allowed to exit the Input property sheet, except via Cancel, until you test. 

• Mouse Miscellanea.  PS/2 and USB wheel mice work well in ICA and RDP sessions.  The 
extra wheel/button does not work in native applications (emulators, viewers, browsers). 
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Display 
 
Use the Display property sheet to configure the terminal's display screen properties. 
 

 
Display Property Sheet 

• Video Resolution.  Use the drop-down list to select the terminal display resolution, and the radio 
buttons to select the color depth. The terminal will support resolutions from 600x480x8x60 up 
to1280x1024x16x75 if the monitor will support them. Eight-bit color is typically sufficient for 
emulator sessions 
• Test Video Settings.  Use this button to preview your video changes.  If you make any change 

in the video settings, you will not be allowed to advance from this sheet until you have tested 
the new settings. 

• Screen Saver.  By default this function is not activated. 
• Type.  If you want a screen saver, choose, from the drop-down list, a blank screen, X logo, or 

the Linux penguin. 
• Timeout. Adjust the amount of idle time before your Screen Saver is activated. 
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• Advanced Parameters.  Click on this button to see the following dialog box. 
 

 
Advanced Display Parameters Dialog Box 

• Enable Power Saving.  If you check this box to enable power saving, you will activate the 
following three settings: 
• Standby.  Enter the number of minutes (1-999) for the Standby timeout.  Standby acts much 

like a blank screen saver. 
• Suspend.  Enter the number of minutes (1-999) for the Suspend timeout..  Suspend turns off 

most terminal functions, such as the video sync signal.   
• Power off.  Power Off is not supported at this time. 
• Note: The timeout numbers are not cumulative; if the Suspend timeout is shorter than the 

Standby timeout, the terminal will go into Suspend without ever going into Standby. 
• Enable Font Server.  2x14 terminals have a limited number of fonts stored in flash memory.  

Therefore, you may occasionally be disappointed at the appearance of some Web pages in the 
browser.  However, this limitation can be overcome if you have a font server on your network.  
With an enabled font server, the browser will automatically ask it for any font that is not stored 
locally.  Enter the IP address and port number of your font server here. 
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Desktop 
 

This tab provides a number of desktop appearance and session-jump Hot Key options. 
 

 
Desktop Property Sheet 

• Terminal Modality.  These are the three viewing modes discussed in Viewing Modes.  Change to a 
different mode here if you wish. 

• Desktop mode-Taskbar.  If you choose Desktop mode, you are presented with a number of 
Taskbar appearance options. 
• Position.  You may choose to either place the Taskbar at the top or bottom edge of the Desktop 

screen. 
• Automatically hide.  Check this box to hide the Taskbar.  With this setting, the Taskbar will 

appear only when you move the cursor to the Desktop edge where the Taskbar is hidden. 
• Show CPU load.  Check this box to display a small moving line graph representing the load on 

the terminal CPU. 
• Show clock.  Check this box to display the system clock.  You can set the clock from the Misc. 

tab. 
• Show virtual desktops.  Virtual desktops are not supported in the 2x14. 
• Show network load.  Check this box to display a small moving bar graph representing the load 

on the terminal network. 
• Theme.  Select a Windows XP or a Windows 2000 appearance in the Taskbar and the Start 

menu. 
• Desktop color.  Click on the color bar to display a color palette from which to choose the 

background screen color.  This choice will be applied in both WBT and Desktop viewing modes. 
• HotKeys.  This drop-down list provides a number of options for task switching in WBT and 

Desktop viewing modes. 
• WBT.  This is the default task-switching option, and is the only one available for the TBT 

viewing mode.  See Viewing Modes|TBT|Navigation for an explanation of WBT Hot Keys. 
• Alt-Tab.  Switch among tasks by pressing Alt+Tab. 
• Ctrl-Tab.  Switch among tasks by pressing Ctrl+Tab. 
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• Alt-Tab List.  This is very similar to Alt-Tab task switching in Windows.  Press Alt+Tab to see 
an iconed list of tasks.  Each depression of the Alt key will highlight the next icon, and lifting 
the Tab key will select the highlighted task. 

Enable Right Alt….  Check this box to allow the hot key combinations RightAlt+Up/DownArrow for 
task switching in all viewing modes. 

Remote Window Manager.  If you have a UNIX or Linux Remote Window Manager (RWM), and 
you only want to run X Window sessions, you can check this box.  This setting may seem to duplicate 
the Remote Window Manager setting in Creating a New Connection|X Window Session.  But there is 
an important difference.  If you enable Remote Window Manager here, you will see only the desktop 
provided by the specified RWM.  So you will not be able to run any of the sessions that you may have 
created in the Connections Manager session list; in fact, you won’t even see Connections Manager or 
the Start menu.  If you want to run sessions from Connections Manager, add your X Windows sessions 
there and enable RWM there if you wish.  This will put each session in its own window in the normal 
Desktop environment.  Note: Do not make this selection unless you really mean it.  After enabling 
it, you cannot switch back to Terminal Modality without resetting the terminal to factory 
defaults.  Ignore any instructions about disabling Remote Windows Manager during bootup. 

• Protocol.  If you enable RWM, you have to choose a protocol for finding one. 
• Broadcast.  The 2x14 will do a broadcast over the local sub-net, looking for any RWM that will 

respond. 
• Query.  You must enter the IP address of a specific RWM in the address box. 
• Indirect.  Enter the IP address of a meta-RWM in the address box.  This meta-RWM will 

provide you with a list of available RWMs. 
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Firmware 
 

Use the Firmware properties sheet if you wish to update your terminal's firmware over the network.  
For more information, please refer to the Firmware Upgrades section. 
 

 
Firmware Property Sheet 
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Security 
 
A 2x14 provides four levels of security. 
 

 
Security Property Sheet 

• Hide connections configuration tab.  Check this box to hide the Connections tab in Connections 
Manager.  This prohibits a user from adding, deleting, or editing sessions.  Note: In Desktop 
viewing mode, this renders the Connections Manager useless. 

• Shadowing.  When used in conjunction with YESmanager, Affirmative Computer Products’ 
powerful Remote Central Manager, the terminal’s screens can be viewed remotely, and full remote 
control of the terminal can be enabled. 
• Allow Shadowing View Only.  Check this box to allow the terminal screens to be viewed at the 

remote YESmanager console. 
• Allow Shadowing Full Control.  Check this box to allow full control of terminal functions 

from the remote YESmanager console.  Actually, when shadowing is activated in YESmanager, 
control will be shared between the remote administrator and the local user.  Note:  Enabling 
Full Control will have no effect unless you also enable View Only. 

• Require Password….  Check this box to enable password security for terminal configuration.  
Then enter and confirm a password in the boxes. 
Note: The password is designed to avoid any unreasonable change to the Terminal Properties 
Settings.  Please do NOT activate the password unless you are the administrator.  If you forget the 
password, it will be difficult to recover.  There is only one local method of recovery if you forget 
the password. 
• Ask your system administrator to use the secret hot key sequence to reset Terminal Properties to 

factory defaults. 
• User Authentication.  Check this box to enable password security for user access to sessions. 

• Local Authentication.  This radio button is always enabled.  If you checked User 
Authentication, enter and confirm a password in the boxes.  You can also allow or forbid the 
user to change the user password. 
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• Remote Authentication….  This is not supported in the 2x14 terminals. 
Note: Even if a user password is required, the user can still access Terminal Properties without 
entering the correct password.  Therefore, it is strongly recommended that you also enable Require 
Password… if you are going to use user authentication. 

 78



2x14 User’s Guide—Editing Terminal Properties 

 

Printers 
 

 
Printers Property Sheet 

In addition to using local printers for TNXXXXe printer emulation sessions, 2x14 terminals can be 
configured as network print servers for use from Windows sessions or from other stations on the 
network.  Either local printers or network printers can serve as the printing devices.  Three modes of 
network printing are possible. 
 

LPD 
 
The Berkeley versions of the UNIX™ operating system provide printer spooling with a collection of 
programs: lpr (assign to queue), lpq (display the queue), lprm (remove from queue), and lpc (control the 
queue). These programs interact with an autonomous process on network print servers called the line 
printer daemon (LPD). 
 
Each 2x14 terminal includes an LPD module that allows an LPR device on the network to assign print 
jobs to a local printer or network printer attached to the terminal.  Check the Share local…using 
LPD/LPR box to enable LPD printing. 
. 
• Printer Port.  Select one, two, or three ports from LPT1, COM1/2 (2614, 2814 only), Net, and 

USB. 
• Queue name.  Define a queue name for each printer port.  This will be the queue name used by 

LPR devices to assign print jobs to that port. 
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• Configure. 
• COM1/2.  If you chose a COM port, you can change the default port settings to match your 

serial printer.  Click on the appropriate Configure button to see the Serial Devices 
Configuration dialog box. 

 

 
Serial Devices Configuration Dialog Box for LPD Printing 

Select the desired settings from the drop-down lists. 
• Net.  If you chose Net, you will have to configure the network printer. Click on the Configure 

button to see the Network Printer Configuration dialog box. 
 

 
Network Printer Configuration Dialog Box 

• IP address.  Enter the IP address of the network printer. 
• Queue name.  Enter the queue name used to assign print jobs to the network printer.  It is 

not the same name as the Net Queue name assigned in the Printers properties sheet. 
 

RAW 
 
RAW is the default protocol for network printing from a Windows client.  Check the Share 
local…using RAW protocol box to enable RAW printing.   
• Printer Port.  Select one, two, or three ports from LPT1 and COM1/2 (2614, 2814 only). 
• Port.  There should be no reason to change the default port numbers. 
• Configure. If you chose a COM port, you can change the default port settings to match your serial 

printer.  Click on the appropriate Configure button to see the Serial Devices Configuration dialog 
box. 
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Serial Devices Configuration Dialog Box for RAW Printing 

Select the desired settings from the drop-down lists. 
 

ThinPrint 
 
ThinPrint enables direct printing from the terminal and other network devices to local printers. With the 
ThinPrint Client and a ThinPrint server (usually, but not necessarily, a Citrix MetaFrame server), a print 
job can be delivered over the network to the terminal and from there direct to the selected printer.   To 
learn more about ThinPrint advantages, go to http://www.thinprint.com/ on the Web. 
 
To configure ThinPrint: 
1. Check Enable Thinprint Client. 
2. Check the box for your local printer port.  Note that only one port can be selected. 
3. Enter a name for this ThinPrint printer.  The name will identify this printer at the ThinPrint server.  

Unix conventions generally apply when entering printer names. If a name contains a blank space, 
for instance, it is captioned in quotation marks “”. For example, the name for HP LaserJet 5L is 
”HP LaserJet 5L”.  If the printer name contains quotation marks, a backslash is entered at the 
beginning.  For example, the name for HP “super” LaserJet 5L is ”HP \”super\” LaserJet 5L”. 

4. Optionally, you can click on Configure.  The Thinprint Client Configuration dialog box will 
appear.  ThinPrint will work without filling in any of these fields, but you may want to fine-tune the 
client. 

 

 
Thinprint Client Configuration Dialog Box 

• Class.  Printer classes can be defined at the ThinPrint server.  If you want this printer to be in 
such a class, enter the class name here. 

• Bandwidth.  You can enter a bandwidth value which is the same or smaller than that set at the 
ThinPrint server.  If client control is disabled at the server, server settings are applied.  No input 
or 0 (zero) means that the server setting will be applied. 

• Packet Size.  You can enter the size of packets for streaming.  No input or 0 (zero) means that 
the server setting will be applied.  Typically this does not need to be defined in the client. 
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Miscellaneous 
 

 
Miscellaneous Property Sheet 

• Network File System.  This is a parameter for mounting network drives as local drives. 
• None.  Do not mount network drives locally. 
• SMB.  Mount Windows drives.  Enter the appropriate settings in the entry boxes. 
• NFS.  Mount UNIX/Linux drives.  Enter the appropriate settings in the entry boxes. 

• Date and Time.  You can enter the date and time here. 
• Time Zone.  You can choose your time zone here from the drop-down list, but it will be of no use 

unless you also enable a timeserver. 
• Enable Time Server.  Check this box to allow the terminal to sync the local current time, shown in 

the Date/Time dialog box, with any timeserver using the Network Time Protocol (NTP).  If you 
don’t have a local timeserver, there are several available on the Web. If you check the box, and then 
enter a valid timeserver (time.nist.gov works well for us) in the Time Server box, the local clock 
will connect to the timeserver and sync the local clock every time the terminal is booted up.   
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Editing an Existing Connection 
 

For all connections except Internet Browser and TNXXXXe, properties must be edited from the 
Configure tab of Connections Manager.  Highlight the session of interest and click on Edit.  For 
TNXXXXe connections, there is a choice of viewing modes, as discussed in TNXXXXe later in this 
section. 
 

Citrix ICA Client 
 
When you click on Edit, you will see the same ICA Connection Configuration sheet that you saw when 
creating the session.  See Creating a New Connection|Citrix ICA Client for property details. 
 
 

Client VNC 
 
When you click on Edit, you will see the same VNCviewer Connection Configuration sheet that you 
saw when creating the session.  See Creating a New Connection|Client VNC for property details. 
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Internet Browser 
 
When you click on Edit, you will see the same Browser Connection Configuration sheet that you saw 
when creating the session.  See Creating a New Connection|Internet Browser for property details.  
However, many more properties can be configured from within an open browser session.  Go to 
File>Edit>Preferences in the Menu bar to open the Netscape Preferences dialog box and fine-tune 
your browser session. 
 

 
Netscape Preferences Dialog Box 

The Category list can be opened to show sub-categories by clicking on the category arrow, as 
shown below. 

 

 
Netscape Preferences Dialog Box Showing Sub-Categories 
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Microsoft Remote Desktop Client 
 
When you click on Edit, you will see the same RDP Connection Configuration sheet that you saw 
when creating the session.  See Creating a New Connection|Microsoft Remote Desktop Client for 
property details. 
 
 

Telnet Connection 
 
When you click on Edit, you will see the same Telnet Connection Configuration sheet that you saw 
when creating the session.  See Creating a New Connection|Telnet Connection for property details. 

 85



2x14 User’s Guide—Editing an Existing Connection 

 

TNXXXXe 
 
Editing an existing emulation connection is quite different in TBT and non-TBT viewing modes.  Many 
more configuration parameters are accessible in a non-TBT mode, and you may have to edit from one 
of those modes in order to get the emulation settings you need.  Settings made in non-TBT mode 
remain in effect if you return to the TBT viewing mode. 
 
Editing in TBT mode is done from the same parameter screens used when adding a connection.  
Highlight the connection name in Connections Manager and press F6 to open the parameter screens for 
that connection.  Refer to Creating a New Connection|TNXXXXe|TBT Viewing Mode for parameter 
details.  
 
The remainder of this section will discuss editing in the Desktop and WBT viewing modes.  Connection 
properties are edited in the Configure tab of Connections Manager.  Highlight the session of interest 
and click on Edit. 
 

Display Sessions 
 
The screen shots you see in this section are TN5250e editing screens.  There are very few differences 
between the 5250 and 3270 screens, and any significant differences for TN3270e sessions will be 
discussed in the text. 
 
For TN5250e sessions, you will see a Displays Sessions Properties sheet with seven property tabs.  For 
TN3270e sessions, you will see a Displays Sessions Properties sheet with six property tabs.  The 
opening view is of the Connections tab and property sheet. 
 

Connection 

 
Connection Property Sheet for TN5250e 

The properties on this property sheet were already configured in the Setup Wizard when this session 
was created, although you can change them here if you wish 
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General 

 
General Property Sheet for TN5250e 

Code Page 
YESterm/IP supports numerous language Code Pages. The Code Page selected here from the drop-
down list should be the same one configured on the host for this specific device.  It is also possible to 
create a new custom Code Page Table.  See How To…|Create a Custom Language Code Page for 
instructions. 
 

Keyboard Language 
YESterm/IP supports several non-English keyboard languages.  If you wish to use one of them, select it 
from the drop-down list. 
 
Keyboard Type 
YESterm/IP supports three different keyboard types (101 PC, 101 Terminal, and 122 Key) for several 
different languages.  It is also possible to create a custom keyboard map, if desired.  Activate Edit to 
get to the keyboard map page. 
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Keyboard Map Page for 5250 122-Key U.S. English Keyboard 

You can check the current mapping in one of two ways: 
• Scan Codes.  The keyboard sends a unique scan code to the terminal when a key is pressed.  If you 

want to see what key is associated with a specific scan code, type that code in the Edit box, shown 
highlighted in the above figure.  The associated key will highlight, and any command mapped to 
that key will show in the Action boxes.  Of course, most people couldn’t care less about scan codes, 
so this method may be of little use to you. 

• Mouse Clicks.  Position the cursor over the key of interest and click.  The scan code for that key 
will show in the Edit box, and any mapped command will show in the Action boxes.  If you want to 
see the effect of that key plus a modifier key (Shift, Alt, Ctrl), click on the modifier key and then 
on the action key. 

 
Edit 
Activate this button to initiate custom keyboard mapping.  See How To…|Create a Custom Keyboard 
Map for the mapping procedure. 
 
Default 
This button will erase any custom mapping that exists in this map.  Everything goes back to defaults.  
Obviously, you want to be very careful around this key if you have done much custom mapping. 
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Options 

 
Keyboard Options Dialog Box 

This button opens a special dialog box where you can specify the Host Keyboard Language Option, and 
enable the Multinational character set. 
 

Font 
Select one of two Font styles to be used as the default Font for the display session. 
 

Print Screen 
From the drop-down list, select how the Print Screen function is to be performed: 
• Local Direct Print.  Make this selection if you wish to print to a local printer attached to the LPT1 

port. 
• Through the Host.  Make this selection if you wish to print to a remote printer through the host. 
• Extended Local Print.  This selection provides local printing on steroids.  To use it, you must 

create a printer emulation session.  This session can be used with either a local or a network printer, 
and it allows you to format your print output.  See Printer Sessions for more information.  If you 
select this option, you must choose a printer session from the lower drop-down list. 

• Function Disabled.  Screens cannot be printed. 
 
The Print Screen function can be activated from: 
• Emulator Button bar. 
• Emulator Menu bar (File|Print) 
• Keyboard in accordance with the keyboard map. 
Key Pad, if it contains a corresponding button. 
 

Cursor 
Select the type of cursor you want to use. 
 

Miscellaneous 
• Euro Support. When this option is enabled, you will enter the Euro symbol when you press Alt+E. 
• Keyboard Buffer.  This option enables Typeahead. 
• Keyboard Clicker. If this option is enabled, you can hear an enhanced click every time you press a 

key on the keyboard. 
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• Error Message Beep.  If this option is enabled, you can hear a "Beep" when an input error is made. 
• System Message Beep.  If this option is enabled, you can hear a "Beep" when a message is received 

from the Host. 
Lock NumLock.  This option has no effect since NumLock is always enabled in an emulator session. 
 

Attributes 
This properties sheet allows extensive editing of your screen appearance.  At the lower right corner of 
this sheet are two radio buttons allowing you to make these edits global for all sessions, or to restrict 
their use to only this session. 
 

 
Attributes Property Sheet for TN5250e 

 

Default View 
You have a choice of Standard or Advanced views.  Both options support mouse click interfaces.  A 
single left-click moves the screen cursor to the location of the mouse cursor, and a double left-click 
sends the Enter command to the host.  See the Hot Spot section for screen shots of both views.  Either 
view can be overridden from the emulation screen Toolbars if desired. 
• Standard.  This selection provides the standard green screen “text” appearance for your session 

screens, duplicating terminal screens.  Hot Spots are invisible unless the mouse cursor is placed 
over one of them, and then only that one Hot Spot is visible.  If you are in TBT mode, the Standard 
view is most familiar to you.  But you can operate in the Advanced view if you wish, although the 
efficiency of the Advanced view is lost without use of a mouse.  

• Advanced (Recommended for WBT and Desktop modes).  This selection provides a “graphics” 
appearance for your session screens, resembling a Windows application.  All the Hot Spots are 
shown as raised buttons.  Input fields are shown as recessed panels with background colors of 
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white, peach, or gray.  All colors are automatically re-mapped to present maximum contrast, and 
readability.  Advanced View is the most productive way to operate in non-TBT viewing modes 
since all menu items, Function Keys, sub-file options, and custom hot spots are always visible and 
accessible as raised buttons which can be activated by a mouse left-click. 

 
 

Attribute Settings (Standard View Only) 
Set the appearance of your green screens by modifying field color attribute settings and other visual 
effects.  This includes properties such as foreground and background color, blinking, underscore, and 
the use of column separators.  You will see a preview of the “new look” in the Sample field.  Be careful 
with the colors you choose; a wrong choice can cause text or fields to be invisible on the screen because 
of lack of color contrast. 
• Edit (Column Separator).  Activate this button to invoke this dialog box. 
 

 
Edit Column Separator Dialog Box 

Make your choices and view them in the Sample field. 
 

Hot Spot 
Changes made in this property sheet affect all sessions.  There is only one Hot Spot configuration per 
emulator, not one per session.  Hot Spots are of little value if you are using the TBT viewing mode. 
 

 
Hot Spot Property Sheet 
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A Hot Spot is an area of the session window on which you can single-click the left mouse button to 
execute a command or function. Actually, a Hot Spot is the result of a text search by the emulator for 
the specified Keyword on the screen.  The Function Key and Numeric fields (from 1 to 99 followed by 
a "period" or "space") Hot Spots are active by default, but you can add other Hot Spot keys and/or 
edit/remove them. 
 
A Hot Spot can be used to: 
• Simulate a menu selection. 
• Simulate a function key. 
• Simulate a sub-file option (double-click). 
• Execute a Recorded Sequence that has the same name as the word that you select on the screen. 
• Execute a command that you select. 
 
To enable the use of Hot Spots, you must check the Enable Hot Spots box. 
 
Standard View 
If Standard View is selected in the Advanced tab or the emulation screen Toolbars, Hot Spots are 
invisible unless a mouse cursor is dragged over them, and then only the one under the mouse cursor 
becomes visible. 
 

 
Emulation Screen with Standard View and Hot Spots 

Advanced View 
Hot Spots are displayed as raised buttons if the Advanced View option is selected in the Attributes tab 
or the emulation screen Toolbars.  Advanced View is the most productive way to operate in non-TBT 
viewing mode since all menu items, Function Keys, sub-file options, and custom hot spots are always 
visible and accessible as raised buttons. 
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Emulation Screen with Advanced View and Hot Spots 

To Edit a Hot Spot: 
1. Select the Function Key you want to modify. 
2. Click on Edit. 
3. If you want to send a Text String to the host every time you press the Function key, type it into the 

Text String field. 
4. Select the Action from the Drop-Down List 
5. From the drop-down list, select the command or the Recorded Sequence that you want to associate 

to the Hot Spot key. 
6. In c.80, specify where, in an 80-column screen, the text search engine should start looking for the 

specified Keyword.  For example, the default start for the word “More” is column 68.  So if there is 
a word “More” to the left of that column, it will not be defined as a Keyword or Hot Spot. 

7. In c.132, specify where, in a 132-column screen, the text search engine should start looking for the 
specified Keyword. 

8. Click on Accept. 
9. Click on Apply. 
 
To Remove a pre-defined Hot Spot: 
1. Select the Function Key. 
2. Click on Remove. 
 
To Add a Hot Spot: 
1. Click on Add. 
2. Type the Hot Spot Key Word you want to detect. If you want to send a Text String to the host, type 

it into the Text String field. 
3. Select the Action from the Drop-Down List 
4. From the drop-down list, select the command or the Recorded Sequence that you want to associate 

to the Hot Spot. 
5. Specify the text search start columns in c.80 and c.132. 
6. Click on Accept. 
7. Click on Apply. 
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Key Pad 
A Key Pad is a small window with several customizable push buttons, each having an assigned 
function.  You can make it visible on the screen by clicking on the Key Pad button on the Buttons 
toolbar, or selecting View/Key Pad from the Menu bar.  You can choose a function from the Key Pad 
with your mouse instead of typing the equivalent command, pressing a key, or running a Recorded 
Sequence. 

 
Emulation Screen with Key Pad 

The Key Pad tab allows you to change the characteristics of the pop-up Key Pad.  Changes made in this 
property sheet affect all sessions.  There is only one Key Pad configuration per emulator, not one per 
session. 
 

 
Key Pad Property Sheet for TN5250e 
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To Edit a Key Pad button: 
1. Select the Function Key you want to modify from the Button Label list. 
2. Click on Edit. 
3. If you want to send a Text String to the host every time you press the Function key, type it into the 

Text String field. 
4. Select the Action from the Drop-Down list 
5. Select the command or the Recorded sequence from the Drop-Down list that you want to associate 

to the Hot Spot key. 
6. Click on Accept. 
7. Click on Apply. 
 
To Remove a Key Pad button: 
1. Select the Function Key you want to remove. 
2. Click on Remove. 
 
To Add a Key Pad button: 
1. Click on Add. 
2. In the Name field, type the text you want to associate to the button when you pop up the Key Pad. 
3. If you want to add a Text String to be sent to the host, type it into the Text String field. 
4. Select the Action from the Drop-Down List. 
5. From the Drop-Down list, select the command or the Recorded sequence that you want to associate 

to the Key Pad button. 
6. Click on Accept. 
7. Click on Apply. 
 

Sign On (5250 Only) 
The Sign On feature of the emulator uses the "Enhanced Display Auto-Signon and Password 
Encryption" feature of the AS/400 to allow a secure connection to the AS/400 without using SSL. 
 

 
Sign On Property Sheet for TN5250e 
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For this feature to work to your benefit, the "Remote Signon" parameter of the AS/400 configuration 
should be enabled. To verify if this parameter is enabled, use the WRKSYSVAL command.  To enable 
this parameter, you may use the following command: 
CHGSYSVAL SYSVAL(QRMTSIGN) VALUE('*VERIFY') 
 

Advanced 
The Advanced property sheet allows enabling/disabling of several useful features. 
 

 
Advanced Property Sheet for TN5250e 

Appearance 
• Show Menu and Toolbar.  If you want to eliminate the “Windows” look, uncheck this box.  In 

addition to changing the appearance, this will also prevent the user from using Hot Spots or Key 
Pad, and from viewing the keyboard mapping. 

• Status Bar type. 
• Classic 5250/3270.  Provides the classic “green screen” look in the status bar. 

 

 
 

• Graphic.  Provides the “Windows” look to the status bar and displays the connection name. 
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Security Configuration 
YESterm/IP provides extreme flexibility in allowing, or prohibiting, the user to view and change the 
characteristics of the display screen.  If you choose to show the Menu and Tool bars in Appearance 
above, you can choose to individually enable or hide every option item shown in the Menu bar, and its 
corresponding button in the Buttons bar.  The default is that all options except Properties are enabled. 
1. Select the appropriate item from the drop-down list 
2. Click on the Enable… check box.to insert a check in the check box, or to remove one that is 

already there.  
 

Host Device Connection 
When using named devices, careless name assignment or unusual session activation circumstances, 
such as a power failure/reconnect, can cause two sessions to request the same name.  In such a case, the 
host will not open the second session.  Checking the Allow request of…. box will cause the emulator 
to request a virtual assignment for the second session if it is rejected because of name conflict.  This 
does not fix the basic problem, but at least the session can be opened. 
 
For AS/400 hosts, IBM recommends setting an AS/400 “Keep Alive Timeout” to 40 seconds in order to 
facilitate reconnection of named sessions.  The AS/400 command CHGTELNA, executed from an 
AS/400 green screen, followed by the F4 key will display the screen that controls the setting of this 
parameter. 
 

Miscellaneous 
• Acoustic messages.  You can select Wave device if you have external speakers. 
• Enable debug trace.  If you enable the trace, enter the Destination IP Address. 
 
 

Printer Sessions 
 
For TN5250e sessions, you will see a Printer Sessions Properties sheet with six properties tabs.  For 
TN3270e sessions, you will see a Printer Sessions Properties sheet with four properties tabs.  The 
opening view is of the Connections tab and properties sheet. 
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Connection (5250) 

 
Connection Property Sheet for TN5250e 

Six of the seven parameters on this property sheet were already configured in the Setup Wizard when 
this session was created, although you can change them here if you wish.  The additional parameter is: 
• Use this session to support….  If this session is used for Print Screen Extended Local Printing, 

check this box. 
 

Connection (3270) 

 
Connection Property Sheet for TN3270e  
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Six of the eight parameters on this property sheet were already configured in the Setup Wizard, 
although you can change them here if you wish.  The additional parameters are: 
• Use this session to support….  If this session is used for Print Screen Extended Local Printing, 

check this box. 
• Associate device.  Usually a printer session is associated with a specific printer device name.  

However, there are some mainframe configurations with no "free" printer devices, but only printer 
devices associated to specific display devices.  In this case, you have to specify a display session 
name to which a printer is associated. 

 

Input (5250) 
The Input tab allows you to define specific parameters that affect the appearance of the printed page.  
Note:  If you are using Host Print Transform (see Advanced), the Input settings do not apply. 
 

 
Input Property Sheet for TN5250e 

Language 
YESterm/IP supports a number of different Code Pages. The Code Page selected here from the drop-
down list should be the same as that configured on the AS/400 for the specific device. 
 
It is also possible to create a new custom Code Page Table.  See How To…|Create a Custom Language 
Code Page for instructions. 
 

Page Layout 
Set the default page layout.  Parameters are: 
• Page Orientation. Select from Portrait, Landscape, and COR (Computer Output Reduction).  

Note: If you are using an impact dot-matrix printer, Portrait is recommended. 
• Automatic Page Orientation.  This option is enabled by Default.  Note: If you are using an impact 

dot-matrix printer, it is recommended that this be Disabled. 
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• COR Line Spacing Reduction. This feature solves the problem of nonprintable margin area on the 
printer.  Note: It is recommended that this feature be used only with laser printers. 

• COR Override.  This function corresponds to the IBM 3812 configuration parameter and defines 
that a job with draft quality is printed in COR. 

 

Overrides 
If you wish to override the host system output settings, you can do so here. 
Note: If you are using an impact dot-matrix printer, it is recommended that you set Print Quality to 
Force Draft. 
 

Input (3270) 

 
Input Property Sheet for TN3270e 

Language 
YESterm/IP supports a number of different Code Pages. The Code Page selected here from the drop-
down list should be the same as that configured on the mainframe for the specific device. 
 
It is also possible to create a new custom Code Page Table.  See How To…|Create a Custom Language 
Code Page for instructions. 
 

Default Page Settings 
Select the desired default settings from the drop-down lists and enter the maximum print parameters.  
Note: If you are using an impact dot-matrix printer, Portrait is recommended for Page Orientation. 
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Output 
The Output properties define the communication with the printer. 
 

 
Output Property Sheet for TN5250e 

• Time Out.  This parameter defines a timer (in seconds) that starts to count down every time, during 
a printing job, that the host system stops sending data. If no more data are received within the 
timeout value selected, the printer session will assume that the print job is finished, and a Form 
Feed command is sent to the printer. 

• Printer Driver. The PassThrough Drivers offered here, specifically developed by Affirmative, 
generate a standard text data stream. Everything is sent to the printer in text mode allowing better 
control of the printer and better performance.  Select a PassThrough Driver from the drop-down list 
of pre-configured Printer Profiles for your selection and use.  Even if your printer is not on this list, 
it probably emulates one of the listed printers.  Note:  If you are using an HP PCL printer, it is 
recommended that you use HP PCL (Standard COR) for U.S. operation and HP PCL Laser 
Emulation for European operation.  Note:  If you are using Host Print Transform (see Advanced), 
select Empty Driver. 

• Driver Configuration.  If you wish, you can modify parameters of a listed driver. For more 
information on how to customize or create a new Passthrough Printer Driver, refer to How 
To…|Modify a Passthrough Driver. 

 

Euro 
If your printer is Euro ready, you may wish to bypass the PassThrough Euro sequence.  To do so, 
activate the Euro button to bring up the Euro Printing Mode dialog box 
 

 101



2x14 User’s Guide—Editing an Existing Connection 

 
Euro Printing Mode Dialog Box 

Select the Use Euro ready printer radio button and choose a Code Page character. 
 

Printer Port 
Choose and configure the local or network printer port used in this session.  Choose Parallel port, 
COM1/2 (2614 only), or Lan printer.  Direct USB printing is not yet supported in emulation sessions, 
although it will be supported in a future firmware release. 
• Port printer configuration.  After you choose a printer port, you need to configure it. 

• Parallel Port.  Click on Parallel Port Config… to configure whether or not to reset the printer 
at the start of every print job. 

• COM1/2 (2614 only).  Click on Serial Port Configuration to see the Serial Port dialog box.   
 

 
Serial Port Dialog Box 

Select the baud rate and flow control from the drop-down lists.  Note that parity and stop bits are 
not configurable. 
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• Lan Printer.  Click on Lan Configuration to see the Lan Printer Configuration dialog box.  
Note that SMB printer is grayed out, since it is not supported in emulation sessions. 

 

 
LAN Printer Configuration Dialog Box 

• LPR printer.  Make this selection to assign print jobs to a network printer that is 
configured as an LPD server. 
• Host name/IP Address.  If you are using a Hosts table (see Editing Terminal 

Properties|Network|Advanced Parameters|Hosts Table), you can type in the host 
network name.  Otherwise, type in the IP address of the LPD host. 

• LPR queue name.  This will be the queue name assigned at the LPD host to be used 
by LPR devices to assign print jobs. 

• Port Number.  Leave at the default unless otherwise directed by your network 
administrator. 

• Job length counter.  Leave unchecked unless otherwise directed by your system 
administrator. 

• RAW printer.  RAW is the default protocol for most TCP/IP networks.  
• Host name/IP.  If you are using a Hosts table (see Editing Terminal 

Properties|Network|Advanced Parameters|Hosts Table), you can type in the host 
network name.  Otherwise, type in the IP address of the RAW host. 

• Port Number.  Leave at the 9100 default unless otherwise directed by your system 
administrator. 

• USB.  Even though USB is grayed out, there is a circuitous way to print to a local USB 
printer.  If you wish to do this, proceed as follows: 
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1. Set up the printer as an LPD printer, as described in Editing Terminal 
Properties|Printers|LPD. 

2. Select Lan printer under Printer Port. 
3. Configure the LAN printer as an LPR printer. 

• Host name/IP Address.  Enter the IP Address of this terminal. 
• LPR queue name.  Enter the queue name that you assigned in step 1. 
• Port Number.  Leave at the default. 
• Job length counter.  Leave unchecked. 

4. Now you should be able to print to this printer from this session. 
 

HPT (Hex Passthrough) (5250 only) 
Hex Passthrough allows portions of a data stream to be sent directly from the host to the printer.  There 
is no modification done to these portions by the emulator driver.  In order for the emulator to recognize 
these inviolate data stream portions, they must be identified at the beginning and end by escape 
sequences – a combination of special characters that the emulator can identify. 
 

 
Hex Passthrough Property Sheet for TN5250e 

• Sequences.  Enter the Leading Sequence and the Trailing Sequence you want to use. The default 
sequences are %& and %&; however, most printers use the reverse (&%).  You can enter up to 4 
characters for each sequence. 

• HPT Mode.  Select one of four modes to define rather or not HPT prints spaces and rather or not it 
updates the column counter. 
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Advanced (5250 only) 
The Advanced Tab allows you to set Default parameters and enable the Host Print Transform feature. 
 

 
Advanced Property Sheet for TN5250e 

• Queue Name/Queue Library/Default Font.  These are host parameters and should be given to you 
by your host administrator. 

 

Host Transform 
When Host Print Transform is enabled, the host does the EBCDIC-to-ASCII conversion of the print 
stream, and the local Passthrough Driver is not used. 
• Printer.  You must choose a compatible model from the drop-down list.  Your AS/400 may have a 

more extensive list of compatible printers.  If your printer is on the AS/400 list, but not on our list, 
you can type in the printer model here as it appears in the AS/400 list; be sure to put an asterisk in 
front of the model name. 

• Drawer # 1.  Choose an input print media size if applicable. 
• Drawer # 2.  Choose an input print media size if applicable. 
• Envelope.  Choose an envelope size if applicable. 
• Customizing Object Name.  Enter the object name here if you have chosen *WSCTS from the 

Printer drop-down list. 
• Customizing Object Library.  Enter the object library name here if you have chosen *WSCTS 

from the Printer drop-down list. 
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Miscellaneous 

 
Miscellaneous Property Sheet for TN5250e 

• Security Configuration.  Default mode is to hide the Properties entries from the Tool bar and the 
Menu bar so that the user cannot make configuration changes.  Check this box if you wish to 
provide user access to the configuration parameters. 

• Misc.  If you enable the debug trace, enter the Destination IP Address. 
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How To… 
 

Create a Custom Language Code Page 
This procedure is the same for either a display or a printer session.  To do this, select one of the 
available Code Pages (the one that comes closest to the one you want to create) and click on Edit.  
Assuming that your base Code Page is International 5, the following screen will appear: 
 

 
International 5 Code Page Table 

To read the table, use the left column for the first hex character of the EBCDIC code, and the top row 
for the second hex character of the EBCDIC code.  For example, the standard EBCDIC code for A is 
C1; the standard ASCII code for A is 41.  Look at the table above and you see that the cell 
corresponding to EBCDIC C1 has the value 41 in it. 
 
Double-click the cells you want to change and enter the new values.  To assist you in your 
customization, the standard code tables for EBCDIC and ASCII are shown here. 
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EBCDIC Code Page 

In this code page, the top row corresponds to the first digit of the EBCDIC hex character pair, and the 
left row corresponds to the second digit.  For example, the hex pair 5B represents an $.
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ASCII Code Page for Terminal Font 

In this code page, the top row corresponds to the first digit of the ASCII hex character pair, and the left 
row corresponds to the second digit.  For example, the hex pair 24 represents an $.

 109



2x14 User’s Guide—Editing an Existing Connection 

 

Create a Custom Keyboard Map 
To do this, select, in Display Session Properties>General>Keyboard Type, one of the available 
Keyboard Layouts (the one that best matches the one you want to create) and click on Edit.  Assuming 
that you chose the 101 PC keyboard for U.S. English, the following screen will appear. 
 

 
Keyboard Map Page for 101 PC Keyboard 

Select the key, or key plus modifier (Ctrl, Alt, Shift) to which you want to associate a specific action. 
On the upper half of the window, you can see the keyboard Scan-Code and the associated default 
action.  To modify the action, click on Edit.  The following dialog box will appear: 
 

 
Edit Scancode Map Dialog Box 

From the Action drop-down list, you can select the action that you want to associate with the selected 
key from among the following options: 
• No operation.  No action will be performed when you press the key. 
• Host Command.  Choose the desired command function from the lower drop-down list. 
• Recorded Key Sequence.  If you have previously recorded one or more key sequences, you will 

see their names in the lower drop-down list.  Choose the desired Recorded Sequence from this list. 
• EBCDIC Characters Sequence.  Enter the Scan-Code sequence you want to associate to the key.  

Although you can use this to enter multiple characters, like a Recorded Sequence, this option is 
typically used to access some special character not normally seen on a keyboard.  See Create a 
Custom Language Code Page for a standard code page for EBCDIC. 
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Modify a Printer Passthrough Driver 
Any Passthrough Driver can be customized, and it is also possible to create a new Driver.  To edit an 
existing Passthrough Driver, do the following: 
1. Highlight the connection name in the Configure tab of Connection Manager and activate Edit. 
2. Follow the path Printer Session Properties>Output>Printer Driver. 
3. Select the Driver from the drop-down list and activate Driver Configuration in the Output.  You 

will see a screen with five tabs. 
 

General 

 
Driver General Property Sheet 

This sheet allows you to select: 
• Variable Line Spacing.  If you enable this function you must enter the Inch fractions. 
• Default Tray. 
• Permanent Save.  You must check this box if you wish to save the driver changes. 
• New Driver Name.  This name will appear in the Passthrough Driver drop-down list if you check 

Permanent Save.  The default new name is User- in front of the selected driver name.  But you can 
enter a completely new name if you wish. 
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Transcode Table 

 
Driver Transcode Property Sheet 

This sheet allows you to: 
• Define the Default Code Page. If you want, you can also edit the Code Page by clicking on Edit 

Code Page.  Select a value that you wish to modify, click on Edit, and a Code Page screen will 
appear where you can enter the new value.  See Create a Custom Language Code Page for editing 
instructions. 

• Customize the Escape sequence used to call the Code Page.  Select the Code Page from the list, 
activate Edit, and an Edit Passthrough Sequence dialog box will appear where you can enter the 
new value. 

 

 
Transcode Edit Passthrough Sequence Dialog Box 
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Escape Sequences 

 
Driver Escape Sequences Property Sheet 

This sheet allows you to customize all the Escape commands used to perform specific functions.  Select 
a function, activate Edit, and an Edit Passthrough Sequence dialog box will appear.  Make your 
changes there. 
 

 
Edit Passthrough Sequence Dialog Box 
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Euro 

 
Driver Euro Property Sheet 

This sheet allows you to customize the Escape command used to print the EURO symbol. This special 
function allows you to print the EURO symbol even on those printers that are not EURO ready.  Select 
the command you wish to customize, then activate Edit, and an Edit Passthrough Sequence dialog box 
will appear where you can enter the new value. 
 

 
Edit Passthrough Sequence Dialog Box 
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Font ID 

 
Driver Font ID Property Sheet 

This sheet allows you to customize the Escape commands used to call a Printer Font that has been 
associated with a Host System Font ID.  To edit a Font ID, select the item, activate Edit, and an Edit 
Font ID and Sequence dialog box will appear where you can enter the new value. 
 

 
Edit Font ID and Sequence Dialog Box 

You can also remove a font or add a new font to the list.  If you activate Add, an Edit Font ID and 
Sequence dialog box will appear where you can enter the new values. 
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Using a Connection 
 

Connections are typically opened, or activated, in one of four ways. 
1. In Desktop viewing mode, display connections in the Start menu and then click on the connection of 

choice. 
2. In Desktop viewing mode, open Connections Manager, highlight the connection of choice, and then 

click on Connect. 
3. In WBT viewing mode, open Connections Manager, highlight the connection of choice in the 

Connections tab, and then click on Open. 
4. Configure a session to Autostart (see Connections Manager|Configurtion|Startup) at bootup.  In 

TBT viewing mode, all sessions are Autostart by default. 
 
Most connection types can be used without any explanation here.  But we have user information for 
several types that may be unfamiliar to you. 
 

Client VNC 
 

1. Open the Client VNC session from the Start menu or Connections Manager. 
2. If you have configured the session correctly, including password, and if VNC Server is on at the 

target device, you will see the target screen.  If the terminal video resolution is less than the target 
video resolution, you will have to scroll to see the complete target screen. 

3. If you have not included a password in the session configuration, you will have to enter a password 
in a dialog box before you can see the target screen. 

4. If any of the configuration parameters are incorrect, if VNC Server is not on at the target device, or 
if you enter an incorrect password, you will see no action.  You will not see any error message. 

 
Notes: 
1. You can configure multiple Client VNC sessions, but only one can be active at any one time. 
2. If the terminal video resolution is equal to or less than the target video resolution, and you are in the 

Desktop viewing mode, you will need to hide the Task Bar (see Editing Terminal 
Properties|Desktop) in order to see the whole target screen or do horizontal scrolling. 
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Internet Browser 
 
No doubt you are familiar with Web browsing in general.  However, here are some details about using 
the Netscape 4.78 browser.  When you open the browser session, you will go to your designated initial 
page and see something like the following screen 
 

 
Browser Screen Example 

Basic operations can be controlled from the Menu Bar, the Navigation Toolbar, the Location Toolbar, 
and the Personal Toolbar.  Everything that can be done from the Navigation and Location Toolbars can 
also be done from the Menu Bar, and the Menu Bar will also allow additional operations or 
configuration  
 

Menu Bar 
 

 
Browser Menu Bar 

The Menu Bar contains six menus.  Open the desired menu by left-clicking on it. 
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File 

 
Browser File Menu 

• Navigator Window.  Click on this selection to go to your Home page.  Note: Your Home page is 
the one designated in Edit>Preferences.  It is not necessarily the Initial page designated in the 
Browser Connection Configuration dialog box when the session was created. 

• Open Page.  Click here to open the Open Page dialog box. 
 

 
Browser Open Page Dialog Box 

Enter the url of the Web page that you wish to browse and click on Open.  You can even open a 
local file if you wish, although it’s not likely to be very useful. 

• Save As.  Click here to open the Save As dialog box to save the current page in Text, Html, or 
Postscript format. 

• Close.  It is possible to open multiple windows (see Window|Multiple Windows) in the same 
session.  If you have multiple windows, click on Close to close the current window. 

• Exit.  Click here to close the browser session.  This will close all open windows in this session 
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Print 
Click here to open the Print dialog box. 

 

 
Browser Print Dialog Box 

Browser printing uses a derivation of a popular Open Source program called Ghostscript.  The Print 
Command box automatically contains a Ghostscript command line that allows you to print to the first 
printer configured in Terminal Properties>Printers.  If you have more than one configured printer, and 
you do not want to print to the first one, you can change the queue name (the last term in the script) to 
designate the desired printer.  You can also change the default device type from laserjet (as in 
-sDEVICE=laserjet) to one in the following table. 

  
Table 1.  Compatible Printers for Browser Printing 

Device Type Compatible Printers 
• bj10e • Canon BJ10e, BJ20 
• bj200 Canon BJ200, BJC70, 210, 240, 250 (b/w only) 
• bjc600 CanonBJC-50, 70, 80, 210 (color), 240 (color), 250, 600, 610, 1000, 

2000, 4000, 4100 (b/w only), 4200, 4300, 4550, 6000, C2500 
bjc800 Canon BJC-800, 4300, 4650, 7000, 
cdeskjet HP DeskJet 500C 
• cdj550 HP DeskJet 550C, 570C, 600, 660C, 672C (b/w only), 682C, 683C, 

693C, 694C, 695C, 850, 870Cse (color only), 895Cxi, 970, 1220C, 
OfficeJet  590, Olivetti jp450, Xerox XJ6C 

cdjcolor HP DeskJet 400, 500C, 540C, 690C, 693C (color only) 
cdjmono HP DeskJet 500C, 510, 520, 540C, 693C b/w only 
cljet5 HP Color LaserJet 5, 5M 
cljet5c HP Color LaserJet 5, 5M 
deskjet HP DeskJet, DeskJet Plus 
djet500 HP DeskJet 500, DeskJet Portable, OfficeJet 590 
epson Canon 4100 (color), Epson-compatible dot matrix 
epswrite Encapsulated PostScript 
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Device Type Compatible Printers 
ibmpro IBM 9-pin Proprinter 
ijs HP InkJet Server 
laserjet HP LaserJet 
lj5gray HP LaserJet 5, 6 
lj5mono HP LaserJet 5, 6 
ljet2p HP LaserJet IId, IIp, III, IIIp 
ljet3 HP LaserJet III, IIIp 
ljet3d HP LaserJet IIID 
ljet4 HP DeskJet 870Cse, Laserjet 4, 5, 5L, 6L, 1100 
ljet4d HP LaserJet 4 with duplex 
ljetplus HP LaserJet Plus, Canon Laser LBP-600, NEC SuperScript 
pj HP PaintJet XL 
pjxl HP PaintJet XL color 
pjxl300 HP CopyJet, DeskJet 600 (300dpi only), 1200C, 1600C, PaintJet 

1200C, XL300 
psgray PostScript Level 1 8-bit gray 
psmono PostScript Level 1 monochrome 
psrgb PostScript Level 2 
pswrite PostScript 
pxlcolor HP color PCL XL 
pxlmono HP monochrome PCL XL 
uniprint Canon BJC 610, HP DeskJet 550C, NEC P2X, Epson Stylus Color, 

Color II, Color 500, Color 600, Color 800, Color 1520, Sun rasterfile 
 

If you do not see your printer in this list, do not despair.  Your printer probably is compatible with 
PostScript, PCL or one of the listed printers.  For more details on device types and printer 
compatibility, see http://www.cs.wisc.edu/~ghost/doc/printer.htm
http://www.cs.wisc.edu/~ghost/doc/AFPL/devices.htm
 
Note:  Do not change any other terms in the command unless you really know your Ghostscript.  
But if you should happen to do so by mistake, you can restore the default command by resetting the 
terminal to factory defaults in Terminal Properties>General or by retyping the command into the Print 
Command box. If you do not have the command memorized, here it is: 
gs -q -dNOPAUSE -dBATCH -sDEVICE=<device name> -sOutputFile- -|lpr -P <queue name>. 
 

Edit 

 
Browser Edit Menu 
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• Cut.  This selection will seem to be active if you have highlighted some material in the current 
page.  But it is not applicable in a browser session, and you will get an error beep if you attempt to 
use it. 

• Copy.  You can highlight and select material to be copied from an open Web page.  Select the 
material in the typical Windows fashion, and then click on Copy.  You can also go this by right-
clicking to open a menu which includes the Copy option. 

• Paste.  This selection will seem to be active if you have some material in the Clipboard.  But it is 
not applicable in a browser session, and you will get an error beep if you attempt to use it. 

• Select All.  Click here to select the whole page for copying. 
• Find in Page.  Click here to open the Find dialog box. 
 

 
Browser Find Dialog Box 

Enter the text string that you wish to find on the open page, and click on Find. 
• Search Internet.  Click here to open the Netscape Search Page. 
 

 
Browser Netscape Search Page 

Enter keywords for the URL you are seeking, or open one of the more-specific directories. 
• Preferences.  This option is only available from the Menu Bar.  Click here to open the Netscape 

Preferences dialog box and fine-tune your browser session.  See Editing an Existing 
Connection|Internet Browser for more information. 
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View 

 
Browser View Menu 

• Navigation Toolbar.  Click here to toggle the appearance or disappearance of the Navigation 
Toolbar. 

• Location Toolbar.  Click here to toggle the appearance or disappearance of the Location Toolbar. 
• Personal Toolbar.  Click here to toggle the appearance or disappearance of the Personal Toolbar. 
• Reload.  Click here to reload the current Web page from the source server. 
• Show Images.  You can inhibit image downloading in Edit>Preferences>Advanced.  If you do 

this, the Show Images option will be activated, and clicking on it will download the images for the 
current Web page. 

• Refresh.  Click here to refresh the current Web page from local cache. 
• Stop Animations.  Click here to stop any animations that are present in the current Web page. 
• Page Source.  Click here to view the html source code controlling the current Web page. 
• Page Info.  Click here to view details about the structure of the current Web page. 
• Character Set.  When the browser encounters a foreign character set, it automatically adjusts to 

display the different characters.  But you can choose a default character set here.   
 

Go 

 
Browser Go Menu 

This menu allows you to navigate to Web pages within the focused browser window. 
• Back.  Click here to go back to the previous Web page. 
• Forward.  Click here to return to the page that you most recently came Back from. 
• Home.  Click here to go to the Home page configured in Edit>Preferences>Navigator. 
• List.  At the bottom of this menu, below Home, you see a list of the Web pages that you have 

visited since opening this window.  Click on an entry to go directly to that page. 
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Window 

 
Browser Window Menu 

• Navigator.  Click here to open a window browsing your Home page. 
• Radio.  Click here to go to the Netscape Radio page. 
• Server Tools.  This is not supported in the 2x14 terminals. 
 

Bookmarks 
Click here to see the Bookmarks (also known as Favorites in the Windows Internet Explorer world) 
menu. 
 

 
Browser Bookmark Menu 

There are a number of predefined Bookmarks in various categories, and of course you can add, delete, 
and edit existing and new Bookmarks.  Also note that you can customize your Personal Toolbar from 
this menu by dragging and dropping your favorite Bookmarks into it. 
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Tools 
Click here to see the Tools menu. 
 

 
Browser Tools Menu 

• History.  Click here to see the Communications History window. 
 

 
Browser Communications History Window 

This window shows a list of all the Web sites visited in the last x days by all windows in all browser 
sessions.  The number of days, x, is specified in Edit>Preferences>Navigator.  Click on a column 
heading to re-sort the list.  Double-click on a site name to go there again. 
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• Security Info.  Click here to see the Security Info sheet. 
 

 
Browser Security Info Sheet 

In addition to security information, you can set many security parameters from dialog boxes 
opened by clicking on items in the left-hand list. 

• Java Console.  Click here to open the Java Console screen. 
 

 
Browser Java Console Screen 
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Multiple Windows 
It is possible to open up to three active windows—two URL windows and one History file window--in 
one browser session using the Window menu.  But you have to do it in a certain way; the procedure is 
as follows: 
1. Open a Web page other than the Home page. 
2. Open the Window menu.  You will see the title of the Web page listed as number 1 in the window 

list at the bottom of the Window menu. 
3. Click on Navigator.  This will open, as a second window, your Home page, and you will see the 

title of the Home page listed as number 1 and the first Web page listed as number 2 in the window 
list at the bottom of the Window menu. 

4. Now both windows are active within the same session, and both have placeholders in the Desktop 
Toolbar.  You can switch focus between them by clicking on the desired window title in the 
window list, or by clicking on the placeholder in the Desktop Toolbar. 

5. You can also open, at any time, a window showing the History file by clicking on Tools>History. 
 
Note:  It is possible to change the appearance of a window from the View menu, or the preferences of a 
window from Edit>Preferences.  In such a case, each window in the session will have its own 
configuration until you close the session.  When you close the session, the session will assume, when it 
is re-opened, the configuration of the last window in focus. 
 

Help 

 
Browser Help Menu 

Open this menu to gain access to a variety of on-line help from Netscape. 

 127



2x14 User’s Guide—Using a Connection 

 

Navigation Toolbar 
 

 
Browser Navigation Toolbar with Text 

The Navigation Toolbar provides quick and easy access to a number of the most popular options in the 
Menu Bar.  If you do not need it, you can hide it to increase the size of your display window. When the 
toolbar is displayed, a small square appears next to the Navigation Toolbar option in the View menu.  
This toolbar can be configured (Edit>Preferences>Appearance) to show icons only, text only, or 
icons plus text as seen above.  It can also be configured to show tool tips when the cursor is placed on 
the icon or text. 
 

 
This button duplicates the action of the menu Go>Back command. 
 

 
This button duplicates the action of the menu Go>Forward command. 
 

 
This button duplicates the action of the menu View>Reload command. 
 

 
This button duplicates the action of the menu Go>Home command. 
 

 
This button duplicates the action of the menu Edit>Search Internet command. 
 

 
This button loads your personal version of the Netscape home page. 
 

 
This button duplicates the action of the menu File>Print command. 
 

 
This button duplicates the action of the menu Window>Tools>Security Info command. 
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This button is unusable. 
 

 
If the browser is downloading a new Web page, this button will stop the download. 

 
This button loads the generic version of the Netscape home page. 
 

Location Toolbar 
 

 
Browser Location Toolbar 

The Location Toolbar allows you to specify a Web site for browsing or keywords for a Netscape 
search.  If you do not need it, you can hide it to increase the size of your display window. When the 
toolbar is displayed, a small square appears next to the Location Toolbar option in the View menu. 
 

 
This button duplicates the action of the menu Window>Bookmarks command. 
 

 
This icon gives you a quick and easy way to put a link to the current page on your Personal Toolbar.  
Just drag the icon to the Personal Toolbar, and a button will be created there with a link to the current 
page.  But after you drag it there, you cannot drag it off the Personal Toolbar.  If you want to delete it, 
you will have to do it from Bookmarks>Edit Bookmarks. 
 

 
This section of the Location Toolbar serves three purposes: 
1. Type in a url and press PC Enter to go directly to a desired Web site. 
2. Type in key words and press PC Enter to do a Netscape search on the Web without going to the 

Netscape search site via Edit>Search Internet. 
3. Click on the drop-down arrow at the right to show a list of any previous search results.  Then you 

can click on a list item to go directly to those results. 
 

 
This button accesses the Smart Browsing feature as configured in 
Edit>Preferences>Navigator>Smart Browsing. 
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Personal Toolbar 
 

 
Browser Personal Toolbar 

The Personal Toolbar allows you to create your own toolbar with iconed links to the Web sites of your 
choice.  If you do not need it, you can hide it to increase the size of your display window.  When the 
toolbar is displayed, a small square appears next to the Personal Toolbar option in the View menu. 
 
This toolbar initially has the default links shown above.  You can delete any of these links, and add new 
links via drag and drop, from Window>Bookmarks.  You can also add links with the Location Bar  

icon as described as above.  
  

 

Multiple Sessions 
It is possible to create multiple browser sessions.  Each one will have its own name in the Connections 
list, and each one can have its own Initial and Home pages. 
• If you change the appearance of an open session from the View menu, or the preferences from 

Edit>Preferences, all the other browser sessions that are on the Connections list will assume that 
same configuration when you close that open session, except for Initial and Home pages. 

• If you have multiple sessions open at the same time, the configurations can be unique until you 
close the sessions.  At that time, all the sessions will take on the configuration of the final one 
closed. 
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TNXXXXe 
 

Display Session 
 

Menu Bar 
Menu-bar commands of the display session window consist of commands and functions that are unique 
for each window (session). 
 

 
Display Session Menu Bar 

The system administrator may disable any or all of the Menu bar commands.  See Editing an Existing 
Connection|TNXXXXe|Display Sessions|Advanced|Security Configuration. 
 
If you have a mouse, open the desired menu by left-clicking on the menu name.  Without using a 
mouse, you can view the File menu by pressing and releasing the LeftAlt key.  Then you can use the 
Tab or Left/RightArrow keys to move to other menus.  Or you can press Alt+e/t/v/? to open the 
Edit/Tools/View/? menu. 
 
The Menu bar may be enabled but invisible, if visibility is not enabled in Editing an Existing 
Connection|TNXXXXe|Display Sessions|Advanced|Appearance.  In this case, use the mouseless 
method of menu viewing described above 
 

File (Alt) 

 
Display File Menu 

• Connect (n).  A display session typically comes up in the connected state.  But if, for some reason, 
the session is not connected, this command will attempt to connect the display session to the host. 

• Disconnect (d).  This command disconnects the display session from the host.  It is recommended 
that you disconnect only from the Sign-On screen. 

• Properties (p)…  This command allows you to edit/modify the Properties of the display session in 
use.  For more information on this function, please refer to Editing an Existing 
Connection|TNXXXXe|Display Sessions.  When you change properties here, most changes are 
effective immediately, but some require that you exit the session and reopen it. 

• Print (r).  This command prints the contents of the display screen to the printer designated in 
Editing an Existing Connection|TNXXXXe|Display Sessions|General|Print Screen. 

• Close All (a).  This command closes all active sessions, including printer sessions. 
• Close (c).  This command closes the display session in use. 
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Edit 

 
Display Edit Menu 

• Cut (t).  This command copies, into the Clipboard, data contained in the selected area and removes 
it from the display.  A mouse is required for this operation, since the mouse cursor is used to draw a 
box around the selected area.  The Cut process is: 
1. Use the mouse cursor to draw a box around the area to be copied.  Be precise when you draw 

the box, or else the paste process may try to copy the data into a restricted area.  The selected 
area will be highlighted in white. 

2. Open the Edit menu. 
3. Activate Cut.  Note: Cut does not duplicate host attributes such as color and intensity.   
4. Return the mouse cursor to the green screen and left click.  The white highlight will disappear. 

• Copy (r).  This command accomplishes the same function as Cut, except that the selected data is 
not removed from the display.  The Copy process is the same as the Cut process, except that you 
activate Copy in Step 3. 

• Copy All (a).  This command copies the entire screen into the Clipboard. 
• Paste (p).  This command pastes the current contents of the Clipboard onto the session window, 

starting at the current cursor position.  If the contents of the clipboard are larger than the space 
available in the presentation space (screen), they may be clipped.  Paste does not overlay the 
clipboard contents onto areas that are protected by the host application. 

 

Tools 

 
Display Tools Menu 

Tools commands allow you to work with the Record/Playback function.  If you regularly do the same 
things when you work with a host system, it is convenient to record the keystrokes you make and have 
YESterm/IP play them back when you want to do the same job again.  Record/Playback allows you to 
do this.  All your keystrokes can be saved in a macro file; when you play the file back (Playback), 
everything that happened will be reproduced exactly.  Any macro that you create is available in all 
display emulation sessions.  For more information on how to work with Record/Playback, refer to How 
To…|Record a Keystrokes Sequence.
 
• Start Recording (s).  This command starts the Keystrokes Recording process. 
• Stop Recording (r).  This command stops the Keystrokes Recording process. 
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Macro Recording Dialog Box 

When you Stop Recording, the Macro Recording dialog box will be displayed, allowing you to save 
the recorded keystrokes into a named file for subsequent playback. 

• Pause Recording (p).  Including a Pause command into a recorded sequence will cause the 
Playback operation to pause at this point in the sequence.  This pause is typically used to enter 
variable data during Playback. 

• Delete Macro (d).  This command will bring up the Recorded Macro Delete dialog box. 
 

 
Recorded Macro Delete Dialog Box 

In this box will be a list of the available macros for this session.  Select the one to be deleted and 
activate OK.  This macro will now be deleted from all display emulation sessions. 

• Playback.  No, you do not see an actual Playback command.  But, at the bottom of the Tools menu 
below the line, you will see a list of the available macros for this session.  Select the one to be 
played and press the PC Enter key; that macro will then be executed. 
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View 
Commands in the View menu are used to manipulate the Emulator display window. 
 

 
Display View Menu 

• Toolbar-Menu (t).  This toggle command hides or displays the Menu and Buttons toolbars.  After 
you hide the toolbars, you will have to use LeftAlt and the Arrow keys to access menu options. 

• Ruler (r).  This toggle command hides or displays the crosshairs Ruler.  It has the same effect as 
the Rule key on the keyboard.  When the command is checked, the Ruler is displayed.   

• Attributes (a).  This toggle command hides or displays the 5250 attribute fields. 
• Advanced View (d).  This toggle command activates/deactivates the graphics Windows look, with 

Hot Spots displayed as raised buttons if they have been enabled. 
 

 
Emulation Screen with Advanced View and Hot Spots 

Hot Spots are only useful if you have a mouse.  For more information on the Hot Spot feature, refer 
to Editing an Existing Connection|TNXXXXe|Display Sessions|Hot Spot. 
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• Keypad (k).  This toggle command hides or displays the Key Pad.  The Key Pad can be 
repositioned as desired on the screen by dragging and dropping. 

 

 
Partial Emulation Screen Showing Keypad 

Key Pad is only useful if you have a mouse.  For more information on the Key Pad feature, refer to 
Editing an Existing Connection|TNXXXXe|Display Sessions|Key Pad. 

 

? 

 
Display Help Menu 

• Contents (c).  This command is not used in the TBT. 
• Keyboard Help…(k).  This command displays the keyboard map in use. You can see the mapping, 

but you cannot edit it from this screen.  This display can be used in two ways: 
1. If you click on a key to which a command has been mapped, you will see that command 

highlighted in the List Box. 
2. If you highlight a command in the List Box, the key or key combination that executes that 

command will be highlighted on the keyboard graphic.  Some commands can be executed from 
several different key combinations.  In that case, you will see the notation (x of y), which 
indicates that this is the xth sequence out of y possibilities.  To cycle through the combinations 
for that command, click on Next Sequence. 

• About…(a).  This command displays detailed information on the YESterm/IP program such as 
version, copyrights, and other useful information. 
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Buttons Bar 
The Buttons bar is displayed across the top of the application window to the right of the Menu bar.  The 
Buttons bar provides quick access to commands you use on a regular basis, if you have a mouse.  If you 
do not need it, you can hide it and the Menu bar to increase the size of your display window.  When the 
toolbar is displayed, a check mark appears next to the Toolbar option in the View menu. 
 

 
Display Session Buttons Bar 

The system administrator may disable any or all of the Menu bar commands.  See Editing an Existing 
Connection|TNXXXXe|Display Sessions|Advanced|Security Configuration. 
 
The command/button definitions are: 
 

 
Connect.  Duplicates the function of the menu File>Connect command. 
 

 
Disconnect.  Duplicates the function of the menu File>Disconnect command. 
 

 
Print.  Duplicates the function of the menu File>Print command. 
 

 
Properties.  Duplicates the function of the menu File>Properties command. 
 

 
Copy.  Duplicates the function of the menu Edit>Copy command. 
 

 
Paste.  Duplicates the function of the menu Edit>Paste command 
 

 
Start Recording.  Duplicates the function of the menu Tools>Start Recording command.  In fact, if 
you use the menu version, you will see that this button is also depressed. 
 

 
Pause.  Duplicates the function of the menu Tools>Pause command.  If you use the menu version, you 
will see that this button is also depressed. 

 
Stop Recording.  Duplicates the function of the menu Tools>Stop Recording command. 
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Playback.  Displays a list of available macros.  Click on the one to be played, and that macro will then 
be executed. 
 

 
Ruler.  Duplicates the function of the menu View>Ruler command. 
 

 
Attributes.  Duplicates the function of the menu View>Attributes command. 
 

 
Hot Spots. Duplicates the function of the menu View>Advanced View command. 
 

 
Keypad.  Duplicates the function of the menu View>Keypad command. 
 

 
Keyboard Help.  Duplicates the function of the menu ?>Keyboard Help command. 
 

 
I, II, III, IV.  These buttons correspond to the emulation sessions shown in order in the Terminal 
Connections Manager screen.  Inactive sessions will have corresponding grayed-out buttons, while 
buttons for active sessions will not be grayed-out.  To jump to another active session, just click on the 
button for that session. 
 

Printer Session 
 

Menu Bar 
 
Menu-bar commands of the printer session window consist of commands and functions that are unique 
for each printer window (session). 
 
If you have a mouse, open the desired menu by left-clicking on the menu name.  Without using a 
mouse, you can view the File menu by pressing and releasing the LeftAlt key.  Then you can use the 
Tab or RightArrow keys to move to other menus.  Or you can press Alt+t/? to open the Tools or ? 
menu. 
 

 
Printer Session Menu Bar 
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File (Alt) 

 
Printer File Menu 

• Connect (n).  A printer session typically comes up in the connected state.  But if, for some reason, 
the session is not connected, this command will attempt to connect the printer session to the host. 

• Disconnect (d).  This command disconnects the printer session from the host. 
• Properties… (p). This command allows you to view/edit/modify the Properties of the printer 

session in use.  It will be grayed out and inactive unless it has been enabled in Editing an Existing 
Connection|TNXXXXe|Printer Sessions|Miscellaneous.  For more information on Properties, please 
refer to Editing an Existing Connection|TNXXXXe|Printer Sessions.  When you change properties 
here, most changes are effective immediately. 

• Close (c).  This command closes the printer session. 
 

Tools 

 
Printer Tools Menu 

• Abort Print Job (a).  This command aborts the print job in process. 
• Clear Document List (c).  This command clears the Document List.  The Document List contains a 

history of all documents printed since the session was started. 
. 

? 

 
Printer Help Menu 

 
• Contents (c).  This command is not used in the TBT.  
• About… (a).  This command displays detailed information on the YESterm/IP program such as 

version, copyrights, and other useful information. 
 

Buttons Bar 
The Buttons bar is displayed across the top of the application window to the right of the Menu bar. The 
Buttons bar provides quick access, if you have a mouse, to commands you use on a regular basis. 
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Printer Session Buttons Bar 

The command/button definitions are: 
 

 
Connect.  Duplicates the function of the menu File>Connect command. 
 

 
Disconnect.  Duplicates the function of the menu File>Disconnect command. 
 

 
Properties.  Duplicates the function of the menu File>Properties command. 
 

 
Contents.  Duplicates the function of the menu ?>Contents command. 
 

 
I, II, III, IV.  These buttons correspond to the emulation sessions shown in order in the Terminal 
Connections Manager screen.  Inactive sessions will have corresponding grayed-out buttons, while 
buttons for active sessions will not be grayed-out.  To jump to another active session, just click on the 
button for that session. 
 

How To… 
 

Record a Keystrokes Sequence (Macro) 
If you regularly do the same things when you work with a host system, it is convenient to record the 
keystrokes you make and have YESterm/IP play them back when you want to do the same job again.  
Record/Playback allows you to do this.  All your keystrokes can be saved in a file; when you play the 
file back (Playback), everything that happened will be reproduced.  Your macro will be available in all 
display sessions of the same type. 
 
Note: Macros are limited to 512 data “items”.  A character keystroke counts as one item, while a cursor 
movement keystroke counts as two items.  If you try to enter more than 512 items, an error message 
will appear and a spurious character will be attached to the macro that may make the macro useless. 
 

Graphics Display Session 
When configuring a display emulation session, you have the choice of a graphics display mode or a 
5250 text display mode.  See Editing an Existing Connection|TNXXXXe|Display 
Sessions|Advanced|Appearance for details on making this choice. 
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In order to create a macro in a graphics display session, you have to: 
1. Open a display session. 
2. Place the cursor in the field where you wish to start the sequence. 
3. Activate Tools>Start Recording or press the Recrd key or click on the corresponding Toolbar 

button.  You will see, in the right side of the Status bar, the information REC: 0. This tells you how 
much information has been entered into the macro. 

4. Type the data and cursor movements that you want to record.  As you type, the information counter 
will advance by one for each character and by two for each cursor movement. 

5. Stop the recording by activating Tools>Stop Recording or pressing the Recrd key or clicking on 
the corresponding Toolbar button. 

6. Name the macro.  There are no naming restrictions. 
 
Example: 
Assume you want to record the CL command to display the description of a specific device.  The 
command is WRKDEVD PRTXXXX, where PRTXXXX identifies a specific printer.  So, the 
procedure is: 
1. Place the cursor. 
2. Activate Start the Recording. 
3. Type WRKDEVD 
4. Activate Pause. 
5. Type PRTXXXX (the name of the device) and press Enter. 
6. Activate Stop the Recording. When you stop, you will be prompted to save the recorded 

keystrokes to a file. 
Note: The Pause function will automatically end when you press the Enter key. 
 

5250 Text Display Session 
In a 5250 text display session, you can record a macro by using Menu commands or Toolbar icons in 
exactly the same way as in a graphics display session (see above).  But, if you are using a 122-key 
keyboard, the Recrd key works differently.  This additional procedure for recording macros is as 
follows: 
1. Place the cursor in the field where you want to record the macro. 
2. Press Recrd.  You will see, in the center of the Status bar, an R indicating Record mode and a 

countdown counter.  For the first macro, this count starts at 8161.  (Why 8161?  I have no idea.) 
3. Press the F key, Fx, that you wish to associate with the forthcoming macro.  You will see the R in 

the status bar replaced by Fx. 
4. Type the data and cursor movements that you want to record.  The counter will count down by one 

for each character keystroke and down by two for each cursor movement keystroke 
5. When you are finished with the desired keystrokes, press Recrd again.  This ends the recording 

process.  You now have a macro named Fx.  This macro will appear in the Macro list as Fx. 
6. When you record the next macro, the counter will start at the final count of the preceding macro.  

This count is for information purposes only; there is no limit to the total number of keystrokes in all 
the macros. 

Note:  You must use the keyboard Recrd key.  Activating Start Recording from the Menu or Button 
bars will result in the graphical procedure explained in the previous section. 

 140



2x14 User’s Guide—Using a Connection 

 

Play a Recorded Keystrokes Sequence (Macro) 
 

Graphics Display Session 
In order to play a recorded keystrokes sequence in a graphics display session, you have to: 
1. Place the cursor on the screen where you want to play the sequence. 
2. Activate Tools or press the Play key or click on the corresponding Toolbar button.  You will see a 

list of available macros. 
3. Select the sequence from the list.  The sequence will be executed. 
 
If you have assigned a sequence to a key as part of a custom keyboard map, you can also play the 
sequence as follows: 
1. Place the cursor on the screen where you want to play the sequence. 
2. Press the designated key.  The sequence will be executed. 
 

5250 Text Display Session 
In a 5250 text display session, you can play back a macro from the Tools menu or from the Toolbar in 
exactly the same way as in a graphics display session (see above).  But you also have another option if 
you are using a 122-key keyboard and if you have used the alternate method of sequence recording.  
This additional procedure for playing macros is as follows: 
1. Place the cursor on the screen where you want to play the sequence. 
2. Press the Play key.  You will see, in the center of the Status bar, a P indicating playback mode and 

a count that has no bearing whatsoever on the macro execution.   
3. Press the F key corresponding to the desired macro.  The macro will be executed, and the Status bar 

will resume its regular appearance. 
 
 
 

Return to Table of Contents
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Firmware Upgrades 
You will need to use the Affirmative Computer Products remote central management software, 
YESmanager, to upgrade the 2x14 firmware.  YESmanager is available free of charge; contact 
Affirmative Computer Products to obtain the latest version.  The User Guide for YESmanager is 
available at http://www.affirmative.net/pub/YESmanagerUserGuide.pdf. 
 
After you have obtained the install files for YESmanager, proceed as follows: 
1. Install YESmanager on a PC or server on the same network as the target terminal.  The operating 

system can be Windows 98 on up through XP.  It installs quite easily, and you will not need to 
reboot the computer. 

2. Download the latest 2x14 firmware per Affirmative Computer Products’ instructions.  It will arrive 
in a zipped .tar format.  Note: Do not extract the zipped files. 

3. Move the .tar file to the computer with the YESmanager installation. 
4. From this point, you have a choice of two methods to upgrade your firmware: 

• “Push” the new firmware from YESmanager. 
• “Pull” the new firmware from YESmanager. 

 

“Push” 
 
There are advantages to pushing the new firmware down to your 2x14 terminals. 
• There need be no user interaction at the terminal end, other than to power up the terminal. 
• The system administrator can upgrade all the 2x14 terminals without ever leaving the YESmanager 

console. 
• The system administrator can save the terminal properties and session configurations before the 

upgrade and reinstall them after the firmware upgrade. 
 
The push procedure is as follows: 
1. Turn on the 2x14. 
2. Open YESmanager. 
3. In the left pane of the YESmanager screen, you will see a list of all the Affirmative terminals found 

on your network. 
4. Select the 2x14 needing the upgrade. 
5. Right click 
6. Select Configurations>Upload from device.  The current configuration of the terminal will be 

uploaded and stored in YESmanager. 
7. Select the 2x14 again. 
8. Right click. 
9. Select Firmware Update. 
10. Browse to the .tar file containing the new firmware. 
11. Select OK.  YESmanager will push the new firmware down to the 2x14, and the 2x14 will 

automatically reboot upon completion. 
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12. When the terminal status light in YESmanager turns green again, select the terminal.  If the 
terminal is on a different sub-net than the YESmanager console, you will have to exercise Refresh 
on the terminal in order to see the status. 

13. Right click. 
14. Select Special Functions>Factory Default and confirm that you want to reset the terminal to 

defaults. 
15. When the terminal status light in YESmanager turns green again, select the terminal.  If the 

terminal is on a different sub-net than the YESmanager console, you will have to exercise Refresh 
on the terminal in order to see the status. 

16. Select Configurations>Download to device.  The original configuration that you uploaded in step 
6 will be downloaded to the terminal, and the terminal will be rebooted. 

17. The terminal will now have the new firmware with all of the original sessions and terminal 
properties. 

 

“Pull” 
 
A firmware upgrade can also be initiated from the terminal, after some initial preparation at the 
YESmanager console.  The procedure is: 
1. At the YESmanager console, move the new firmware .tar file into the folder C:\Program 

Files\Affirmative\YESmanager\htdocs. 
2. Turn on the 2x14. 
3. Open YESmanager. 
4. In the left pane of the YESmanager screen, you will see a list of all the Affirmative terminals found 

on your network. 
5. Select the 2x14 needing the upgrade. 
6. Right click 
7. Select Configurations>Upload from device.  The current configuration of the terminal will be 

uploaded and stored in YESmanager.  You are doing this because, after the upgrade, the terminal 
should be reset to factory defaults for stability purposes.  But with this step, you have the terminal 
and session configuration details safely stored and can restore them after the reset. 

8. The look and feel of the succeeding steps will be different, depending upon viewing mode, although 
the actions will be the same, so the rest of the procedure will be separated into TBT and non-TBT. 
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TBT Viewing Mode 
 
9. At the terminal, go to Terminal Properties>Upgrade. 
 

 
Upgrade Property Sheet for TBT Viewing Mode 

10. In Upgrade Server, enter the IP address of the YESmanager console. 
11. Leave Port at 9999. 
12. Activate Query update server.  You will see the Available Upgrade information filled in as shown 

in the next screen. 
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Upgrade Property Sheet with Upgrade Information for TBT Viewing Mode 

13. Information about the Available Upgrade is now displayed.  If you do not see this information, your 
Upgrade Server parameters are incorrect or the .tar file is not in the correct folder on the 
YESmanager server. 
• Package.  This is the upgrade description. 
• Version.  This is the version of the upgrade.  NOTE:  Verify that this is the version you are 

expecting.  If you try to upgrade to a firmware package intended for another model of 
Affirmative Computer Products terminal, strange things can happen. 

14. After verifying the upgrade version, activate Upgrade. 
15. You will see the upgrade progress displayed on the screen in a series of messages as each module in 

the firmware is upgraded.  When the upgrade is complete, the terminal will be automatically 
rebooted. 

16. It is recommended that you do a reset to factory defaults at this point.  If you do not, you may 
experience some performance instability, depending upon the nature of the upgrade, and when you 
call Affirmative Computer Products Tech Support, the first thing they will ask you to do is to reset 
to defaults.  So save yourself the aggravation and reset now. 

17. Remember back in step 7, where we had you do a configuration upload in YESmanager?  Well, 
now you can do a configuration download from YESmanager and restore all your pre-upgrade 
settings and sessions. 

18. You can resume normal terminal operation. 
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Non-TBT Viewing Mode 
 
9. At the terminal, go to Terminal Properties>Firmware. 
 

 
Firmware Property Sheet for Non-TBT Viewing Mode 

10. In Upgrade Server, enter the IP address of the YESmanager console. 
11. Leave Port at 9999. 
12. Activate Get list.  You will see the properties sheet updated with information similar to that shown 

in the next screen. 
 

 
Firmware Property Sheet with Upgrade Information for Non-TBT Viewing Mode 
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13. You probably have more information here than you need, or want, to know.  This is a list of the 
modules making up the terminal firmware: 
• Package.  This is the module name. 
• Installed.  This is the module version. 
• Dim inst.  This the amount of flash memory required for the module. 
• Available.  This is the available module upgrade.  It is possible to upgrade or delete individual 

modules, but we see no advantage to doing that at the user level, so you won’t see any 
individual module information here.  Instead, you will see Everything (YES) at the bottom of 
the list, and the new firmware package version on the right.  If you don’t see this information, 
your Upgrade Server parameters are incorrect or the .tar file is not in the correct folder on the 
YESmanager server.  NOTE: Verify that this is the version you are expecting.  If you try to 
upgrade to a firmware package intended for another model of Affirmative Computer Products 
terminal, strange things can happen. 

• Dim upgr.  This is the amount of flash memory required for the upgraded module, if we were 
providing individual module upgrades. 

14. After verifying the upgrade version, activate Upgrade. 
15. You will see the upgrade progress displayed on the screen in a series of messages as each module in 

the firmware is upgraded.  When the upgrade is complete, the terminal will be automatically 
rebooted. 

16. It is recommended that you do a reset to factory defaults at this point.  If you do not, you may 
experience some performance instability, depending upon the nature of the upgrade, and when you 
call Affirmative Computer Products Tech Support, the first thing they will ask you to do is to reset 
to defaults.  So save yourself the aggravation and reset now. 

17. Remember back in step 7, where we had you do a configuration upload in YESmanager?  Well, 
now you can do a configuration download from YESmanager and restore all your pre-upgrade 
settings and sessions. 

18. You can resume normal terminal operation. 
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Troubleshooting Your Terminal 
 

The following table provides some solutions to common problems that can occur during setting up or 
using your 2x14 terminal. 
 

Problems Solution 

1 The monitor screen is blank 

• Make sure the terminal is turned on. 
• Make sure the monitor is plugged into an AC outlet and turned 

on. 
• Make sure the VGA connector is plugged into the terminal. 

2 
Your monitor can not display after 
advancing past the logo screen or after 
changing the display setting 

The display setting may be at a higher resolution or refresh frequency 
than the monitor will support.  Execute one of the following recovery 
options: 
• Use a better monitor for display. 
• Use a better monitor for display while changing the display 

settings to be compatible with the original monitor. 
• Ask your MIS or network administrator to reset your terminal to 

factory default settings through the Remote Management" 
software, if it is installed at your server site. 

3 The mouse does not work 
• If it is a PS/2 mouse, make sure the mouse is plugged into the 

mouse port, not the keyboard port. 
• Test the terminal using a known good mouse. 

4 The keyboard does not respond 
• Make sure the keyboard is plugged into the keyboard port, not the 

mouse port. 
• Test the terminal using a known good PS/2 keyboard. 

5 The network connection does not work 

• Check the network connection. 
• Verify the terminal IP address is correct in Terminal Properties. 
• Check the server's IP address. 
• If you are using the terminal default setting of DHCP address 

assignment, make sure there is a workable DHCP server on your 
network. 

• If you are using a specified IP address, make sure that there is not 
another network device with the same IP address. 
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6 Forgot the password setting and cannot 
reconfigure the terminal. 

Ask your system administrator to use the secret hot key sequence to 
reset Terminal Properties to factory defaults. 

7 The mouse cursor is jittery. 
• Your terminal is being shadowed from the Remote Management 

console. 
• Your network is overloaded and data collisions are occurring. 

8 

You are using a USB wireless network 
adapter, and the terminal did not 
connect to the network at terminal 
bootup 

• Verify your SSID. 
• If you are using WEP encryption, verify your key. 
• Reboot your terminal. 

 
                   
 

Support 
 
Affirmative Computer Products offers Technical Support services for all the Affirmative products.  You 
can access Affirmative Technical Support in one of the following ways: 
 
• via Phone 

• 480-946-1444 
• 888-353-5250 

• via Fax 
• 480-946-9250 

• via E-mail 
• support@affirmative.net 
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Appendix 1.  Specifications 
 

2214 

 
ITEM SPECIFICATIONS 

Processor • SIS 550 200 MHz  

Communication and Ports 

• 10/100 dual-speed Ethernet, Twisted Pair (RJ45). 
• One parallel port (DB-25 Female connector). 
• Enhanced ps/2 keyboard interface. 
• Enhanced ps/2 mouse interface. 
• Two USB ports. 
• Audio out 

Embedded O.S. • Linux 

Video 
• SVGA 
• 640x480, 800x600, 1024x768, and 1280x1024 with high color. 
• Refresh frequency up to 85 Hz 

Memory • SDRAM -- 128 MB SDRAM standard. (Max. 256MB) 
• Flash -- 32 MB DOM standard 

Server Operating System Support 

• Microsoft Windows 2003 Server 
• Microsoft Windows 2000 (Server Edition) 
• Microsoft Windows NT 4.0 (TSE) 
• Citrix MetaFrame XP 
• Citrix MetaFrame 
• Citrix WinFrame 
• UNIX 
• Linux 
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ITEM SPECIFICATIONS 

Optional Devices 
• USB storage 
• USB to COM port adapter 
• USB wireless adapter (802.11b) 

• Software Features 

• Netscape 4.78 browser with PDF viewer and JVM plug-in 
• Time zone and SNTP support 
• Terminal access password for security 
• Multi-session Autostart  
• LPD 
• Terminal emulation 
• VNC viewer 
• Remote management software 
• Wake on LAN (WOL) 

Temperature • Operating: 5 ºC to 40 ºC (41 ºF to 104 ºF) 
• Storage: -40 ºC to 60 ºC (-4 ºF to 140 ºF) 

Relative Humidity • 90% maximum, non-condensing 

Operating Altitude 
Range • 0 to 10,000 feet (0 to 3050 meters) 

 
 
Environment 
      
      
      
     

Power • Full range auto-sensing 100 ~ 240 VAC at 50 Hz ~ 60 Hz 
• 10 Watts 

Regulatory Compliance 

• UL 
• C-UL 
• TUV 
• FCC Class B 
• CE mark 

Dimension (WxDxH) • 194.5 x 151.5 x 40 (mm) Physical 
Characteristics 

Weight • 0.65 Kg 
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2614 

 
ITEM SPECIFICATIONS 

Processor 
  

• National Semiconductor Media Gx1 300 MHz with 5530A 
support chip 

Communication and Ports 

• Microsoft RDP and Citrix ICA protocol compliant 
• 10/100 dual speed Ethernet, Twisted Pair (RJ45) 
• One parallel port (DB-25 Female connector) 
• Two serial ports with RS-232C (DB-9 male connectors) 
• Enhanced ps/2 keyboard interface 
• Enhanced ps/2 mouse interface 
• Two USB ports 
• Audio out and Microphone in 

Embedded O.S. • Linux 

Video 

• SVGA 
• 640x480, 800x600, and 1024x768 with high colors 
• 1280x1024 with 256 colors 
• Refresh frequency up to 85 Hz 

Memory • SDRAM -- 128 MB SDRAM standard. (Max. 256MB) 
• Flash -- 32 MB DOC or DOM standard 

Server Operating System Support 

• Microsoft Windows 2003 Server 
• Microsoft Windows 2000 (Server Edition) 
• Microsoft Windows NT 4.0 (TSE) 
• Citrix MetaFrame XP 
• Citrix MetaFrame 
• Citrix WinFrame 
• UNIX 
• Linux 

Optional Devices • USB storage 
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ITEM SPECIFICATIONS 

Software Features 

• Netscape 4.78 browser with PDF viewer and JVM plug-in. 
• Time zone and SNTP support 
• Terminal access password for security 
• Multi-session Autostart 
• LPD & ThinPrint support 
• VNC viewer 
• Terminal emulation 
• Remote management software 

Temperature • Operating: 5 ºC to 40 ºC (41 ºF to 104 ºF) 
• Storage: -40 ºC to 60 ºC (-4 ºF to 140 ºF) 

Relative Humidity • 90% maximum, non-condensing 

Operating Altitude 
Range • 0 to 10,000 feet (0 to 3050 meters) 

Environment 
      
      
      
     

Power • Full range auto-sensing 100 ~ 240 VAC at 50 Hz ~ 60 Hz 
• 15 Watts 

Regulatory Compliance 

• UL 
• C-UL 
• TUV 
• FCC Class B 
• CE mark 

Dimension (WxDxH) • 231 x 201 x 45 (mm) Physical 
Characteristics 

Weight • 1.35 Kg 
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2814 

 
 

ITEM SPECIFICATIONS 
Processor 
  • VIA Eden 733 MHz 

Communication and Ports 

• Microsoft RDP and Citrix ICA protocol compliant 
• 10/100 dual speed Ethernet, Twisted Pair (RJ45) 
• One parallel port (DB-25 Female connector) 
• Two serial ports with RS-232C (DB-9 male connectors) 
• Enhanced ps/2 keyboard interface 
• Enhanced ps/2 mouse interface 
• Two USB ports 
• Audio out and Microphone in 

Embedded O.S. • Linux 

Video 
• SVGA 
• 640x480, 800x600, 1024x768, and 1280x1024 with true colors 
• Refresh frequency up to 85 Hz 

Memory 
• SDRAM -- 128 MB SDRAM standard. (Max. 256MB) 
• Flash -- 64 MB Compact Flash standard 
• 8MB shared system RAM for video 

Server Operating System Support 

• Microsoft Windows 2003 Server 
• Microsoft Windows 2000 (Server Edition) 
• Microsoft Windows NT 4.0 (TSE) 
• Citrix MetaFrame XP 
• Citrix MetaFrame 
• Citrix WinFrame 
• UNIX 
• Linux 

Optional Devices • USB storage 
• USB 802.11b wireless 
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ITEM SPECIFICATIONS 

Software Features 

• Netscape 7.x browser (Mozilla) with PDF viewer and JVM plug-
in. 

• Time zone and SNTP support 
• Terminal access password for security 
• Multi-session Autostart 
• LPD & ThinPrint support 
• VNC viewer 
• Terminal emulation 
• Remote management software 

Temperature • Operating: 5 ºC to 40 ºC (41 ºF to 104 ºF) 
• Storage: -40 ºC to 60 ºC (-4 ºF to 140 ºF) 

Relative Humidity • 80% maximum, non-condensing 

Operating Altitude 
Range • 0 to 10,000 feet (0 to 3050 meters) 

Environment 
      
      
      
     

Power • Full range auto-sensing 96 ~ 264 VAC at 50 Hz ~ 60 Hz 

Regulatory Compliance 

• UL 1950 
• C-UL 
• TUV 
• FCC Class B 
• CE mark 
• CB IEC60950 
• C-TICK 
• BSMI 

Dimension (WxDxH) • 51 x 202 x 232 (mm) Physical 
Characteristics 

Weight • 2.20 Kg 
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Appendix 2.  TCP/IP Error Codes 
 

Here is a comprehensive list of standard TCP/IP error codes that can occur during network operation.  
Some of them are quite esoteric and may not be applicable to YEStation operation, but this list should 
include any networking error code that you encounter.  They should be useful in troubleshooting 
network errors, many of which are caused by incorrect configuration. 
 
10004  
Interrupted function call.  
 
10013  
Permission denied.  
 
10014  
Bad address.  
 
10022  
Invalid argument.  
 
10024  
Too many open sockets.  
 
10035  
Resource temporarily unavailable.  
 
10036  
Operation now in progress.  A blocking operation is in progress.  
 
10037  
Operation already in progress.  
 
10038  
Socket operation on non-socket.  
 
10039  
Destination address required.  
 
10040  
Message too long.  
 
10041  
Protocol wrong type for socket.  
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10042  
Bad protocol option.  
 
10043  
Protocol not supported.  
 
10044  
Socket type not supported.  
 
10045  
Operation not supported.  
 
10046  
Protocol family not supported.  
 
10047  
Address family not supported by protocol family.  
 
10048  
Address is already in use.  If you attempt to set up a server on a port that is already is in use, you will 
get this error.  
 
10049  
Cannot assign requested address.  
 
10050  
Network is down.  
 
10051  
Network is unreachable.  
 
10052  
Network dropped connection on reset.  
 
10053  
Software caused the connection to abort, usually due to connection or protocol error.  
 
10054  
Connection reset by peer.  This occurs when an established connection is shut down for some reason by 
the remote computer.  
 
10055  
No buffer space available.  
 
10056  
Socket is already connected.  
 
10057  
Socket is not connected.  
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10058  
Cannot send after socket shutdown.  
 
10060  
Connection timed out.  Bad IP address or bad LAN connection. 
 
10061  
Connection refused. You will usually see this error when a server refuses a connection from a client, 
because the server is not listening on that port, or the server is not a valid host. 
  
10064  
Host is down.  
 
10065  
The IP address of the host is unreachable from your terminal.  Check IP addresses of host, terminal, and 
gateway.  
 
10067  
Too many processes.  
 
10091  
Network subsystem is unavailable.  
 
10092  
Unsupported version of WINSOCK.DLL.  
 
10093  
TCP networking has not been initialized on your computer.  
 
10094  
Graceful shutdown in progress.  
 
11001  
Host not found.  (DNS error.)  
 
11002  
Non-authoritative host not found.  Temporary DNS error.  
 
11003  
Non-recoverable error.  (DNS error.)  
 
11004  
Valid name, no data record of requested type.  (DNS error). 
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